IP : IP ルーティング

IS-IS のネットワークのタイプとフレームリレー インターフェイス

2002 年 12 月 31 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

目次


概要

Intermediate System-to-Intermediate System(IS-IS)には、ポイントツーポイントとブロードキャストの 2 種類のネットワークがあります。Open Shortest Path First(OSPF)と異なり、IS-IS にはポイントツーマルチポイントのネットワーク タイプはありません。それぞれのタイプのネットワークでは、異なるタイプの IS-IS HELLO(IIH)パケットが交換され、隣接関係が構築されます。ポイントツーポイント ネットワークでは、ポイントツーポイントの IIH が使用され、ブロードキャスト ネットワークではレベル 1 またはレベル 2、あるいはその両方の IIH が交換されます。この文書では、設定の不一致の例を示し、この問題の診断方法と解決方法について説明します。

正しい設定例

マルチポイントのシリアル インターフェイスは、ブロードキャスト インターフェイスと同じ方法で扱われます。たとえば下のネットワーク ダイアグラムでは、3 台のフルメッシュ型のルータ間にある WAN マルチポイント接続が、1 つの LAN 接続のように扱われています。LAN と同様に、Designated Intermediate System(DIS)が選ばれています。

次の図では、3 台すべてのルータがポイントツーマルチポイント インターフェイスでフレームリレー クラウドに接続されています。ルータ E の Serial 1 や、ルータ G の Serial 0 のようなメインのインターフェイスは、デフォルトでマルチポイントになっています。ルータ H とルータ F はポイントツーポイント接続されています。ルータの設定は次の図のようになっています。

ネットワーク ダイアグラム

ルータ E

 clns routing

 

  !

  !Connection to Backbone

  interface Ethernet0

   ip address 172.17.1.1 255.255.255.0

   ip router isis

   clns router isis

  !

  interface Serial1

   ip address 10.10.10.1 255.255.255.0

   ip router isis

   encapsulation frame-relay

   clns router isis

   frame-relay map clns 123 broadcast

   frame-relay map clns 121 broadcast

   frame-relay map ip 10.10.10.3 121 broadcast

   frame-relay map ip 10.10.10.4 123 broadcast

   frame-relay lmi-type ansi

   isis circuit-type level-1

  !

  router isis

   net 49.0001.1111.1111.1111.00

 
ルータ G

 clns routing

 

 !

 interface Serial0

  ip address 10.10.10.3 255.255.255.0

  ip router isis

  encapsulation frame-relay

  clns router isis

  frame-relay map clns 112 broadcast

  frame-relay map clns 113 broadcast

  frame-relay map ip 10.10.10.1 112 broadcast

  frame-relay map ip 10.10.10.4 113 broadcast

  frame-relay lmi-type ansi

 !

 router isis

  net 49.0001.3333.3333.3333.00

  is-type level-1

 
ルータ H

 clns routing

  !

 

  interface Serial0

   no ip address

   no ip directed-broadcast

   no ip mroute-cache

   encapsulation frame-relay

   frame-relay lmi-type ansi

  !

  interface Serial0.1 multipoint

 

   ip address 10.10.10.4 255.255.255.0

   no ip directed-broadcast

   ip router isis

   clns router isis

   frame-relay map clns 132 broadcast

   frame-relay map clns 131 broadcast

   frame-relay map ip 10.10.10.1 132 broadcast

   frame-relay map ip 10.10.10.3 131 broadcast

  !

  interface Serial0.2 point-to-point

   ip address 10.20.20.4 255.255.255.0

   no ip directed-broadcast

   ip router isis

   clns router isis

   frame-relay interface-dlci 130

  !

  router isis

   passive-interface Ethernet0

   net 49.0001.4444.4444.4444.00

   is-type level-1

 
ルータ F

 clns routing

 

 !

 interface Serial2

  no ip address

  no ip directed-broadcast

  encapsulation frame-relay

  frame-relay lmi-type ansi

 !

 interface Serial2.1 point-to-point

  ip address 10.20.20.2 255.255.255.0

  no ip directed-broadcast

  ip router isis

  clns router isis

  frame-relay interface-dlci 103

 !

 router isis

  net 49.0001.2222.2222.2222.00

  is-type level-1

 

メッシュ内にあるすべてのルータで、show clns neighbor コマンド、show isis database コマンド、および show isis database details コマンドを使用することで、マルチポイント WAN 接続での IS-IS 接続の影響を調べることができます。

全ルータでの show clns neighbor コマンドの出力は次のとおりです。


 Router_H#show clns neighbor

 

 System Id      SNPA                Interface   State  Holdtime  Type Protocol

 Router_E       DLCI 132            Se0.1       Up     26        L1   IS-IS

 Router_F       DLCI 130            Se0.2       Up     23        L1   IS-IS

 Router_G       DLCI 131            Se0.1       Up     26        L1   IS-IS

 

 Router_G#show clns neighbor

 

 System Id      SNPA                Interface   State  Holdtime  Type Protocol

 Router_E       DLCI 112            Se0         Up     25        L1   IS-IS

 Router_H       DLCI 113            Se0         Up     7         L1   IS-IS

 

 Router_E#show clns neighbor

 

 System Id      SNPA                Interface   State  Holdtime  Type Protocol

 Router_H       DLCI 123            Se1         Up     6         L1   IS-IS

 Router_G       DLCI 121            Se1         Up     22        L1   IS-IS

 Backbone       *HDLC*              Se0         Up     22        L2   IS-IS

 

 Router_F#show clns neighbor

 

 System Id      Interface   SNPA                State  Holdtime  Type Protocol

 Router_H       Se2.1       DLCI 103            Up     27        L1   IS-IS

 

show isis database コマンドの出力では、ルータ H が DIS であることが分かります。


 Router_H#show isis database

 IS-IS Level-1 Link State Database

 LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL

 Router_E.00-00        0x000001EC   0x1D12        44            1/0/0

 Router_F.00-00        0x00000124   0x63A2        54            0/0/0

 Router_G.00-00        0x00000130   0x0C3B        33            0/0/0

 Router_H.00-00      * 0x0000012F   0xEA6C        42            0/0/0

 Router_H.01-00      * 0x00000123   0xBA21        43            0/0/0

 

 Router_G#show isis database

 IS-IS Level-1 Link State Database

 LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL

 Router_E.00-00        0x00000E8F   0xD2FD        46            1/0/0

 Router_F.00-00        0x00000DC0   0x0657        45            0/0/0

 Router_G.00-00      * 0x00000DD0   0xA6F3        41            0/0/0

 Router_H.00-00        0x00000DDA   0x6F30        42            0/0/0

 Router_H.01-00        0x00000DBE   0x2C08        50            0/0/0

 

 Router_E#show isis database

 IS-IS Level-1 Link State Database

 LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL

 Router_E.00-00      * 0x00000EA6   0xA415        54            1/0/0

 Router_F.00-00        0x00000DD7   0xD76E        46            0/0/0

 Router_G.00-00        0x00000DE7   0x780B        40            0/0/0

 Router_H.00-00        0x00000DF0   0x4346        37            0/0/0

 Router_H.01-00        0x00000DD5   0xFD1F        46            0/0/0

 

 IS-IS Level-2 Link State Database

 LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL

 Router_E.00-00      * 0x00000F19   0x1598        38            0/0/0

 Backbone.00-00        0x00000E94   0x5C24        56            0/0/0

 

この DIS に対する link-state packet(LSP; リンクステート パケット)も検査することができます。次の出力では、疑似ノードの LSP Router_H.01-00 がフルメッシュ型の WAN を表しており、このメッシュに接続された全ルータは、LAN 上にある疑似ノード LSP のように見えています。


 Router_H#show isis database details Router_H.01-00

 

 IS-IS Level-1 LSP Router_H.01-00

 LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL

 Router_H.01-00      * 0x00000126   0xB424        55            0/0/0

   Metric: 0  IS Router_H.00

   Metric: 0  IS Router_G.00

   Metric: 0  IS Router_E.00

 

 Router_G#show isis database details Router_H.01-00

 

 IS-IS Level-1 LSP Router_H.01-00

 LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL

 Router_H.01-00        0x00000DBE   0x2C08        35            0/0/0

   Metric: 0  IS Router_H.00

   Metric: 0  IS Router_E.00

   Metric: 0  IS Router_G.00

 

 Router_E#show isis database details Router_H.01-00

 

 IS-IS Level-1 LSP Router_H.01-00

 LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL

 Router_H.01-00        0x00000DD6   0xFB20        42            0/0/0

   Metric: 0  IS Router_H.00

   Metric: 0  IS Router_E.00

   Metric: 0  IS Router_G.00

 

設定の不一致による問題

設定の不一致による問題の例を見てみましょう。ルータ F の Serial 2.1 インターフェイスをポイントツーポイントからマルチポイントへ変更すると、ルータ F とルータ H との間に問題が発生します。次の出力でわかるように、ルータ H の設定が変わっています。

ルータ H

 clns routing

 !

 

 interface Serial0

  no ip address

  no ip directed-broadcast

  no ip mroute-cache

  encapsulation frame-relay

  frame-relay lmi-type ansi

 !

 interface Serial0.1 multipoint

  ip address 10.10.10.4 255.255.255.0

  no ip directed-broadcast

  ip router isis

  clns router isis

  frame-relay map clns 132 broadcast

  frame-relay map clns 131 broadcast

  frame-relay map ip 10.10.10.1 132 broadcast

  frame-relay map ip 10.10.10.3 131 broadcast

 !

 interface Serial0.2 point-to-point

  ip address 10.20.20.4 255.255.255.0

  no ip directed-broadcast

  ip router isis

  clns router isis

  frame-relay interface-dlci 130

 !

 router isis

  passive-interface Ethernet0

  net 49.0001.4444.4444.4444.00

  is-type level-1

 
ルータ F

 clns routing

 

 !

 interface Serial2

  no ip address

  no ip directed-broadcast

  encapsulation frame-relay

  frame-relay lmi-type ansi

 !

 interface Serial2.1 multipoint

  ip address 10.20.20.2 255.255.255.0

  no ip directed-broadcast

  ip router isis

  clns router isis

  frame-relay interface-dlci 103

 !

 router isis

  net 49.0001.2222.2222.2222.00

  is-type level-1

 

この時点で、もはやルータ H ではルータ F を IS-IS 近隣ルータとは見なしていません。


 Router_H#show clns neighbor

 

 System Id      SNPA                Interface   State  Holdtime  Type Protocol

 Router_G       DLCI 131            Se0.1       Up     6         L1   IS-IS

 Router_E       DLCI 132            Se0.1       Up     21        L1   IS-IS

 

ルータ F はルータ H を IS-IS 近隣ルータとして見ていますが、状態は INIT です。このことは、ルータ F に隣接関係に関する問題が発生していることを意味します。


 Router_F#show clns neighbor

 

 System Id      Interface   SNPA                State  Holdtime  Type Protocol

 Router_H       Se2.1       DLCI 103            Init   26        L1   IS-IS

 

問題の原因

この問題は、ルータ F がポイントツーポイント インターフェイスからシリアル IIH を送信し、ルータ H がマルチポイント インターフェイスからシリアル IIH を送信していることが原因となっています。ルータ H で debug isis adj packets をオンにすると、ルータ F の Serial 2.1 から LAN IIS が送信されているにもかかわらず、ルータ H の Serial 2.1 では IIH がまったく着信していないことが分かります。


 Router_H#debug isis adj packets

 IS-IS Adjacency related packets debugging is on

 ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01

 ISIS-Adj: Sending serial IIH on Serial0.2

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 ISIS-Adj: Sending L1 IIH on Serial0.1

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01

 ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01

 ISIS-Adj: Sending serial IIH on Serial0.2

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01

 ISIS-Adj: Sending L1 IIH on Serial0.1

 ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 ISIS-Adj: Sending serial IIH on Serial0.2

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 ISIS-Adj: Sending L1 IIH on Serial0.1

 ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01

 ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 

ルータ F で同じデバッグをオンにすると、ルータ F は Serial2.1 インターフェイス で、ルータ H からシリアル IIH を受信していることが分かります。ルータ F が送信しようとしている LAN IIH は、カプセル化の失敗によってドロップされています。


 Router_F#debug isis adj packets

 IS-IS Adjacency related packets debugging is on

 ISIS-Adj: Encapsulation failed for level 1 IIH on Serial2.1

 ISIS-Adj: Encapsulation failed for level 1 IIH on Serial2.1

 ISIS-Adj: Encapsulation failed for level 1 IIH on Serial2.1

 ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00

 ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT

 ISIS-Adj: Action = GOING UP, new type = L1

 ISIS-Adj: Encapsulation failed for level 1 IIH on Serial2.1

 ISIS-Adj: Encapsulation failed for level 1 IIH on Serial2.1

 ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00

 ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT

 ISIS-Adj: Action = GOING UP, new type = L1

 ISIS-Adj: Encapsulation failed for level 1 IIH on Serial2.1

 ISIS-Adj: Encapsulation failed for level 1 IIH on Serial2.1

 ISIS-Adj: Encapsulation failed for level 1 IIH on Serial2.1

 ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00

 ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT

 ISIS-Adj: Action = GOING UP, new type = L1

 ISIS-Adj: Encapsulation failed for level 1 IIH on Serial2.1

 ISIS-Adj: Encapsulation failed for level 1 IIH on Serial2.1

 ISIS-Adj: Encapsulation failed for level 1 IIH on Serial2.1

 ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.2), cir type L1, cir id 00

 

ルータ F とルータ H の間でリンクのタイプに不一致があるときに発生する問題を分析したものを次に示します。

  • LAN 隣接関係でハンドシェイクを行うと、DOWN、INIT、または UP のいずれかの状態になります。
  • ルータ F の Serial 2.1 サブインターフェイスから発信されるレベル 1 IIH のカプセル化に失敗します。
  • ルータ F からの発信の際のカプセル化に失敗したため、ルータ H ではルータ F からの LAN IIH をまったく受信しません。
  • ルータ F では、IIH がルータ H から送られてきていることは分かりますが、ポイントツーポイント IIH であることは認識できません。これは、ルータ F のサブインターフェイスがマルチポイントだからです。ルータ F では、ルータ H から送られる IIH で何かが欠損しているか、あるいは誤りがあることを検出します。そのため、ルータ F では LAN 隣接関係を構築しますが、その隣接関係を INIT 状態とします。

解決方法

この問題の解決方法は、リンクの両側の設定が、ポイントツーポイントかマルチポイントかを確認することです。この場合は、ルータ F の Serial 2.1 インターフェイスをポイントツーポイントに戻し、ルータ H の Serial 2.1 インターフェイスの設定に合わせます。変更の後、インターフェイスをフラップします。

次のデバッグ出力は、上記の変更を行って、ルータ F の Serial 2 インターフェイスをフラップした後に生じた現象を示しています。この時点で、ルータ F は自身の Serial 2.1 インターフェイスでシリアル IIH を送受信できるようになっています。


 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2.1, changed state to down

 %LINK-5-CHANGED: Interface Serial2, changed state to administratively down

 %FR-5-DLCICHANGE: Interface Serial2 - DLCI 103 state changed to DELETED

 %FR-5-DLCICHANGE: Interface Serial2 - DLCI 101 state changed to DELETED

 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2.1, changed state to up

 %FR-5-DLCICHANGE: Interface Serial2 - DLCI 103 state changed to ACTIVE

 %SYS-5-CONFIG_I: Configured from console by console

 %LINK-3-UPDOWN: Interface Serial2, changed state to up

 %FR-5-DLCICHANGE: Interface Serial2 - DLCI 101 state changed to ACTIVE

 ISIS-Adj: Sending serial IIH on Serial2.1

 ISIS-Adj: Sending serial IIH on Serial2.1

 ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00

 ISIS-Adj: rcvd state INIT, old state DOWN, new state INIT

 ISIS-Adj: Action = GOING UP, new type = L1

 ISIS-Adj: New serial adjacency

 ISIS-Adj: Sending serial IIH on Serial2.1

 ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00

 ISIS-Adj: rcvd state UP, old state INIT, new state UP

 ISIS-Adj: Action = GOING UP, new type = L1

 

ルータ H から見ると、事態が通常の状態に戻っています。


 Router_H#show clns neighbor

 

 System Id      SNPA                Interface   State  Holdtime  Type Protocol

 Router_F       DLCI 130            Se0.2       Up     28        L1   IS-IS

 Router_G       DLCI 131            Se0.1       Up     8         L1   IS-IS

 Router_E       DLCI 132            Se0.1       Up     29        L1   IS-IS

 

debug isis adj packets コマンドの出力も正常な状態に戻っています。


 ISIS-Adj: Rec serial IIH from DLCI 130 on Serial0.2, cir type 1, cir id 00

 ISIS-Adj: rcvd state 0, old state 0, new state 0

 ISIS-Adj: Action = 2, new_type = 0

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 ISIS-Adj: Sending serial IIH on Serial0.2

 ISIS-Adj: Sending L1 IIH on Serial0.1

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01.01

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01.01

 ISIS-Adj: Rec serial IIH from DLCI 130 on Serial0.2, cir type 1, cir id 00

 ISIS-Adj: rcvd state 0, old state 0, new state 0

 ISIS-Adj: Action = 2, new_type = 0

 ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01.01

 ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01.01

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01.01

 ISIS-Adj: Sending L1 IIH on Serial0.1

 ISIS-Adj: Sending serial IIH on Serial0.2

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01.01

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01.01

 ISIS-Adj: Rec serial IIH from DLCI 130 on Serial0.2, cir type 1, cir id 00

 ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01.01

 ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01.01

 ISIS-Adj: Sending serial IIH on Serial0.200

 ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01.01

 ISIS-Adj: Sending L1 IIH on Serial0.1

 ISIS-Adj: Sending serial IIH on Serial0.2

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01.01

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01.01

 ISIS-Adj: Rec serial IIH from DLCI 130 on Serial0.2, cir type 1, cir id 00

 ISIS-Adj: rcvd state 0, old state 0, new state 0

 ISIS-Adj: Action = 2, new_type = 0

 ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01.01

 

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13794