WAN : フレーム リレー

Distributed Traffic Shaping(DTS; 分散トラフィック シェーピング

2014 年 2 月 19 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 6 月 1 日) | フィードバック

目次


概要

このドキュメントでは Distributed Traffic Shaping(DTS)を説明しており、現在利用可能な情報が多数統合されています。

トラフィック シェーピング(TS)により、特定のインターフェイスでトラフィック フローを制御するメカニズムが提供されます。 「分散」TS は、Cisco 7500 や 12000 シリーズ インターネット ルータのようなハイエンド プラットフォーム固有の機能です。 これらのプラットフォームには、メイン プロセッサ(Route Switch Processor(RSP; ルータ スイッチ プロセッサ) または Gigabit Route Processor(GRP; ギガビット ルート プロセッサ))から、個々のインターフェイス プロセッサ(Versatile Interface Processor(VIP; 多用途インターフェイス プロセッサ)または Line Card(LC; ライン カード))にトラフィック シェーピングをオフロードさせる機能があります。 Distributed Cisco Express Forwarding(dCEF)が適切なスイッチング モードであるネットワークでは、VIP やライン カードでの DTS はトラフィック シェーピングの論理上の選択肢です。

DTS でトラフィックをシェーピングする理由

このドキュメントをお読みの場合は、おそらくトラフィックをシェーピングする理由は想像できるでしょう。 分散されたパズルのピースに例えると、きわめて明確なはずです。メイン プロセッサが行う作業を個々のカード プロセッサに分散しています。 シェーピングに関しては、多数のお客様は単にプロバイダーとの契約に基づく回線の保証速度を超えないようにされています。 これによりクラウドでの廃棄が防止され、その結果、プロバイダーがパケットを廃棄した際の TCP/IP による再転送が削減されます。 トラフィックのシェーピングが必要となる一般的なシナリオを次に示します。 この例では、ブランチ オフィスに 128K 回線だけがある場合、中央サイトでは T1 レートでトラフィックを転送する必要はありません。

DTS を使用する理由は、他にもたくさんあります。 利点には、関連の Quality of Service(QoS)機能の分類、多様なタイプのトラフィックに渡って帯域幅をできるだけ効率的に使用するためのドライブが含まれます。 DTS でのトラフィック シェーピングの設定は、インターフェイス レベル、サブインターフェイス レベル、または ATM やフレーム リレー Permanent Virtual Circuit(PVC; 相手先固定接続)の論理インターフェイス レベルで行われます。

シェーピングにより一連のネットワーク ゴールを達成し、次の基準をキーとすることが可能です。

  • 物理または論理インターフェイスでのトラフィックすべて
  • 簡単および拡張 IP ACL(IP アドレス、TCP/UDP ポート、IP 優先順位)によって分類されるトラフィック
  • QoS グループ(Committed Access Rate(CAR)によって内部パケット ラベルが適用されたアップストリーム、または QoS Policy Propagation(QPPB)で分類されるトラフィック)
DTS は、平均パケット サイズが 250 バイト以上で 8M のスタティック RAM(SRAM)装備の VIP2-50 以上が使用されている場合、OC-3 レートまでをサポートしながら、VIP あたり最大で 200 のシェープ キューをサポートします。 通常のトラフィック シェーピング(GTS)とは異なり、DTS では Weighted Fair Queueing(WFQ; 重み付け均等化キューイング)をイネーブルにする必要はありません。 その代わり、DTS はシェーピングされたキューに均等化キューイングまたは分散 First-In, First-Out(FIFO; ファーストイン ファーストアウト)を使用します。

プラットフォーム特有の項目

次の表は、プラットフォームに依存する TS の設定方法を示します。ここでは主に、この機能がハイエンドのプラットフォームで重要であることが示されています。
 
 
12000 シリーズ
7500 シリーズ
7200、3600、2600 およびその他の非 VIP プラットフォーム
サポートされているシェーピング メカニズム
DTS
DTS
GTS またはフレーム リレー TS
設定コマンド
ポリシーマップでの shape コマンド
ポリシーマップでの shape コマンド
メイン インターフェイスでの traffic-shape rate コマンド、またはメイン インターフェイスでの frame-relay traffic-shaping コマンド および map-class 設定コマンドでシェーピング パラメータを指定
distributed Cisco Express Forwarding(dCEF)の必要性
デフォルトは CEF
必要(show cef linecard コマンドで確認)
不要


7500 シリーズでの DTS 注記

Cisco 7500 シリーズでは、Frame Relay Traffic Shaping(FRTS; フレーム リレー トラフィック シェーピング)が非分散モードの RSP で実行されるため、現在、frame-relay traffic-shaping コマンドを使用して FRTS を設定する機能はブロックされています。 dCEF と FRTS を使用すると、CEF「パント」隣接関係によりすべてのパケットが RSP でファーストスイッチされますが、これは転送のパフォーマンスを最大化するのに最適とはいえません。

Cisco IOS(R) ソフトウェア リリース 12.1(5)T に関しては、VIP で QoS ポリシーが分散モードで実行されます。Route/Switch Processor(RSP; ルート/スイッチ プロセッサ)ベースの QoS はサポートされません。 したがって、Cisco 7500 シリーズで VIP インターフェイスに DTS を実装するには、shape コマンドと Modular QoS Command Line Interface(MQC)の他のコマンドを使用する必要があります。

Cisco 7500 シリース以外のプラットフォームで Cisco IOS ソフトウェア リリース 12.1(2)T が Low Latency Queueing(LLQ; 低遅延キューイング)のサポートを導入する一方で、VIP での分散 LLQ(dLLQ)は 12.1(5)T で導入されました。 分散型のバージョンではこの機能のパフォーマンスが向上しています。 Data-Link Connection Identifier(DLCI; データリンク接続識別子)ごとに一意のサービスポリシーが設定できます。 マップクラスを使用しなくても、サブインターフェイスや DLCI に service-policy コマンドを直接適用できます。 ただし、マップクラス内に dLLQ を設定することを推奨します。

フレーム リレー インターフェイスに分散 FRF.12(フラグメンテーション)を適用する場合には、マップクラスを定義して、マップクラスの下でサービスポリシーを適用する必要があります。 FRF.12 は Cisco IOS ソフトウェア バージョン 12.0(4)T で導入され、Cisco IOS ソフトウェア バージョン 12 1(2)T からは Cisco 805、1600、1700、2500、4500、および 4700 ルータ プラットフォームにも拡大されています。詳細情報は『追加プラットフォームでの FRF.12 のサポート』にあります。

Cisco 12000 シリーズ インターネット ルータでの DTS 注記

12000 シリーズでは、ファスト スイッチングとプロセス スイッチングはオプションではありません。 インバウンド ライン カード(LC)のテーブルで転送エントリへの宛先プレフィクスの解決ができない場合、そのパケットは廃棄されます。 グリーニング隣接関係に一致するパケットだけが、Gigabit Routing Processor(GRP; ギガバイト ルーティング プロセッサ)にパントされます。 さらに 12000 では、LC CPU では機能に関して GRP へのパケットのパントは行われず、LC からは Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)の到達不能が送信されます(no ip unreachables コマンドが設定されていない場合)。 12000 では、GRP にパントされるトラフィックは、ルータ上のインターフェイスを宛先とするパケットまたはルータを送信元とするパケットだけです。 詳細情報は「エンジン タイプ別の QoS 機能」をご覧ください。

DTS の設定

VIP ベースのフレーム リレー インターフェイスに DTS を設定するには、最初の 2 つのステップを使用します(7500 シリーズ)。
  1. 次のコマンドで dCEF をイネーブルにします。
  2. router(config)#ip cef distributed
  3. 分散スイッチングでフレーム リレー インターフェイスがイネーブルにされていることを確認します。
router(config-if)# interface serial 2/0/0
 router(config-if)# ip route-cache distributed
router#show ip interface serial 2/0/0
 Serial8/0/0 is up, line protocol is up
   Internet address is 64.0.0.2/24
   Broadcast address is 255.255.255.255
   ICMP redirects are always sent
   ICMP unreachables are always sent
   ICMP mask replies are never sent
   IP fast switching is enabled
   IP fast switching on the same interface is disabled
   IP Flow switching is disabled
   IP CEF switching is enabled
   IP Distributed switching is enabled
   IP Fast switching turbo vector
   IP CEF switching with tag imposition turbo vector
   IP multicast fast switching is enabled
   IP multicast distributed fast switching is disabled
   IP route-cache flags are Fast, Distributed, CEF
   Router Discovery is disabled
   IP output packet accounting is disabled
  1. トラフィック クラスの作成(必須)
  2. DTS を使用するトラフィック ポリシーの作成(必須)
  3. サービス ポリシーの付加と DTS のイネーブル(必須)
  4. DTS のモニタリングと保守(オプション)

トラフィック クラスの作成

モジュラ QoS CLI を使用して機能をイネーブルにする最初のステップは、トラフィック クラスの作成です。
 

  コマンド 目的
ステップ 1 
Router(config)# class-map [match-any | match-all] class-name
 
名前と、基準の一部またはすべてが一致して構成するかを指定します。

モジュラ QoS CLI に関する情報、およびトラフィック クラスを作成する手順は『モジュラ QoS CLI インターフェイス概要』と参照してください。

DTS を使用するトラフィック ポリシーの作成 

DTS をイネーブルにするには、トラフィック ポリシーを設定する必要があります。 ルータに定義されたクラスの数だけ、最大で 256 までトラフィック ポリシーを設定できます。

トラフィック ポリシーを設定するには、policy-map コマンドを使用して、まずグローバル設定モードでトラフィック ポリシー名を指定します。次に、ポリシーマップ設定モードで下の表の設定コマンドを使用して、トラフィック クラス名とトラフィック シェーピングを設定します。

トラフィック ポリシーでポリシーが定義された他のどのクラスとも一致基準が合わない場合、トラフィックはトラフィック ポリシーのデフォルト クラスに誘導されます。
 

  コマンド 目的
ステップ 1 
Router(config)# policy-map 
 policy-name
 
作成するトラフィック ポリシーの名前を指定します。
ステップ 2 
Router(config-pmap)# class class-name 
 
 
トラフィック ポリシーに含まれる事前定義トラフィック クラスの名前を指定します。 このプロセスの前のステップで、このクラスが定義されています。
ステップ 3 
Router(config-pmap-c)# shape 
 <average | peak> <meanrate>[<burst size> [<excess 
 burst size>]]
ターゲットの bps レートを指定します。

サービス ポリシーの付加と DTS のイネーブル 

インターフェイス、サブインターフェイス、またはマップクラスにトラフィック ポリシーを付加して、インターフェイスで DTS をイネーブルにするには、インターフェイス(またはマップクラス)設定モードで次のコマンドを使用します。 フレームリレー マップ クラスにサービス ポリシーを適用するには、dLLQ と FRF.12 の適用を強く推奨します。

フラグメンテーションに関する詳細は「FRF.12 および DTS」を参照してください。
 

コマンド 目的
Router(config-if)# service-policy output policy-name
* APPLY TO FR MAP-CLASS for llq and fragmentation
DTS をイネーブルにして、インターフェイスまたはマップクラスに指定のトラフィック ポリシーを付加します。

DTS のモニタリングと保守

DTS 機能のモニタリングと保守には、必要に応じて EXEC モードで次のコマンドを使用します。

QoS に関する追加のモニタリング コマンドは、『show policy-map interface』を参照してください。
 

コマンド 目的
Router# show interface [interface-name] shape
 
トラフィック シェーピングの詳細ステータスを表示します。
Router# show policy policy-name
 
指定されたトラフィック ポリシーを構成するすべてのクラスの設定を表示します。
Router# show policy policy-name class class-name
 
指定されたトラフィック ポリシーの指定クラスの設定を表示します。

設定例

メイン インターフェイスの DTS
次の例では、インターフェイス pos1/0/0 から出力されるトラフィックが 10 Mbps のレートでシェーピングされます。
router(config)# class-map class-interface-all
 router(config-cmap)# match any
 router(config-cmap)# exit
 router(config)# policy-map DTS-interface-all-action
router(config-pmap)# class class-interface-all
 router(config-pmap-c)# shape average 10000000 
 router(config-pmap-c)# exit
 router(config)# interface pos1/0/0
 router(config-if)# service-policy output DTS-interface-all-action
 
メイン インターフェイスのクラスベース DTS

次の例では、2 つのクラスが作成され、アクセス リスト番号に基づいて一致基準が定義されます。 インターフェイス fdi4/0/0 から出力され、アクセス リスト 10 の基準に一致するトラフィックが 16 Mbps にシェーピングされます。 アクセス リスト 20 の基準に一致するトラフィックが 8 Mbps にシェーピングされます。

注:次の IP アドレスは単なる例です。

router(config)# access-list 10 permit 171.69.0.0
 router(config)# access-list 20 permit 192.168.0.0
 router(config)# class-map class1
 router(config-cmap)# match access-group 10
 router(config-cmap)# exit
 router(config)# class-map class2
 router(config-cmap)# match access-group 20
 router(config-cmap)# exit
 router(config)# policy-map DTS-interface-class-action
router(config-pmap)# class class1
 router(config-pmap-c)# shape average 16000000
 router(config-pmap-c)# exit
 router(config-pmap)# class class2
 router(config-pmap-c)# shape average 8000000
 router(config-pmap-c)# exit
 router(config-pmap)# interface fd4/0/0
 router(config-if)# service-policy output DTS-interface-class-action
追加設定例』を参照してください。

問題を識別するツール

フレーム リレーのカプセル化が設定された VIP インターフェイスは、トラフィックを通過させている際にサービスポリシーが適用されると、バス エラーでクラッシュする可能性があります。 この問題は Cisco IOS ソフトウェアのさまざまなバージョンで解決されています(Cisco Bug ID CSCdt88568)。 この DDTS と追加の不具合に関する詳細は、シスコの TAC ToolsBug Toolkit を参照してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。



ツール情報

追加リソースについては、シスコの TAC Tools for Access-Dial Technologies を参照してください。

関連情報

関連トピック

その他のドキュメント


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 22600