スイッチ : Cisco Nexus 1000V シリーズ スイッチ

Nexus 1000V シリーズ スイッチ ポートチャネル の 設定例

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

この資料は Cisco Nexus 1000V シリーズ スイッチ(N1KV)のポート チャネルを配置するとき使用する最良 の 方法を記述したものです。 N1KV はホスト毎に複数のインターフェイスが含まれているポート プロファイルのためにポート チャネルを必要とします。

著者:Cisco TAC エンジニア、Carlos Lopez および Matthew Wronkowski

前提条件

要件

次の項目に関する知識があることが推奨されます。

  • N1KV
  • Cisco Unified Computing System (UCS)
  • Cisco Nexus および Catalyst シリーズ スイッチ

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • N1KV
  • UCS

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

設定

このセクションはこれらのコンフィギュレーションが含まれています:

エンドホスト モードの UCS B シリーズ サーバの N1KV

Cisco UCS はブレードとアップストリーム ネットワーク間の 2 つのダイバース なパスを使用します。 現在、ファブリック Interconnects ブレードの方にサポート リンク 集約 制御プロトコル(LACP) /Virtual ポート チャネル(vPC)サウスバウンド。 これは N1KV 観点からの静的ポート チャネルが使用する必要があることを意味します。 アップストリーム スイッチがマルチシャーシ EtherChannel をサポートしないので、MAC ピンで止めることが必要となります。

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on mac-pinning
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream switch configuration
-None required

vPC と Nexus 5000/7000 スイッチに接続される UCS Cシリーズ サーバまたはラックマウント サーバの N1KV

このトポロジーでは、各ラック サーバは各スイッチに 2 つの異なる Nexus スイッチに物理的に- 1 ケーブル接続されます。 LACP はリンクの最もよいトラフィック ディストリビューションおよび非破壊的な付加/減算を可能にするので、望ましいモードです。 アップストリーム Nexus スイッチに既に設定される vPC ピア リンクがあっていることが仮定されます。

# VSM configuration
feature lacp
lacp offload
port-channel load-balance ethernet source-mac
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode active
no shutdown
system vlan 100,101,102,103
state enabled

# Nexus 5k/7k switches #1 & #2 configuration
interface port-channel1000
switchport mode trunk
vpc 1000
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable

no lacp suspend-individual <- Nexus 7k only!!!
!
interface Ethernet1/11
description ESX-Host1
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active

vPC なしでスイッチに接続される UCS Cシリーズ サーバまたはラックマウント サーバの N1KV

このトポロジーでは、各ラック サーバは 2 つの異なるスイッチに物理的に接続されますが、vPC は利用できません。 唯一のサポートされる構成は MAC ピンで止めることです。 この設定は UCS B シリーズ サーバで使用されるそれと同一です。 アップストリーム スイッチがマルチシャーシ イーサチャネル技術をサポートしないので、静的ポート チャネル(モード)はサポートされません。

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on mac-pinning
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream switch configuration
-None required

6500 VSS またはスタッキング スイッチに接続される UCS Cシリーズ サーバまたはラックマウント サーバの N1KV

このトポロジーでは、アップストリーム スイッチは単一 シャーシとして機能します。 これは N1KV が LACP と接続するようにします。

# VSM configuration
feature lacp
lacp offload
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode active
no shutdown
system vlan 100,101,102,103
state enabled

# 6500 VSS configuration
interface Port-channel1000
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
!
interface GigabitEthernet1/1/1
description ESX-Host1 adapter 1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active
!
interface GigabitEthernet2/1/1
description ESX-Host1 adapter 2
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active

静的ポート チャネルと単一アップストリーム スイッチに接続される UCS Cシリーズ サーバまたはラックマウント サーバの N1KV

このトポロジーでは、サーバはアップストリーム スイッチに単一ホームです。 このトポロジーはスイッチ 冗長性を提供しないし、最良 の 方法ではないです。

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream Nexus switch
interface port-channel 1000
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
!
interface Ethernet1/11
description ESX-Host1
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode on

確認

このセクションでは、設定が正常に機能していることを確認します。

show run interface po{X} membership
show port-channel summary

トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つ情報を提供します。

show port-channel summary
show port-channel internal event-history [all|errors]debug lacp all


Document ID: 116739