ワイヤレス / モビリティ : ワイヤレス LAN(WLAN)

Cisco Autonomous Access Points バージョン 15.2(4) JA 上の WDS でのローカル RADIUS サーバ設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

このドキュメントでは、ローカル RADIUS サーバを使用した Autonomous アクセス ポイント(AP)でワイヤレス ドメイン サービス(WDS)を設定する方法について説明します。 このドキュメントは、新しい GUI による設定を中心に説明しますが、コマンドライン インターフェイス(CLI)での設定についても説明します。

著者:Cisco TAC エンジニア、Maithri B および Surendra BG

前提条件

要件

Autonomous AP 上の GUI と CLI での基本的な設定に関する知識があることが推奨されます。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Autonomous AP IOS® ソフトウェア リリース 15.2(4)JA1 上の Cisco 3602e シリーズ アクセス ポイント。 このデバイスは、WDS AP およびローカル RADIUS サーバとして機能します。
  • Autonomous AP IOS ソフトウェア リリース 15.2(4)JA1 上の Cisco 2602i シリーズ アクセス ポイント。 このデバイスは、WDS クライアント AP として機能します。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

設定

: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

GUI の設定

SSID の作成

この手順では、新しいサービス セット ID(SSID)を作成する方法について説明します。

  1. 新しい SSID を作成するには、[Security] > [SSID Manager] に移動し、[NEW] をクリックします。

    116597-config-wds-radius-01.png

  2. SSID で Extensible Authentication Protocol(EAP)認証を設定します。

    116597-config-wds-radius-02.png

  3. 目的の暗号化レベルを設定します。 この例では、Wi-Fi Protected Access 2(WPA2)を使用します。

    116597-config-wds-radius-03.png

  4. [Apply] をクリックして、設定を保存します。

  5. [Security] > [Encryption Manager] に移動し、必要な暗号化方式を選択します。

    116597-config-wds-radius-04.png

WDS AP 上のローカル RADIUS サーバの設定

この手順では、WDS AP 上でローカル RADIUS サーバを設定する方法について説明します。

  1. [Security] > [Server Manager] に移動し、ローカル RADIUS として WDS AP Bridge Virtual Interface(BVI)IP を追加し、共有秘密を追加します。

    116597-config-wds-radius-05.png

  2. [Security] > [Local Radius Server] > [General Set-Up] タブに移動します。 使用する EAP プロトコルを定義します。 この例では、Light Extensible Authentication Protocol(LEAP)認証を有効にします。

    116597-config-wds-radius-06.png

  3. また、ネットワーク アクセス サーバ(NAS)の IP とクライアントのユーザ名およびパスワード クレデンシャルを同じページ上で追加することもできます。 これで、WDS AP 上でのローカル RADIUS の設定は完了です。

    116597-config-wds-radius-07.png

WDS クライアント AP 上のローカル RADIUS サーバの設定

この図では、WDS AP の IP アドレスを RADIUS サーバとして設定する方法を示します。

116597-config-wds-radius-08.png

これでどちらの AP も LEAP 認証用の SSID を使用して設定され、WDS サーバはローカル RADIUS として機能します。 外部 RADIUS に対しても同じ手順を使用します。 変わるのは RADIUS サーバの IP のみです。

WDS AP 上の WDS の有効化

この手順では、WDS AP で WDS を有効にする方法について説明します。

  1. [Wireless] > [WDS] > [General Set-Up] タブに移動し、[Use this AP as Wireless Domain Services] チェック ボックスをオンにします。 これにより AP 上で WDS サービスが有効になります。

  2. 複数の WDS AP があるネットワークでは、プライマリ WDS とバックアップ WDS を定義するために、[Wireless Domain Services Priority] オプションを使用します。 値の範囲は 1 ~ 255 であり、255 の優先順位が最も高くなります。

    116597-config-wds-radius-09.png

  3. 同じページの [Server Groups] タブに移動します。 すべての WDS クライアント AP を認証するインフラストラクチャ サーバ グループ リストを作成します。 WDS AP のローカル RADIUS サーバをこの目的で使用できます。 ローカル RADIUS サーバはすでに追加されているため、ドロップダウン リストに表示されます。

    116597-config-wds-radius-10.png

  4. [Use Group For:] の [Infrastructure Authentication] オプション ボタンを有効にし、[Apply] をクリックして設定を保存します。

  5. WDS AP のユーザ名とパスワードを、ローカル RADIUS サーバ リストに追加できます。

WDS クライアント AP 上の WDS の有効化

この手順では、WDS クライアント AP で WDS を有効にする方法について説明します。

  1. [Wireless] > [AP] に移動し、[Participate in SWAN Infrastructure] チェック ボックスをオンにします。 SWAN は Structured Wireless-Aware Network の略です。

    116597-config-wds-radius-11.png

  2. WDS クライアント AP は、WDS AP を自動検出できます。 または、[Specified Discovery] テキスト ボックスに、クライアント登録用の WDS AP の IP アドレスを手動で入力できます。

    また、WDS AP 上で設定されたローカル RADIUS サーバでの認証用に、WDS クライアントのユーザ名とパスワードを追加することもできます。

CLI の設定

WDS AP

次に示すのは WDS AP の設定例です。

Current configuration : 2832 bytes
!
! Last configuration change at 05:54:08 UTC Fri Apr 26 2013
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname MAIB-WDS-AP
!
!
logging rate-limit console 9
enable secret 5 $1$EdDD$dG47yIKn86GCqmKjFf1Sy0
!
aaa new-model
!
!
aaa group server radius rad_eap
server name Local-Radius
!
aaa group server radius Infrastructure
server name Local-Radius
!
aaa authentication login eap_methods group rad_eap
aaa authentication login method_Infrastructure group Infrastructure
aaa authorization exec default local
!
!
!
!
!
aaa session-id common
no ip routing
no ip cef
!
!
!
!
dot11 syslog
!
dot11 ssid WDS-EAP
authentication open eap eap_methods
authentication network-eap eap_methods
authentication key-management wpa version 2
guest-mode
!
!
dot11 guest
!
!
!
username Cisco password 7 13261E010803
username My3602 privilege 15 password 7 10430810111F00025D56797F65
!
!
bridge irb
!
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption mode ciphers aes-ccm
!
ssid WDS-EAP
!
antenna gain 0
stbc
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
no ip address
no ip route-cache
!
encryption mode ciphers aes-ccm
!
ssid WDS-EAP
!
antenna gain 0
peakdetect
dfs band 3 block
stbc
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface GigabitEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface BVI1
ip address 10.106.54.146 255.255.255.192
no ip route-cache
ipv6 address dhcp
ipv6 address autoconfig
ipv6 enable
!
ip forward-protocol nd
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip radius source-interface BVI1
!
!
radius-server local
no authentication eapfast
no authentication mac
nas 10.106.54.146 key 7 045802150C2E1D1C5A
user WDSClient1 nthash 7
072E776E682F4D5D35345B5A227E78050D6413004A57452024017B0803712B224A
!
radius-server attribute 32 include-in-access-req format %h
radius-server vsa send accounting
!
radius server Local-Radius
address ipv4 10.106.54.146 auth-port 1812 acct-port 1813
key 7 060506324F41584B56
!
bridge 1 route ip
!
!
wlccp authentication-server infrastructure method_Infrastructure
wlccp wds priority 254 interface BVI1
!
line con 0
line vty 0 4
transport input all
!
end

WDS クライアント AP

次に示すのは WDS クライアント AP の設定例です。

Current configuration : 2512 bytes
!
! Last configuration change at 00:33:17 UTC Wed May 22 2013
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname MAIB-WDS-Client
!
!
logging rate-limit console 9
enable secret 5 $1$vx/M$qP6DY30TGiXmjvUDvKKjk/
!
aaa new-model
!
!
aaa group server radius rad_eap
server name WDS-Radius
!
aaa authentication login eap_methods group rad_eap
aaa authorization exec default local
!
!
!
!
!
aaa session-id common
no ip routing
no ip cef
!
!
!
!
dot11 syslog
!
dot11 ssid WDS-EAP
authentication open eap eap_methods
authentication network-eap eap_methods
authentication key-management wpa version 2
guest-mode
!
!
dot11 guest
!
eap profile WDS-AP
method leap
!
!
!
username Cisco password 7 062506324F41
username My2602 privilege 15 password 7 09414F000D0D051B5A5E577E6A
!
!
bridge irb
!
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption mode ciphers aes-ccm
!
ssid WDS-EAP
!
antenna gain 0
stbc
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
no ip address
no ip route-cache
!
encryption mode ciphers aes-ccm
!
ssid WDS-EAP
!
antenna gain 0
peakdetect
dfs band 3 block
stbc
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface GigabitEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface BVI1
ip address 10.106.54.136 255.255.255.192
no ip route-cache
ipv6 address dhcp
ipv6 address autoconfig
ipv6 enable
!
ip forward-protocol nd
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip radius source-interface BVI1
!
!
radius-server attribute 32 include-in-access-req format %h
radius-server vsa send accounting
!
radius server WDS-Radius
address ipv4 10.106.54.146 auth-port 1812 acct-port 1813
key 7 110A1016141D5A5E57
!
bridge 1 route ip
!
!
wlccp ap username WDSClient1 password 7 070C285F4D06485744
wlccp ap wds ip address 10.106.54.146
!
line con 0
line vty 0 4
transport input all
!
end

確認

ここでは、設定が正常に動作していることを確認します。 設定が完了すると、WDS クライアント AP を WDS AP に登録できます。

WDS AP では、WDS のステータスが Registered と表示されます。

116597-config-wds-radius-12.png

WDS クライアント AP では、WDS のステータスが Infrastructure になります。

116597-config-wds-radius-13.png

アウトプット インタープリタ ツール登録ユーザ専用)は、特定の show コマンドをサポートしています。 show コマンド出力の分析を表示するには、アウトプット インタープリタ ツールを使用してください。

WDS AP 上の CLI 検証出力

次の手順は、WDS AP の設定を確認する方法を示しています。

MAIB-WDS-AP#sh wlccp wds ap

HOSTNAME MAC-ADDR IP-ADDR IPV6-ADDR STATE
MAIB-WDS-Client f872.ea24.40e6 10.106.54.136 :: REGISTERED

MAIB-WDS-AP#sh wlccp wds statistics

WDS Statistics for last 10:34:13:
Current AP count: 1
Current MN count: 0
AAA Auth Attempt count: 2
AAA Auth Success count: 2
AAA Auth Failure count: 0
MAC Spoofing Block count: 0
Roaming without AAA Auth count: 0
Roaming with full AAA Auth count:0
Fast Secured Roaming count: 0
MSC Failure count: 0
KSC Failure count: 0
MIC Failure count: 0
RN Mismatch count: 0

WDS クライアント AP 上の CLI 検証出力

次の手順は、WDS クライアント AP の設定を確認する方法を示しています。

MAIB-WDS-Client#sh wlccp ap

WDS = bc16.6516.62c4, IP: 10.106.54.146 , IPV6: ::
state = wlccp_ap_st_registered
IN Authenticator = IP: 10.106.54.146 IPV6: ::
MN Authenticator = IP: 10.106.54.146 IPv6::

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 116597