Cisco IOS と NX-OS ソフトウェア : Cisco IOS Embedded Event Manager(EEM)

PfR 転送ループを検出する、クリアするのに使用される EEM アプレット

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

この資料はパフォーマンス ルーティング(PfR)が複数のボーダー中継(BRs)を通してトラフィックを最適化するネットワークで使用する組み込みイベント マネージャ(EEM)アプレットを記述したものです。 いくつかの転送ループはまた観察されます。 アプレットはループが収集し観察される、転送ループの影響を使用されますときデータを軽減するために。

Fabrice Ducomble および Atri Basu によって貢献される、Cisco TAC エンジニア。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

EEM バージョン 4.0 をサポートするこの文書に記載されている情報は Cisco IOS ® ソフトウェアに基づいています

Cisco IOS リリースによってサポートされる EEM バージョンをチェックするためにこのコマンドを使用して下さい:

Router#sh event manager version | i Embedded
Embedded Event Manager Version 4.00
Router#

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

背景説明

PfR はトラフィック クラス(TC)を制御する時、BRs のダイナミックルート ルート・マップ/Access Control List (ACL)を作成します。 他の BRs のルート マップは内部 インターフェース(ネクスト・ホップ = 指定 BR)を指定するが、『Exit』 を選択 されるへの『Exit』 を選択 されたポイントが付いている BR のルート マップ。

    

問題はダイナミック ACL が別の BRs の間できちんと同期化されないとき発生します(バグに、たとえばよる)。

このピクチャでは、フォーカスは送信される DSCP EF と 172.16.1.0/24 に IP パケットを一致させる TC にあります。 このシナリオでは、関連 ACL項目は指定 BR (BR2)から、ない BR-1 から取除かれます。 すべての IP パケットと一致する向かうプレフィクス エントリが付いている BR2 のその TC ヒットのパケット 172.16.1.0/24 に。 プレフィクス エントリのために『Exit』 を選択 される BR-1 へ Exit-1、そう BR2 ポイントの関連ルート マップ /ACL です。

   

その TC のパケットは BRs の間で今 Time To Live (TTL)が 0 に達するまでループします。

この資料は使用される必要な EEM アプレットを提供したものです:

  • BRs 間の転送ループを検出する
  • 関連情報を収集し、PfR をクリアして下さい

コンボ主幹制御器(MC)の場合には /BR 使用されるアプレットは(MC が BRs の 1 つで動作するとき)もっと簡単です。 専用 MC のシナリオはまたカバーされます。

EEM アプレット 詳細

このセクションはこのプロセスに使用する Access-list、またアプレット ログファイルを説明します。

使用される Access-list

転送ループを検出するために、アプレットは ACL に下位 TTL のパケットを一致するために頼ります。

: TTL で一致する ACL は集約サービス ルータ(ASR) 1000 シリーズ バージョン 3.7s (15.2(4)S)およびそれ以降でサポートされます。

TTL 値、比較的低い連続した一致する使用するために、2x で ACE を推奨します(20 はその各パケットのために 21) 1 つ(および 1 だけ得るため) BRs 間のループを見つけ。 使用される TTL 値はトレースルート パケットからの頻繁なヒットを避けるには余りにも低くないはずです。

interface gig0/0 (internal interface)
 ip access-group LOOP in
!
ip access-list extended LOOP
 permit ip 10.116.48.0 0.0.31.255 any ttl range 20 21
 permit ip any any

ACL は提示 pfr マスター ボーダー トポロジー コマンド 出力に報告される内部 インターフェースに置く必要があります。

ソース IP 範囲(ここに 10.116.48.0/20)は内部ネットワーク(内部 インターフェースによって到達可能プレフィックス)を一致する必要があります。

: 1 つのアクセス リストエントリ(ACE)で内部ネットワークをサマライズできなければ複数の ACE を使用できます; ただし複数の行のヒット カウントをチェックするために、スクリプトはわずかに修正される必要があります。

: auto-tunnel 機能はオフになる必要があります(PfR マスター モードのモード auto-tunnel 無し)。 BRs が直接接続されない場合、手動一般的ルーティングカプセル化は作成されるトンネルインターフェイスに置く必要があり、ACL。

識別するためにリモート site/TC がループによって影響を与えられる、各々のリモート site/TC のための特定の ACE のインターフェイスに第 2 ACL 発信を、追加できます。

interface gig0/0 (internal interface)
 ip access-group LOOP-DETAIL out

!
ip access-list extended LOOP-DETAIL

permit ip 10.116.48.0 0.0.31.255 10.116.132.0 0.0.0.255 ttl range 20 21
permit ip 10.116.48.0 0.0.31.255 10.116.128.0 0.0.0.255 ttl range 20 21
  .... (add here one line per remote site)
permit ip any an

宛先IP は異なるリモートサイトのサブネットと一致します:

10.116.132.0/24 -> site-1
10.116.128.0/24 -> site-2

ループによって影響を与えられる正確な TC を識別する必要がある場合またリモートサイトごとの複数の行を追加できます。

アプレット義務

アプレットは ACL ループの TTL で一致する ACE 30 秒毎にの hitcounts をチェックします。 これらのチェックの結果に基づいて、アプレットはこれらのタスクを行うかもしれません:

  • hitcounts が設定された閾値(THRESHOLD_1)を超過すれば、アプレットは ACL 数をクリアし、15 秒の hitcounts を再確認します。
  • 15 秒後に、hitcounts が秒しきい値(THRESHOLD_2)の上にある場合、ループがあるかもしれません。 一組の出力を集め、ループ問題を解決するために PfR をクリアして下さい。 
  • 第 2 しきい値はグローバル 変数と定義されます、従ってアプレット 再始動なしで容易に調整されます。
  • これらのしきい値の最適値は TC ごとの平均パケット レートによって主に決まります。

アプレット ログファイル

アプレットは(THRESHOLD_1 および THRESHOLD_2 が両方超過するとき) hitcounts の数を把握するログファイルを維持し(数が 0)より大きい、一時的なループ(THRESHOLD_1 がない THRESHOLD_2 超過するが、とき)または実質ループの遭遇とき。

コンボ MC/BR および他の BR シナリオのためのアプレット

これらはこの資料に説明がある最も簡単なシナリオです。 ループ 検出および PfR 消去は同じデバイスで、そうそこにですデバイス EEM アプレット通信を入力する必要行われません。 別途のアプレットはコンボ MC/BR および他の BRs で動作します。

コンボ MC/BR のアプレット

この出力はコンボ MC/BR で使用されるアプレットのための重要な情報を表示するものです。 この特定の出力に関するいくつかの注記はここにあります:

  • THRESHOLD_1 のために表示される値は 1000 であり、THRESHOLD_2 のために表示される値は 500 です。 これはループによって影響を与えられる TC の比率が 1000/30 より高い場合アプレットが起動することを意味します(33 pps)。
  • ディスク 変数はログおよび出力 ファイルがどこに押されるか識別します(ここにブートフラッシュで示されていて)。
  • ログファイルのエントリのタイムスタンプは show clock コマンド出力から得ます。 中央の文字は(「米国東部標準時刻」としてここに示されているタイムゾーンによって)決まり、調節する必要があります(操作を 240)参照して下さい。
  • ループの場合には集める必要がある出力は「xxxxxx」が 1970 年以来の秒数であるブートフラッシュのスクリプト出力xxxxxxx ファイルで押されます、(各ループ 発生の一意のファイル名前を作るのに使用される)。
  • 集められるコマンドは操作 330、340、350、および 360 にリストされています。 いくつかのそれ以上/異なるコマンドは追加することができます。
event manager environment THRESHOLD_1 1000
event manager environment THRESHOLD_2 500
event manager environment DISK bootflash

!
event manager applet LOOP-MON authorization bypass
 event timer watchdog name LOOP time 30
 action 100 cli command "enable"
 action 110 cli command "show ip access-list LOOP"
 action 120 set regexp_substr 0
 action 130 regexp "range 20 21 \(([0-9]+) matches\)"
 $_cli_result _regexp_result regexp_substr
 action 140 cli command "clear ip access-list counters LOOP"
 action 150 if $regexp_substr gt 0
 action 200 set MATCHES $regexp_substr
 action 210 file open LOGS $DISK:script-logs.txt a
 action 220 cli command "enable"
 action 230 cli command "show clock"
 action 240 regexp "[0-9]+:[0-9]+:[0-9]+.[0-9]+ est [A-Za-z]+
  [A-Za-z]+ [0-9]+ 201[0-9]" $_cli_result _regexp_result

 action 250 set TIME $_regexp_result
 action 260 if $MATCHES gt $THRESHOLD_1
 action 270 wait 15
 action 280 cli command "show ip access-list LOOP"
 action 290 set regexp_substr 0
 action 300 regexp "range 20 21 \(([0-9]+) matches\)"
  $_cli_result _regexp_result regexp_substr
 action 310 if $regexp_substr gt $THRESHOLD_2
 action 320 cli command "enable"
 action 330 cli command "show ip access-list LOOP-DETAIL
  | tee /append $DISK:script-output-$_event_pub_sec.txt"
 action 340 cli command "show pfr master traffic-class perf det
  | tee /append $DISK:script-output-$_event_pub_sec.txt"
 action 350 cli command "show route-map dynamic detail
  | tee /append $DISK:script-output-$_event_pub_sec.txt"
 action 360 cli command "show ip route
  | tee /append $DISK:script-output-$_event_pub_sec.txt"

 action 370 cli command "clear pfr master *"
 action 380 cli command "clear ip access-list counters LOOP-DETAIL"
 action 390 file puts LOGS "$TIME - LOOP DETECTED - PfR CLEARED -
  matches $MATCHES > $THRESHOLD_1 and $regexp_substr
> $THRESHOLD_2 - see $DISK:script-output-$_event_pub_sec.txt"
 action 400 syslog priority emergencies msg "LOOP DETECTED -
  PfR CLEARED - see $DISK:script-output-$_event_pub_sec.txt !"
 action 410 else
 action 420 file puts LOGS "$TIME - TEMPORARY LOOP : matches
  $MATCHES > $THRESHOLD_1 and $regexp_substr < or = $THRESHOLD_2"
 action 430 cli command "clear ip access-list counters LOOP-DETAIL"
 action 440 end
 action 450 else
 action 460 cli command "en"
 action 470 cli command "clear ip access-list counters LOOP-DETAIL"
 action 480 file puts LOGS "$TIME - number of matches =
  $MATCHES < $THRESHOLD_1"
 action 490 end
 action 500 else
 action 510 cli command "clear ip access-list counters LOOP-DETAIL"
 action 520 end

他の BRs のためのアプレット

このセクションは他の BRs に使用するアプレットを記述します。 この特定の出力に関するいくつかの注記はここにあります:

  • アプレットはコンボ MC/BR のスクリプトが 30 秒毎に実行する間、20 秒毎に実行します。 これは PfR が MC/BR で動作するアプレットによってクリアされる前に BR のアプレットが起動するようにします。
  • ユニークなしきい値はエラー陽性を避ける必要使用されませんでしたり、そうそこにです。
  • しきい値のために表示される値は 700、MC/BR アプレットの THRESHOLD_1 値に従って設定 する必要があります。
  • アプレット ログファイルは flash0script-logs.txt ファイルで押されます。 これは操作 170 およびディスク 変数で変更することができます。
  • ログファイルのエントリのタイムスタンプは show clock コマンド出力から得ます。 中央の文字は(「米国東部標準時刻」としてここに示されているタイムゾーンによって)決まり、調節する必要があります(操作を 190)参照して下さい。
  • ループの場合には集める必要がある出力は「xxxxxx」が 1970 年以来の秒数であるスクリプト出力xxxxxxx ファイルで押されます、(各ループ 発生の一意のファイル名前を作るのに使用される)。
  • 集められるコマンドは操作 230 および操作 240 にリストされています。 いくつかのそれ以上/異なるコマンドは追加することができます。
event manager environment THRESHOLD 700
event manager environment DISK flash 0

!
event manager applet LOOP-BR authorization bypass
  event timer watchdog name LOOP time 20
 action 100 cli command "enable"
 action 110 cli command "show ip access-list LOOP"
 action 120 set regexp_substr 0
 action 130 regexp "range 20 21 \(([0-9]+) matches\)"
  $_cli_result _regexp_result regexp_substr
 action 140 cli command "clear ip access-list counters LOOP"
 action 150 if $regexp_substr gt 0
 action 160  set MATCHES $regexp_substr
 action 170  file open LOGS $DISK:script-logs.txt a
 action 180  cli command "show clock"
 action 190  regexp "[0-9]+:[0-9]+:[0-9]+.[0-9]+
  est [A-Za-z]+ [A-Za-z]+ [0-9]+ 201[0-9]" $_cli_result _regexp_result

 action 200  set TIME $_regexp_result
 action 210  if $MATCHES gt $THRESHOLD
 action 220   cli command "enable"
 action 230   cli command "show route-map dynamic detail | tee /append
  $DISK:script-output-$_event_pub_sec.txt"
 action 240   cli command "show ip route | tee /append
  $DISK:script-output-$_event_pub_sec.txt"
 action 250   file puts LOGS "$TIME : matches = $MATCHES >
  $THRESHOLD - see $DISK:script-output-$_event_pub_sec.txt"
 action 260   syslog priority emergencies msg "LOOP DETECTED -
  Outputs captured - see $DISK:script-output-$_event_pub_sec.txt !"
 action 270  else
 action 280   file puts LOGS "$TIME : matches = $MATCHES < or = $THRESHOLD"
 action 290  end
 action 300 end  

専用 MC シナリオのためのアプレット

PfR ループ 検出および消去/統計収集は相互デバイス EEM アプレット通信を備えなければならないさまざまなデバイスで完了します。 デバイス間の通信はさまざまな方法で行われます。 この資料は IGP でアドバタイズされる専用ループバックの到達可能性をチェックするためにトラッキングされるオブジェクトによってデバイス通信を記述したものです。 イベントが検出するとき、オブジェクトがトラッキングされるオフラインになるときリモートデバイスのアプレットが起動するようにするループバックはシャットダウンされます。 交換される異なるループバック 情報 ニーズを使用できますもし違ったら。

アプレット通信

これらのアプレットおよび通信方法は使用されます:

アプレット名前か。何か。トリガーか。通信か。
LOOP-BRBRs

ループを検出するために ACL hitcounts をチェックして下さい

定期的締められた Loop100
LOOP-MCMC- PfR 情報を集めて下さい
-オフ PfR
トラック到達可能性 Loop100締められた Loop200
COLLECT-BRBRs情報の収集到達可能性 Loop200 をトラッキングして下さいnone


 

イメージはここにありますこれを説明する:

これはアプレットによって使用されるプロセスです:

  1. ループは BRs の LOOP-BR アプレットによって検出する。 ループが BR2 で最初に検出することが仮定されます。
  2. アプレットは BR2 の Loop100 を締め、情報は内部ゲートウェイ プロトコル(IGP)でアドバタイズされます。
  3. BR2 の Loop100 のためのトラッキングされたオブジェクトは MC でオフラインになり、LOOP-MC アプレットは開始します。 PfR は出力を集められますマスターし、MC のループバック 200 はシャットダウンされます。 情報は IGP でアドバタイズされます。 10 第 2 スリープ タイマーは始まります。
  4. MC の Loop200 のためのトラッキングされたオブジェクトは両方で BRs オフラインになります。 これは Br 仕様情報を収集する COLLECT-BR アプレットを引き起こします。
  5. スリープ タイマー(ステップは 3)始まり、MC は PfR をクリアします。

: オフラインになる PfR がクリアされる前に BR-1 がループを検出する、トラッキングされたオブジェクトは MC で無視されます(LOOP-MC アプレットは分を一度実行します)。

トラック オブジェクトおよびループバックを作成して下さい

このセクションはループバック(IP をアドバタイズされます IGP で確認して下さい)およびトラック オブジェクトを作成する方法を記述します。

オブジェクトをトラッキングして下さい

トラック オブジェクトを作成するとき留意するべきいくつかの重要な点はここにあります:

  • 単一トラック オブジェクトは MC の loopback200 をトラッキングするために使用される BRs で必要とされます、(これはデータ収集を引き起こします)。
  • 複数のトラック オブジェクトは MC で必要とされます:
    • トラック 1 および 2 は BR-1 および BR2 の loopback100 をトラッキングするためにそれぞれ使用されます。
    • BRs 間に接続上の問題があるとき)トラック 11 および 12 は BR-1 と BR2 間の接続をトラッキングするためにそれぞれ使用されます(PfR 消去を避けます。
    • 20 をトラッキングします論理的のおよびトラック 11 および 12 の間でトラッキングして下さい。 これはすべての BRs にその MC gets 到達可能性を確認するために使用されます。
  • トラック タイマー IP ルート値は 1秒に到達可能性 問題検出を高速化するために設定 されます(デフォルト値は 15 秒です)。 

BR-1

interface Loopback100
  ip address 10.100.100.1 255.255.255.255
!
track timer ip route 1
track 1 ip route 10.100.100.200 255.255.255.255 reachability

BR2

interface Loopback100
ip address 10.100.100.2 255.255.255.255
!
track timer ip route 1
track 1 ip route 10.100.100.200 255.255.255.255 reachability

MC

interface Loopback200
ip address 10.100.100.200 255.255.255.255
!
track timer ip route 1

track 1 ip route 10.100.100.1 255.255.255.255 reachability
track 2 ip route 10.100.100.2 255.255.255.255 reachability
track 11 ip route 10.116.100.1 255.255.255.255 reachability
track 12 ip route 10.116.100.2 255.255.255.255 reachability
track 20 list boolean and
 object 11
 object 12

BR および MC ループバック

LOOP-BR

このセクションは BRs のループバックを作成する方法を記述します。 留意するべきいくつかの注記はここにあります:

  • THRESHOLD_1 値は 1000 であり、THRESHOLD_2 値は 500 です。 これはループによって影響を与えられる TC の比率が 1000/30 より高い場合アプレットが起動することを意味します(33 p/s)。
  • アプレット ログファイルはブートフラッシュの script-detect-logs.txt ファイルで押されます。 これは操作 210 でおよびディスク 変数と変更されます。
  • ログファイルのエントリのタイムスタンプは sh clock 出力から得ます。 中央の文字は(「米国東部標準時刻として」示されているタイムゾーンによって)決まり、調整(240)操作を必要とします。
  • Loopback100 notifiy MC を閉じた後、5 秒を(IGP を確認することは情報を伝搬する時間があります)待ち、それを再開して下さい(370)操作
event manager environment THRESHOLD_1 100event manager environment 
  THRESHOLD_2 500event manager environment DISK bootflash

!event manager applet LOOP-BR authorization bypass

 event timer watchdog name LOOP time 30 maxrun 27
 action 100 cli command "enable"
 action 110 cli command "show ip access-list LOOP"
 action 120 set regexp_substr 0
 action 130 regexp "range 20 21 \(([0-9]+) matches\)"
  $_cli_result _regexp_result regexp_substr
 action 140 cli command "clear ip access-list counters LOOP"
 action 150 if $regexp_substr gt 0
 action 200  set MATCHES $regexp_substr
 action 210  file open LOGS $DISK:script-detect-logs.txt a
 action 220  cli command "enable"
 action 230  cli command "show clock"
 action 240  regexp "[0-9]+:[0-9]+:[0-9]+.[0-9]+
  est [A-Za-z]+ [A-Za-z]+ [0-9]+ 201[0-9]"
  $_cli_result _regexp_result

 action 250  set TIME $_regexp_result
 action 260  if $MATCHES gt $THRESHOLD_1
 action 270  wait 15
 action 280  cli command "show ip access-list LOOP"
 action 290  set regexp_substr 0
 action 300  regexp "range 20 21 \(([0-9]+) matches\)"
  $_cli_result _regexp_result regexp_substr
 action 310  if $regexp_substr gt $THRESHOLD_2
 action 320  cli command "enable"
 action 330  cli command "conf t"
 action 340  cli command "interface loop100"
 action 350  cli command "shut"
 action 360  file puts LOGS "$TIME - LOOP DETECTED - Message sent to MC -
  matches $MATCHES > $THRESHOLD_1 and $regexp_substr > $THRESHOLD_2"
 action 370  wait 5
 action 375  cli command "enable"
 action 380  cli command "conf t"
 action 390  cli command "interface loop100"
 action 400  cli command "no shut"
 action 410  else
 action 420  file puts LOGS "$TIME - TEMPORARY LOOP : matches $MATCHES >
$THRESHOLD_1 and $regexp_substr < or = $THRESHOLD_2"
 action 430  cli command "clear ip access-list counters LOOP-DETAIL"
 action 440  end
 action 450  else
 action 460  cli command "en"
 action 470  cli command "clear ip access-list counters LOOP-DETAIL"
 action 480  file puts LOGS "$TIME - number of matches =
  $MATCHES < $THRESHOLD_1"
 action 490  end
 action 500 else
 action 510  cli command "clear ip access-list counters LOOP-DETAIL"
 action 520 end

LOOP-MC

このセクションは MC のループバックを作成する方法を記述します。 留意するべきいくつかの注記はここにあります:

  • ratelimit 値はどの位の割りでによってアプレットが 60 という ratelimit 値と動作するか決まります(スクリプトは分最大値ごとに一度動作します)。 これは同じループが両方 BRs 検出するとき二度クリアする PfR を避けるために使用されます。
  • 操作 130 では、すべての BRs に到達可能性をチェックする 2 秒前に待って下さい。 これは MC と BRs 間の接続上の問題によって引き起こされる false positive を避けるためです。
  • 操作 240 では、PfR をクリアする前に Loopback200 をシャットダウンした 10 秒後待って下さい。 これは BRs はデータを収集する時間があることを確かめるためです。
event manage environment DISK bootflash
event manager applet LOOP-MC authorization bypass

event syslog pattern "10.100.100.[0-9]/32 reachability Up->Dow" ratelimit 60
action 100 file open LOGS $DISK:script-logs.txt a
 action 110 regexp "10.100.100.[0-9]" "$_syslog_msg" _regexp_result
 action 120 set BR $_regexp_result
 action 130 wait 2
 action 140 track read 20
 action 150 if $_track_state eq "up"
 action 160  cli command "enable"
 action 170  cli command "show clock"
 action 180  regexp "[0-9]+:[0-9]+:[0-9]+.[0-9]+
  est [A-Za-z]+ [A-Za-z]+ [0-9]+ 201[0-9]"
  "$_cli_result" _regexp_result
 action 190  set TIME "$_regexp_result"
 action 200  cli command "show pfr master traffic-class perf det
  | tee /append $DISK:script-output-$_event_pub_sec.txt"
 action 210  cli command "conf t"
 action 220  cli command "interface loop200"
 action 230  cli command "shut"
 action 240  wait 10
 action 250  cli command "conf t"
 action 260  cli command "interface loop200"
 action 270  cli command "no shut"
 action 280  cli command "end"
 action 290  cli command "clear pfr master *"
 action 300  file puts LOGS "$TIME - LOOP DETECTED by $BR -
  PfR CLEARED - see $DISK:script-output-$_event_pub_sec.txt"
action 310  syslog priority emergencies msg "LOOP DETECTED by $BR -
  PfR CLEARED - see $DISK:script-output-$_event_pub_sec.txt !"
 action 320 else
 action 330  file puts LOGS "$TIME - REACHABILITY LOST with
$BR - REACHABILITY TO ALL BRs NOT OK - NO ACTION"
 action 340 end

COLLECT-BR

このセクションは BR を集める方法を記述します。 アプレットは BR が Loopback200 に到達可能性を緩めるときで起動します(10.100.100.200) MC で。 集まるために使用されるコマンドは操作 120130、および 140 にリストされています。

event manager environment DISK bootflash
event manager applet COLLECT-BR authorization bypass

event syslog pattern "10.100.100.200/32 reachability Up->Dow" ratelimit 45
 action 100 file open LOGS $DISK:script-collect-logs.txt a
 action 110 cli command "enable"
 action 120 cli command "sh ip access-list LOOP-DETAIL |
tee /append $DISK:script-output-$_event_pub_sec.txt"
 action 130 cli command "show route-map dynamic detail
  | tee /append
$DISK:script-output-$_event_pub_sec.txt"
 action 140 cli command "show ip route | tee /append
  $DISK:script-output-$_event_pub_sec.txt"
 action 150 cli command "show clock"
 action 160 regexp "[0-9]+:[0-9]+:[0-9]+.[0-9]+ CET [A-Za-z]+ [A-Za-z]+
  [0-9]+ 201[0-9]" "$_cli_result" _regexp_result
 action 170 set TIME "$_regexp_result"
 action 180 file puts LOGS "$TIME - OUTPUTs COLLECTED -
  see $DISK:script-output-$_event_pub_sec.txt"

SYSLOG-MC

ループが検出するとき MC の syslog はここにあります:

MC#
*Mar  8 08:52:12.529: %TRACKING-5-STATE: 1 ip route 10.100.100.1/32
 reachability Up->Down
MC#
*Mar  8 08:52:16.683: %LINEPROTO-5-UPDOWN:
 Line protocol on Interface Loopback200, changed state to down
*Mar  8 08:52:16.683: %LINK-5-CHANGED: Interface Loopback200,
 changed state to administratively down
MC#
*Mar  8 08:52:19.531: %TRACKING-5-STATE: 1
 ip route 10.100.100.1/32 reachability Down->Up
MC#
*Mar  8 08:52:24.727: %SYS-5-CONFIG_I: Configured from console by
  on vty0 (EEM:LOOP-MC)
*Mar  8 08:52:24.744: %PFR_MC-1-ALERT: MC is inactive due to PfR
 minimum requirements not met;
 Less than two external interfaces are operational
MC#
*Mar  8 08:52:24.757: %HA_EM-0-LOG: LOOP-MC:
 LOOP DETECTED by 10.100.100.1 - PfR CLEARED
 - see unix:script-output-1362732732.txt !
MC#
*Mar  8 08:52:26.723: %LINEPROTO-5-UPDOWN:
 Line protocol on Interface Loopback200, changed state to up
MC#
*Mar  8 08:52:26.723: %LINK-3-UPDOWN: Interface Loopback200,
 changed state to up
MC#
*Mar  8 08:52:29.840: %PFR_MC-5-MC_STATUS_CHANGE: MC is UP
*Mar  8 08:52:30.549: %TRACKING-5-STATE: 2
 ip route 10.100.100.2/32 reachability Up->Down
MC#
*Mar  8 08:52:37.549: %TRACKING-5-STATE: 2
 ip route 10.100.100.2/32 reachability Down->Up
MC#

: これらのアプレットは 3つ以上と調整の BRs 使用することができます。



Document ID: 116206