ルータ : Cisco ASR 9000 シリーズ アグリゲーション サービス ルータ

XR L2VPN 設定 変換プロセスへの L2 スイッチングの設定

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

このドキュメントでは、Cisco IOS® レイヤ 2 スイッチング設定を Cisco IOS XR レイヤ 2 バーチャル プライベート ネットワーク(L2VPN)の設定に変換する方法について説明します。

著者:Cisco TAC エンジニア、Manuel Irizarry、David Powers および Samuel Milstead

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアに限定されるものではありませんが、L2VPN の設定にあたり、9000 シリーズ アグリゲーション サービス ルータ(ASR)に関連するイーサネット仮想回線(EVC)モデルを使用するハードウェアのバージョンに限定されます。 ASR 9000 シリーズ ルータは EVC モデルを使用し、Cisco IOS XR を実行する Carrier Routing System(CRS)ルータは使用しません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

背景説明

ASR 9000 シリーズ ルータは、レイヤ 2(L2)の設定、特に 802.1Q および 802.1AD の IEEE モデルに準拠していません。 代わりに、EVC モデル を使用しています。 EVC モデルによって、Cisco IOS XR は新しい方法で最新の 802.1Q VLAN タグを利用できます。 従来は、分類、VLAN、転送、および、MAC アドレス ルックアップの実行にどの Content Addressable Memory(CAM)テーブルを使用するかを VLAN タグが定義しています。 EVC モデルを使用すると、柔軟性が向上し、拡張性が高められ、このコンセプトから切り離されます。 EVC モデルは Cisco IOS の最大で 4,096 という VLAN 数制限を取り除きます。

EVC が使用するビルディング ブロック:

  • イーサネット フロー ポイント(EFP):物理またはバンドル インターフェイスにおいて、トラフィックの分類に使用されるレイヤ 2 の論理サブインターフェイスです。

  • EVC:L2 の単一インスタンスのエンドツーエンド表現です。 EFP は、ノード内の EVC のエンド ポイントとして定義されます。 複数の EVC が 1 つの物理インターフェイスをパス スルーできることから、EFP 設定は主に、そのインターフェイス上の特定の EVC に属するトラフィックを認識し、転送動作とその EVC 固有の機能を適用するために利用されます。

  • ブリッジ ドメイン(BD) :デバイス内部のイーサネット ブロードキャスト ドメインです。 ブロードキャスト ドメインから VLAN を分離できます。 BD には EFP の一対多マッピングがあります。 特定の EVC のノードの EFP はすべて、BD を使用してグループ化されます。 EFP が同じ BD に属し、同じ番号の BD であれば、EFP は、異なる VLAN 番号であってもトラフィックを受信します。

問題

ASR 9000 シリーズ ルータの Cisco IOS XR はイーサネット仮想回線(EVC)モデルを使用します。 EVC モデルには、トランク、VLAN インターフェイス、またはスイッチ仮想インターフェイス(SVI)の概念はありません。 Cisco IOS のトランク、VLAN インターフェイス、および SVI はサブインターフェイス、L2VPN BD、およびブリッジ仮想インターフェイス(BVI)で、Cisco IOS XR 設定に変換されます。 初めて Cisco IOS XR に移行する際、Cisco IOS ユーザによっては EVC モデルはなじみがない場合があります。

解決策

Cisco IOS XR の設定には、次の 3 つの手順を実行します。

  1. VLAN を表す l2transport オプションを使用して、インターフェイスまたはサブインターフェイスの設定によって EFP を作成します。

  2. EFP をグループ化するために BD を作成します。

  3. レイヤ 3(L3)SVI が必要な場合、その BD に属する L2 インターフェイスの基本的な L3 機能を提供するために、Cisco IOS の interface vlan の代わりに、Cisco IOS XR の interface BVI によって設定します。

: BVI インターフェイスは、VLAN タグをサポートしません。 そのため、BVI が EFP の入力トラフィックを処理できるように、VLAN タグは入力でポップされ、出力で追加される必要があります。 これは rewrite コマンドで実行します。

設定の変換

次に、Cisco IOS から Cisco IOS XR への設定変換方法の例を示します。

IOS 設定

interface GigabitEthernet3/13
switchport
switchport access vlan 4
speed 1000
duplex full
!
interface GigabitEthernet3/14
switchport
switchport access vlan 130
speed 1000
duplex full
!
interface GigabitEthernet3/15
switchport
switchport access vlan 133
speed 1000
duplex full
!
interface TenGigabitEthernet13/3
description IOS Trunk
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1*,4,130,133
switchport mode trunk
no ip address
!
interface Vlan 4
ip address 10.10.4.1 255.255.255.0

interface Vlan 130
ip address 10.10.130.1 255.255.255.0
!

*Vlan 1 is the native vlan

EFP インターフェイスを作成します。 Cisco IOS XR は、EFP および EVC 設定のための構造化 CLI を実装しています。 EFP を設定するには、次のインターフェイス コンフィギュレーション コマンドを使用します。

  • l2transport コマンド:このコマンドは、サブインターフェイス、物理ポート、またはバンドルポートの親インターフェイスを EFP として指定します。

  • encapsulation コマンド:VLAN 一致基準を指定するには、このコマンドを使用します。

  • rewrite コマンド:VLAN タグの書き換え基準を指定するには、このコマンドを使用します。

インターフェイス TenGigabitEhternet 13/3(トランク ポート)の ASR 9000 の設定

interface GigabitEthernet 0/0/0/1
!
interface GigabitEthernet 0/0/0/1.1 l2transport
encapsulation dot1q untagged **
!

interface GigabitEthernet 0/0/0/1.4 l2transport
encapsulation dot1q 4
rewrite ingress tag pop 1 symmetric

interface GigabitEthernet 0/0/0/2
!
interface GigabitEthernet 0/0/0/2.130 l2transport
encapsulation dot1q 130
rewrite ingress tag pop 1 symmetric
!
interface GigabitEthernet 0/0/0/3
!
interface GigabitEthernet 0/0/0/3.133 l2transport
encapsulation dot1q 133
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0
!
interface tengig0/0/0/0.4 l2transport
no ip address
encapsulation dot1q 4
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0.130 l2transport
no ip address
encapsulation dot1q 130
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0.133 l2transport
no ip address
encapsulation dot1q 133
rewrite ingress tag pop 1 symmetric
!

ネイティブ VLAN 1 を登録するには、トラフィックのタグ付けを解除し、dot1q タグなしカプセル化で l2transport サブインターフェイスを作成します。 l2transport インターフェイスで、または IOS デバイスでポートがスイッチポート アクセスのポート設定に接続されている場合はサブインターフェイスで、encapsulation dot1q untagged コマンドを使用します。

次に例を示します。

IOS:

interface Gigabitethernet 1/1
switchport
switchport access vlan 3

IOSXR:

interfage GigabitEthernet 0/1/1/1.1 l2transport
encapsulation dot1q untagged

EFP を作成したら、BVI インターフェイスを作成して BD に追加できます。 BVI インターフェイスは、Cisco IOS のインターフェイス VLAN に対応するために使用されます。

interface BVI4
ipv4 address 10.10.4.1 255.255.0.0
!
interface BVI130
ipv4 address 10.130.1.1 255.255.0.0
!

BVI インターフェイス番号は、VLAN ID と一致させる必要はありません。 これは、L2 トランスポート インターフェイスのサブインターフェイス番号にも当てはまります。 ただし、わかりやすくするために、この例では、BVI 番号は dot1q タグと一致し、EFP のサブインターフェイス番号とも一致します。

この例では、EFP および BVI を一緒にブリッジするように、l2-VPN BD が作成されます。

l2vpn
bridge group VLAN4
bridge-domain VLAN4
interface ten0/0/0/0.4
!
interface GigabitEthernet 0/0/0/1.4
!
routed interface bvi4
!
!
bridge-domain VLAN130
interface ten0/0/0/0.130
!
interface GigabitEthernet 0/0/0/2.130
!
routed interface bvi130
!
!
bridge-domain VLAN133
interface ten0/0/0/0.133
!
interface GigabitEthernet 0/0/0/3.133
!
!
!
!

ブリッジ グループ(BG)は、いくつかの BD を同じ機能グループに結合する非機能的設定階層です。 これは、複数のドメインに対する 1 グループとは対照的に、ドメインに対する複数の個々のグループの作成として機能します。

同等のコマンド

次の表に、Cisco IOS で使用可能な他のコマンド、および BD で設定された Cisco IOS XR での同等のコマンドを記載します。

[IOS]IOS XR
switchport block unicast}flooding unknown-unicast disable
switchport port-security maximummac limit maximum(範囲 5 ~ 512000)
switchport port-security violationmac limit action(flood、no-flood、shutdown)mac limit notification(both、none、trap)
mac address-table notification mac-move次の設定が必要: mac secure action none mac secure logging
switchport port-security mac-addressinterface x mac limit max y static-mac-address H.H.H

関連情報



Document ID: 116500