ワイヤレス / モビリティ : ワイヤレス VLAN

CT5760 コントローラおよび Catalyst 3850 スイッチの設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

このドキュメントでは、5760 ワイヤレス LAN コントローラ(WLC)および 3850 スイッチでワイヤレス サービスをインストールおよび準備する手順について説明します。 このドキュメントでは、プラットフォームの両方の初期設定およびアクセス ポイント(AP)の加入プロセスについて説明します。

著者:Antoine KMEID および Serge Yasmine、Cisco TAC エンジニア

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • ユニファイド アクセス CT5760 ワイヤレス コントローラ - バージョン 3.02.02SE
  • ユニファイド アクセス Catalyst 3850 スイッチ - バージョン 3.02.02SE

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

ユニファイド アクセス CT5760 ワイヤレス コントローラの背景説明

CT5760 WLC は、次世代のユニファイド ワイヤレス アーキテクチャの集中型コントローラとして配布することを想定した、スマート ASIC が搭載された最初の Cisco IOS-XE® ソフトウェア ベースのコントローラです。 またこのプラットフォームは、Converged Access 3850 シリーズのスイッチを使用した、新しいモビリティ機能もサポートします。

通常は CT5760 コントローラがコアの近くに配置されます。 コア スイッチに接続されたアップリンク ポートが EtherChannel トランクのポートとして設定でき、ポートの冗長性を保障することができます。 この新しいコントローラは最大 1000 個のアクセス ポイント(AP)および 12,000 クライアントまで拡張可能な、高パフォーマンスのワイヤレス コントローラです。 このコントローラには、60 Gbps の合計容量の 6 台の 10 Gbps のデータ ポートがあります。

5760 シリーズは Cisco Aironet AP、Cisco Prime Infrastructure、および Cisco Mobility Services Engine と連動して、ビジネスに不可欠なワイヤレス データ、音声、ビデオ、およびロケーション サービス アプリケーションをサポートします。

116342-config-wlc-01.png

ユニファイド アクセス Catalyst 3850 スイッチの背景説明

Cisco Catalyst 3850 シリーズは、1 つのプラットフォームに有線とワイヤレスを完全統合した、エンタープライズクラスの次世代スタッカブル アクセス レイヤ スイッチです。 IOS XE ソフトウェアにより有効になったワイヤレス サービスは、Control and Provisioning of Wireless Access Points(CAPWAP)プロトコルでサポートされます。 Cisco の新しい Unified Access Data Plane(UADP; ユニファイド アクセス データ プレーン)ASIC はスイッチに電源を投入し、統一された有線およびワイヤレス ポリシーの適用、アプリケーションの可視性、柔軟性、およびアプリケーションの最適化を有効にします。 こうした統合のベースとなっているのが、新たに強化された Cisco StackWise-480 の復元力です。 Cisco Catalyst 3850 シリーズ スイッチは、フル IEEE 802.3at Power over Ethernet Plus(PoE+)、モジュラおよび現場交換可能なネットワーク モジュール、冗長ファン、および電源装置をサポートしています。

116342-config-wlc-02.png

5760 WLC の初期設定

このセクションでは、ワイヤレス サービスをホストするために 5760 WLC を正常に設定するための手順を説明します。

設定

セットアップ スクリプト

         --- System Configuration Dialog ---

Enable secret warning
----------------------------------
In order to access the device manager, an enable secret is required
If you enter the initial configuration dialog, you will be prompted for the
enable secret
If you choose not to enter the intial configuration dialog, or if you exit setup
without setting the enable secret,
please set an enable secret using the following CLI in configuration mode-
enable secret 0 <cleartext password>
----------------------------------

Would you like to enter the initial configuration dialog? [yes/no]: yes

At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.

Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system

Would you like to enter basic management setup? [yes/no]: yes

Configuring global parameters:

  Enter host name [Controller]: w-5760-1

  The enable secret is a password used to protect access to
  privileged EXEC and configuration modes. This password, after
  entered, becomes encrypted in the configuration.
  Enter enable secret: cisco

  The enable password is used when you do not specify an
  enable secret password, with some older software versions, and
  some boot images.
  Enter enable password: cisco

  The virtual terminal password is used to protect
  access to the router over a network interface.
  Enter virtual terminal password: cisco

Configure a NTP server now? [yes]:
Enter ntp server address : 192.168.1.200
Enter a polling interval between 16 and 131072 secs which is power of 2:16


  Do you want to configure wireless network? [no]: no

Setup account for accessing HTTP server? [yes]: yes
    Username  [admin]: admin
    Password  [cisco]: cisco
    Password is UNENCRYPTED.

  Configure SNMP Network Management? [no]: no

Current interface summary

Any interface listed with OK? value "NO" does not have a valid configuration

Interface             IP-Address      OK?   Method    Status     Protocol
Vlan1                  unassigned     NO    unset     up         up      
GigabitEthernet0/0    unassigned      YES   unset     up         up      
Te1/0/1               unassigned      YES   unset     up         up      
Te1/0/2               unassigned      YES   unset     down       down    
Te1/0/3               unassigned      YES   unset     down       down    
Te1/0/4               unassigned      YES   unset     down       down    
Te1/0/5               unassigned      YES   unset     down       down    
Te1/0/6               unassigned      YES   unset     down       down    

Enter interface name used to connect to the
management network from the above interface summary: vlan1

Configuring interface Vlan1:

Configure IP on this interface? [yes]: yes
    IP address for this interface: 192.168.1.20
    Subnet mask for this interface [255.255.255.0] : 255.255.255.0
    Class C network is 192.168.1.0, 24 subnet bits; mask is /24

Wireless management interface needs to be configured at startup
It needs to be mapped to an SVI that's not Vlan 1 (default)

Enter VLAN No for wireless management interface:  120
Enter IP address :192.168.120.94
Enter IP address mask: 255.255.255.0

次のコンフィギュレーション コマンド スクリプトが作成されました。

w-5760-1
enable secret 4 tnhtc92DXBhelxjYk8LWJrPV36S2i4ntXrpb4RFmfqY^Q
enable password cisco
line vty 0 15
password cisco
ntp server 192.168.1.200 maxpoll 4 minpoll 4
username admin privilege 15 password cisco
no snmp-server
!
no ip routing

!
interface Vlan1
no shutdown
ip address 192.168.1.20 255.255.255.0
!
interface GigabitEthernet0/0
shutdown
no ip address
!
interface TenGigabitEthernet1/0/1
!
interface TenGigabitEthernet1/0/2
!
interface TenGigabitEthernet1/0/3
!
interface TenGigabitEthernet1/0/4
!
interface TenGigabitEthernet1/0/5
!         
interface TenGigabitEthernet1/0/6
vlan 120
interface vlan 120
ip addr  192.168.120.94 255.255.255.0
exit
wireless management interface Vlan120
!
end


[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.

Enter your selection [2]: 2

Building configuration...
Compressed configuration from 2729 bytes to 1613 bytes[OK]
Use the enabled mode 'configure' command to modify this configuration.


Press RETURN to get started!

接続するアクセス ポイントに必要な設定

: 重要 - グローバル設定でスイッチに正しい boot コマンドがあることを確認します。 これがフラッシュで展開されていると、w-5760-1(config)#boot system flash: packages.conf boot コマンドが必要になります。

  1. ネットワーク接続を設定します。

    CAPWAP トラフィック フローがインバウンド/アウトバウンドのバックボーン ネットワークに接続された TenGig のインターフェイスを設定します。 この例では、使用するインターフェイスは TenGigabitEthernet1/0/1 です。 VLAN 1 と VLAN 120 が許可されます。

    interface TenGigabitEthernet1/0/1
    switchport trunk allowed vlan 1,120
    switchport mode trunk
    ip dhcp relay information trusted
    ip dhcp snooping trust

    デフォルト ルート アウトバウンドを次のように設定します。

    ip route 0.0.0.0 0.0.0.0 192.168.1.1
  2. Web アクセスを設定します。

    GUI は https:// <ipaddress>/wireless から入手できます。

    ログイン情報は、初期設定ダイアログですでに定義されています。

    username admin privilege 15 password cisco

    116342-config-wlc-03.png

  3. ワイヤレス管理インターフェイスが正しく設定されていることを確認します。
         wireless management interface Vlan120
         w-5760-1#sh run int vlan 120
         Building configuration...

         Current configuration : 62 bytes
         !
         interface Vlan120
         ip address 192.168.120.94 255.255.255.0
        end

      w-5760-1#sh ip int br
      Interface               IP-Address      OK?    Method   Status      Protocol

      Vlan1                   192.168.1.20   YES    manual    up          up
      Vlan120                 192.168.120.94  YES    manual    up          up
      GigabitEthernet0/0      unassigned      YES    unset     down        down
      Te1/0/1                unassigned      YES   unset     up          up
      Te1/0/2               unassigned      YES   unset     down        down
      Te1/0/3                unassigned      YES   unset     down        down
      Te1/0/4                unassigned      YES   unset     down        down
      Te1/0/5                unassigned      YES    unset     down        down
      Te1/0/6                unassigned      YES    unset     down        down
      Capwap2                unassigned      YES   unset     up          up

    w-5760-1#
  4. アクティブなライセンスが適切な AP count で有効化されていることを確認します。

    : 1) 5760 にはアクティブ化されたライセンス レベルがなく、画像はすでに IP サービス イメージとなっています。 2) Mobility Controller(MC)として動作する 5760 は、最大 1000 個の AP をサポートすることができます。

    w-5760-1#license right-to-use activate apcount <count> slot 1 acceptEULA
  5. AP が導入されている国の規制区域に従って、正しい国番号が WLC で設定されていることを確認します。
    w-5760-1#show wireless country configured

     Configured Country.............................: US  - United States
     Configured Country Codes
        US  - United States : 802.11a Indoor,Outdoor/ 802.11b / 802.11g

    国番号を変更するには、次のコマンドを入力してください:

    w-5760-1(config)#ap dot11 24ghz shutdown

    w-5760-1(config)#ap dot11 5ghz shutdown

    w-5760-1(config)#ap country BE
    Changing country code could reset channel and RRM grouping configuration.
    If running in RRM One-Time mode, reassign channels after this command.
    Check customized APs for valid channel values after this command.
    Are you sure you want to continue? (y/n)[y]: y
    w-5760-1(config)#no ap dot11 24ghz shut
    w-5760-1(config)#no ap dot11 5ghz shut
    w-5760-1(config)#end
    w-5760-1#wr
    Building configuration...
    Compressed configuration from 3564 bytes to 2064 bytes[OK]


    w-5760-1#show wireless country configured

     Configured Country.............................: BE  - Belgium
     Configured Country Codes
        BE  - Belgium : 802.11a Indoor,Outdoor/ 802.11b / 802.11g

  6. AP が DHCP オプション 43、Domain Name Service(DNS)、または CAPWAP の他の検出メカニズムで、WLC の IP アドレス(この例では 192.168.120.94)を学習できることを確認します。

確認

AP が結合されたことを確認するには、次の show ap summary コマンドを入力してください。

w-5760-1#show ap summary

Number of APs: 1

Global AP User Name: Not configured
Global AP Dot1x User Name: Not configured

AP Name              AP Model  Ethernet MAC    Radio MAC       State
--------------------------------------------------------------------------
APa493.4cf3.232a     1042N     a493.4cf3.232a  10bd.186d.9a40  Registered

トラブルシューティング

AP の加入に関する問題をトラブルシューティングする便利なデバッグ:

w-5760-1#debug capwap ap events
capwap/ap/events debugging is on

w-5760-1#debug capwap ap error
capwap/ap/error debugging is on

w-5760-1#debug dtls ap event
dtls/ap/event debugging is on

w-5760-1#debug capwap ios event
CAPWAP Event debugging is on

5760-1#debug capwap ios error
CAPWAP Error debugging is on

3850 スイッチの初期設定

この項では 3850 でワイヤレス サービスをホストするために必要な設定について説明します。

設定

セットアップ スクリプト

         --- System Configuration Dialog ---

Enable secret warning
----------------------------------
In order to access the device manager, an enable secret is required
If you enter the initial configuration dialog, you will be prompted
for the enable secret
If you choose not to enter the intial configuration dialog, or if you
exit setup without setting the enable secret,
please set an enable secret using the following CLI in configuration mode-
enable secret 0 <cleartext password>
----------------------------------
Would you like to enter the initial configuration dialog? [yes/no]: yes

At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.


Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system

Would you like to enter basic management setup? [yes/no]: yes
Configuring global parameters:

  Enter host name [Switch]: sw-3850-1

  The enable secret is a password used to protect access to
  privileged EXEC and configuration modes. This password, after
  entered, becomes encrypted in the configuration.
  Enter enable secret: Cisco123

  The enable password is used when you do not specify an
  enable secret password, with some older software versions, and
  some boot images.
  Enter enable password: Cisco123

  The virtual terminal password is used to protect
  access to the router over a network interface.
  Enter virtual terminal password: Cisco123

  Do you want to configure country code? [no]: yes

  Enter the country code[US]:US

Note :  Enter the country code in which you are installing this 3850 Switch and
the AP(s). If your country code is not recognized, enter one that is compliant
with the regulatory domain of your own country

Setup account for accessing HTTP server? [yes]: yes
    Username  [admin]: admin
    Password  [cisco]: cisco
    Password is UNENCRYPTED.

  Configure SNMP Network Management? [no]: no

Current interface summary

Any interface listed with OK? value "NO" does not have a valid configuration

Interface              IP-Address      OK? Method Status   Protocol
Vlan1                  unassigned      NO  unset up       down    
GigabitEthernet0/0     unassigned      YES unset up       up      
GigabitEthernet2/0/1   unassigned      YES unset  down     down    
GigabitEthernet2/0/2   unassigned      YES unset  down     down    
GigabitEthernet2/0/3   unassigned      YES unset  down     down    
...

...
...
GigabitEthernet2/0/46  unassigned      YES unset  down     down    
GigabitEthernet2/0/47  unassigned      YES unset  down     down    
GigabitEthernet2/0/48  unassigned      YES unset  up       up      
GigabitEthernet2/1/1   unassigned      YES unset  down     down    
GigabitEthernet2/1/2   unassigned      YES unset  down     down    
GigabitEthernet2/1/3   unassigned      YES unset  down     down    
GigabitEthernet2/1/4   unassigned      YES unset  down     down    
Te2/1/1               unassigned      YES unset  down     down    
Te2/1/2                unassigned      YES unset  down     down    
Te2/1/3                unassigned      YES unset  down     down    
Te2/1/4               unassigned      YES unset  down     down    

Enter interface name used to connect to the
management network from the above interface summary: vlan1

Configuring interface Vlan1:
  Configure IP on this interface? [yes]: yes
    IP address for this interface: 192.168.1.2
    Subnet mask for this interface [255.255.255.0] : 255.255.255.0
    Class C network is 192.168.1.0, 24 subnet bits; mask is /24

次のコンフィギュレーション コマンド スクリプトが作成されました:

hostname sw-3850-1
enable secret 4 vwcGVdcUZcRMCyxaH2U9Y/PTujsnQWPSbt.LFG8lhTw
enable password Cisco123
line vty 0 15
password Cisco123
  ap dot11 24ghz shutdown
  ap dot11 5ghz shutdown
  ap country US
  no ap dot11 24ghz shutdown
  no ap dot11 5ghz shutdown

username admin privilege 15 password 0 cisco
no snmp-server
!
no ip routing

!
interface Vlan1
no shutdown
ip address 192.168.1.2 255.255.255.0
!
interface GigabitEthernet0/0
shutdown
no ip address
!
interface GigabitEthernet2/0/1
!
interface GigabitEthernet2/0/2
!
interface GigabitEthernet2/0/3
...

...

...
interface GigabitEthernet2/0/46
!
interface GigabitEthernet2/0/47
!
interface GigabitEthernet2/0/48
!
interface GigabitEthernet2/1/1
!
interface GigabitEthernet2/1/2
!
interface GigabitEthernet2/1/3
!         
interface GigabitEthernet2/1/4
!
interface TenGigabitEthernet2/1/1
!
interface TenGigabitEthernet2/1/2
!
interface TenGigabitEthernet2/1/3
!
interface TenGigabitEthernet2/1/4
!
end


[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.

Enter your selection [2]:    2
The enable password you have chosen is the same as your enable secret.
This is not recommended.  Re-enter the enable password.
Changing country code could reset channel and RRM grouping configuration.
If running in RRM One-Time mode, reassign channels after this command.
Check customized APs for valid channel values after this command.
Are you sure you want to continue? (y/n)[y]: y
% Generating 1024 bit RSA keys, keys will be non-exportable...
[OK] (elapsed time was 1 seconds)

Building configuration...
Compressed configuration from 4414 bytes to 2038 bytes[OK]
Use the enabled mode 'configure' command to modify this configuration.




Press RETURN to get started!

接続するアクセス ポイントに必要な設定

: 重要 - 適切な boot コマンドがグローバル コンフィギュレーションで設定されていることを確認します。 これがフラッシュで展開されていると、boot system switch all flash: packages.conf コマンドが必要になります。

  1. ワイヤレス前提条件を設定します。

    ワイヤレス サービスを有効化するには、3850 は ipservices または ipbase のライセンスを実行する必要があります。

  2. スイッチでワイヤレスを有効化します。

    : AP は同じ VLAN 上でアクセス モードのスイッチ ポートに接続する必要があります。

    • ワイヤレス管理を有効化します。
      sw-3850-1(config)#wireless management interface vlan <1-4095>
    • MC を定義します。

      AP の接続を許可するために MC を定義する必要があります。

      1. この 3850 が MC になる場合、wireless mobility controller コマンドを入力します。

        sw-3850-1(config)#wireless mobility controller

        : この設定変更にはリブートが必要です。

      2. この 3850 がモビリティ エージェント(MA)として機能する場合は、次のコマンドを使用して、MC の IP アドレスにこのことを示します。
        sw-3850-1(config)#wireless mobility controller ip a.b.c.d

        また MC では、次のコマンドを入力します。

        3850MC(config)#wireless mobility controller peer-group <SPG1>

        3850MC(config)#wireless mobility controller peer-group <SPG1> member
        ip w.x.y.z
  3. ライセンスの可用性を確認します。

    アクティブな AP ライセンスが MC で使用できることを確認してください(MA は、MC でアクティブ化されたライセンスを使用します)。

    : 1) 3850 のワイヤレス サービスを有効化するには、3850 は ipservices または ipbase のライセンスを実行する必要があります。 2) AP count ライセンスは MC で適用され、自動的にプロビジョニングされて MA で適用されます。 3) MC として動作する 3850 は、最大 50 個の AP をサポートすることができます。

    sw-3850-1#show license right-to-use summary

                  License Name    Type        Count   Period left
                  -----------------------------------------------
                  ipservices      permanent   N/A     Lifetime
                  apcount         base       1       Lifetime
                  apcount         adder       49      Lifetime
                 -----------------------------------------------

    License Level In Use: ipservices
    License Level on Reboot: ipservices
    Evaluation AP-Count: Disabled
    Total AP Count Licenses: 50
    AP Count Licenses In-use: 1
    AP Count Licenses Remaining: 49

    3850 で AP count ライセンスをアクティブ化するには、MC に必要な AP count を指定して次のコマンドを入力します。

    sw-3850-1#license right-to-use activate apcount <count> slot <#> acceptEULA
  4. AP ディスカバリ プロセスを設定します。

    AP がコントローラに加入するためには、スイッチ ポート設定をワイヤレス管理 VLAN でアクセス ポートとして設定する必要があります

    VLAN 100 をワイヤレス管理インターフェイスに使用する場合:

    sw-3850-1(config)#interface gigabit1/0/10
    sw-3850-1(config-if)#switchport mode access
    sw-3850-1(config-if)#switchport access vlan 100
  5. Web アクセスを設定します。

    GUI は https:// <ipaddress>/wireless から入手できます。

    ログイン情報は、初期設定ダイアログですでに定義されています。

    username admin privilege 15 password 0 cisco ( username for Web access)

    116342-config-wlc-04.png

  6. AP が導入されている国の規制ドメインに従って、正しい国番号がスイッチで設定されていることを確認します。
    sw-3850-1#show wireless country configured 

     Configured Country.............................: US  - United States
     Configured Country Codes
      US  - United States : 802.11a Indoor,Outdoor/ 802.11b / 802.11g

    国番号を変更するには、次のコマンドを入力してください:

    sw-3850-1(config)#ap dot11 24ghz shutdown 

    sw-3850-1(config)#ap dot11 5ghz shutdown

    sw-3850-1(config)#ap country BE
    Changing country code could reset channel and RRM grouping configuration.
    If running in RRM One-Time mode, reassign channels after this command.
    Check customized APs for valid channel values after this command.
    Are you sure you want to continue? (y/n)[y]: y
    sw-3850-1(config)#no ap dot11 24ghz shut
    sw-3850-1(config)#no ap dot11 5ghz shut
    sw-3850-1(config)#end
    sw-3850-1#wr
    Building configuration...
    Compressed configuration from 3564 bytes to 2064 bytes[OK]


    sw-3850-1#show wireless country configured

     Configured Country.............................: BE  - Belgium
     Configured Country Codes
        BE  - Belgium : 802.11a Indoor,Outdoor/ 802.11b / 802.11g

確認

AP が加入したことを確認するには、show ap summary コマンドを入力します。

sw-3850-1#show ap summary

Number of APs: 1

Global AP User Name: Not configured
Global AP Dot1x User Name: Not configured

AP Name              AP Model Ethernet MAC    Radio MAC          State
------------------------------------------------------------------------------

APa493.4cf3.232a     1042N     a493.4cf3.231a  10bd.186e.9a40      Registered

トラブルシューティング

AP の加入に関する問題をトラブルシューティングする便利なデバッグ:

sw-3850-1#debug capwap ap events
capwap/ap/events debugging is on

sw-3850-1#debug capwap ap error
capwap/ap/error debugging is on

sw-3850-1#debug dtls ap event
dtls/ap/event debugging is on

sw-3850-1#debug capwap ios event
CAPWAP Event debugging is on

sw-3850-1#debug capwap ios error
CAPWAP Error debugging is on

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 116342