IP : レイヤ 2 トンネル プロトコル(L2TP)

L3 ネットワーク間の L2 ブリッジングの設定例

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

このドキュメントは、レイヤ 3(L3)のネットワークを通じてレイヤ 2(L2)のネットワークをブリッジする方法について説明します。

著者:Atri Basu、Jay Young Taylor、および Mani Ganesan、Cisco TAC エンジニア

前提条件

要件

次の項目に関する知識があることが推奨されます。

  • レイヤ 2 トンネリング プロトコル バージョン 3(L2TPv3)
  • 総称ルーティング カプセル化(GRE)

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

背景説明

多くの場合、ホットスポットから中央の場所に WiFi のトラフィックを集約するためにはソリューションが必要です。 このような場合、ソリューションで、顧客宅内機器(CPE)デバイスがエンド ホストからのイーサネット トラフィックをブリッジすること、またエンドポイントへのイーサネット トラフィックを介してパッケージをカプセル化することを許可する必要があります。

アグリゲーション サービス ルータ(ASR)を使用している場合、これを行うための簡単な方法は、ソフト GRE 経由のイーサネットを使用することです。 ただし、サービス統合型ルータ(ISR)やその他すべての CPE デバイスについては、このオプションはありません。 Cisco IOS® の旧バージョンでは、GRE トンネルのインターフェイスを使用する物理インターフェイスのブリッジングによって GRE 経由で L2 をトンネルすることができました。 通常のブリッジングは着信パケットから VLAN ヘッダーを削除しますが、ルータで Integrated Routing and Bridging(IRB)を使用すると、同じインターフェイスで同じネットワーク層プロトコルをルートおよびブリッジすることができ、ルータが 1 台のインターフェイスから別のインターフェイスへ VLAN ヘッダーを保持することを許可します。

: 以前の Cisco IOS バージョンでトンネル インターフェイスに bridge-group を設定すると、IOS は、コマンドがリリースおよびサポートされていないがコマンドを受け入れることを報告します。 最近のバージョンでは、このコマンドは完全に廃止され、エラー メッセージを表示します。

前述の解決策は、シスコではサポートされません。 L2 ネットワークをブリッジングするためにサポートされているソリューションは、このドキュメントで説明するように、L2TPv3 を使用することです。 L2TPv3 は、イーサネット、802.1q(VLAN)、フレームリレー、High-Level Data Link Control(HDLC; ハイレベル データ リンク制御)、および Point-to-Point Protocol(PPP)などのさまざまな L2 プロトコルの伝送をサポートします。 この文書では主にイーサネットの拡張について説明します。

設定

この設定は非常に基本的なものです。 ルータ r100 および r202 は同じネットワーク上でホストの役割をします。一方、r101 および r201 には L3 インターフェイスおよび L2 インターフェイスが各 1 個存在します。 目的は、r101 と r201 がルートの要件なしで互いに ping 接続できるように L2TPv3 接続をセットアップすることです。

ネットワーク図

トンネルの設定

L2TP のトンネル設定では、次の 3 ステップを実行します:

  1. L2TP クラスを設定(任意選択)

    このクラスは、認証を定義するために使用します。また L2TP トンネルのパラメータを制御するために使用します。 これを使用する場合、2 個のエンドポイントは互いにミラーする必要があります。
    l2tp-class test
    hostname stanford
    password 7 082E5C4B071F091805

  2. 疑似回線クラスを設定

    名前からわかるように、2 個のエンドポイント間の実際のトンネル(疑似回線)を設定するには、このセクションを使用します。 疑似回線のカプセル化、エンドポイント、および制御チャネル プロトコルを含むテンプレートを定義します。
    pseudowire-class test
    encapsulation l2tpv3
    ip local interface Loopback0
    ip pmtu

  3. トンネルの宛先を提供するために Xconnect を使用

    L2TP の疑似回線を接続回線(ローカル L2 側へのインターフェイス)にバインドし、宛先を定義します。 

注意する点:

  • 接続回線自体に IP アドレスが設定されていません。
  • IP ローカル インターフェイスで設定されているトンネル送信元は、疑似回線クラスのセクションにあります。
  • トンネルの宛先は、xconnect コマンドで定義されます。

考慮事項

  • GRE トンネリング ソリューションと同様に、L2 トンネルを終端するためにルータを使用すると、L2 プロトコル データ ユニット(PDU)のメッセージをトンネルを介して転送できません。 適切な L2 プロトコルのトンネリングがない場合(このデバイスではサポートされていません)、これらのメッセージは L2 インターフェイスによって使用されます。

  • L2 プロトコルのトンネリングのサポート(Cisco Discovery Protocol、スパニングツリー プロトコル、VLAN トランキング プロトコル、およびリンク層検出プロトコル)では、デバイスをスイッチにする必要があります。 このスイッチは、トラフィックをトンネルして可能な選択肢を制限できるように、L3 対応である必要があります。

  • L3 トンネリングのカプセル化は、トンネルを実行するデバイスに依存します:
    1. Cisco 7301 では、L2TPv3 のカプセル化をサポートしています。
    2. Cisco 65xx は、L2TPv3 トンネルを使用する L2 拡張をサポートしていません。 ただし、L2 は Any Transport over MPLS(AToM)オプションを指定すると、MLPS のコアを介して拡張できます。
    3. L2TP のトンネルは、Cisco 4500 スイッチではサポートされません。

  • 単一の xconnect のトンネル インターフェイスは物理インターフェイスまたはサブインターフェイスで設定できます。 個々のインターフェイスが各疑似回線のエンドポイントに必要です。 同じ pw-class と同じ L2TP ID を使用して xconnect の複数のインターフェイスを設定できません。

  • L2TP トンネルの最大ペイロードの最大伝送ユニットのサイズは、通常は、標準のイーサネットを介して伝送されるトラフィック用に 1460 バイトです。 L2TP over User Datagram Protocol(UDP; ユーザ データグラム プロトコル)の場合、オーバーヘッドは IP ヘッダー(20 バイト)、UDP ヘッダー(8 バイト)、および L2TP ヘッダー(12 バイト)の結果です。

設定例

ルータ r101 の設定

interface Ethernet0/0
ip address 172.16.1.100 255.255.255.0

ルータ r100 の設定

pseudowire-class test
encapsulation l2tpv3
protocol none
ip local interface fast 0/0
!
interface FastEthernet0/0
description WAN
ip address 198.51.100.100 255.255.255.0
!
interface FastEthernet0/1
description LAN
no ip address
speed 100
full-duplex
xconnect 203.0.113.102 1 encapsulation l2tpv3 manual pw-class test
l2tp id 1 2
!
ip route 0.0.0.0 0.0.0.0 198.51.100.1

ルータ r202 の設定

pseudowire-class test
encapsulation l2tpv3
protocol none
ip local interface fast 0/0
!
interface FastEthernet0/0
description WAN
ip address 203.0.113.102 255.255.255.255

interface FastEthernet0/1
no ip address
duplex auto
speed auto
xconnect 198.51.100.100 1 encapsulation l2tpv3 manual pw-class test
l2tp id 2 1

ルータ r201 の設定

interface Ethernet0/0
ip address 172.16.1.201 255.255.255.0

: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

確認

ルータ上のすべての L2TP セッションについて、他の L2TP 対応デバイスに設定された L2TP の制御チャネルの詳細情報を表示するには、show l2tun tunnel all コマンドを使用します。

L2TPv3 のカプセル化が正しく動作していることを確認するには、同じ VLAN にあると想定されるリモート サイトでホストを ping 接続します。 ping に成功した場合に、設定が正しく動作していることを確認するには、次のコマンドを使用できます。 特定の show コマンドがアウトプット インタープリタ ツール登録ユーザ専用)でサポートされています。 show コマンド出力の分析を表示するには、アウトプット インタープリタ ツールを使用します。

  • show arp コマンドは、アドレス解決プロトコル(ARP)のキャッシュを表示します。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。



Document ID: 116266