音声 : ゲートウェイ プロトコル

マルチポイント PVC とプライオリティ設定による VoIP over Frame Relay

2013 年 10 月 3 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2007 年 7 月 6 日) | フィードバック

概要

このドキュメントでは、ハブ アンド スポーク型のトポロジにおける Voice over IP(VoIP)フレーム リレーのためのトラフィック シェーピングとプライオリティ設定について説明しています。ハブは、それぞれのリモート スポークに対して 1 つの、2 つの相手先固定接続(PVC)で構成され、データと音声の両方が同じ PVC 経由で送信されます。このドキュメントで説明するプライオリティ設定とフラグメンテーションは、今回のシナリオだけでなく、音声とデータの PVC と、データ専用の PVC を組み合わせたシナリオにも適用できる点に注目してください。データ PVC は、音声とデータの PVC と同様にトラフィック シェーピングする必要があります。これは、1 つの物理パイプを共有する場合、このハブのケースでは、シリアライゼーション遅延がすべてのデータに影響を及ぼすためです。

下のトポロジでは、ニューヨークがハブの中央ルータです。ローリーとサンノゼは、フレーム リレー ネットワーク経由でこのハブに接続されたリモート ルータです。ニューヨーク ルータには 2 つの PVC が接続されています。このケースでは、ニューヨークからローリーへの送信は 64 kbps 以下、サンノゼへの送信は 192 kbps 以下にする必要があります。これは、フレーム リレー マップクラスに設定された認定情報レート(CIR)を超過しないようにするためです。

このドキュメントに示したトポロジでは、VoIP 設定されたルータがフレーム リレー クラウドに直接接続されています。ただし、音声対応ルータ(Cisco AS5300 を除く)をネットワーク内の任意の場所に配置できるトポロジもあります。詳細については、記載された注意事項を参照してください。音声ルータは、LAN 接続を経由して WAN に接続されている他のルータに接続できる点にも注意してください。音声ルータがフレーム リレー サービスに直接接続されていない場合、WAN 接続関連のすべての設定コマンドは、音声ルータではなく WAN に接続しているルータに対して発行します。

注:  高速シリアル インターフェイスを備えた Cisco AS5300 ルータは、WAN へのデータ接続をサポートするように設計されていません。Cisco AS5300 は、主に音声コールを処理する中間的な LAN ルータとして使用する必要があるため、WAN への直接接続向けの専用ルータが必要になります。

前提条件

要件

この設定を実施するには、次の前提条件を満たしている必要があります。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOSR ソフトウェア リリース 12.3(5) Enterprise Plus が稼働している 3 台の Cisco 3640 ルータ

  • スポークで Foreign Exchange Station(FXS)ポートに接続されている 4 台のアナログ電話

  • ハブ ルータで T1 コントローラに接続されている 1 台の PBX

スポークは、Cisco 2600 または 1750 プラットフォームでも対応できです。デジタル音声の場合、ハブは Cisco 2600 または 3600 プラットフォームで対応できます。ハブにアナログ音声しか存在しない場合は、Cisco 1750 プラットフォームで対応できます。トラフィック シェーピングと設定はすべて、他のプラットフォームにも適用されます。

注: このドキュメントの内容は特定のソフトウェアに限定されるものではありませんが、Cisco IOS ソフトウェアのバージョンによっては使用できないコマンドも含まれています。たとえば、frame-relay fragment コマンドは IP Plus ではサポートされていますが、IP イメージではサポートされていません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

VoIP over Frame Relay のためのトラフィック シェーピングとプライオリティ設定

VoIP over Frame Relay を実行する場合、フレーム上で送信されるトラフィックはフレーム リレー CIR 以下のレベルを維持する必要があります。図に示すようにフレーム リレー トラフィック シェーピング(FRTS)が設定されている場合、ルータは CIR を超過するトラフィックを送信しません。CIR を超える速度で実行するようにルータを設定すると、音声品質に問題が生じる可能性があります。保証された CIR を超えて PVC を実行すると、音声品質は保証されません。

注: フレーム リレー パケットの受信時に逆方向明示的輻輳通知(BECN)ビットが設定されている場合、ルータの転送レートを特定の値まで下げるようにアダプティブ シェーピングを設定することができます。ただし、音声パケットを伝送する場合は、トラフィック レートがフレーム リレー サービスの CIR を超えないようにしてください。これは、リアル タイムの音声パケットがネットワーク経由で送信される際に、適切な品質と配信を保証するためです。CIR を超える設定は、音声トラフィックを伝送しないデータ PVC でのみ推奨されます。

注: ルータで VoIP を設定して使用する前に、Cisco IOS ソフトウェアの Quality of Service(QoS)機能について理解しておくことを推奨します。QoS 機能の詳細については、『キューイング、トラフィック シェーピング、およびフィルタリング』と『ボイスに関するフレームリレーのフラグメンテーション』を参照してください。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは次の図に示すネットワーク設定を例にあげています。

voip_fr_mp_1.gif

コンフィギュレーション

このドキュメントでは、次の設定を使用します。

ニューヨーク ハブ ルータ
Current configuration:
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname newyork
!
logging buffered 50000 debugging
enable secret < password > [Choose a strong password with 
at least one capital letter, one number, and one special character.]
!
controller T1 2/0
framing esf
linecode b8zs
ds0-group 1 timeslots 1-4 type e&m-wink-start
!
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay traffic-shaping

!--- この CLI コマンドは両方の PVC のトラフィック シェーピングを有効にします。

!
interface Serial2/0.1 point-to-point
description Connection to Raleigh PVC
ip address 172.16.120.2 255.255.255.0
  frame-relay interface-dlci 100
  class class-raleigh
!
interface Serial2/0.2 point-to-point
description Connection to San Jose PVC
ip address 172.16.130.2 255.255.255.0
frame-relay interface-dlci 200
  class class-sanjose
!
ip classless
!
map-class frame-relay class-raleigh
 frame-relay cir 64000
 frame-relay bc 640
 frame-relay be 0
 frame-relay mincir 64000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment 80

!--- 音声の伝送時の 10 ms の遅延で推奨されるフラグメント サイズ
!--- 設定した CIR 64000 に基づくトラフィック。
!--- 設定した CIR 64000 に基づいています。

 frame-relay ip rtp priority 16384 16383 48

!--- CRTP なし、それぞれ 24 kbps の 2 つの g729 コール。

 !
map-class frame-relay class-sanjose
 frame-relay cir 192000
 frame-relay bc 1920
 frame-relay be 0
 frame-relay mincir 192000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment 240

!--- これは、音声トラフィックの伝送時の 10 ms の遅延で推奨されるフラグメント サイズです
!--- 設定した CIR 192000 に基づいています。

frame-relay ip rtp priority 16384 16383 48 

!--- 圧縮リアルタイム プロトコル(cRTP)なし、それぞれ 24 kbps の 2 つの g729 コール。

!
!
voice-port 2/0:1
!
dial-peer cor custom
!
dial-peer voice 100 pots

!--- 公衆交換電話網(PSTN)へのコール。

 destination-pattern 212.......
prefix 212
port 2/0:1
!
dial-peer voice 200 pots

!--- 企業ネットワークへのコールが 4 桁の内線で転送されます。

destination-pattern 567....
 port 2/0:1
!
dial-peer voice 110 voip

!--- ローリーへのコール。

destination-pattern 919392....
session target ipv4:172.16.120.1
 ip qos dscp cs5 media
dtmf-relay h245-alphanumeric
!
dial-peer voice 210 voip    
!--- サンノゼへのコール。

destination-pattern 408527....
session target ipv4:172.16.130.1
 ip qos dscp cs5 media
dtmf-relay h245-alphanumeric
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 no login
!
end  

ip qos dscp コマンドは、ip precedence(ダイヤルピア)に代わるコマンドとして IOS バージョン 12.2(2)T で導入されました。

frame-relay ip rtp priority コマンドでは、UDP(ユーザ データグラム プロトコル)宛先ポートの範囲内の一連のリアルタイム プロトコル(RTP)パケット フローで厳密なプライオリティ キューを予約します。

注: frame-relay ip rtp priority コマンドにより、他のトラフィックに比べて絶対的なプライオリティが付与されるため、使用には注意が必要です。輻輳時に、トラフィックが設定した帯域幅を超えた場合、その超過したトラフィックはすべてドロップします。

Cisco 3640 ローリー
Current configuration:
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname raleigh3640a
!

logging buffered 50000 debugging
enable secret < password > [Choose a strong password with at 
least one capital letter, one number, and one special character.]
!
no ip subnet-zero
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
dial-peer voice 1 pots
 destination-pattern 9193924100
port 1/0/0
!
dial-peer voice 2 voip
 destination-pattern 2126789001
  ip qos dscp cs5 media
 dtmf-relay h245-alphanumeric
 session target ipv4: 172.16.120.2 
!

interface Loopback0
 ip address 172.16.125.1 255.255.255.255
 no ip directed-broadcast
!

interface Serial2/0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
interface Serial2/0.1 point-to-point
description Connection to New York
 ip address 172.16.120.1 255.255.255.0

 frame-relay interface-dlci 100
  class fr_class_voip  
!
!
ip classless
no ip http server
!
!
map-class frame-relay fr_class_voip
 frame-relay cir 64000
 frame-relay bc 640
 frame-relay be 0
 frame-relay mincir 64000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment  80


!--- 音声トラフィックの伝送時の 10 ms の遅延で推奨されるフラグメント サイズ。


!--- 設定した CIR 64000 に基づいています。


  frame-relay ip rtp priority 16384 16383 48
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 no login
!
end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を示しています。

特定の show コマンドは、Output Interpreter Tool 登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show frame-relay fragment—Cisco ルータで実行されたフレームリレー フラグメンテーションに関する情報を表示します。

  • show traffic-shape queue—仮想回線(VC)DLCI(データリンク接続識別子)レベルでキューイングされたエレメントに関する情報を表示します。このコマンドは、フレームリレー上での IP RTP プライオリティの動作を確認する際に使用します。リンクが輻輳している場合、ボイス フローは重み(weight)0 で識別されます。これはボイスフローがプライオリティ キューを使用していることを示します。下記の出力例を参照してください。

  • show frame-relay pvc [dlci#]—トラフィック シェーピング パラメータ、断片化値、廃棄されたパケットなどの情報を表示します。詳細については、ここで紹介する出力例と『フレームリレーの設定とトラブルシューティング』を参照してください。

newyork#show frame-relay fragment

interface   dlci   frag-type   frag-size   in-frag   out-frag   dropped-frag
 
Serial1/0.1 100    end-to-end    80          16        20           0 

Serial1/0.2 200    end-to-end    240         12        10           0 

newyork#show traffic-shape  serial 2/0.1
Interface Se2/0.1

     Access    Target   Byte   Sustain   Excess   Interval    Increment    Adapt
VC   List      Rate     Limit  bits/int  bits/int (ms)        (bytes)      Active

100            64000    80     640       0         10          80          -
  
newyork#show traffic-shape queue
Traffic queued in shaping queue on Serial2/0.1 dlci 100
  Queueing strategy: weighted fair
  Queueing Stats: 0/600/64/0 (size/max total/threshold/drops)
     Conversations  0/1/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 16 kilobits/sec

Traffic queued in shaping queue on Serial2/0.2 dlci 200
  Queueing strategy: weighted fair
  Queueing Stats: 0/600/64/0 (size/max total/threshold/drops)
    Conversations  0/1/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 144 kilobits/sec

newyork#show frame-relay pvc 100

PVC Statistics for interface Serial2/0 (Frame Relay DCE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial2/0.1

input pkts 1078          output pkts 1078         in bytes 157792
out bytes 172284         dropped pkts 0           in pkts dropped 0
out pkts dropped 0                out bytes dropped 0
in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
out BECN pkts 0          in DE pkts 0             out DE pkts 0
out bcast pkts 28        out bcast bytes 8498
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:27:48, last time pvc status changed 00:27:48
Queueing strategy: weighted fair
Current fair queue configuration:
	Discard     Dynamic      Reserved
	threshold   queue count  queue count
		64          16           0
Output queue size 0/max total 600/drops 0
fragment type end-to-end        fragment size 80
cir 64000     bc   640       be 0         limit 80     interval 10
mincir 64000     byte increment 80    BECN response no  IF_CONG no
frags 2707      bytes 172284    frags delayed 2707      bytes delayed 172284
shaping inactive
traffic shaping drops 0
ip rtp priority parameters 16384 32767 48000

トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つ情報を紹介します。

トラブルシューティング手順

次に、この設定に関連するトラブルシューティング情報と手順をご紹介します。

  1. 音声用に実装されたフレーム リレーおよび QoS をトラブルシューティングして、動作が正しいことを確認します。

  2. 必要に応じて、ボイスコールの問題をトラブルシューティングします。

    注: トラブルシューティングの詳細については、『QoS(フラグメンテーション、トラフィック シェーピング、LLQ / IP RTP プライオリティ)が備わった VoIP over Frame Relay』を参照してください。

トラブルシューティングのためのコマンド

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。OIT を使用して、show コマンド出力の解析を表示できます。

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • debug priority—プライオリティ キューイング(PQ)イベントを表示して、このキューで廃棄が発生しているかどうかを確認します。詳細は、『プライオリティ キューイングによる出力ドロップのトラブルシューティング』を参照してください。

  • debug frame-relay fragment—フレームリレー フラグメンテーションに関連するイベントまたはエラー メッセージを表示します。このコマンドは、選択したインターフェイスの PVC レベルでのみ有効になります。

    newyork#debug priority 
    Priority output queueing debugging is on
    newyork#ping 172.16.120.1
    Type escape sequence to abort. 
    Sending 5, 100-byte ICMP Echos to 172.16.120.1, timeout is 2 seconds: 
    !!!!! 
    Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms 
    newyork# 
    *Mar  1 05:11:24.746: PQ: Serial2/0 output (Pk size/Q 104/2)
    *Mar  1 05:11:24.754: PQ: Serial2/0 output (Pk size/Q 104/2) 
    *Mar  1 05:11:24.810: PQ: Serial2/0 output (Pk size/Q 104/2)
    *Mar  1 05:11:24.818: PQ: Serial2/0 output (Pk size/Q 104/2) 
    *Mar  1 05:11:24.874: PQ: Serial2/0 output (Pk size/Q 104/2) 
    *Mar  1 05:11:24.882: PQ: Serial2/0 output (Pk size/Q 13/0) 
    
    newyork#debug frame-relay fragment interface serial 2/0 100
    This may severely impact network performance.
    You are advised to enable no logging console debug. Continue?[confirm]
    Frame Relay fragment/packet debugging is on
    Displaying fragments/packets on interface Serial2/0 dlci 100 only
    
    *Mar  1 20:58:32.838: Serial1/0.1(o): dlci 100, tx-seq-num 3645, 
    B bit set, frag_hdr 03 B1 9C 3D
    *Mar  1 20:58:32.846: Serial1/0.1(o): dlci 100, tx-seq-num 3646, 
    E bit set, frag_hdr 03 B1 5C 3E
    *Mar  1 20:58:32.890: Serial1/0.1(i): dlci 100, rx-seq-num 17, 
    exp_seq-num 17,B bit set,
    	 frag_hdr 03 B1 80 11
    *Mar  1 20:58:32.894: Serial1/0.1(i): dlci 100, rx-seq-num 18, 
    exp_seq-num 18,E bit set,
    	 frag_hdr 03 B1 40 12

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12162