IP : IP アプリケーション サービス

IPv6 HSRP の設定例

2013 年 10 月 3 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2011 年 10 月 31 日) | フィードバック

概要

このドキュメントでは、ホット スタンバイ ルータ プロトコル(HSRP)を IPv6 用に設定する方法について説明します。アクティブ ルータとスタンバイ ルータを選択するには、ルータのグループ内で HSRP を使用します。ルータ インターフェイスのグループでは、アクティブ ルータが、パケットのルーティングのために選択するルータです。アクティブ ルータで障害が発生したとき、または事前設定の条件が満たされたときは、スタンバイ ルータが引き継ぎます。HSRP は、IPv6 ホストに仮想ファースト ホップだけを提供するように設計されています。

HSRP IPv6 グループには、HSRP グループ番号に基づく仮想 MAC アドレス、およびデフォルトで HSRP 仮想 MAC アドレスに基づく HSRP の仮想 IPv6 リンクローカル アドレスがあります。HSRP グループがアクティブな場合、定期的なルート アドバタイズメント(RA)が HSRP 仮想 IPv6 リンクローカル アドレス宛てに送信されます。これらの RA は、グループがアクティブ状態ではなくなるときに最後の RA が送信されると停止します。

HSRP では、プライオリティ メカニズムを使用して、デフォルトのアクティブ ルータにする HSRP 設定済みルータを決定します。ルータをアクティブ ルータとして設定するには、他のすべての HSRP 設定済みルータのプライオリティよりも高いプライオリティをそのルータに割り当てる必要があります。デフォルトのプライオリティは 100 です。このため、1 つのみのルータのプライオリティを高く設定すると、そのルータがデフォルトのアクティブ ルータになります。HSRP バージョン 2 では新しい IP マルチキャスト アドレス 224.0.0.102 を使用して hello パケットを送信します。バージョン 1 では、このマルチキャスト アドレスが 224.0.0.2 です。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • HSRP の設定に関する知識。詳細は、『HSRP の設定』を参照してください。

  • IPv6 アドレッシングと基本接続を実装する基礎知識。詳細については、「IPv6 アドレッシングおよび基本的な接続の実装」を参照してください。

  • HSRP IPv6 を設定する前に、インターフェイスに対して HSRP バージョン 2 をイネーブルにする必要があります。

  • HSRP IPv6 を設定するには、IPv6 ユニキャスト ルーティングをデバイスで有効にする必要があります。

使用するコンポーネント

このドキュメントの設定は、Cisco IOS Software Release ソフトウェア 12.4 (15)T 13 の Cisco 3700 シリーズ ルータに基づきます。

注: IPv6 コマンドのライセンス情報を確認してください。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

ルータ R1 と R2 は、シリアル インターフェイスを介して R3 に接続します。R1 と R2 のファスト イーサネット インターフェイスは、R1 がアクティブ ルータ、R2 がスタンバイ ルータとして動作するような方法で HSRP IPv6 で設定されています。R1 のシリアル インターフェイス S0/0 がダウンすると、R2 ルータの状態がスタンバイからアクティブに変わります。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool(登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

ipv6-hsrp-01.gif

コンフィギュレーション

このドキュメントでは、次の設定を使用します。

次のビデオへのリンクを参照してください(Cisco サポート コミュニティ leavingcisco.com で利用可能)。Cisco IOS ルータで IPv6 用に HSRP を設定する方法が説明されています。

IPv6 の HSRP の設定 leavingcisco.com

ipv6-hsrp-02.gif

ルータ R1 の設定
R1#show run
Building configuration...
!
hostname R1
!
ip cef
!
ipv6 unicast-routing
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:AB8:2001::1010/64
 ipv6 enable
 standby version 2
 standby 1 ipv6 autoconfig

!--- スタンバイ グループとスタンバイ IP アドレスを割り当てます。


 standby 1 priority 120


!--- アクティブ ルータとして R1 を設定します。
!--- これを実行するには、プライオリティ値 
!--- (この場合は 120)をルータの Fa0/0 インターフェイスに割り当てます。
!--- デフォルトのプライオリティ値は 100 です。


 standby 1 preempt delay minimum 30


!--- preempt コマンドにより、ルータは、その他すべての  
!--- HSRP 設定ルータよりもプライオリティが高いとき、
!--- アクティブ ルータになります。
!---- このコマンドを使用しないと、ルータのプライオリティ値 
!--- が高くても、アクティブ ルータになりません。
!--- 遅延の最小値のため、ローカル ルータはアクティブ 
!--- ロールを引き継ぐことを最低 30 秒延期します。


 standby 1 track Serial0/0 90


!--- HSRP がシリアル 0/0 を追跡することを示します。
!--- インターフェイスのプライオリティが設定され(この場合は  
!--- 90)、追跡するインターフェイスがダウンした場合、
!--- ルータのプライオリティ値が 90 下がることを示します。
!--- デフォルトの減少値は 10 です。

!
interface Serial0/0
 no ip address
 ipv6 enable
 ipv6 address 2010:AB8:2001::1010/64
 clock rate 2000000
!
end

ルータ R2 の設定
R2#show run
Building configuration...
!
hostname R2
!
ip cef
!
ipv6 unicast-routing
!
interface FastEthernet0/0

!--- R2 をスタンバイ ルータとして設定し、
!--- デフォルトのプライオリティ値を 100 にします。

 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:AB8:2001::1011/64
 ipv6 enable
 standby version 2
 standby 1 ipv6 autoconfig
 standby 1 preempt delay minimum 30
 standby 1 track Serial0/0
!
interface Serial0/0
 no ip address
 ipv6 address 2010:AB8:2010::1020/64
 ipv6 enable
 clock rate 2000000
!
end

ルータ R3 の設定
R3#show run
Building configuration...
!
hostname R3
!
ip cef
!
ipv6 unicast-routing
!
interface Serial0/0
 no ip address
 ipv6 address 2010:AB8:2001::1011/64
 ipv6 enable
 clock rate 2000000
!
interface Serial0/1
 no ip address
 ipv6 address 2010:AB8:2010::1021/64
 clock rate 2000000
!
end

確認

設定を確認するには、R1 と R2 ルータで show standby コマンドを使用します。

ルータ R1
R1#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Active 
!--- R1 ルータはアクティブ状態です。

    4 state changes, last state change 02:51:30
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.480 secs
  Preemption enabled, delay min 30 secs
  Active router is local
  Standby router is FE80::C010:21FF:FE78:0, priority 100 (expires in 7.036 sec)
  Priority 120 (configured 120)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

ルータ R2
R2#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Standby
!--- R2 ルータはスタンバイ状態です。

    4 state changes, last state change 02:51:43
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.900 secs
  Preemption enabled, delay min 30 secs
  Active router is FE80::C00F:21FF:FE78:0, priority 120 (expires in 9.928 sec)
    MAC address is c20f.2178.0000
  Standby router is local
  Priority 100 (default 100)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

アクティブ ルータ(この例では R1)がダウンすると、次のテーブルのようにスタンバイ ルータの状態がすぐにアクティブに変わります。

アクティブ ルータ(R1)がダウンすると
ルータ R1
R1(config)#interface s0/0
R1(config-if)#shut
R1(config-if)#exit
*Mar  1 00:01:34.879: %LINK-5-CHANGED: Interface Serial0/0, changed state to 
      administratively down
*Mar  1 00:01:35.879: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, 
      changed state to down
R1#
*Mar  1 00:04:06.691: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Mar  1 00:04:36.175: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Active -> Speak
R1#
*Mar  1 00:04:46.175: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Speak -> Standby

!--- インターフェイスがダウンすると、アクティブ ルータの状態はスタンバイに変わります。

ルータ R2
*Mar  1 00:04:35.631: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Standby ->Active


!--- スタンバイ ルータがアクティブ ルータになります。
 

R2#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Active
    2 state changes, last state change 00:10:39
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.532 secs
  Preemption enabled, delay min 30 secs
  Active router is local
  Standby router is FE80::C00F:21FF:FE78:0, priority 30 (expires in 7.524 sec)
  Priority 100 (default 100)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 113216