IP : IP ルーティング

BGP MED 属性について

2013 年 10 月 3 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2011 年 4 月 26 日) | フィードバック

概要

このドキュメントの目的は、ボーダー ゲートウェイ プロトコル(BGP)の Multi Exit Discriminator(MED)属性が自律システム(AS)の境界を越えたときの動作について、異なるシナリオに実装することで詳しく理解することです。

MED は、AS へのエントリ ポイントが複数ある場合に、特定のルートに到達するように、別の AS に対して動的に影響を与える方法を提供します。BGP は体系的な手順に従って最適なパスを選択します。MED 以外にも、ウェイト、ローカル プリファレンス、オリジネート ルート、AS パスなど考慮すべき重要な属性がいくつかあります。このため、これらのいずれかの条件と合致する場合、MED 属性については考慮されません。

注: その他の要素がすべて等しい場合、最低値 の MED が優先されます。

前提条件

要件

BGP に関する基本的な知識があることが推奨されます。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。このドキュメントのシナリオは、次のハードウェアとソフトウェアのバージョンに基づくものです。

  • シナリオ 1: Cisco IOS® ソフトウェア リリース 12.4 以降が稼働する Cisco 2600 ルータ

  • シナリオ 2: Cisco IOS ソフトウェア リリース 12.4 以降が稼働する Cisco 2600 ルータ

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

ケース スタディ

シナリオ 1

BGP スピーカはピアからルートを学習すると、ルートの MED は外部 BGP(eBGP)ピアではなく別の内部 BGP(iBGP)ピアに渡されます。

次のネットワーク構成について考えてみます。

bgpmed-attr-01.gif

ここでは、ルータ R1 とルータ R2 が同一の AS 上(たとえば AS#100)に存在し、ルータ R3 は AS#101 に属しています。分かりやすくするため、IP アドレスは /24 ブロックを使用します。

ルータ R1 と R2 は、次のように設定されています。

ルータ 1
(Config)#interface Loopback10
(Config-if)#ip address 10.10.10.10 255.255.255.255
(Config-if)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.1 255.255.255.0
(Config)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 10.10.10.10
(Config-router)#bgp log-neighbor-changes
(Config-router)#network 10.10.10.10 mask 255.255.255.255 route-map ATTACH_MED
(Config-router)#neighbor 192.1.12.2 remote-as 100
(Config-router)#no auto-summary
(Config)#access-list 10 permit 10.0.0.0
(Config)#route-map ATTACH_MED permit 10
(Config)#match ip address 10
(Config)#set metric 100

ルータ 2
(Config)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.2 255.255.255.0
(Config-if)#interface Serial1/0
(Config-if)#ip address 192.1.23.2 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.3 203 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 22.22.22.22
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.12.1 remote-as 100
(Config-router)#neighbor 192.1.23.3 remote-as 101
(Config-router)#neighbor 192.1.23.3 ebgp-multihop 3
(Config-router)#no auto-summary

ルータ R3 の設定は、次のとおりです。

ルータ 3
(Config)#interface Serial1/0
(Config-if)#ip address 192.1.23.3 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.2 302 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 101
(Config-router)#no synchronization
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.2 remote-as 100
(Config-router)#neighbor 192.1.23.2 ebgp-multihop 3
(Config-router)#no auto-summary

この構成では、R1 と R2 で iBGP が実行中です。そのため、特定のメトリックを持つアップデートが AS に到達すると、AS 内部ではメトリックを使用してルートが決定されます。R2 から show ip bgp コマンドを実行すると、10.10.10.10 のメトリック値が表示されます。これは、iBGP ネイバーの 192.1.12.1 から学習したもので、MED 値は 100 です。

R2 の出力結果は、次のとおりです。

bgpmed-attr-02.gif

R2 と R3 は異なる AS にあるので、両ルータ間では eBGP が実行されています。同じアップデートが第 3 の AS(たとえば AS#101)に送信される場合、メトリックは 0 に戻ります。R3 から show ip bgp コマンドを実行すると、10.10.10.10 が AS の境界(101)を越えるため、メトリックが削除されます。

R3 の出力結果は、次のとおりです。

bgpmed-attr-03.gif

このシナリオを見ると、隣接する自律システムからの着信トラフィックに対して、MED 属性が影響を与えていることは明らかです。MED 属性は、さらに離れた自律システムのルート判断に影響を与えることはできません。BGP スピーカはピアからルートを学習すると、ルートの MED は eBGP ピアではなく、任意の iBGP ピアに渡されます。その結果、MED は隣接する自律システム間でのみ関連性を持つことになります。

シナリオ 2

network コマンドか redistribute コマンドのいずれかによって)BGP に挿入されたルートが IGP(RIP または EIGRP、もしくは OSPF)を使用している場合、MED のメトリック値は IGP のメトリックから受け継ぎ、ルートはこの MED を使用して eBGP ネイバーにアドバタイズされます。

このシナリオでは、次のネットワーク構成を使用しています。

bgpmed-attr-04.gif

このネットワークでは、R1 は RIP ネットワークで動作するよう設定されています。ルータ R2 と R3 では BGP が実行されており、R2 には AS 100 が、R3 には AS 101 が設定されています。

ルータ R1 は次のように設定されます。

ルータ R1
(Config)#interface Loopback10
(Config-if)#ip address 10.10.10.10 255.255.255.255
(Config-if)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.1 255.255.255.0
(Config)#router rip
(Config-router)#network 10.0.0.0
(Config-router)#network 192.1.12.0
(Config-router)#no auto-summary

ルータ R2 と R3 には BGP が設定されているので、R2 は BGP に RIP ネットワークをインジェクトするため、再配布を実行します。

ルータ R2
(Config)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.2 255.255.255.0
(Config-if)#interface Serial1/0
(Config-if)#ip address 192.1.23.2 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.3 203 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router rip
(Config-router)# network 192.1.12.0
(Config-router)#no auto-summary
(Config-router)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 22.22.22.22
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.3 remote-as 101
(Config-router)#neighbor 192.1.23.3 ebgp-multihop 3
(Config-router)#redistribute rip metric 1
 Config-router)#no auto-summary

ルータ R3
(Config)#interface Serial1/0
(Config-if)#ip address 192.1.23.3 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.2 302 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 101
(Config-router)# no synchronization
(Config-router)#bgp router-id 33.33.33.33
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.2 remote-as 100
(Config-router)#neighbor 192.1.23.2 ebgp-multihop 3
(Config-router)#no auto-summary

R2 では RIP と BGP の両方が実行されています。show ip bgp コマンドを実行すると、プレフィックス 10.0.0.0 ネットワークのメトリックは 1 になっていることに気付きます。この値は、RIP から受け継いだものです。

R2 の出力結果は、次のとおりです。

bgpmed-attr-05.gif

しかし、eBGP を実行中の R3 には、IGP から受け継いだ MED 値に基づいてネットワークがアドバタイズされています。この例では RIP です。プレフィックス 10.0.0.0 には、RIP のメトリック値 1 の IGP MED 値がアドバタイズされます。

これは、次の出力結果で確認できます。

bgpmed-attr-06.gif

このシナリオを見ると、network コマンドまたは redistribute コマンドを使用して BGP ルータにインジェクトされたネットワークでは、実際の MED 値は IGP メトリックによって置き換わることが明らかです。この属性は、AS への優先パスに関する外部隣接ルータのヒントです。前述したとおり、最適なルートの決定でより重要な属性が他にある場合、MED 属性については考慮されません。より決定的な属性で同様の効果を得るには、ルート マップ下で set as-path prepend コマンドを実行してください。特定のルートに対して AS パスを付加すると、その他の AS でも同じパスが引き続き表示されるようになります。as-path prepend コマンド使用の詳細については、『set as-path prepend コマンドの使用』を参照してください。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 112965