IP : IP アドレッシング サービス

IPv6 のスタティック NAT-PT の設定例

2013 年 10 月 3 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2012 年 9 月 10 日) | フィードバック

概要

ネットワーク アドレス変換 - ポート変換(NAT-PT)は、IPv6 から IPv4 への変換メカニズムです。これによって IPv6 専用デバイスと IPv4 専用デバイスの間の通信が可能になります。NAT-PT は、単一の V4 アドレスを使用して IPv6 のみのネットワークと IPv4 のみのネットワークの間の透過的な直接通信を実現するために配置されます。

このドキュメントでは、設定例を通じてスタティック NAT-PT の実装について説明します。IPv6 ネットワーク ノードは、NAT-PT ルータに設定されている IPv4 と IPv6 のアドレス マッピングを使用して、IPv4 ネットワーク ノードと通信します。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • NAT の概念と運用に関する基本的な知識

  • IPv6 アドレス割り当て方式に関する基本的な知識

  • IPv6 スタティック ルーティングに関する基本的な知識

注: NAT-PT は、ドメイン ネーム システム(DNS)への依存度の高さや変換に関する全般的な制限が原因で IETF では廃止扱いとなり、スケーラブルな変換サービスを維持するには複雑すぎるテクノロジーと見なされてきました。NAT-PT は廃止されましたが、ユーザ間の IPv6 変換は増えつつあり、NAT64 が導入されました。NAT64 の詳細については、次のドキュメントを参照してください。

使用するコンポーネント

このドキュメントで紹介する設定は、Cisco IOS® ソフトウェア リリース 12.4 (15)T 13 を搭載した Cisco 3700 シリーズ ルータに基づくものです。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この例では、3 台のルータ R1、R2、R3 がシリアル インターフェイスを通じて接続されています。R1 が NAT-PT ルータとして機能し、IPv4 アドレスを使用するルータ R2 と IPv6 アドレスを使用するルータ R3 と接続しています。

注: NAT-PT は、シスコ エクスプレス フォワーディング(CEF)ではサポートされないので、無効にする必要があります。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用します。

ネットワーク図

この例では、次のネットワーク構成を使用しています。

nat-ptv6-01.gif

コンフィギュレーション

この例では、次の設定を使用します。

R1 の設定
hostname R1
ipv6 unicast-routing
!
interface Serial0/0
 ip address 192.168.30.10 255.255.255.0
 duplex auto
 speed auto
 ipv6 nat
!
interface Serial0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:DB8:3002::9/64
 ipv6 enable
!
ipv6 route ::/0 2001:DB8:3002::10
ipv6 nat v4v6 source 192.168.30.9 2000::960B:202

!--- R2 fa0/0 の ipv4 アドレスを ipv6 アドレスに変換します。
          
ipv6 nat v6v4 source 3001:11:0:1::1 150.11.3.1

!--- R3 の loop0 の ipv6 アドレスを ipv4 アドレスに変換します。
              
ipv6 nat prefix 2000::/96

!--- 2000::/96 と一致する送信先プレフィクス 
!---が NAT-PT によって変換されます。
                            
!
end

R2 の設定
hostname R2
!
interface Serial0/0
 ip address 192.168.30.9 255.255.255.0
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.30.10
!

!
end

R3 の設定
hostname R3
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 3001:11:0:1::1/64
!
interface Serial0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:DB8:3002::10/64
!
ipv6 route ::/0 2001:DB8:3002::9
!

確認

このセクションでは、設定が正常に機能していることを確認します。

ルータ R3 内

次に示すとおり、R3 の Loopback0 の IPv6 アドレスからのパケットはすべて、IPv6 アドレス 2000::960B:202 を使用することで、fa0/0 IPv4 アドレスに到達できます。

ping
R3#ping 2000::960b:202 sou lo 0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000::960B:202, timeout is 2 seconds:
Packet sent with a source address of 3001:11:0:1::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/60/124 ms

!--- ルータ R3 は アドレス 
!--- 3001:11:0:1::1 を通じてルータ R2 に到達できます。

ルータ R2 内

ping
R2#ping 150.11.3.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.11.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/68/120 ms

!--- 正常な ping 応答により、ルータ R2
!--- から IPv6 ネットワークに到達できることがわかります。

ルータ R1 内

show ipv6 nat translations

show ipv6 nat translations
R1#show ipv6 nat translations
Prot  IPv4 source              IPv6 source
      IPv4 destination         IPv6 destination
---   ---                      ---
      192.168.30.9             2000::960B:202

---   150.11.3.1               3001:11:0:1::1
      ---                      ---

R1#show ipv6 nat translations
Prot  IPv4 source              IPv6 source
      IPv4 destination         IPv6 destination
---   ---                      ---
      192.168.30.9             2000::960B:202

---   150.11.3.1               3001:11:0:1::1
      ---                      ---

!--- このコマンドはルータ内のアクティブな NAT-PT 変換を示します。

debug ipv6 nat detailed

debug ipv6 nat detailed
R1#debug ipv6 nat detailed
R1#
*Mar  1 09:12:41.877: IPv6 NAT: Found prefix 2000::/96
*Mar  1 09:12:41.881: IPv6 NAT: IPv4->IPv6:
                 src (192.168.30.9 -> 2000::960B:202)
                 dst (0.0.0.0 -> ::)
                 ref_count = 1, usecount = 0, flags = 513,
                 rt_flags = 0, more_flags = 0

*Mar  1 09:12:41.881: IPv6 NAT: IPv4->IPv6:
                 src (0.0.0.0 -> ::)
                 dst (150.11.3.1 -> 3001:11:0:1::1)
                 ref_count = 1, usecount = 0, flags = 257,
                 rt_flags = 0, more_flags = 0

*Mar  1 09:12:41.925: IPv6 NAT: IPv6->IPv4:
                 src (3001:11:0:1::1 -> 150.11.3.1)
                 dst (2000::960B:202 -> 192.168.30.9)
                 ref_count = 1, usecount = 0, flags = 2,
                 rt_flags = 0, more_flags = 0

*Mar  1 09:12:41.925: IPv6 NAT: icmp src (3001:11:0:1::1) -> (150.11.3.1), 
                 dst (2000::960B:202) -> (192.168.30.9)
*Mar  1 09:12:41.965: IPv6 NAT: Found prefix 2000::/96
*Mar  1 09:12:41.965: IPv6 NAT: IPv4->IPv6:
                 src (192.168.30.9 -> 2000::960B:202)
                 dst (150.11.3.1 -> 3001:11:0:1::1)
                 ref_count = 1, usecount = 0, flags = 2,
                 rt_flags = 0,


!--- このコマンドは NAT-PT イベントについての詳細情報を表示します。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 113275