サーバ - ユニファイド コンピューティング : Cisco UCS Manager

UCS FCoE アップリンク 設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

この資料にイーサネット(FCoE)アップリンク上の Fibre Channel を設定する方法を記述されています。 Cisco Unified Computing System (UCS)バージョン 2.1 および それ 以降 バージョンでは、イーサネット(FCoE)サポート上のマルチホップ Fibre Channel はもたらされました。 このサポートは Fibre Channel (FC)およびイーサネットを両方運ぶ 2 つの個別のリンクから単一 アップリンクにアップリンク 強化を可能にします。

: 統一されたアップリンクは統一されたポートと異なっています。 どのファブリック相互接続(FI)でも、生成 1 が含まれている、アップリンクを統一できます。 ただし、生成だけ 2 FIs ポートを統一しました。

クリストファー ブラウンによって貢献される、Cisco TAC エンジニア。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

この文書に記載されている情報は UCS マネージャ(UCSM)バージョン 2.1 に基づいています。 少なくともこの資料を使用するためにバージョン 2.1(1a) を実行して下さい。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

設定

サポートされている設定

これらのコンフィギュレーションすべてでは、同じ型の port-channel とリンクを取り替えることができます。 たとえば、設定が 1 リンクを示せば、それは 1 port-channel で代りに設定することができます。 ただし、同じ port-channel のイーサネットおよび統一されたポートがあることができません。

仮想ポート チャネル(vPC)の FCoE アップリンク

この設定は統一されたリンクが含まれていませんが、それは現在 の 環境に FCoE アップリンクを統合最も簡単な方法です。 この設定は FC ファブリックを交差させる必要を省きます。

ピンで止めることと相互接続される

この設定では、Nexus 5000 シリーズ スイッチ(N5ks)および FIs は相互接続、しかし一緒にポート チャネリングされなくてです。 これはいくつかの統一されたアップリンクがあることを可能にしますがまだよく知られている な ネットワーク設計を維持します。

すべての統一されたアップリンク

この設定はほとんどの強化を提供します。 これらのリンクがまたポート チャネルである場合もあるすべてのリンク統一されたアップリンクでなければなりませんことを覚えていて下さい。 これはもっとも一般的な 実装である可能性が高いです。

UCS の設定

UCS を設定する 3 つのステップがあります:

  1. 仮想 な ストレージ エリア ネットワーク(VSAN)を設定して下さい。
  2. 統一されたアップリンクを設定して下さい。
  3. ポート チャネル(オプションの)を設定して下さい。

VSAN を設定する

この設定では、VSAN 500 はファブリック A からあり、VSAN 600 はファブリック B.からあります。 これは標準 FC のための VSAN を作成するのが常である同じ 設定です。

統一されたアップリンクを設定して下さい

統一されたアップリンクは GUI に隠れます。 統一されたポートを作るために、アップリンクか FCoE アップリンクで最初にそれを設定して下さい。 それから、ように統一されたポートそれを設定できます。 この設定は最初のロールを取除きません。 その代り、それは両方ともあるインターフェイスを作成します。

VSAN をこの時点で設定 することを確かめて下さい。

この時点で、UCS は統一されたトラフィックのために設定されます。 この例はポート チャネルを使用しません。 ただし、ポート チャネルを普通この時点で設定できます。 port-channel のための VSAN タブの下で VSAN を設定 することを確かめて下さい。

N5k の設定

N5k の設定は 3 つのステップで構成されています:

  1. イネーブル FCoE およびデフォルト Quality of Service (QoS)設定。 FCoE VLAN を作成し、それに VSAN を結合 して下さい。
  2. イーサネットインターフェイス設定して下さい(または port-channel を)。
  3. 仮想ファイバ チャネル(vFC)を作成し、イーサネットインターフェイスにそれを結合 して下さい。

: UCS はデフォルトで N ポート 仮想化(NPV)スイッチです従ってアップストリーム スイッチは N ポート識別子 Virtulization (NPIV)モードにある必要があります(有効に なるために機能 npiv コマンドを入力して下さい)。  N ポート 仮想化をこの機能に関する詳細については設定することを参照して下さい。

FCoE を有効に し、QoS 設定をディフォルトして下さい

N5k が FCoE のために既に設定されている場合このステップをスキップできます。 N5k が FCoE のために設定されない場合、手順に関してはこの資料の終わりに付録 A を参照して下さい。

イーサネットインターフェイス設定して下さい(またはポート チャネルを)

これは UCS に普通接続するインターフェイスのための設定です。  FCoE VLAN を許可することを確かめて下さい。

f340-31-15-5596-1(config)# interface ethernet 1/32
f340-31-15-5596-1(config-if)# switchport mode trunk
f340-31-15-5596-1(config-if)# switchport trunk allowed vlan all

これは非常に基本的な幹線コンフィギュレーションの例です。 このインターフェイスに FCoE 設定がないことに注意して下さい。

vFC を設定して下さい

これは UCS からの FCoE すべてのトラフィックを処理する vFC のための設定です、:

f340-31-15-5596-1(config-if)# int vfc 25
f340-31-15-5596-1(config-if)# switchport trunk allowed vsan 500
f340-31-15-5596-1(config-if)# no shut
f340-31-15-5596-1(config-if)# bind interface ethernet 1/32
f340-31-15-5596-1(config-if)#

この例で注意するべき少数のポイントがあります:

  • vFC 数は重要ではありません。 それはまだ使用中ではない限り何でもである場合もあります。
  • これはトランキング ファブリック(TF)ポートです、従って VSAN を許可することを確かめて下さい。
  • UCS に直面するインターフェイスにこれを結合 して下さい。 これは FCoE トラフィックが送信 されたり/受信される物理インターフェイスです。 それは VSAN と関連付けられる VLAN で送信 されます。

この時点で、すべてを申し分なく設定してもらいます。 VSAN がアップするようにするために show interface vfc XX コマンドを入力して下さい。

f340-31-15-5596-1(config-if)# show interface vfc 25
vfc25 is trunking
Bound interface is Ethernet1/32
Hardware is Ethernet
Port WWN is 20:18:54:7f:ee:d3:f8:bf
Admin port mode is F, trunk mode is on
snmp link state traps are enabled
Port mode is TF
Port vsan is 500
Trunk vsans (admin allowed and active) (500)
Trunk vsans (up) (500)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()
1 minute input rate 4448 bits/sec, 556 bytes/sec, 1 frames/sec
1 minute output rate 610448 bits/sec, 76306 bytes/sec, 27 frames/sec
27347 frames input, 45743308 bytes
0 discards, 0 errors
114710 frames output, 218235936 bytes
0 discards, 0 errors
last clearing of "show interface" counters Thu May 9 13:37:42 2013

Interface last changed at Thu May 9 14:03:44 2013

VSAN がない場合、設定および接続を確認して下さい。 そうでイーサネットポートそれでもあったら N5k のダウンして下さい、フラップして下さい。

この時点で、標準 FC 設定(ブート ポリシー、ゾーニング)を適用します。

f340-31-15-5596-1(config-if)# show flogi database
--------------------------------------------------------------------------------
INTERFACE VSAN FCID PORT NAME NODE NAME
--------------------------------------------------------------------------------
fc2/3 500 0xd80000 20:42:00:0d:ec:b1:34:c0 21:f4:00:0d:ec:b1:34:c1
fc2/3 500 0xd80001 20:00:00:25:b5:12:dc:5f 20:00:00:25:b5:13:dc:2f
[svinfra-esxi-1]
fc2/3 500 0xd80003 20:00:00:25:b5:12:dc:3f 20:00:00:25:b5:13:dc:0f
[svinfra-esxi-2]
vfc7 500 0xd80060 25:f6:00:0d:ec:cc:d3:ff 21:f4:00:0d:ec:cc:d3:c1
vfc7 500 0xd80061 20:00:00:25:b5:19:70:28 20:00:00:25:b5:19:70:18
vfc25 500 0xd80042 20:00:00:25:b5:ab:1a:01 20:00:00:25:b5:00:00:8f
vfc25 500 0xd80043 20:00:00:25:b5:ab:1a:02 20:00:00:25:b5:00:00:9f
vfc25 500 0xd80044 20:00:00:25:b5:00:3a:08 20:00:00:25:b5:00:00:5f
vfc25 500 0xd80045 20:00:00:25:b5:00:3a:09 20:00:00:25:b5:00:00:4f
vfc25 500 0xd80048 2d:9a:00:05:73:c2:c6:3f 21:f4:00:05:73:c2:c6:01

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

付録 A - N5k 基本的な FCoE 設定

FCoE のための N5k を設定するために、入力して下さい:

feature fcoe
system qos
service-policy type network-qos fcoe-default-nq-policy
service-policy type queuing input fcoe-default-in-policy
service-policy type queuing output fcoe-default-out-policy
service-policy type qos input fcoe-default-in-policy

これらのコマンドは最初に FCoE を有効に し、次に FCoE のために必要であるデフォルト QoS ポリシーを有効に します。 カスタム QoS 設定がある場合、ベースとしてそれらを使用して下さい。 デフォルト 設定はここにあります:

  policy-map type qos fcoe-default-in-policy
class type qos class-fcoe
set qos-group 1
class type qos class-default
set qos-group 0

policy-map type queuing fcoe-default-in-policy
class type queuing class-fcoe
bandwidth percent 50
class type queuing class-default
bandwidth percent 50
policy-map type queuing fcoe-default-out-policy
class type queuing class-fcoe
bandwidth percent 50
class type queuing class-default
bandwidth percent 50

policy-map type network-qos fcoe-default-nq-policy
class type network-qos class-fcoe

pause no-drop
mtu 2158
class type network-qos class-default

mtu 1500
multicast-optimize

見てわかるように、これらのポリシーは FCoE トラフィック クラスを作成し、非ドロップするのためにそれを示し、それに専用 帯域幅を与えます。 必要とすると同時にこれらを修正できます(たとえば、ジャンボ フレームを追加するため)。

次に、VLAN に VSAN を結合 する必要があります:

f340-31-15-5596-1(config)# vlan 500
f340-31-15-5596-1(config-vlan)# name VNX_500
f340-31-15-5596-1(config-vlan)# fcoe vsan 500
f340-31-15-5596-1(config-vlan)#

これは VLAN 500 が入る FCoE VLAN であること、そしてどのトラフィックでも VSAN 500 に切り替える必要があることを N5k に告げます。

この時点で、N5k は FCoE のために設定され、UCS 接続の用意します。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 116188