マルチプロトコル ラベル スイッチング(MPLS) : MPLS

統一された MPLS 設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

この資料は統一されたマルチプロトコル ラベル スイッチング(MPLS)の目的を記述し、設定例を提供したものです。

Cisco TAC エンジニア、Luc De Ghein により寄稿されました。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

背景説明

統一された MPLS の目的はスケーリングについて完全にあります。 patforms には異なる型およびネットワークの一部にサービスがある MPLS ネットワークをスケーリングするために、それは個別の領域にネットワークを分割する理にかなっています。 典型的な設計は側の集約のセンターでコアがある階層をもたらします。 スケーリングするために、そこにコアの異なる Interior Gateway Protocols (IGP) vs 集約である場合もあります。 スケーリングするために、他に 1 IGP からの IGP プレフィックスを配ることができません。 他の IGP に 1 IGP からの IGP プレフィックスを配らない場合、エンドツーエンド ラベル スイッチド パス(LSP)は可能性のあるではないです。

エンドツーエンド MPLS サービスを提供するために LSP がエンドツーエンドであることを必要とします。 目標は保存することある、しかしより大きいスケーラビリティをですので MPLS サービス(MPLS VPN、MPLS L2VPN)をもたらすこと。 これをするために、エンドツーエンド プレフィックスを配る Border Gateway Protocol (BGP) (Provider Edge (PE) ルータのループバック プレフィックス)にいくつかの IGP プレフィックスを移動して下さい。

アーキテクチャ

図 1 3 つの個別の領域のネットワークを示します: 側の 1 コアおよび 2 つの集約エリア。 各 エリアはそのの間でエリア境界ルータ(ABR)の再配布無しで自身の IGP を、実行します。 BGP の使用は必要エンドツーエンド MPLS LSP を提供するためです。 BGP はドメイン全体を渡るラベルの PE ルータのループバックをアドバタイズし、エンドツーエンド LSP を提供します。 BGP は RFC 3107 の PE と ABR の間で展開されます、つまり BGP が IPv4 プレフィクス + ラベル(AFI/SAFI 1/4)を送信 することを意味します。

ネットワークのコアおよび集約部品が統合されて、エンドツーエンド LSP が提供されるので、統一された MPLS ソリューションはまた「シームレス MPLS と言われます」。

新 技術かプロトコルはここでは、MPLS、ラベル配布プロトコル (LDP)、IGP および BGP だけを使用されません。 他の一部にネットワークの 1 人の部からの PE ルータのループバック プレフィックスを配りたいと思わないので BGP のプレフィックスを運ぶ必要があります。 内部ボーダーゲートウェイプロトコル(iBGP)はプレフィックスの 1 つのネットワーク、従ってネットワークの他の一部の IGP によって認識されていないネクストホップ アドレスでです PE ルータのループバック プレフィックス使用されます。 これは IGP プレフィクスへの recurse へのネクストホップ アドレスが使用することができないことを意味します。 トリックは ABR ルータにルート リフレクタ(RR)をし、反映された iBGP プレフィックスのための自己にネクスト ホップを、設定 することです。 はたらくこれのために新しいノブは必要です。

RR だけより新しいソフトウェアがこのアーキテクチャをサポートすることを必要とします。 RR が彼ら自身にネクスト ホップが設定されていると BGP プレフィックスをアドバタイズするので BGP プレフィックスにローカル MPLS ラベルを割り当てます。 これはデータ平面で、これらのエンドツーエンド LSP で転送されるパケットにラベルスタックで余分 MPLS ラベルがあることを意味します。 RR はフォワーディングパスにあります。

: このアーキテクチャに、どの MPLS サービスでも提供されます。 たとえば、MPLS VPN か MPLS L2VPN は PE ルータの間で提供されます。 これらのパケットのためのデータ平面の違いはラベルスタックで 2 つのラベルがときにあった一方それらにラベルスタックで今 3 つのラベルがあることです、統一された MPLS は使用されませんでした。

2 つの可能 な シナリオがあります:

  • ABR はネットワークの集約部品に ABR によって(BGP によって反映されて)アドバタイズされるプレフィックスのための自己にネクスト ホップを設定 しません。 このような理由で、ABR は集約 IGP にコア IGP からの ABR のループバック プレフィックスを再配布する必要があります。 これがされる場合、今でもスケーラビリティがあります。 ABR ループバック プレフィックスだけ(コアから)リモート集約部品からの PE ルータからのないループバック プレフィックス集約部品にアドバタイズされる必要があります。

  • ABR は集約部品に ABR によって(BGP によって反映されて)アドバタイズされるプレフィックスのための自己にネクスト ホップを設定 します。 このような理由で、ABR は集約 IGP にコア IGP からの ABR のループバック プレフィックスを再配布する必要はありません。

両方のシナリオで、ABR はコア部品にネットワークの集約部品からの ABR によって(BGP によって反映されて)アドバタイズされるプレフィックスのための自己にネクスト ホップを設定 します。 これがされない場合、ABR はコア IGP に集約 IGP からの PE のループバック プレフィックスを再配布する必要があります。 これがされる場合、スケーラビリティがありません。

ネクスト ホップを反映された iBGPルートのための自己に設定 するために、すべてのコマンド ネイバー x.x.x.x next-hop-self を設定して下さい。

設定

これはシナリオ 2.のための PE ルータおよび ABR の設定です。

: toplogy は図 2.示されています。 サービス例は xconnect (MPLS L2VPN)です。 PE ルータと ABR 間で、IPv4 + ラベルのための BGP があります。

PE1

interface Loopback0
 ip address 10.100.1.4 255.255.255.255

!
interface Ethernet1/0
 no ip address
 xconnect 10.100.1.5 100 encapsulation mpls
!
router ospf 2
 network 10.2.0.0 0.0.255.255 area 0
 network 10.100.1.4 0.0.0.0 area 0
!
router bgp 1
 bgp log-neighbor-changes
 network 10.100.1.4 mask 255.255.255.255
 neighbor 10.100.1.1 remote-as 1
 neighbor 10.100.1.1 update-source Loopback0
 neighbor 10.100.1.1 send-label

RR1


interface Loopback0
 ip address 10.100.1.1 255.255.255.255
router ospf 1
 network 10.1.0.0 0.0.255.255 area 0
 network 10.100.1.1 0.0.0.0 area 0
!
router ospf 2
 redistribute ospf 1 subnets match internal route-map ospf1-into-ospf2
 network 10.2.0.0 0.0.255.255 area 0
!
router bgp 1
 bgp log-neighbor-changes
 neighbor 10.100.1.2 remote-as 1
 neighbor 10.100.1.2 update-source Loopback0
 neighbor 10.100.1.2 next-hop-self all
 neighbor 10.100.1.2 send-label
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 route-reflector-client
 neighbor 10.100.1.4 next-hop-self all
 neighbor 10.100.1.4 send-label

ip prefix-list prefix-list-ospf1-into-ospf2 seq 5 permit 10.100.1.1/32

route-map ospf1-into-ospf2 permit 10
 match ip address prefix-list prefix-list-ospf1-into-ospf2


RR2

interface Loopback0
 ip address 10.100.1.2 255.255.255.255

router ospf 1
 network 10.1.0.0 0.0.255.255 area 0
 network 10.100.1.2 0.0.0.0 area 0
!
router ospf 3
 redistribute ospf 1 subnets match internal route-map ospf1-into-ospf3
 network 10.3.0.0 0.0.255.255 area 0
!
router bgp 1
 bgp log-neighbor-changes
 neighbor 10.100.1.1 remote-as 1
 neighbor 10.100.1.1 update-source Loopback0
 neighbor 10.100.1.1 next-hop-self all
 neighbor 10.100.1.1 send-label
 neighbor 10.100.1.5 remote-as 1
 neighbor 10.100.1.5 update-source Loopback0
 neighbor 10.100.1.5 route-reflector-client
 neighbor 10.100.1.5 next-hop-self all
 neighbor 10.100.1.5 send-label

ip prefix-list prefix-list-ospf1-into-ospf3 seq 5 permit 10.100.1.2/32

route-map ospf1-into-ospf3 permit 10
 match ip address prefix-list prefix-list-ospf1-into-ospf3


PE2

interface Loopback0
 ip address 10.100.1.5 255.255.255.255

interface Ethernet1/0
 no ip address
 xconnect 10.100.1.4 100 encapsulation mpls

router ospf 3
 network 10.3.0.0 0.0.255.255 area 0
 network 10.100.1.5 0.0.0.0 area 0

router bgp 1
 bgp log-neighbor-changes
 network 10.100.1.5 mask 255.255.255.255
 neighbor 10.100.1.2 remote-as 1
 neighbor 10.100.1.2 update-source Loopback0
 neighbor 10.100.1.2 send-label

: コア IGP (集約 IGP の再配布への 1) ospfospf2ospf はルート マップと 3) 実行された。 このルート マップは RR のループバック プレフィックスが集約 IGP に再配布するようにします。 この理由は RR のループバック プレフィクスがコア IGP (1) ospf にだけ直接アドバタイズされることです。 ただし、RR のループバック プレフィクスは集約 IGP で PE ルータの BGP が RR のループバックとピアリングできるようにまた知っている必要があります。

確認

コントロール プレーン オペレーションを確認するために図 2 参照して下さい。

MPLS ラベル アドバタイズメントを確認するために図 3 参照して下さい。

確認をパケット転送 図 4 参照して下さい。

これはパケットが PE1 から PE2 へのどのように転送されるかです。 PE2 のループバック プレフィクスはプレフィクスが対象であるように、10.100.1.5/32 です。

PE1#show ip route 10.100.1.5

Routing entry for 10.100.1.5/32
  Known via "bgp 1", distance 200, metric 0, type internal
  Last update from 10.100.1.1 00:11:12 ago
  Routing Descriptor Blocks:
  * 10.100.1.1, from 10.100.1.1, 00:11:12 ago
    Route metric is 0, traffic share count is 1
    AS Hops 0
    MPLS label: 22


PE1#show ip cef 10.100.1.5
10.100.1.5/32
  nexthop 10.2.2.6 Ethernet0/0 label 19 22


PE1#show ip cef 10.100.1.5 detail
10.100.1.5/32, epoch 0, flags rib defined all labels
  1 RR source [no flags]
  recursive via 10.100.1.1 label 22
    nexthop 10.2.2.6 Ethernet0/0 label 19

PE1#show bgp ipv4 unicast labels

   Network          Next Hop      In label/Out label
   10.100.1.4/32    0.0.0.0         imp-null/nolabel
   10.100.1.5/32    10.100.1.1      nolabel/22


P1#show mpls forwarding-table labels 19 detail
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label      Label      or Tunnel Id     Switched      interface             
19         Pop Label  10.100.1.1/32    603468        Et1/0      10.2.1.1  
        MAC/Encaps=14/14, MRU=1504, Label Stack{}
        AABBCC000101AABBCC0006018847
        No output feature configured


RR1#show mpls forwarding-table labels 22 detail
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label      Label      or Tunnel Id     Switched      interface            
22         21         10.100.1.5/32    575278        Et0/0      10.1.1.3  
        MAC/Encaps=14/22, MRU=1496, Label Stack{17 21}
        AABBCC000300AABBCC0001008847 0001100000015000
        No output feature configured


RR1#show bgp ipv4 unicast labels
   Network          Next Hop      In label/Out label
   10.100.1.4/32    10.100.1.4      19/imp-null
   10.100.1.5/32    10.100.1.2      22/21


P3#show mpls forwarding-table labels 17 detail
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label      Label      or Tunnel Id     Switched      interface            
17         Pop Label  10.100.1.2/32    664306        Et1/0      10.1.2.2  
        MAC/Encaps=14/14, MRU=1504, Label Stack{}
        AABBCC000201AABBCC0003018847
        No output feature configured


RR2#show mpls forwarding-table labels 21 detail
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label      Label      or Tunnel Id     Switched      interface            
21         17         10.100.1.5/32    615958        Et0/0      10.3.1.7  
        MAC/Encaps=14/18, MRU=1500, Label Stack{17}
        AABBCC000700AABBCC0002008847 00011000
        No output feature configured


RR2#show bgp ipv4 unicast labels
   Network          Next Hop      In label/Out label
   10.100.1.4/32    10.100.1.1      22/19
   10.100.1.5/32    10.100.1.5      21/imp-null


P2#show mpls forwarding-table labels 17 detail
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label      Label      or Tunnel Id     Switched      interface            
17         Pop Label  10.100.1.5/32    639957        Et1/0      10.3.2.5  
        MAC/Encaps=14/14, MRU=1504, Label Stack{}
        AABBCC000500AABBCC0007018847
        No output feature configured


PE1#trace
Protocol [ip]:
Target IP address: 10.100.1.5
Source address: 10.100.1.4

DSCP Value [0]:
Numeric display [n]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 10.100.1.5
VRF info: (vrf in name/id, vrf out name/id)
  1 10.2.2.6 [MPLS: Labels 19/22 Exp 0] 3 msec 3 msec 3 msec
  2 10.2.1.1 [MPLS: Label 22 Exp 0] 3 msec 3 msec 3 msec
  3 10.1.1.3 [MPLS: Labels 17/21 Exp 0] 3 msec 3 msec 2 msec
  4 10.1.2.2 [MPLS: Label 21 Exp 0] 2 msec 3 msec 2 msec
  5  *  *  *
  6 10.3.2.5 4 msec *  4 msec

: ホップ 5 は示しますか。5 ** *か。 これはルータ P2 に traceroute のソース IP アドレス 10.100.1.4 (PE1)のためのルートがないという理由によります。 従って、ルータ P2 は PE1 にインターネット制御メッセージ プロトコル (ICMP) エラーメッセージを送り返すことができません。 これは統一された MPLS のポイントが他の集約部品の IGP で現れるべき 1 人の集約部品のすべての PE ルータのループバック プレフィックスを持たないことであるので、正常です。 ルータ P2 はオリジナル ラベル スタックが付いている ICMPエラーメッセージを転送するように試みません。 これはオリジナル ラベル スタックに 1 ラベルがあるただという理由によります。 パケットのこのオリジナル ラベル スタックに 2つ以上のラベルがある場合、ICMPエラーメッセージは LSP に沿って転送され、traceroute のもとに到達できます。 オリジナル ラベル スタックに 1 ラベルだけある場合、ICMPエラーメッセージを生成するルータはルート ルックアップを試み、ルーティング テーブルの使用とそれをルーティングすることを試みます(オリジナル ラベル スタックの使用なしで)。

P2#show ip route 10.100.1.4
% Subnet not in table

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連情報


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 116127