ルータ : Cisco ASR 903 シリーズ アグリゲーション サービス ルータ

EVC 設定の後の ASR 903 Port-Channel グループ メンバー フラップ

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

この資料は port-channel グループ メンバーがフラップする問題にイーサネット 仮想接続(EVC)が Cisco ASR 903 シリーズ アグリゲーション サービス ルータで設定された後ソリューションを記述したものです。

アメル Ibrahimovic によって貢献される、Cisco TAC エンジニア。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

この文書に記載されている情報はカスタマー エッジ デバイスの方の port-channel でプロバイダー エッジ デバイスで設定される Cisco ASR 903 シリーズ アグリゲーション サービス ルータに基づいています。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

問題

port-channel グループ メンバーはイーサネット 仮想接続(EVC)を設定した後フラップし始めます; EVC 設定を取除くとき、port-channel グループ メンバーはもはやフラップしません。

ログはこれと同じような出力を表示する:

GigabitEthernet0/0/4 taken out of port-channel1
GigabitEthernet0/0/4 added as member-2 to port-channel1
GigabitEthernet0/0/5 taken out of port-channel1
GigabitEthernet0/0/5 added as member-2 to port-channel1

この問題は EVC の ASR 903 ポート チャネルに特定で、この設定 例で見られます:

!
interface Port-channel1
mtu 1604
no ip address
no negotiation auto
service instance 999 ethernet
encapsulation dot1q 999
rewrite ingress tag pop 1 symmetric
bridge-domain 999
!
service instance 1700 ethernet
encapsulation dot1q 1700
rewrite ingress tag pop 1 symmetric
xconnect 172.26.225.1 1700 encapsulation mpls pw-class TE101
!
service instance 1820 ethernet
encapsulation dot1q 1820
rewrite ingress tag pop 1 symmetric
xconnect 172.26.225.15 1820 encapsulation mpls pw-class TE305
!
interface GigabitEthernet0/0/4
mtu 1604
no ip address
negotiation auto
service-policy input Core-In
service-policy output Core-Out
channel-group 1 mode active
!
interface GigabitEthernet0/0/5
mtu 1604
no ip address
negotiation auto
cdp enable
service-policy input Core-In
service-policy output Core-Out
channel-group 1 mode active

解決策

ASR 903 の EVC でポート チャネルを設定するとき、タグが付いていないカプセル化および L2 プロトコルで 1 EVC を設定して下さい。 次に、例を示します。

interface Port-channel1
!
service instance 1 ethernet
encapsulation untagged
bridge-domain 1
l2protocol peer
!

ASR 903 サービス インスタンスおよびポート チャネルに関する詳細については、Cisco ASR 903 ルータのイーサネット 仮想接続の設定EFPs および EtherChannel セクションを参照して下さい。



Document ID: 116116