サーバ - ユニファイド コンピューティング : Cisco UCS Manager

UCS アップストリーム ポート チャネルの設定例

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

このドキュメントでは、Cisco UCS サーバでアップストリーム ポート チャネルを設定する方法について説明します。

寄稿者:Joe LeBlanc および Andrew Kelly、Cisco TAC Engineer

前提条件

要件

この設定を試行する前に、ポート チャネルに関する知識を得ておくことを推奨します。

使用するコンポーネント

このドキュメントの情報は、Cisco Unified Computing System(UCS)に基づくものです。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

設定

UCS ポート チャネルの設定は Link Aggregation Control Protocol(LACP)モード アクティブで静的に設定されます。 この設定は変更できません。 したがって、すべてのアップストリーム ポート チャネル設定も LACP モード アクティブに従う必要があります。 または、LACP モード パッシブに対するアップストリーム スイッチ ポートを設定できます。

CLI 設定

変更できない UCS インターフェイスのコンフィギュレーション例を次に示します。

UCS1-B(nxos)# show run interface eth1/19

!Command: show running-config interface Ethernet1/19
!Time: Fri Oct 12 20:25:59 2012

version 5.0(3)N2(2.11)

interface Ethernet1/19
description U: Uplink
pinning border
switchport mode trunk
switchport trunk allowed vlan 1,107,110-111,115,119,
168,175,179,183,200-201,279,283,379,383,555-556
channel-group 100 mode active
no shutdown

ポート チャネル インターフェイス設定を次に示します。

UCS1-B(nxos)# show run interface po100

!Command: show running-config interface port-channel100
!Time: Fri Oct 12 20:21:19 2012

version 5.0(3)N2(2.11)

interface port-channel100
description U: Uplink
switchport mode trunk
pinning border
switchport trunk allowed vlan 1,107,110-111,115,119,
168,175,179,183,200-201,279,283,379,383,555-556
speed 10000

ポート チャネルのメンバを表示するためにポート チャネルで show interface コマンドを実行できます。

UCS1-B(nxos)# show interface po100
port-channel100 is up
Hardware: Port-Channel, address: 000d.eccd.665a (bia 000d.eccd.665a)
Description: U: Uplink
MTU 1500 bytes, BW 20000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is trunk
full-duplex, 10 Gb/s
Beacon is turned off
Input flow-control is off, output flow-control is off
Switchport monitor is off
EtherType is 0x8100
Members in this channel: Eth1/19, Eth1/20

アップストリーム ポート チャネルは、UCS 設定と一致するために LACP である必要があります。 他の設定が存在していることがありますが、(少なくとも)次の設定がある必要があります。

5k# show run int eth1/3

!Command: show running-config interface Ethernet1/3
!Time: Sat Oct 13 00:30:51 2012

version 5.1(3)N2(1)

interface Ethernet1/3
switchport mode trunk
spanning-tree port type edge trunk
channel-group 100 mode active

NXOS のデバイスに spanning-tree port type edge trunk があります。 この設定により、リンクがフラップしたときに、ポートがただちにアップに戻ることが保障されます。 障害状態では、アップストリーム スイッチ ポートが STP の状態を遷移しないことが重要です。その場合、ダウンタイムが長くなります。 このコマンドの詳細については、spanning-tree port type edge を参照してください。

Cisco IOS でこのコマンドに相当するコマンドは spanning-tree portfast trunk です。

詳細は、次のドキュメントを参照してください。

: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

GUI 設定

  1. ポート チャネル インターフェイスを作成します。

    116095-configure-ucs-upstream-port-channel-01.jpg

  2. ポートを選択し、二重矢印をクリックして [Port Channel] に追加します。

  3. [Finish] をクリックすると、LACP がアップストリーム スイッチとネゴシエートする間、ポート チャネルはダウンとして表示されます。

    116095-configure-ucs-upstream-port-channel-02.jpg

アップストリームのスイッチが正しく設定されると、全体的なステータスがアップ状態に移行します。

トラブルシューティング

  • 速度が両側で異なる場合、ポート チャネルが起動しません。 これはよく起こる設定ミスです。
  • まずすべてのリンクを個別に起動してから、近隣ポートを確認しなければならないことがあります。 近隣ポートを確認するには、show cdp neighbor を使用します。


Document ID: 116095