セキュリティ : Cisco FlexVPN

FlexVPN の移行: DMVPN から別のハブの FlexVPN への完全移行

2013 年 6 月 28 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 12 月 21 日) | 英語版 (2013 年 11 月 22 日) | フィードバック

概要

このドキュメントでは、Dynamic Multipoint VPN(DMVPN)ネットワークから別のハブ デバイス上の FlexVPN への移行方法について説明します。

: 両方のフレームワーク コンフィギュレーションがデバイス上で共存できます。

このドキュメントでは、最も一般的なシナリオについてのみ紹介します。 DMVPN は認証に事前共有キーを使用し、ルーティング プロトコルとして Enhanced Interior Gateway Routing Protocol(EIGRP)を使用します。 このドキュメントでは、ボーダー ゲートウェイ プロトコル(BGP)(推奨されるルーティング プロトコル)および EIGRP(あまり推奨されない)への移行について説明します。

前提条件

要件

このドキュメントでは、読者が DMVPN と FlexVPN の基本概念について理解していることを前提としています。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • ISR:15.2(4)M1 以降

  • ASR1k:3.6.2 リリース 15.2(2)S2 以降

注: 一部のソフトウェアとハードウェアは IKEv2 をサポートしません。 詳細は、『Cisco Feature Navigator』を参照してください。

新しいプラットフォームとソフトウェアの数多い利点の中に、次世代暗号化使用のサポートがあります。たとえば、RFC 4106 に記載されている IPsec の暗号化に AES GCM を使用できます。

AES GCM により、一部のハードウェアでは暗号化速度の大幅な向上が実現できます。

シスコが推奨する次世代暗号化の使用と移行については、次を参照してください。

http://www.cisco.com/web/about/security/intelligence/nextgen_crypto.html

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

移行手順

現在、DMVPN から FlexVPN への推奨される移行方法では、2 つのフレームワークは同時に動作しません。

この制限は ASR 3.10 リリースで導入される新しい移行機能によって解除される予定です。このリリースは CSCuc08066登録ユーザ専用)を含むシスコ側の複数の拡張要求に対応するものです。 これらの機能は 2013 年 6 月後半に提供予定です。

両方のフレームワークが共存し、同じデバイス上で同時に動作する移行は穏やかな移行と呼ばれ、最小限の影響と、一方のフレームワークから他方への円滑なフェールオーバーを表します。

両方のフレームワークのコンフィギュレーションが共存するが同時に動作しない移行は、完全移行と呼ばれます。 これは、一方のフレームワークから他方へのスイッチオーバーによって、わずかな時間であっても VPN 通信が失われることを意味します。

異なる 2 つのハブ間の完全移行

このドキュメントでは、既存の DMVPN ハブから新しい FlexVPN ハブへの移行について説明します。

この移行では、FlexVPN へ移行済みのスポーク間の通信、および DMVPN をまだ実行しているスポーク間の通信が可能であり、移行はスポークごとに個別に複数フェーズで実行できます。

ルーティング情報が正しく登録された場合は、移行後のスポークと移行していないスポークの間の通信も可能なままです。 ただし、移行後のスポークと移行していないスポークの間にスポーク間トンネルが構築されないため、追加の遅延が発生する場合があります。

一方で、移行後のスポークは移行後のスポークとの間で直接スポーク間トンネルを確立できます。 移行していないスポークについても同様です。

新しい移行機能が提供されるまでの、異なるハブを使用した DMVPN から FlexVPN への移行の実施方法を次に示します。

  1. DMVPN 上の接続性を確認する。

  2. FlexVPN のコンフィギュレーションを適切な場所に追加し、新しいコンフィギュレーションに含まれるトンネルをシャットダウンする。

  3. (メンテナンスの時間帯に)各スポークで 1 つずつ DMVPN トンネルをシャットダウンする。

  4. ステップ 3 と同じスポークで FlexVPN トンネル インターフェイスのシャットダウンを解除する。

  5. スポークからハブへの接続性を確認する。

  6. FlexVPN 内のスポーク間の接続性を確認する。

  7. Flex からの DMVPN によるスポーク間の接続性を確認する。

  8. スポークごとに個別にステップ 3 〜 7 を繰り返す。

  9. ステップ 5、6、または 7 の確認が正常に行われなかった場合は、FlexVPN インターフェイスをシャットダウンし、DMVPN インターフェイスのシャットダウンを解除して DMVPN に戻す。

  10. バックアップ DMVPN 上のスポークからハブへの通信を確認する。

  11. バックアップ DMVPN 上のスポーク間の通信を確認する。

カスタム アプローチ

ネットワークまたはルーティングが複雑なために、この方法が最善でないと考えられる場合には、移行前にシスコの担当者にご連絡ください。 カスタム移行プロセスについては、担当のシステム エンジニアまたはアドバンスド サービス エンジニアにご相談ください。

ネットワーク トポロジ

転送ネットワーク トポロジ

次の図はインターネット上のホストの一般的な接続トポロジを示しています。 ハブの loopback0(172.25.1.1)の IP アドレスが DMVPN IPsec セッションを終端するために使用されています。 FlexVPN では新しいハブの IP(172.25.2.1)が使用されます。

2 つのハブ間のリンクにも注目してください。 このリンクは移行中に FlexVPN クラウドと DMVPN クラウドの間の接続を可能にするために重要です。

FlexVPN に移行済みのスポークの DMVPN ネットワークとの通信を可能にしたり、その逆を可能にしたりします。

flexvpn-hard-hub-01.png

オーバーレイ ネットワーク トポロジ

このトポロジ図には、オーバーレイに使用される 2 つの分離されたクラウドが示されています。 DMVPN(緑色の接続)と FlexVPN(赤色の接続)です。

ローカルエリア ネットワークのプレフィクスは対応するサイトを表しています。

10.1.1.0/24 サブネットはインターフェイス アドレッシングに関して実際のサブネットを表している訳ではなく、FlexVPN クラウド専用の IP 空間の集まりを表しています。 この背景にある合理性については、「FlexVPN のコンフィギュレーション」セクションで後ほど説明します。

flexvpn-hard-hub-02.png

コンフィギュレーション

DMVPN のコンフィギュレーション

ここでは、DMVPN のハブとスポークの基本的なコンフィギュレーションについて説明します。

IKEv1 認証には事前共有キー(PSK)を使用します。

IPsec が確立されると、スポークからハブへの NHRP 登録が実行され、ハブはスポークの NBMA アドレッシングを動的に学習できます。

NHRP がスポークとハブで登録を実行すると、ルーティングの隣接関係が確立されてルートが交換されます。 この例では、オーバーレイ ネットワーク用の基本的なルーティング プロトコルとして EIGRP を使用します。

スポークの DMVPN コンフィギュレーション

事前共有キーの認証を行いルーティング プロトコルに EIGRP を使用する DMVPN のコンフィギュレーションの基本的な例を次に示します。

crypto isakmp policy 10

  encr aes

  authentication pre-share

crypto isakmp key cisco address 0.0.0.0 

crypto isakmp keepalive 30 5

crypto isakmp profile DMVPN_IKEv1

  keyring DMVPN_IKEv1

  match identity address 0.0.0.0 

crypto ipsec transform-set IKEv1 esp-aes esp-sha-hmac 

  mode transport

crypto ipsec profile DMVPN_IKEv1

  set transform-set IKEv1 

  set isakmp-profile DMVPN_IKEv1

interface Tunnel0

ip address 10.0.0.101 255.255.255.0

 no ip redirects

 ip mtu 1400

 ip nhrp map 10.0.0.1 172.25.1.1

ip address 10.0.0.101 255.255.255.0

 no ip redirects

 ip mtu 1400

 ip nhrp map 10.0.0.1 172.25.1.1

 ip nhrp map multicast 172.25.1.1

 ip nhrp network-id 1

 ip nhrp holdtime 900

 ip nhrp nhs 10.0.0.1

 ip nhrp shortcut

 ip tcp adjust-mss 1360

 tunnel source Ethernet0/0

 tunnel mode gre multipoint

 tunnel protection ipsec profile DMVPN_IKEv1

router eigrp 100

 network 10.0.0.0 0.0.0.255

 network 192.168.102.0

 passive-interface default

 no passive-interface Tunnel0

ハブの DMVPN コンフィギュレーション

ハブのコンフィギュレーションでは、IP アドレスが 172.25.1.1 の loopback0 からトンネルが開始されます。

それ以外はルーティング プロトコルとして EIGRP を使用する DMVPN ハブの標準的な展開です。

crypto isakmp policy 10

 encr aes

 authentication pre-share

crypto isakmp key cisco address 0.0.0.0 

crypto ipsec transform-set IKEv1 esp-aes esp-sha-hmac 

 mode transport

crypto ipsec profile DMVPN_IKEv1

 set transform-set IKEv1 

interface Tunnel0

 ip address 10.0.0.1 255.255.255.0

 no ip redirects

 ip mtu 1400

 ip nhrp map multicast dynamic

 ip nhrp network-id 1

 ip nhrp holdtime 900

 ip nhrp server-only

 ip nhrp redirect

 ip summary-address eigrp 100 192.168.0.0 255.255.0.0

 ip tcp adjust-mss 1360

 tunnel source Loopback0

 tunnel mode gre multipoint

 tunnel protection ipsec profile DMVPN_IKEv1

router eigrp 100

 network 10.0.0.0 0.0.0.255

 network 192.168.0.0 0.0.255.255

 passive-interface default

 no passive-interface Tunnel0

FlexVPN のコンフィギュレーション

FlexVPN は、次の基礎となる同じテクノロジーに基づいています。

  • IPsec: DMVPN のデフォルトとは異なり、IPsec SA のネゴシエーションには IKEv1 ではなく IKEv2 が使用されます。 IKEv2 は、復元力をはじめ、保護された D チャネルを確立するために必要なメッセージ数まで、IKEv1 よりも優れた機能を提供します。

  • GRE: DMVPN とは異なり、静的および動的なポイントツーポイント インターフェイスが使用され、静的なマルチポイント GRE インターフェイスのみではありません。 この設定により、特にスポークごとまたはハブごとの動作の柔軟性が増します。

  • NHRP: FlexVPN では、NHRP は主にスポーク間の通信の確立に使用されます。 スポークはハブに登録されません。 .

  • ルーティング: スポークはハブへの NHRP 登録を実行しないため、ハブとスポークが双方向の通信を行うための別のメカニズムが必要になります。 DMVPN と同様に動的ルーティング プロトコルを使用できます。 ただし、FlexVPN では IPsec を使用してルーティング情報を通知できます。 デフォルトではトンネルの反対側に IP アドレスの /32 ルートとして通知するため、スポークからハブへの直接通信が可能になります。

DMVPN から FlexVPN への完全移行では、同じデバイス上で 2 つのフレームワークが同時に動作することはありません。 ただしそれらを分離しておくことをお勧めします。

複数のレベルで分離を行います。

  • NHRP:異なる NHRP ネットワーク ID を使用します(推奨)。

  • ルーティング:別のルーティング プロセスを使用します(推奨)。

  • VRF:VRF の分離によって柔軟性が増しますが、ここでは説明しません(任意)。

スポークの FlexVPN コンフィギュレーション

DMVPN と比較した場合、FlexVPN のスポーク コンフィギュレーションの相違点の 1 つは、インターフェイスが 2 つある可能性があることです。

スポークからハブへの通信のための必須のトンネルと、スポーク間のオプションのトンネルがあります。 スポーク間のダイナミック トンネリングを使用せず、すべてハブ デバイスを経由して送信することを選択した場合は、バーチャルテンプレート インターフェイスを削除し、トンネル インターフェイスから NHRP ショートカット スイッチングを削除できます。

スタティック トンネル インターフェイスは、ネゴシエーションによって受け取った IP アドレスを持つことにも注意してください。 これにより、FlexVPN クラウド内でスタティック アドレスを作成しなくても、トンネル インターフェイス IP をハブからスポークへ動的に提供できます。

aaa new-model

aaa authorization network default local

aaa session-id common

crypto ikev2 profile Flex_IKEv2

 match identity remote fqdn domain cisco.com

 authentication remote rsa-sig

 authentication local rsa-sig

 aaa authorization group cert list default default

 virtual-template 1

crypto ikev2 dpd 30 5 on-demand

ハードウェアが対応している場合は、AES GCM の使用を推奨します。

crypto ipsec transform-set IKEv2 esp-gcm

 mode transport

crypto ipsec profile default

 set ikev2-profile Flex_IKEv2

! set transform-set IKEv2

interface Tunnel1

 ip address negotiated

 ip mtu 1400

 ip nhrp network-id 2

 ip nhrp shortcut virtual-template 1

 ip nhrp redirect

 ip tcp adjust-mss 1360

 shutdown

 tunnel source Ethernet0/0

 tunnel destination 172.25.2.1

 tunnel path-mtu-discovery

 tunnel protection ipsec profile default

interface Virtual-Template1 type tunnel

 ip unnumbered Tunnel1

 ip mtu 1400

 ip nhrp network-id 2

 ip nhrp shortcut virtual-template 1

 ip nhrp redirect

 ip tcp adjust-mss 1360

 tunnel path-mtu-discovery

 tunnel protection ipsec profile default

IKEv2 で大規模な認証を実行する方法として PKI を推奨します。

ただし、制限を認識したうえで事前共有キーを使用することもできます。

「cisco」を PSK として使用するコンフィギュレーション例を次に示します。

crypto ikev2 keyring Flex_key

 peer Spokes

 address 0.0.0.0 0.0.0.0

 pre-shared-key local cisco

 pre-shared-key remote cisco

crypto ikev2 profile Flex_IKEv2

 match identity remote address 0.0.0.0

 authentication remote pre-share

 authentication local pre-share

 keyring local Flex_key

 aaa authorization group psk list default default

FlexVPN ハブのコンフィギュレーション

ハブでは一般的にスポークからハブへのダイナミック トンネルの終端のみが行われます。 これがハブのコンフィギュレーションに FlexVPN 用のスタティック トンネル インターフェイスがない理由です。 代わりにバーチャルテンプレート インターフェイスが使用されます。

ハブ側では、スポークへ割り当てるプール アドレスを指定する必要があります。

このプールのアドレスは、後でルーティング テーブルに、/32 ルートとしてスポークごとに追加されます。

aaa new-model

aaa authorization network default local

aaa session-id common

crypto ikev2 authorization policy default

 pool FlexSpokes

crypto ikev2 profile Flex_IKEv2

 match identity remote fqdn domain cisco.com

 authentication remote rsa-sig

 authentication local rsa-sig

 aaa authorization group cert list default default

 virtual-template 1

crypto ikev2 dpd 30 5 on-demand

ハードウェアが対応している場合は、AES GCM の使用を推奨します。

crypto ipsec transform-set IKEv2 esp-gcm

 mode transport

次のコンフィギュレーションでは AES GCM の動作がコメント アウトされていることに注意してください。

crypto ipsec profile default

 set ikev2-profile Flex_IKEv2

! set transform-set IKEv2

interface Loopback0

 description DMVPN termination

 ip address 172.25.2.1 255.255.255.255

interface Loopback100

 ip address 10.1.1.1 255.255.255.255

interface Virtual-Template1 type tunnel

 ip unnumbered Loopback100

 ip nhrp network-id 2

 ip nhrp redirect

 tunnel path-mtu-discovery

 tunnel protection ipsec profile default

ip local pool FlexSpokes 10.1.1.100 10.1.1.254

IKEv2 の認証では、スポークと同じ原則がハブにも適用されます。

拡張性と柔軟性のために証明書を使用します。 ただし、PSK にはスポークと同じコンフィギュレーションを再利用できます。

注: IKEv2 は認証に関する柔軟性を提供します。 一方で PSK を使用して認証を行い、他方で RSA-SIG を使用することができます。

ハブ間 BGP 接続

ハブが特定のプレフィクスの場所を知るように設定する必要があります。

これは一部のスポークを FlexVPN に移行し、残りのスポークを DMVPN のままにする過程でさらに重要になります。

ハブ間 BGP 接続は、DMVPN のハブのコンフィギュレーションに基づきます。

router bgp 65001

 network 192.168.0.0

 neighbor 192.168.0.2 remote-as 65001

トラフィックの移行

オーバーレイ ルーティング プロトコルとして BGP に移行(推奨)

オーバーレイ ルーティング プロトコルとして BGP に移行します(推奨)。BGP はユニキャスト交換に基づくルーティング プロトコルです。 その特性から DMVPN ネットワークでは最も拡張性があるプロトコルです。

この例では、iBGP を使用します。

スポークの BGP コンフィギュレーション

スポークの移行は 2 つの部分から成ります。 BGP のダイナミック ルーティングをイネーブルにします。

router bgp 65001

 bgp log-neighbor-changes

 network 192.168.101.0

 neighbor 10.1.1.1 remote-as 65001

BGP ネイバーが起動し(移行のこのセクションの「ハブの BGP コンフィギュレーション」を参照)、BGP 上の新しいプレフィクスが学習された後で、トラフィックを既存の DMVPN クラウドから新しい FlexVPN クラウドに振り向けることができます。

ハブの BGP コンフィギュレーション

FlexVPN ハブ: フル BGP コンフィギュレーション

ハブではネイバーシップ設定をスポークごとに個別に保持することを避けて、ダイナミック リスナーを設定します。

この設定では BGP は新しい接続を開始しませんが、規定された IP アドレス プールからの接続を受け入れます。 この例ではそのプールは 10.1.1.0/24 であり、新しい FlexVPN クラウド内のすべてのアドレスになります。

注意点が 2 つあります。

  1. FlexVPN ハブは特定プレフィクスの DMVPN ハブをアドバタイズするため、抑制されないマップになります。

  2. FlexVPN サブネット 10.1.1.0/24 をルーティング テーブルにアドバタイズするか、または DMVPN ハブが FlexVPN ハブをネクスト ホップとして認識するようにします。

このドキュメントでは後者のアプローチについて示します。

access-list 1 permit any

route-map ALL permit 10

 match ip address 1route-map SET_NEXT_HOP permit 10

 set ip next-hop 192.168.0.2

router bgp 65001

 network 192.168.0.0

 bgp log-neighbor-changes

 bgp listen range 10.1.1.0/24 peer-group Spokes

 aggregate-address 192.168.0.0 255.255.0.0 summary-only

 neighbor Spokes peer-group

 neighbor Spokes remote-as 65001 neighbor 192.168.0.1 remote-as 65001

 neighbor 192.168.0.1 route-reflector-client

 neighbor 192.168.0.1 unsuppress-map ALL

 neighbor 192.168.0.1 route-map SET_NEXT_HOP out

DMVPN ハブ: フル BGP および EIGRP のコンフィギュレーション

DMVPN ハブのコンフィギュレーションは、特定のプレフィクスを FlexVPN ハブから受け取り、EIGRP から学習したプレフィクスをアドバタイズするだけなので簡単です。

router bgp 65001

 bgp log-neighbor-changes

 redistribute eigrp 100

 neighbor 192.168.0.2 remote-as 65001

トラフィックの BGP/FlexVPN への移行

前に説明したように、移行は DMVPN 機能をシャットダウンし、FlexVPN を起動することによって実行する必要があります。

次の手順によって影響を最小にできます。

  1. スポークごとに個別に次を行います。

    interface tunnel 0
    
       shut

    この時点でこのスポークへの IKEv1 セッションが何も確立されていないことを確認します。

    これは、show crypto isakmp sa コマンドの出力をチェックしたり、「crypto logging session」で生成される syslog メッセージを監視したりすることで確認できます。

    確認できたら FlexVPN の起動に進むことができます。

  2. 同じスポークで次を行います。

    interface tunnel 1
    
       no shut

確認手順

IPsec の安定性

IPsec の安定性を評価する最善の方法は、次のコンフィギュレーション コマンドをイネーブルにして syslog を監視することです。

crypto logging session

セッションがアップ ダウンを繰り返している場合は、IKEv2/FlexVPN レベルの問題を示しており、移行を始める前に修正する必要があります。

BGP 情報の登録

IPsec が安定している場合、BGP テーブルにスポークからのエントリ(ハブ上)およびハブからのサマリー(スポーク上)が登録されていることを確認します。 BGP の場合、これは次のコマンドで表示できます。

show bgp 

! or

show bgp ipv4 unicast 

! or

show ip bgp summary

FlexVPN ハブの正しい情報の例を次に示します。

BGP router identifier 172.25.2.1, local AS number 65001

(...omitted...)Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

*10.1.1.100 4 65001 112 123 16 0 0 01:35:58 1

192.168.0.1 4 65001 97 99 16 0 0 01:24:12 4

ハブがそれぞれのスポークから 1 つのプレフィクスを学習しており、両方のスポークは動的でアスタリスク(*)記号が付いていることがわかります。

また、ハブ間接続から合計 4 つのプレフィクスを受信していることがわかります。

スポークからの同様の情報の例を示します。

show ip bgp summary 

BGP router identifier 192.168.101.1, local AS number 65001

(...omitted...) 

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

10.1.1.1 4 65001 120 109 57 0 0 01:33:23 2

スポークはハブから 2 つのプレフィクスを受信しています。 この設定例では、1 つのプレフィクスは FlexVPN ハブでアドバタイズされたサマリーです。 もう 1 つは DMVPN スポーク上で BGP に再配布された DMVPN 10.0.0.0/24 ネットワークです。

EIGRP を使用した新しいトンネルへの移行

EIGRP は、比較的簡単な導入と高速なコンバージェンスから、DMVPN ネットワークでは一般的な選択です。

ただし、BGP に比べて拡張性が低く、BGP ではすぐに使用可能な高度なメカニズムの多くが提供されません。

次のセクションでは、新しい EIGRP プロセスを使用して FlexVPN に移行する方法の 1 つについて説明します。

更新されたスポークのコンフィギュレーション

別の EIGRP プロセスを使用する新しい AS を追加します。

router eigrp 200

 network 10.1.1.0 0.0.0.255

 network 192.168.101.0

 passive-interface default

 no passive-interface Tunnel1

注: スポーク間トンネルで隣接するルーティング プロトコルの確立は避ける必要があります。 このため、tunnel1(スポークからハブ)のインターフェイスのみを非パッシブにします。

更新された FlexVPN ハブのコンフィギュレーション

同様に FlexVPN ハブでも、スポークで設定されたルーティング プロトコルに合わせて適切な AS のルーティング プロトコルを準備します。

router eigrp 200

 network 10.1.1.0 0.0.0.255

サマリーをスポークに戻す 2 つの方法があります。

  • null0 を指すスタティック ルートを再配布します(推奨)。

    ip route 192.168.0.0 255.255.0.0 null 0
    
    ip route 10.1.1.0 255.255.255.0 null 0ip prefix-list
    
     EIGRP_SUMMARY_ONLY seq 5 permit 192.168.0.0/16
    
    ip prefix-list EIGRP_SUMMARY_ONLY seq 10 permit 10.1.1.0/24
    
    route-map EIGRP_SUMMARY permit 20
    
     match ip address prefix-list EIGRP_SUMMARY_ONLY  
    
    
    
    router eigrp 200
    
     distribute-list route-map EIGRP_SUMMARY out Virtual-Template1
    
     redistribute static metric 1500 10 10 1 1500 route-map EIGRP_SUMMARY

    この方法では、ハブの VT コンフィギュレーションに修正を加えずにサマリーと再配布を制御することができます。

    関連したアクティブなバーチャル アクセスがある場合、ハブの VT コンフィギュレーションは変更できないため、これは重要です。

  • 別の方法として、バーチャルテンプレートで DMVPN スタイルのサマリー アドレスを設定できます。

    このコンフィギュレーションは、サマリーの内部処理と複製がすべてのバーチャル アクセスに対して行われることから推奨されません。 ここでは参考のために紹介します。

    interface Virtual-Template1 type tunnel
    
     ip summary-address eigrp 200 192.168.0.0 255.255.0.0
    
    

    その他の考慮事項として、ハブ間のルーティング交換があります。

    これは EIGRP インスタンスの iBGP への再配布によって行うことができます。

DMVPN ハブ:更新された BGP のコンフィギュレーション

このコンフィギュレーションは基本のままです。 特定のプレフィクスを EIGRP から BGP へ再配布する必要があります。

router bgp 65001

 redistribute eigrp 100

 neighbor 192.168.0.2 remote-as 65001 

FlexVPN ハブ:更新された BGP のコンフィギュレーション

DMVPN ハブと同様に、FlexVPN で新しい EIGRP プロセスのプレフィクスを BGP へ再配布する必要があります。

router bgp 65001

 redistribute eigrp 200

 redistribute static

 neighbor 192.168.0.1 remote-as 65001

トラフィックの FlexVPN への移行

トラフィックを FlexVPN へ移行します。前に説明したように、移行は各スポークで 1 つずつ DMVPN 機能をシャットダウンし、FlexVPN を起動することによって実行する必要があります。

次の手順によって影響を最小にできます。

  1. スポークごとに個別に次を行います。

    interface tunnel 0
    
       shut

    この時点でこのスポークの IKEv1 セッションが何も確立されていないことを確認します。

    これは、show crypto isakmp sa コマンドの出力をチェックしたり、「crypto logging session」で生成される syslog メッセージを監視したりすることで確認できます。

    確認できたら FlexVPN の起動に進むことができます。

  2. 同じスポークで次を行います。

    interface tunnel 1
    
       no shut

確認手順

IPsec の安定性

BGP の場合、IPsec が安定しているか評価する必要があります。 最善の方法は、次のコンフィギュレーション コマンドをイネーブルにして syslog を監視することです。

crypto logging session

セッションがアップ ダウンを繰り返している場合は、IKEv2/FlexVPN レベルの問題を示しており、移行を始める前に修正する必要があります。

トポロジ テーブル内の EIGRP 情報

トポロジ テーブル内の EIGRP 情報です。ハブ上の EIGRP トポロジ テーブルにスポークの LAN エントリが登録されていること、およびスポークにサマリーが登録されていることを確認します。 これはハブとスポークで次のコマンドを発行することで確認できます。

show ip eigrp [AS_NUMBER] topology

スポークの出力例を次に示します。

Spoke1#show ip eigrp 200 topology 

EIGRP-IPv4 Topology Table for AS(200)/ID(192.168.101.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

 r - reply Status, s - sia Status

P 10.1.1.1/32, 1 successors, FD is 26112000

 via Rstatic (26112000/0)

 via 10.1.1.1 (26240000/128256), Tunnel1

P 192.168.101.0/24, 1 successors, FD is 281600

 via Connected, Ethernet1/0

P 192.168.0.0/16, 1 successors, FD is 26114560

 via 10.1.1.1 (26114560/2562560), Tunnel1

P 10.1.1.100/32, 1 successors, FD is 26112000

 via Connected, Tunnel1

P 10.1.1.0/24, 1 successors, FD is 26114560

 via 10.1.1.1 (26114560/2562560), Tunnel1

スポークが LAN のサブネット(イタリック体)とそれらのサマリー(太字)を知っていることがわかります。

ハブの出力例を次に示します。

hub2# show ip eigrp 200 topology 

EIGRP-IPv4 Topology Table for AS(200)/ID(172.25.2.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

 r - reply Status, s - sia Status

P 10.1.1.1/32, 1 successors, FD is 128256

 via Connected, Loopback200

P 192.168.101.0/24, 1 successors, FD is 26905600

 via 10.1.1.100 (26905600/281600), Virtual-Access1

P 192.168.0.0/16, 1 successors, FD is 2562560

 via Rstatic (2562560/0)

P 10.1.1.0/24, 1 successors, FD is 2562560

 via Rstatic (2562560/0)

ハブがスポークの LAN のサブネット(イタリック体)、アドバタイジングしているサマリー プレフィクス(太字)、およびネゴシエーションによって各スポークに割り当てられた IP アドレスを知っていることがわかります。

その他の考慮事項

既存のスポーク間トンネル

DMVPN トンネル インターフェイスのシャットダウンによって、NHRP エントリが削除され、既存のスポーク間トンネルは解除されます。

NHRP エントリのクリア

前に説明したように、FlexVPN ハブはスポークからの NHRP 登録プロセスに依存せずにトラフィックを送り返すルートを知ることができます。 ただし、スポーク間のダイナミック トンネルは NHRP エントリに依存します。

DMVPN では、ハブでの NHRP のクリアによって短期間の接続性の問題が発生する場合があります。

FlexVPN では、スポークでの NHRP のクリアによって、スポーク間トンネルに関連した FlexVPN IPsec セッションが解除されます。 ハブでの NHRP のクリアは、FlexVPN セッションに影響します。

これは、デフォルトの FlexVPN での次の動作が原因です。

  • スポークはハブに登録されません。

  • ハブは NHRP リダイレクタとしてのみ動作し、NHRP エントリをインストールしません。

  • NHRP ショートカット エントリがスポーク間トンネル用にスポーク上でインストールされ、動的になります。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 115727