IP : IP ルーティング

OSPF がノーマル エリアにデフォルト ルートを挿入する方法

2003 年 10 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

この設定例では、OSPF によってノーマル エリアにデフォルト ルートが挿入される方法について説明します。 ノーマル エリアに挿入されるデフォルト ルートは、どの OSPF ルータでも発信が可能です。 しかし、OSPF ルータはデフォルトでは OSPF ドメインへのデフォルト ルートを生成しません。 OSPF によってデフォルト ルートが生成されるようにするには、default-information originate コマンドを使用する必要があります。

ノーマル エリアにデフォルト ルートをアドバタイズするには、2 つの方法があります。 1 つ目は、すでにデフォルト ルートを持つアドバタイジング ルータがある OSPF ドメインに、0.0.0.0 をアドバタイズすることです。 2 つ目の方法は、アドバタイジング ルータにすでにデフォルト ルートがあるかないかにかかわらず 0.0.0.0 をアドバタイズすることです。 2 つ目の方法は、default-information originate コマンドにキーワード「always」を追加することで実現できます。

例として次のネットワーク ダイアグラムを確認します。

ネットワーク ダイアグラム

/image/gif/paws/47868/ospfdb9a.gif

設定

ルータ 1.1.1.1
  Current configuration:
  hostname r1.1.1.1
  interface Loopback0
   ip address 1.1.1.1 255.0.0.0
  interface Serial2/1/0
   ip address 5.0.0.1 255.0.0.0
  router ospf 2
   network 5.0.0.0 0.255.255.255 area 1
  end
  
ルータ 2.2.2.2
  Current configuration:
  hostname r2.2.2.2
  interface Loopback0
   ip address 2.2.2.2 255.0.0.0
  interface Serial0/1/0
   ip address 5.0.0.2 255.0.0.0
  interface ATM1/0.20
   ip address 6.0.0.2 255.0.0.0
  router ospf 2
   network 5.0.0.0 0.255.255.255 area 1
   network 6.0.0.0 0.255.255.255 area 0
   default-information originate
   ip route 0.0.0.0 0.0.0.0 6.0.0.3
  end
  

OSPF データベースの検査

show ip ospf database コマンドを使用して、このネットワーク環境の情報が OSPF データベースにどのように格納されているかを見てみましょう。

  r2.2.2.2#show ip ospf database 
         OSPF Router with ID (2.2.2.2) (Process ID 2) 
                  Router Link States (Area 0) 
  Link ID        ADV Router      Age         Seq#               Checksum     Link count 
  2.2.2.2         2.2.2.2        600         0x80000001         0x9583            1 
                  Summary Net Link States (Area 0) 
  Link ID         ADV Router      Age         Seq#               Checksum 
  5.0.0.0          2.2.2.2        600         0x80000001         0x8E61 
                  Router Link States (Area 1) 
  Link ID        ADV Router      Age         Seq#                Checksum     Link count 
  1.1.1.1         1.1.1.1        864         0x8000005E          0xD350           2 
  2.2.2.2         2.2.2.2        584         0x8000001E          0xF667           2 
                  Summary Net Link States (Area 1) 
  Link ID        ADV Router      Age         Seq#               Checksum 
  6.0.0.0         2.2.2.2        585         0x80000004         0xA87C 
                  Type-5 AS External Link States 
  Link ID        ADV Router      Age         Seq#               Checksum     Tag 
  0.0.0.0         2.2.2.2        601         0x80000001         0xD0D8        0 
  

すでにデフォルト ルートはあるため、ルータ 2.2.2.2 はタイプ 5 の link-state advertisement(LSA; リンクステート アドバタイズメント)をリンク ID 0.0.0.0 で発信します。 これは、このルータの OSPF 設定で default-information originate コマンドを実行した結果です。

  r2.2.2.2#show ip ospf database external 0.0.0.0 
         OSPF Router with ID (2.2.2.2) (Process ID 2) 
                  Type-5 AS External Link States  
    LS age: 650 
    Options: (No TOS-capability, DC) 
    LS Type: AS External Link 
    Link State ID: 0.0.0.0 (External Network Number ) 
    Advertising Router: 2.2.2.2 
    LS Seq Number: 80000001 
    Checksum: 0xD0D8 
    Length: 36 
    Network Mask: /0 
          Metric Type: 2 (Larger than any link state path) 
          TOS: 0 
          Metric: 1 
          Forward Address: 0.0.0.0 
          External Route Tag: 0 
  r2.2.2.2#show ip route 0.0.0.0 
  S* 0.0.0.0/0 [1/0] via 6.0.0.3, 00:28:00, ATM1/0.20  
  r1.1.1.1#show ip route ospf 
  O IA 6.0.0.0/8 [110/65] via 5.0.0.2, 00:00:18, Serial2/1/0 
  O*E2 0.0.0.0/0 [110/1] via 5.0.0.2, 00:00:18, Serial2/1/0 
  

また、default-information originate コマンドにキーワード「always」を追加すると、ルータのルーティング テーブルにデフォルト ルートがない場合でも、ルータに 0.0.0.0 のタイプ 5 LSA を発信させることができます。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 47868