Cisco インターフェイスとモジュール : Cisco Unified SIP Proxy

Cisco Unified SIP Proxy のフェールオーバー設定方法

2016 年 6 月 18 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2016 年 4 月 21 日) | フィードバック

概要

この資料は使用する 2 つのオプションを Cisco Unified SIP プロキシのための冗長性(フェールオーバー)を設定するために説明します。

ランディ元ウーによって貢献される、Cisco TAC エンジニア。

前提条件

要件

次の項目に関する知識があることが推奨されます。

  • Hot Standby Router Protocol(HSRP)
  • DNS
  • Cisco Unified SIP プロキシ(先端)

コンポーネント

この文書に記載されている情報は先端に基づいています。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 この資料で使用された削除されたデフォルト)設定でデバイスすべては起動しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

エラー抵抗力があるデフォルト ゲートウェイを作成して下さい

エラー抵抗力があるデフォルト ゲートウェイを作成する機能は Cisco Unified SIP プロキシ(先端)が提供する主な特徴です。 先端のための冗長性を実現させるのに使用できる 2 つのオプションがあります。 1 つはドメイン ネーム システム サーバ DNS SRV を使用することです; 他は仮想サーバを作成することです。 Hot Standby Router Protocol (HSRP)は仮想サーバが作成することができるメカニズムです。 この資料の最初の一部は DNS SRV を設定する方法を簡潔に説明します。 この資料の他および大半はどのように HSRP 記述しますか。s 機能は統合サービス ルータ(ISR)のシャーシまたは先端 service-module の問題自体を検出するため設定されるである。

オプション1 — DNS SRV

このオプションでは、DNS を使用するためにアップストリーム要素(どの要素が先端に呼び出しを転送する)設定して下さい。 cusp1 に達する試みが失敗する場合、cusp2 を使用する DNS SRV および試みの Next エントリのためのアップストリーム要素クエリー。 DNS はこれがはたらくことができるように正しく設定する必要があります。

  1. 最初に、2 つの DNS SRV (サービス)レコードは各先端のための 1 つ作成する必要があります。 cusp1 を指すレコードに高優先順位があります。

  2. 2 番目に、2 つの DNS A (ホスト名)レコードは DNS SRV レコードの宛先が解決されますように作成する必要があります。 この例に DNSサーバはレコードで含まれているはずであるものが示されています。

116015-configure-failover-cusp-01.png

オプション 2 — HSRP

このダイアグラムは方法の基本的アーキテクチャを HSRP のための先端を設定する提供します。 左側はアップストリーム SIP 要素であり、右側はダウンストリーム SIP 要素です。 これらの要素の間に 192.168.20.7 の IP アドレスの 1 つの仮想ルータはあります。 上下流要素は両方とも仮想ルータの IP アドレスの方の SIP トラフィックを導きます。 仮想ルータの中で 2 人の実際のルータはあります: プライマリおよびセカンダリ。 これら二つのルータはこの同じ仮想 IP アドレスを共有し、コンフィギュレーションは 2 つの例外を除いて同一です。 従って、この資料で与えられるコンフィギュレーションは両方のルータのため同じです。

注: シングル ルータの 2 つの先端のための HSRP 設定はテストされませんでした。 このソリューションを奪取 し、複数の先端のためにそれを拡張することは可能性のあるであるかもしれませんが現時点でサポートされません。

116015-configure-failover-cusp-02.png

セットアップ 基本的な接続

最初に、ルータとブレード間の設定された接続。 これは他の文書でカバーされるが、この資料で冗長に同様に説明されています。 この例では、プライマリルータに 192.168.20.80 のアドレスがあり、先端に 192.168.20.81 のアドレスがあります。

interface GigabitEthernet0/1
ip address 192.168.20.80 255.255.252.0
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.80
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

セカンダリ ルータに 192.168.20.90 のアドレスがあり、先端に 192.168.20.81 のアドレスがあります。

interface GigabitEthernet0/1
ip address 192.168.20.90 255.255.252.0
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.90
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

セットアップ ルータ レベル フェールオーバー

次に、ルータ水平なフェールオーバーは設定する必要があります。 これはプライマリとしてルータの 1 人およびセカンダリとして他の指定を含みます。 2 人のルータの設定にわずかな相違点があります。

プライマリルータのための設定はここにあります:

interface GigabitEthernet0/1
standby 0 ip 192.168.20.7
standby 0 priority 100

セカンダリ ルータのための設定はここにあります:

interface GigabitEthernet0/1
standby 0 ip 192.168.20.7
standby 0 priority 90

ルータは両方ともスタンバイ IP アドレスを仮想ルータに設定 してもらいます; ただし、プライマリルータにセカンダリものより高優先順位があります。 それは他の事柄はすべて同一であるが、プライマリルータ アクティブと見なされます意味し、次にすべての SIP トラフィックはプライマリルータを通っておよびそのルータの先端に行きます。 セカンダリ ルータはスタンバイにプライマリルータが何らかの理由でダウン状態になればその時だけあり、停電のような、引き継ぎます。

インターフェイスをトラッキングして下さい

HSRP はまた先端レベル失敗を検知するために設定する必要があります。 誰かのためのプライマリルータ ダイスの先端原因、ルータ自体が変化しない場合何が起こりますか。 SIP トラフィックはプライマリルータの先端に送信 され続けます。 ルータの優先順位は各ルータにある先端の状態に基づいていました変更する必要があります。

これをする方法は各ルータからの先端へ ICMPエコーを設定することです。 この場合、エコーは 2 つの(2)秒毎に 1 (1)第 2 タイムアウトの、送信 されます。 下部のはこれらの値あります、そしてより速くルータは先端はダウンしていますこと検出することができます。 ただし、ICMPエコーが false positive という結果に終るには設定 された余りにも低ければ、これはできました。 この例の最後の設定行はエコーを始め、永久に行われるためにそれを設定 します。

注: ICMPエコーは SIP ポートの状態をトラッキングできません。 HSRP フェールオーバーは問題がポート レベルにある場合始めることができません。 繰り返すため; ルータが壊れた場合、他のルータは引き継ぎます; IPサービス水平な協定(SLA)のための ping が通らない場合、他のルータは引き継ぎます; SIP ポートが失敗した場合、これは検出する。

ip sla 1
icmp-echo 192.168.20.81
timeout 1000
frequency 2
!!
ip sla schedule 1 life forever start-time now

オブジェクトはそのエコーの状態をトラッキングするために設定する必要があります。 オブジェクト数はこの場合 100 です。 インターフェイスは 20 によってこのオブジェクトのステータスがダウンしている場合ルータの優先順位を減少するために設定 する必要があります。 これはプライマリルータ 非アクティブどういうわけかの先端が行けば、優先順位廃棄します意味します 100 から 80 まで。 その優先順位はそれから 90 の優先順位があるセカンダリのそれより小さいです。 スタンバイ 0 preempt が設定 される場合、プライマリのための引き継ぎにセカンダリ ルータを強制し、それから SIP トラフィックはセカンダリ先端に行きます。

track 100 ip sla 1 reachability
!!
interface GigabitEthernet0/1
standby 0 track 100 decrement 20
standby 0 preempt

プライマリルータの HSRP 設定

ip sla 1
icmp-echo 192.168.20.81
timeout 1000
frequency 2
!!
ip sla schedule 1 life forever start-time now
!!
track 100 ip sla 1 reachability
!!
interface GigabitEthernet0/1
ip address 192.168.20.80 255.255.252.0
standby 0 ip 192.168.20.7
standby 0 priority 100
standby 0 preempt
standby 0 track 100 decrement 20
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.80
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

セカンダリ ルータの HSRP 設定

ip sla 1
icmp-echo 192.168.20.81
timeout 1000
frequency 2
!!
ip sla schedule 1 life forever start-time now
!!
track 100 ip sla 1 reachability
!!
interface GigabitEthernet0/1
ip address 192.168.20.90 255.255.252.0
standby 0 ip 192.168.20.7
standby 0 priority 90
standby 0 preempt
standby 0 track 100 decrement 20
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.90
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

関連情報


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 116015