Cisco インターフェイスとモジュール : Cisco ワイヤレス LAN コントローラ モジュール

メッシュおよび WGB での複数の VLAN サポートの設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、メッシュおよびワークグループ ブリッジ(WGB)の複数 VLAN サポートで、オープン認証(Open Auth)を使用する設定例と、Lightweight Extensible Authentication Protocol(LEAP)を使用する設定例を紹介します。

注: 著者:Cisco TAC エンジニア、Surendra BG

このシリーズの他のドキュメント

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは次のネットワーク設定を使用します。オープン認証の WGB の背後のスイッチで複数 VLAN サポートを実現する方法が示されています。 最後に LEAP を追加します。

トポロジは次のとおりです。

DHCP サーバ - スイッチ - ワイヤレス LAN コントローラ(WLC)- ルート アクセス ポイント(RAP)(メッシュ))))) ((((( WGB - スイッチ

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-01.gif

  • Dynamic Host Configuration Protocol(DHCP)サーバは VLAN 50 および 100 に設定されます。

  • WLC には、VLAN 50 および 100 用に作成されたダイナミック インターフェイスがあります。

  • WGB には、必要な VLAN 50 および 100 のサブインターフェイスがあります。

  • WGB の背後のスイッチには必要な VLAN 50 および 100 があります。

ラボ セットアップでは、VLAN 40 が WLC 管理用であり、VLAN 40 はメッシュ RAP に、VLAN 50 は WGB に置かれています。 WGB スイッチの背後のクライアントは WGB とメッシュ RAP をワイヤレスで通過して VLAN 50 と VLAN 100 から IP アドレスを取得します。

注: 同じセットアップはローカル モードのアクセス ポイント(AP)にも適しています。

設定

このドキュメントでは、次の設定を使用します。

  • WLC WGB

  • アクセス ポイント グループ

  • LEAP

WLC WGB

WLC のコマンドライン インターフェイス(CLI)で、config wgb vlan enable コマンドを入力します。

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-02.gif

WGB CLI で、workgroup-bridge unified-vlan-client コマンドを入力します。

workgroup-bridge unified-vlan-client
dot11 ssid WGB_LWAPP
   vlan 50
   authentication open
   guest-mode
   infrastructure-ssid
end

interface Dot11Radio0
 no ip address
 no ip route-cache
 ssid WGB_LWAPP
 station-role workgroup-bridge
 
interface Dot11Radio0.50
 encapsulation dot1Q 50 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Dot11Radio0.100
 encapsulation dot1Q 100
 no ip route-cache
 bridge-group 100
 
interface FastEthernet0.50
 encapsulation dot1Q 50 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0.100
 encapsulation dot1Q 100
 no ip route-cache
 bridge-group 100

interface BVI1

!--- Grab the IP address from VLAN 50 which is across wireless
 
 ip address dhcp  
 no ip route-cache

アクセス ポイント グループ

スイッチの構成は次のとおりです。

Switch#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
 
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
BGL14-TACLAB-ASW-S8
                 Fas 0/2           150          R S I     WS-C3550- Fas 0/27
SURBG-AP         Fas 0/1           130           T I      AIR-AP124 Fas 0
Switch#
Switch#sh run int fa 0/1
Building configuration...

Current configuration : 127 bytes
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 50
 switchport mode trunk
end

Switch#sh vlan br
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                         
12   VLAN0012                         active
40   VLAN0040                         active
50   VLAN0050                         active
100  VLAN0100                         active
Switch#sh run int vlan 50
Building configuration...
Current configuration : 41 bytes
!
interface Vlan50
 ip address dhcp
end

Switch#sh run int vlan 100
Building configuration...
 
Current configuration : 42 bytes
!
interface Vlan100
 ip address dhcp
end

Switch#sh ip int br | i up
Vlan12                 unassigned      YES DHCP    up                    up
Vlan50                 172.16.1.7      YES DHCP    up                    up
Vlan100                100.0.0.21      YES DHCP    up                    up

結論として、VLAN 50 および 100 のインターフェイスは、メッシュ RAP と WGB をワイヤレスで通過して、セントラル サイトのスイッチの背後にある DHCP サーバから IP アドレスを取得します。

WLC で、正しい VLAN は正しいインターフェイスにマップされます。

VLAN 100 は IP アドレスと WLC のそのエントリを取得します。

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-03.gif

VLAN 50 は IP アドレスと WLC のそのエントリを取得します。

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-04.gif

LEAP

WPA2 - 802.1X ローカル EAP プロファイルの WLAN を設定します。

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-05.gif

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-06.gif

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-07.gif

ローカル Extensible Authentication Protocol(EAP)の認証優先順序で LOCAL ユーザ データベースを指定するようにします。

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-08.gif

WGP AP

dot11 ssid WGB_LWAPP
   vlan 50
   authentication open eap eap
   authentication network-eap eap
   authentication key-management wpa version 2
   dot1x credentials wgb
   dot1x eap profile eapfast
   infrastructure-ssid
   no ids mfp client
!

!--- Profile configured -- LEAP

eap profile eapfast                
 method leap
!
!
!

!--- Credentials used by this WGB AP to get auth with WLC (Local net users)

dot1x credentials wgb         
 username cisco123
 password 7 0822455D0A16544541
 

interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers aes-ccm
 !
 encryption vlan 50 mode ciphers aes-ccm
 !
 ssid WGB_LWAPP
 !
 packet retries 128
 station-role workgroup-bridge
!
interface Dot11Radio0.50
 encapsulation dot1Q 50 native
 no ip route-cache
 bridge-group 1
!
interface Dot11Radio0.100
 encapsulation dot1Q 100
 no ip route-cache
 bridge-group 100
 bridge-group 100 spanning-disabled

クライアントは LEAP セキュリティで実行状態になっています。

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-09.gif

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 115752