音声とユニファイド コミュニケーション : Cisco Unified Border Element

HSRP を使用した Cisco Unified Border Element のハイ アベイラビリティ(HA)の設定例

2012 年 11 月 28 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2012 年 6 月 8 日) | フィードバック

HSRP を使用した Cisco Unified Border Element のハイ アベイラビリティ(HA)の設定例

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
背景説明
設定
      ネットワーク ダイアグラム
      手順 1:CUBE と CUBE 冗長性を有効にする
      手順 2:HSRP を有効にする
      手順 3:HSRP 通信トランスポートを有効にする
      手順 4:インターフェイスの HSRP を設定する
      手順 5:HSRP タイマーを設定する
      手順 6:メディア非アクティビティ タイマーを設定する
      手順 7:HSRP アドレスへの SIP バインディングを設定する
      手順 8:ルータをリロードする
      手順 9:接続されたソフトスイッチを CUBE HSRP 仮想アドレスに指定する
      二重接続された CUBE HSRP の冗長性についての完全なサンプル設定
      単一接続された CUBE HSRP の冗長性についての完全なサンプル設定
      HA 設定の削除
      機能を使用するときの注意
確認
      冗長性状態の確認
      HSRP 状態の確認
      スイッチオーバー後のコール状態の確認
      SIP IP アドレス バインディングの確認
      現在の CPU 使用の確認
      スイッチオーバー中にコールが処理されていることの確認
      テストのための手動フェールオーバーの強制
      フェールオーバー後も保持される単一コールを確認するためのスクリーンショット
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

Cisco Unified Border Element(CUBE)は、Cisco Integrated Services Router Generation 2 ルータ(ISR G2)プラットフォームで実装される場合、ボックスツーボックス冗長性設定を介してハイ アベイラビリティ(HA)を提供します。CUBE ボックスツーボックス冗長性は、長く使用されているルータベースの Hot Standby Routing Protocol(HSRP)ルータ テクノロジーを利用します。

ネットワーク上のホストからの IP トラフィックをルーティングするときに単一ルータの可用性に依存しないため、HSRP テクノロジーでは、高度なネットワーク可用性が提供されます。ルータのグループで HSRP を使用して、アクティブ ルータとスタンバイ ルータを選択します。HSRP は、inside および outside インターフェイスを監視します。いずれかのインターフェイスがダウンすると、デバイス全体がダウンしたと見なされ、スタンバイ デバイスがアクティブになり、アクティブ ルータの役割を引き継ぎます。

ボックスツーボックス冗長性は、HSRP プロトコルを使用して、ルータの HSRP アクティブ/スタンバイ ペアを形成します。アクティブ/スタンバイ ペアは、同じ仮想 IP アドレスを共有し、継続してステータス メッセージを交換します。CUBE セッション情報は、ルータのアクティブ/スタンバイ ペア間でチェックポイントが設定されます。これにより、予期の有無に関係なく、アクティブ ルータがダウンした場合に、スタンバイ ルータがすぐにすべての CUBE 呼処理を引き継ぐことができます。

CUBE ボックスツーボックス冗長性 HA 実装は、SIP-SIP コールの HSRP スイッチオーバーでのメディア保持をサポートしますが、コール シグナリングは保持されません。この機能は、Cisco IOS® ソフトウェア リリース 15.1.2T としてサポートされます。コール シグナリングは、最新の Cisco IOS ソフトウェア リリース 15.2.3T でサポートされます。

注:詳細については、『Cisco Unified Border Element Protocol-Independent Features and Setup Configuration Guide, Cisco IOS Release 15.2M&T 』を参照してください。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • Cisco IOS Voice の設定および使用方法に関する基礎知識

  • CUBE の設定および使用方法に関する基礎知識

  • HSRP ハイ アベイラビリティが一般的なルータ プラットフォームでどのように機能するかに関する基礎知識

CUBE ISR G2 ボックスツーボックス冗長性の設定に関する基本要件には、次のことが含まれます。

  • UC Technology Package ライセンス(SL-29-UC-K9 または SL-39-UC-K9)がインストールされている 2 つの同一の ISR G2、1G DRAM メモリ、Cisco IOS ソフトウェア リリース 15.1.2T 以降

  • 両方のルータが同じイーサネット LAN 上にある。

  • 両方のルータの CUBE 設定が同じで、ルータ間で手動でコピーされる。

  • 一方のルータが HSRP アクティブ ルータで、もう一方のルータがスタンバイ ルータに設定されている。HSRP 設定は、アクティブおよびスタンバイ ルータで若干異なります。

  • SIP-SIP コール フロー

使用するコンポーネント

このドキュメントの情報は、Cisco 2900 または 3900 シリーズ Integrated Service Router Generation 2(ISR G2)で実装される CUBE 8.5(Cisco IOS リリース 15.1.2T)の最低限のソフトウェア リリースに基づいています。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用されるデバイスはすべて、初期設定(デフォルト)の状態から作業を開始しています。ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

ボックスツーボックス冗長性では、2 台の同じ ISR-G2 プラットフォームが必要です。一方はアクティブで、もう一方はスタンバイです。HSRP は、物理インターフェイスで設定され、HSRP グループを形成します。

アクティブ ルータがダウンしハートビート障害が発生すると、セカンド スタンバイ ルータは、最初のルータの IP ルーティング アドレスを引き継ぎ、最初のルータに転送されていた RTP パケットを転送し続けます。

確立されたコールの RTP ストリームは、HSRP プロトコルを介してアクティブおよびスタンバイ ルータ間でチェックポイントが設定されます。そのため、確立されたコールのメディア ストリームは、アクティブ ルータかたスタンバイ ルータへの HSRP フェールオーバー上で保持されます。一時状態のコール(確立されていない、または転送機能や保持機能で変更中のコール)は、フェールオーバー時に切断されます。また、トランスコーディングなどの DSP サービスを使用したコールは保持されません。

設定

このセクションでは、このドキュメントで説明する機能の設定に必要な情報を提供します。

CUBE HSRP 設定では、次の手順を実行します。

  1. CUBE と CUBE 冗長性を有効にする

  2. HSRP を有効にする

  3. HSRP 通信トランスポートを有効にする

  4. インターフェイスの HSRP を設定する

  5. HSRP タイマーを設定する

  6. メディア非アクティビティ タイマーを設定する

  7. HSRP アドレスへの SIP バインディングを設定する

  8. ルータをリロードする

  9. 接続されたソフトスイッチを CUBE HSRP 仮想アドレスに指定する

手順 1 〜 5 が完了したら、両方のルータをリロードします。リロードは、最初に HSRP をルータで設定する場合だけ必要です。

注:このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク ダイアグラム

この図は、Cisco Unified Communications Manager(CUCM)およびサービス プロバイダー(SP)SIP トランク間の PSTN アクセスの SIP トランク導入で使用される ISR G2 ルータのアクティブ/スタンバイ ペアのトポロジを示しています。

cube-hsrp-config-01.gif

手順 1:CUBE と CUBE 冗長性を有効にする

両方のルータで CUBE を有効にします。

voice service voip 
  mode border-element
  allow-connections sip to sip

両方のルータで CUBE 冗長性およびコール チェックポイントを有効にします。

voice service voip 
  redundancy

手順 2:HSRP を有効にする

両方のルータでルータ冗長性スキームを有効にします。

  • scheme:冗長性状態トラッキング スキーム

  • standby:スタンバイ(HSRP)状態トラッキング スキームを有効にする

  • SB:HSRP スタンバイ グループ名

redundancy inter-device
  scheme standby SB

手順 3:HSRP 通信トランスポートを有効にする

HSRP デバイス間通信トランスポートを次のように設定します。

アクティブの設定:

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
        local-ip 10.10.24.14
      remote-port 5000
        remote-ip 10.10.24.13

スタンバイの設定

ipc zone default
  association 1
   no shutdown
   protocol sctp
     local-port 5000
       local-ip 10.10.24.13
     remote-port 5000
       remote-ip 10.10.24.14

注:「local-sctp」プロンプトを終了して、リモート SCTP パラメータを次のように設定します。

XFR-2(config)#ipc zone default
XFR-2(config-ipczone)#association 1
XFR-2(config-ipczone-assoc)#protocol sctp 
XFR-2(config-ipc-protocol-sctp)#no sh
XFR-2(config-ipczone-assoc)#protocol sctp
XFR-2(config-ipc-protocol-sctp)#local-port 5000
XFR-2(config-ipc-local-sctp)#local-ip 10.10.24.13
XFR-2(config-ipc-local-sctp)#exit
XFR-2(config-ipc-protocol-sctp)#remote-port 5000
XFR-2(config-ipc-remote-sctp)#remote-ip 10.10.24.14
XFR-2(config-ipc-remote-sctp)#end

次に、この設定で使用されるフィールドについて説明します。

  • ipc zone default:Inter-Device Communication Protocol(IPC)を設定し、IPC ゾーン コンフィギュレーション モードにします。このコマンドを使用して、アクティブ デバイスとスタンバイ デバイスとの間の通信リンクを開始します。

  • association 1:2 台のデバイス間のアソシエーションを設定して、IPC アソシエーション コンフィギュレーション モードを開始します。ここで、トランスポート プロトコル、ローカル ポート、ローカル IP アドレス、リモート ポートおよびリモート IP アドレスなどのアソシエーションの詳細を設定します。有効なアソシエーション ID の範囲は 1 〜 255 です。アソシエーション ID には、デフォルト値はありません。

  • no shutdown:無効にされているアソシエーションおよびアソシエートされているトランスポート プロトコルを再開します。トランスポート プロトコル パラメータを変更した場合、このアソシエーションをシャットダウンする必要があります。

  • protocol sctp:Stream Control Transmission Protocol(SCTP)をこのアソシエーションのトランスポート プロトコルとして設定し、SCTP プロトコル コンフィギュレーション モードを有効にします。

  • local-port port_num:冗長性ピアとの通信に使用するローカル SCTP ポート番号を定義します。

  • local-ip ip_addr:冗長性ピアとの通信に使用するローカル ルータの IP アドレスを定義します。ローカル IP アドレスは、冗長性ルータのリモート IP アドレスと一致している必要があります。

  • remote-port port_num:冗長性ピアとの通信に使用するリモート SCTP ポート番号を定義します。

  • remote-ip ip_addr:ローカル デバイスとの通信に使用するピア ルータのリモート IP アドレスを定義します。すべてのリモート IP アドレスは同じデバイスを参照する必要があります。

注:local-port および remote-port は、アクティブおよびスタンバイ ルータで 5000 に設定する必要があります。

手順 4:インターフェイスの HSRP を設定する

HSRP デバイス間通信トランスポートを次のように設定します。

アクティブの設定

interface GigabitEthernet0/0
  ip address 10.10.25.14 255.255.255.0
  duplex auto
  keepalive
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
  standby 0 preempt
  standby 0 priority 50
  standby 0 track 2 decrement 10 
  standby 0 name SB
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.14 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3

スタンバイの設定

HSRP のインターフェイスのスタンバイ設定をする場合、(アクティブとスタンバイの両方の CUBE の)inside および outside インターフェイスに preempt と decrement ステートメントを含める必要があります。

inside:
 standby 0 preempt
 standby 0 track 2 decrement 10

outside: 
 standby 6 preempt
 standby 6 track 1 decrement 10

問題は、いずれかのインターフェイスで問題が発生し、preempt が有効になり、他方の CUBE がアクティビティのスイッチを開始することです。この場合、アクティブであった CUBE がリロードされ、コールを引き継ぎます。ただし、インターフェイスがアップになり、対応する(新しい)アクティブ CUBE にいずれかのインターフェイスに関する問題が発生するか、リロードされない限り、アクティブ ロールは引き継がれません。これにより、サブセカンド転送が機能します。

outside インターフェイスを取り外すと、迅速なスイッチオーバーは行われません。完全性のために、両方のインターフェイス(inside および outside インターフェイス)に decrement および preempt ステートメントを含める必要があります。

注:この問題は、Cisco Bug ID CSCtq84246登録ユーザ専用)に記述されています。

interface GigabitEthernet0/0
  ip address 10.10.25.13 255.255.255.0
  duplex auto
  speed auto
  keepalive
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
  standby 0 preempt
  standby 0 priority 50
  standby 0 name SB
		standby 0 track 2 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.13 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
		standby 6 preempt		  
  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3

次に、この設定で使用されるフィールドについて説明します。

  • 0 / 6:スタンバイ グループ番号を定義します。

  • keepalive:HSRP のキープアライブを有効にして、アップ/ダウン イベントを監視します。

  • standby delay:物理インターフェイスがアップになるまで、HSRP 初期化を遅延します。

  • standby x ip:アクティブおよびスタンバイ デバイスで共有される仮想 IPv4 IP アドレスを定義します。このコマンドにより、インターフェイス上で HSRP が有効になります。

  • standby x preempt:ホット スタンバイ グループの他のすべての HSRP 設定ルータよりプライオリティが高い場合、ルータはアクティブ ルータになります。ルータの設定で standby preempt コマンドを使用しない場合、そのルータは、プライオリティが他のすべてのルータより高い場合でも、アクティブ ルータになりません。

  • standby x priority:アクティブ ルータの選択で使用されるホット スタンバイ プライオリティを定義します。範囲は 1 〜 255 です。1 は、最も低いプライオリティ、255 は最も高いプライオリティを示します。

    注:スタンバイ プライオリティが同じ場合、IP アドレスの高いデバイスが、アクティブ ルータのロールを引き継ぎます。

  • standby x name:手順 2(「SB」)で定義したスキームと一致するスタンバイ グループの名前を定義します。複数の HSRP グループの場合、設定で許可されるスタンバイ スキームは 1 つだけなので、同じスタンバイ名が使用されます。

  • standby 6 track 1 decrement 10:プライオリティ トラッキングを定義します。インターフェイス トラッキングの詳細については、ここをクリックしてください。

  • bfd interval 500 min_rx 500 multiplier 3:双方向フォワーディング検出を定義します。

ルータが起動し、インターフェイスがアップになり、アクティブおよびスタンバイ ルータ間でコンタクト(「Hello」)が確立される場合の競合状態を回避するには、次の設定を推奨します。

interface GigabitEthernet0/0
  standby delay minimum 30 reload 60

このコマンドの詳細については、ここをクリックしてください。

手順 5:HSRP タイマーを設定する

2 つの重要な HSRP タイマーがあります。

  • Hello タイマー:特定のルータからの連続した HSRP Hello メッセージ間の間隔。このタイマーは、HSRP インターフェイスで秒単位またはミリ秒単位で設定できます。デフォルト値は 3 秒です。

  • Hold タイマー:Hello メッセージを受信してから送信元ルータが故障していると推測するまでの間隔。この時間は、HSRP インターフェイスで秒単位またはミリ秒単位で設定できます。デフォルト値は 8 秒です。

手順 4 の設定で、HSRP Hello および Hold タイマーは、デフォルト値に設定されています。そのため、これらの設定では、明示的には表示されません。Hello/Hold タイマーの推奨値は、デフォルト値です。

注:デフォルト値以外の値を使用する場合、同じ Hello 時間と Hold タイマー値になるように各ルータを設定します。

Hello および Hold タイマーは、次の CLI を使用して HSRP インターフェイスで設定できます。

Router(config-if)#standby 0 timers ?
  <1-254>  Hello interval in seconds
  msec     Specify hello interval in milliseconds

Router (config-if)#standby 0 timers 2 ?
  <3-255>  Hold time in seconds
  msec     Specify hold interval in milliseconds
Router(config-if)#standby 0 timers 2 msec 40

前述の設定で、Hello タイマーは 2 秒に設定され、Hold タイマーは 40 ミリ秒に設定されています。

注:タイマー設定を下げると、フェールオーバーまたはプリエンプションを高速化できます。ただし、使用 CPU の増加と不要なスタンバイ状態フラッピングを回避するため、Hello タイマーを 1 秒以上、Hold タイマーを 4 秒以上に設定することを推奨します。

手順 6:メディア非アクティビティ タイマーを設定する

メディア非アクティビティ タイマーを使用すると、アクティブ/スタンバイ ルータ ペアはコールを監視し、設定可能な間隔内で Real-Time Protocol(RTP)パケットが受信されない場合、コールを切断します。

コールの RTP パケットがアクティブ/スタンバイ ルータで受信されない場合、SIP メディア非アクティビティ タイマーは、セッションを解放します。これは、通常のコール切断でコールをクリアできない場合のフェールオーバーにより発生する可能性があるハング セッションを保護するために使用されます。

メディア非アクティビティ タイマーの同じ期間を両方のルータで設定する必要があります。デフォルト値は 28 秒です。このタイマーは、次のように設定されます。

ip rtcp report interval 3000
gateway
  media-inactivity-criteria all
  timer receive-rtp 86400
  timer receive-rtcp 5

手順 7:HSRP アドレスへの SIP バインディングを設定する

SIP メッセージングで HSRP 仮想アドレスを使用するように CUBE SIP メッセージングを設定します。

dial-peer voice 100 voip
  description to-SIP
  voice-class sip bind control source-interface GigabitEthernet0/0
  voice-class sip bind media source-interface GigabitEthernet0/0  
!
dial-peer voice 200 voip
  description to-CUCM
  voice-class sip bind control source-interface GigabitEthernet0/1
  voice-class sip bind media source-interface GigabitEthernet0/1

HSRP が物理インターフェイスで設定され、bind コマンドが発行されると、物理 IP アドレスへのコールは失敗します。これは、SIP リスニング ソケットが仮想 IP アドレスにバインドされるが、シグナリング パケットで物理 IP アドレスが使用され、処理できないためです。

手順 8:ルータをリロードする

前述のすべての設定が完了すると、冗長性 show 出力は次のようになります。

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_INIT
  Pending Scheme: Standby (Will not take effect until next reload)
      Pending Groupname: b2bha
  Scheme: <NOT CONFIGURED>
  Peer present: UNKNOWN
  Security: Not configured

ルータをリロードすると、次のように、HSRP 設定が有効になります。

アクティブ ルータ

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
  Scheme: Standby
      Groupname: b2bha Group State: Active
  Peer present: RF_INTERDEV_PEER_COMM
  Security: Not configured

スタンバイ ルータ

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_STDBY
  Scheme: Standby
      Groupname: b2bha Group State: Standby
  Peer present: RF_INTERDEV_PEER_COMM
  Security: Not configured

手順 9:接続されたソフトスイッチを CUBE HSRP 仮想アドレスに指定する

コールを CUBE にルーティングする CUCM、IP-PBX、SIP プロキシ、SP SBC または SP ソフトスイッチは、SIP メッセージングで HSRP 仮想アドレスを使用する必要があります。CUBE 物理 IP アドレスへの SIP メッセージは、HSRP 設定で処理されません。

二重接続された CUBE HSRP の冗長性についての完全なサンプル設定

次に、アクティブおよびスタンバイ CUBE ルータの設定例を示します。この設定では、HSRP Hello および Hold タイマーは、それぞれデフォルト値の 3 および 8 秒を使用し、CLI 出力では明示的に表示されません。

アクティブ ルータの設定

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
        local-ip 10.10.24.14
      remote-port 5000
        remote-ip 10.10.24.13
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
!
redundancy inter-device
  scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 10.10.25.14 255.255.255.0
  duplex auto
  keepalive
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
   standby 0 preempt
  standby 0 priority 50
  standby 0 track 2 decrement 10 
  standby 0 name SB
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.14 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000
!
track 1 interface GigabitEthernet0/0 line-protocol 
!
track 2 interface GigabitEthernet0/1 line-protocol  
!
dial-peer voice 100 voip
  description to-SIP
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
  voice-class sip bind control source-interface GigabitEthernet0/0
  voice-class sip bind media source-interface GigabitEthernet0/0  
!
dial-peer voice 200 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
  voice-class sip bind control source-interface GigabitEthernet0/1
  voice-class sip bind media source-interface GigabitEthernet0/1
!
gateway 
  media-inactivity-criteria all
  timer receive-rtcp 5
  timer receive-rtp 1200

スタンバイ ルータの設定

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
        local-ip 10.10.24.13
      remote-port 5000
        remote-ip 10.10.24.14
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
!
redundancy inter-device
  scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 10.10.25.13 255.255.255.0
  duplex auto
  keepalive
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
  standby 0 preempt
  standby 0 priority 50
  standby 0 name SB
		standby 0 track 2 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.13 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
		standby 6 preempt
  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000
!
track 1 interface GigabitEthernet0/0 line-protocol 
!
track 2 interface GigabitEthernet0/1 line-protocol  
!
dial-peer voice 100 voip
  description to-SIP
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
  voice-class sip bind control source-interface GigabitEthernet0/0
  voice-class sip bind media source-interface GigabitEthernet0/0  
!
dial-peer voice 200 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
  voice-class sip bind control source-interface GigabitEthernet0/1
  voice-class sip bind media source-interface GigabitEthernet0/1
!
gateway 
  media-inactivity-criteria all
  timer receive-rtcp 5
  timer receive-rtp 1200

単一接続された CUBE HSRP の冗長性についての完全なサンプル設定

重接続された CUBE は、特に SP SIP トランク接続の場合、最も一般的な設定ですが、このセクションで説明されている単一接続された CUBE 導入で、CUBE HSRP ボックスツーボックス冗長性を設定することもできます。

アクティブ ルータの設定

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
       local-ip 1.2.175.8
     remote-port 5000
       remote-ip 1.2.175.12
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
  sip
    bind control source-interface GigabitEthernet0/0
    bind media source-interface GigabitEthernet0/0
!
redundancy inter-device
 scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 1.2.175.8 255.255.0.0
  duplex auto
  speed auto
  keepalive
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 1.2.175.100
 standby 0 preempt
  standby 0 priority 50
  standby 0 name SB
  standby 0 track 1 decrement 10
  bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000 
!
dial-peer voice 5 voip
  description to-SIP-application
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
!
dial-peer voice 9 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
!
gateway 
 media-inactivity-criteria all
 timer receive-rtcp 5
 timer receive-rtp 1200

スタンバイ ルータの設定

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
       local-ip 1.2.175.12
     remote-port 5000
       remote-ip 1.2.175.8
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
  sip
    bind control source-interface GigabitEthernet0/0
    bind media source-interface GigabitEthernet0/0
!
redundancy inter-device
 scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 1.2.175.12 255.255.0.0
  duplex auto
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 1.2.175.100
  standby 0 priority 50
		standby 0 preempt
  standby 0 name SB
  standby 0 track 1 decrement 10
  bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000 
!
dial-peer voice 5 voip
  description to-SIP-application
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
!
dial-peer voice 9 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
!
gateway 
 media-inactivity-criteria all
 timer receive-rtcp 5
 timer receive-rtp 1200

HA 設定の削除

次の手順を完了して、すでに開始されている HSRP を CUBE ルータから削除します。

  1. アプリケーション レベル冗長性設定を削除します。

    Router(config)#voice service voip 
    Router(config-voice service voip)#no redundancy
  2. デバイス間コンフィギュレーション モードで設定されたスタンバイ スキームを削除します。

    Router(config)#redundancy inter-device 
    Router(config-red-interdevice)#no scheme standby b2bha
    % Redundancy interdevice scheme change will not take effect until 
    configuration is saved and device reloaded
  3. 設定の変更をメモリに保存して、ルータをリロードします。

    Router(config)#write
    Router#reload
  4. リロード後、このコマンドを実行して、HSRP が無効になっていることを確認します。

    Router#show redundancy inter-device
    Redundancy inter-device state: RF_INTERDEV_STATE_INIT
      Scheme: <NOT CONFIGURED>
      Peer present: UNKNOWN
      Security: Not configured
    
  5. 2 台のデバイス間のアソシエーションを無効にして、SCTP 設定を削除します。

    Router(config)#ipc zone default
    Router(config-ipczone)#association 1
    Router(config-ipczone-assoc)#shutdown
    Router(config-ipczone-assoc)#no protocol sctp
    Router(config-ipczone-assoc)#no association 1
    Router(config-ipczone)#exit
    Router(config)#no ipc zone default
  6. HSRP コマンドの「no」形式を使用して、HSRP 設定をインターフェイスから削除します。

    Router(config)#interface gigabitEthernet 0/0
    Router(config-if)#no standby 0 name
    Router(config-if)#no standby 0 priority 
    Router(config-if)#no standby 0 ip
  7. 設定の変更を保存します。

    Router(config)#write

機能を使用するときの注意

  • HSRP ペアで使用される 2 つのルータは同じでなければなりません(性能とコール キャパシティ レベルを同じにするため)。

  • SIP-SIP コール フローのボックスツーボックス冗長性、SIP トランスポートは、UDP-UDP または UDP-TCP のいずれかにできます。

  • HSRP 仮想アドレスは、IPv4 アドレッシングだけをサポートします。

  • 確立コールのメディア ストリームは、フェールオーバー間で保持されますが、シグナリングは保持されません。そのため、保持されるコールは変更できません(Hold/Resume、転送、コンファレンスなど)。

  • トランスコーディング、DTMF インターワーキング、IVR、SIP-TLS、RSVP、STUN、RTP-SRTP 変換または FAX/モデム機能などの補足サービスに関連するコールは、フェールオーバーで保持されません。

  • ビデオ ストリームは、スイッチオーバーで保持されませんが、オーディオ ストリームは保持されます。

  • HSRP グループは、1 つのルータで複数サポートされますが、1 つの物理インターフェイスでは 1 つだけです。

  • HSRP を使用するループバック アドレスはサポートされません。SIP bind コマンドは、HSRP 仮想 IP アドレスを使用する必要があります。

  • アクティブ ルータとスタンバイ ルータ間の設定の同期化は、手動で行います。自動では行われません。両方のルータに対して、設定を手動で変更する必要があります。

確認

次のように CLI を使用して、HSRP 設定が正しく、稼働していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。OIT を使用して、show コマンド出力の解析を表示できます。

冗長性状態の確認

show redundancy inter-device および show redundancy state コマンドを使用して、冗長性状態を確認します。これらのコマンドは、冗長性デバイス間状態など、冗長性デバイス間情報を表示します。

デバイス間設定が完了する前の show 出力は次のとおりです。

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_PNC_NO_HSRP
Scheme: Standby
Groupname: b2bha Group State: Init
Protocol: <NOT CONFIGURED>

XFR-2#show redundancy states
my state = 3  -NEGOTIATION 
peer state = 1  -DISABLED 
Mode = Simplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (system is simplex (no peer unit))
Communications = Down      Reason: Simplex mode

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

デバイス間設定の完了後で、ルータのリロード前の show 出力は次のとおりです。

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_INIT
Pending Scheme: Standby (Will not take effect until next reload)
Pending Groupname: b2bha
Scheme: <NOT CONFIGURED>
Peer present: UNKNOWN
Security: Not configured

ルータがリロードされると、「Init」状態を示す show 出力は次のとおりです。

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_PNC_NO_HSRP
Scheme: Standby
Groupname: b2bha Group State: Init
Peer present: UNKNOWN
Security: Not configured

CUBE_XFR#show redundancy states 
my state = 3  -NEGOTIATION 
peer state = 13 -ACTIVE 
Mode = Duplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (this unit is still initializing)
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

スイッチオーバー中、たとえば、アクティブ ルータがダウンし、スタンバイ ルータがアクティブに切り替わるときの show の出力は次のとおりです。

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_NO_COMM
Security: Not configured

XFR-2#show redundancy states
my state = 13 -ACTIVE 
peer state = 1  -DISABLED 
Mode = Simplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (system is simplex (no peer unit))
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

スイッチオーバー終了後で、ルータが Hello ステータス メッセージを交換する前の show の出力は次のとおりです。

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_NO_COMM
Security: Not configured

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_HSRP_STDBY_PNC
Scheme: Standby
Groupname: b2bha Group State: Standby
Peer present: RF_INTERDEV_PEER_NO_COMM
Security: Not configured

Hello ステータス メッセージの交換後の show 出力は次のとおりです。

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_COMM
Security: Not configured
  
XFR-2#show redundancy states
my state = 13 -ACTIVE 
peer state = 8  -STANDBY HOT 
Mode = Duplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (peer unit not yet in terminal standby state)
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0  
 
CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_STDBY
Scheme: Standby
Groupname: b2bha Group State: Standby
Peer present: RF_INTERDEV_PEER_COMM
Security: Not configured
        
CUBE_XFR#show redundancy states
my state = 8  -STANDBY HOT 
peer state = 13 -ACTIVE 
Mode = Duplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = cannot be initiated from this the standby unit
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

HSRP 状態の確認

show standby brief コマンドを使用して、HSRP 状態を確認します。このコマンドは、HSRP インターフェイス、スタンバイ グループ番号、プライオリティ、アクティブおよびスタンバイ IP アドレス、仮想 IP アドレスなど、HSRP に関する簡単な出力を示します。show standby コマンドは、詳細な情報を示します。

Router1#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active     Standby      Virtual IP
Gi0/0       0    50    Active  local      9.13.25.134  9.13.25.22

Router2#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active       Standby  Virtual IP
Gi0/0       0    50    Standby 9.13.25.133  local    9.13.25.22

スイッチオーバー後のコール状態の確認

show voice high-availability summary コマンドを使用して、次のことを確認します。

  • スイッチオーバー後のスタンバイ ルータのコールのチェックポイント

  • コール終了時のアクティブ ルータでのメディア非アクティビティ カウント

  • ネイティブおよび非ネイティブ コール(保持されているコールなど)の両方が存在する場合のネイティブおよび非ネイティブ コールを確認する

  • リークした RTP、HA、SPI セッションの存在を確認する

スイッチオーバー後のスタンバイ ルータのコールのチェックポイントの表示

次の例では、スイッチオーバー後にアクティブからスタンバイに 800 コールのチェックポイントが設定されています。

CUBE_XFR#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 0
Number of calls in HA sync pending DB: 0
Number of calls in HA preserved session DB: 0

-----------------------------
First a few entries in HA DB:
-----------------------------

---------------------------------------
First a few entries in Sync Pending DB:
---------------------------------------

----------------------------

======== Voice HA Process INFO ========
Active process current tick: 3100
Active process number of tick events pending: 0
Active process number of tick events processed: 0
voice service voip is  configured to have redundancy

======== Voice HA RF INFO ========
Voice HA RF Client Name: VOIP RF CLIENT
Voice HA RF Client ID: 1345
My current rf state STANDBY HOT
Peer current rf state ACTIVE
Voice HA Standby is not available.
System has not experienced switchover.

======== Voice HA CF INFO ========
Voice HA CF Client Name: CHKPT VOIP SYMPHONY
Voice HA CF Client ID: 252
Voice HA CF Client Status: Peer NOT READY; TP flow ON.

======== Voice HA COUNTERS ========
Total number of checkpoint requests sent (Active): 0
Total number of checkpoint requested received (Standby): 971
Total CREATE received on Standby: 800
Total MODIFY received on Standby: 0
Total DELETE received on Standby: 800
Media Inactivity event count: 0

Checkpoint CREATE overflow: 0
Checkpoint MODIFY overflow: 0
Checkpoint DELETE overflow: 0
HA DB elememnt pool overrun count: 0
HA DB aux element pool overrun count: 0
HA DB insertion failure count: 0
HA DB deletion failure count: 0
Tick event pool overrun count: 0
Tick event queue overrun count: 0
Checkpoint send failure count: 0
Checkpoint get buffer failure count: 0

コール終了時のアクティブ ルータでのメディア非アクティビティ カウントの表示

次の例では、メディア非アクティビティ タイマーにより 800 のコールが作成されます。

XFR-2#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 0
Number of calls in HA sync pending DB: 0
Number of calls in HA preserved session DB: 0

-----------------------------
First a few entries in HA DB:
-----------------------------

---------------------------------------
First a few entries in Sync Pending DB:
---------------------------------------

----------------------------

======== Voice HA Process INFO ========
Active process current tick: 4213
Active process number of tick events pending: 0
Active process number of tick events processed: 0
voice service voip is  configured to have redundancy

======== Voice HA RF INFO ========
Voice HA RF Client Name: VOIP RF CLIENT
Voice HA RF Client ID: 1345
My current rf state ACTIVE
Peer current rf state STANDBY HOT
Voice HA Active and Standby are in sync.
System has experienced switchover.

======== Voice HA CF INFO ========
Voice HA CF Client Name: CHKPT VOIP SYMPHONY
Voice HA CF Client ID: 252
Voice HA CF Client Status: Peer READY; TP flow ON.

======== Voice HA COUNTERS ========
Total number of checkpoint requests sent (Active): 971
Total number of checkpoint requested received (Standby): 800
Total CREATE received on Standby: 800
Total MODIFY received on Standby: 0
Total DELETE received on Standby: 0
Media Inactivity event count: 800

Checkpoint CREATE overflow: 0
Checkpoint MODIFY overflow: 0
Checkpoint DELETE overflow: 0
HA DB elememnt pool overrun count: 0
HA DB aux element pool overrun count: 0
HA DB insertion failure count: 0
HA DB deletion failure count: 0
Tick event pool overrun count: 0
Tick event queue overrun count: 0
Checkpoint send failure count: 0
   Checkpoint get buffer failure count: 0

ネイティブおよび非ネイティブ コール(保持されているコールなど)の両方が存在する場合のネイティブおよび非ネイティブ コールの確認

システムのコール数は、次のように示されます。

  • コールの合計数 =「Number of calls in HA DB」+「Number of calls in HA sync pending DB」。次の出力例では、100 + 50 = 150 です。

  • 保持されている(非ネイティブ)コールの合計数 =「Number of calls in HA preserved session DB」。次の出力例では、70 です。

  • ネイティブ コール(フェールオーバー以降設定され、フェールオーバーで保持されないコール)の合計数は、前述の 2 つの数値と異なります。次の例では、150 – 70 = 80 です。

XFR-2#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 100
Number of calls in HA sync pending DB: 50
Number of calls in HA preserved session DB: 70

リークした RTP、HA、SPI セッションの存在を確認する

メディア非アクティビティによりクリアされた保持される(非ネイティブ)コールの合計数は、次の出力例のように、「Total CREATE received on Standby」–「Total DELETE received on Standby」です。この数値を、「Media Inactivity event count」および show voip fpi stats コマンドの出力で示されるメディア ダウン イベントの数と比較します。

XFR-2#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 0
Number of calls in HA sync pending DB: 0
Number of calls in HA preserved session DB: 0

======== Voice HA COUNTERS ========
Total number of checkpoint requests sent (Active): 971
Total number of checkpoint requested received (Standby): 800
Total CREATE received on Standby: 800
Total MODIFY received on Standby: 0
Total DELETE received on Standby: 0
Media Inactivity event count: 800

SIP IP アドレス バインディングの確認

show sip-ua status コマンドは、SIP バインディング スタータスを表示します。

Router1#show sip-ua status
SIP User Agent Status
SIP User Agent for UDP : ENABLED
SIP User Agent for TCP : ENABLED

SIP User Agent for TLS over TCP : ENABLED
SIP User Agent bind status(signaling): DISABLED
SIP User Agent bind status(media): DISABLED
Snapshot of SIP listen sockets : 2
            Local Address      Listen Port  Secure Listen Port
=============================  ===========  ==================
 10.10.25.14                     5060         5061
 10.10.24.14                     5060         5061
SIP early-media for 180 responses with SDP: ENABLED
SIP max-forwards : 70

現在の CPU 使用の確認

show process cpu history コマンドは、一定間隔で CPU 使用率を確認するときに使用します。

スイッチオーバーを実行する前の CPU 使用率を確認し、CPU 使用率が 70 % 未満の場合だけ強制フェールオーバーを実行します。show process cpu sorted コマンドを繰り返し実行して、特定のプロセスの CPU 使用率情報を取得できます。

スイッチオーバー中にコールが処理されていることの確認

show sip-ua statistics コマンドは、BYE メッセージ数を確認することで、スイッチオーバー中のコール ドロップを確認するときに使用します。スイッチオーバー時に処理中のコールはドロップされます。確立済みのコールだけが保持されます。

show interface accounting コマンドは、スイッチオーバー中のメディア パス確定を確認するときに使用します。

Router#show interfaces g0/0 accounting
GigabitEthernet0/0 
Protocol  Pkts In   Chars In   Pkts Out   Chars Out
Other     1         58         6          360
IP        406       178841     201        16394
ARP       569       34292      0          0
CDP       116       31672      22         7304

IP の「Pkts In」および「Pkts Out」カウンタを確認します。これらは、適切な率で増加します。たとえば、G.711 20 ms パケット化を使用し、VAD を使用しない場合、パケット カウンタは毎秒約 50 増加します。

テストのための手動フェールオーバーの強制

HSRP を使用したボックスツーボックス冗長性は、コールのメディア ステートフル スイッチオーバーをサポートします。つまり、コールのメディア(RTP)が保持されます。シグナリングは保持されません。そのため、アクティブ状態(「sendrecv」接続モードのメディア パス)のコールだけが保持され、一時状態(非アクティブ状態で「sendrecv」接続モードではないメディア パス)のコールはスイッチオーバー中に保持されません。

一時(コール セットアップまたは変更中のコール)および確立状態のコールが混在する場合にスイッチオーバーが発生すると、フェールオーバー中に特定数のコールがドロップされます。ドロップされるコールの予測数は、次のように予測できます。(0.3 + HSRP hold-timer) * CPS。

次の手順を完了し、手動スイッチオーバーを強制実行して、設定および操作が正しいことを確認します。

強制スイッチオーバーをスムーズに行うには、次の手順を実行します。

  • アクティブ/スタンバイ ペアの CPU 使用率を監視します。アクティブ ルータは、アクティブにコールを処理するため CPU 使用率が高くなります。スタンバイ ルータは、スイッチオーバーが発生するまでアイドル状態であるため CPU 使用率は 0 です。

  • 手動スイッチオーバーは、アクティブ ルータの CPU 使用率が 70 % 以下の場合だけ実行されます。スイッチオーバーが発生すると、CPU 使用率が急上昇します。

  • show voip rtp connection および show voice high-availability summary コマンドを使用すると、既存のコールがアクティブ/スタンバイ ルータ ペア間で同期化されます。

HSRP スイッチオーバーにより、以前のアクティブ ルータがリロードされます、以前のスタンバイ ルータが引き継いで新しいアクティブ ルータになり、新しいコールを処理し、保持されるコールが完了するまでこれらのメディア ストリームを保持します。新しいアクティブ ルータは、別のスイッチオーバーが発生するまで、アクティブ ルータのままです。

手動(強制)スイッチオーバーは、次のいずれかの方法で実行できます。

  • アクティブ ルータで CLI「redundancy switch-activity force」を使用する。

  • アクティブ ルータをリロードする。

  • アクティブ ルータをハード リスタートする。

  • HSRP インターフェイスまたは電源ケーブルをアクティブ ルータから外す。

  • アクティブ ルータの HSRP インターフェイスをシャットダウンする。

  • IPC モードでアソシエーションをシャットダウンせずに、アクティブ/スタンバイ ルータの HSRP インターフェイスのパラメータを変更すると、ルータがリロードされます。そのため、インターフェイスのシャットダウンは、これにより、スイッチオーバーを強制実行しない限り、任意の変更前に実行する必要があります。

show voip rtp connections コマンドは、スイッチオーバー後のアクティブおよびスタンバイの両方のルータのアクティブ接続数を示します。

show call active voice brief コマンドは、スイッチオーバー後のスタンバイ ルータの出力を示しません。これは、シグナリング情報のチェックポイントが設定されないためです。

単一スイッチオーバーを実行および確認するための手順

次の手順を実行します。

  1. このドキュメントの「設定」セクションに従い HSRP ボックスツーボックス冗長性を設定します。

  2. 両方ルータを rommon にリロードして保持します。

  3. 一方のルータを起動します。起動したら、show redundancy state コマンドを実行して、my state が Active、peer state が Disabled になっていることを確認します。この動作には、起動後多少の時間がかかります。

    XFR-2#show redundancy states
    my state = 13 -ACTIVE 
    peer state = 1  -DISABLED
  4. もう一方のルータを起動します。起動したら、show redundancy state コマンドを実行して、my state が Standby-Hot、peer state が Active になっていることを確認します。

    CUBE_XFR#show redundancy states
    my state = 8  -STANDBY HOT 
    peer state = 13 -ACTIVE
  5. システムで 1 つ以上のコールを起動します。アクティブおよびスタンバイの両方のルータで show voice high-availability summary および show voip rtp connection コマンドを実行して、コールが起動し、チェックポイントが設定されることを確認します。

  6. アクティブ ルータをリロードして、スイッチオーバーをテストします。電話からコールを発信する場合、電話を使用して、メディア パスが保持されることを確認します。テスト装置を使用する場合、パケット ディスプレイを使用して、コールのメディアが処理されているか確認できます。

    Router#show interfaces g0/0 accounting
    GigabitEthernet0/0 
    Protocol  Pkts In   Chars In   Pkts Out   Chars Out
    Other     1         58         6          360
    IP        406       178841     201        16394
    ARP       569       34292      0          0
    CDP       116       31672      22         7304
  7. メディア非アクティビティをテストします。コールを停止します。show voip rtp connection を繰り返します。メディア非アクティビティ タイマーの有効期限が切れると、アクティブ RTP 接続は失われます。これは、show voice high-availability summary コマンドを使用して、次のように確認できます。

    Router#show voice high-availability summary | include media
    Media Inactivity event count: 1

    Media Inactivity event count は 1 を示します。

フェールオーバー後も保持される単一コールを確認するためのスクリーンショット

フェールオーバー前の表示。

  • アクティブ ルータ(#01)

    cube-hsrp-config-02.gif

  • スタンバイ ルータ(#02)

    cube-hsrp-config-03.gif

アクティブ ルータ(#01)のリロードによる強制フェールオーバー。

cube-hsrp-config-04.gif

スタンバイ ルータ(#02)は、新しいアクティブ ルータを引き継ぎ、コールが保持されます(スタンバイ = 新しいアクティブ)。

cube-hsrp-config-05.gif

以前のアクティブ ルータ(#01)は、新しいスタンバイ ルータとしてリロードされます。コールは、新しいスタンバイで保持されます。

  • 新しいスタンバイ(#01)ルータ:

    cube-hsrp-config-06.gif

  • 新しいアクティブ(#02)ルータ:

    cube-hsrp-config-07.gif

トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つ情報を紹介します。

注:debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

これらの show および debug コマンドは、ボックスツーボックス冗長性のトラブルシューティングに役に立ちます。

show redundancy state
show redundancy inter-device
show standby brief
show standby internal
show sip-ua status
show sip-ua statistics
show voice high-availability summary
show voip rtp connection | include connection
show arp
debug voip ccapi all
debug voip ccapi error
debug voip rtp session
debug voip rtcp session
debug voip rtp error
debug voip rtcp error
debug voice high-availability all
debug voice high-availability error
debug ccsip info
debug ccsip messages
debug ccsip media
debug ccsip error
debug standby terse

注:大量のアクティブ コール トラフィックを処理するシステム、大規模なデバッグを有効にしないでください。

注:スイッチオーバー後およびルータのリロード後、新しいスタンバイ ルータでデバッグを再び有効にする必要があります。

HSRP グループの各ルータは、シンプル ステート マシンを実装することで、プロトコルに参加します。すべてのルータは、イニシャル ステートから始まります。

  1. イニシャル:このステートは、開始ステートにあたり、HSRP は動作していません。設定が変更されたとき、またはインターフェイスが最初に起動したときにこの状態になります。

  2. 学習:ルータはまだ仮想 IP アドレスを決定しておらず、アクティブ ルータからの認証済み Hello メッセージも受信していません。この状態では、ルータはアクティブ ルータからパケットが到達するのを待ち続けます。

  3. リッスン:ルータは仮想 IP アドレスを認識していますが、アクティブ ルータでもスタンバイ ルータでもありません。これらのルータからの Hello メッセージを受信します。

  4. スピーク:ルータは定期的に Hello メッセージを送信し、アクティブ ルータまたはスタンバイ ルータの選出に積極的に参加します。仮想 IP アドレスのないルータはスピーク状態にはなれません。

  5. スタンバイ:ルータは次にアクティブ ルータになる候補で、定期的に Hello メッセージを送信します。一時的な状態を除き、グループ内でスタンバイ ステートになるルータは多くても 1 台です。

  6. アクティブ:現在、ルータはグループの仮想 MAC/IP アドレスに送信されてきたパケットを転送しています。ルータは定期的に Hello メッセージを送信します。一時的な状態を除き、グループ内でアクティブ ステートになるルータは多くても 1 台です。

トラブルシューティングのヒント:アクティブ ルータが 2 台ある

これは、両方のルータがそれぞれからの HSRP Hello を確認できない場合に発生します。

  • 各ルータが他方の IP インターフェイス アドレスを ping できるか確認してください。ping できない場合、ルータ間の通信がダウンしています。

  • debug standby コマンドを使用して、ルータが HSRP Hello パケットを送信、受信または送受信しているか確認します。ピアが Hello を送信するが、受信されない場合、show interface または show controller コマンドを使用して、インターフェイスが HSRP マルチキャスト アドレスをリスニングしているか確認します。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 112095