LAN スイッチング : 802.1Q

Dot1Q/L2P のトンネル上のパケット損失

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この資料は Cisco IOS で悪いネットワーク設計による Dot1Q/L2P トンネル上のパケットロスの解決について説明しますか。 ケーススタディを使って。

前提条件

要件

次の項目に関する知識があることが推奨されます。

  • Dot1Q トンネリングに関する基礎知識

  • OSPF に関する基礎知識

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

ネットワーク構成図

このネットワーク設定では、ルータ 7600 コアのインターフェイス Gi1/44 および Gi 1/43 はそれぞれ、ルータ 3400 メトロ 1 の Fa0/13 および Fa0/12 とルータ オン ア スティックで設定されています。 7600-Dot1Q スイッチで、インターフェイス Gi9/44 および Gi 9/45 は、Dot1q トンネル モードで有効にします。 SVI VLAN インターフェイスは 3400 メトロ エッジで作成され、Fa0/13 および Fa0/12 はトランク ポートとして設定されます。 これらのルータは、OSPF を使用して相互に通信します。

http://www.cisco.com/c/dam/en/us/support/docs/lan-switching/8021q/113632-packet-loss-dot1q-l2p-01.gif

設定

7609 コア
!
version 15.0
hostname 7609-CORE
interface GigabitEthernet1/43
 mtu 9216
 no ip address
 no ip redirects
 no ip proxy-arp
 load-interval 60
 carrier-delay 2
 flowcontrol send off
 storm-control broadcast level 1.00
!
interface GigabitEthernet1/43.3503
 encapsulation dot1Q 3503
 ip address 172.16.41.17 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip mtu 1500
 ip ospf authentication-key 7 072C0E6B6B272D
 ip ospf network point-to-point
 ip ospf hello-interval 3
 ip ospf dead-interval 10
!
!
interface GigabitEthernet1/44
 mtu 9216
 no ip address
 no ip redirects
 no ip proxy-arp
 load-interval 60
 carrier-delay 2
 flowcontrol send off
 storm-control broadcast level 1.00
!
interface GigabitEthernet1/44.3803
 encapsulation dot1Q 3803
 ip address 172.16.73.137 255.255.255.248 secondary
 ip address 172.16.41.21 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip mtu 1500
 ip ospf authentication-key 7 072C0E6B6B272D
 ip ospf network point-to-point
 ip ospf cost 5
 ip ospf hello-interval 3
 ip ospf dead-interval 10

!--- Output omitted.

!
end

7609 DOT1Q
!
version 12.2
!
interface GigabitEthernet9/44
  switchport
 switchport access vlan 24
 switchport mode dot1q-tunnel
 mtu 9216
 load-interval 60
 carrier-delay 2
 flowcontrol send off
 storm-control broadcast level 1.00
 l2protocol-tunnel cdp
 l2protocol-tunnel stp
 l2protocol-tunnel vtp
 no cdp enable
 spanning-tree portfast disable
 spanning-tree bpdufilter enable
!
!
interface GigabitEthernet9/45
 switchport
 switchport access vlan 24
 switchport mode dot1q-tunnel
 mtu 9216
 load-interval 60
 carrier-delay 2
 flowcontrol send off
 storm-control broadcast level 1.00
 l2protocol-tunnel cdp
 l2protocol-tunnel stp
 l2protocol-tunnel vtp
 no cdp enable
 spanning-tree portfast disable
 spanning-tree bpdufilter enable
!

!--- Output omitted.

!
end

3400 メトロ 1
!
version 12.2
!
interface FastEthernet0/3
  port-type nni
 switchport trunk allowed vlan 1052,3503
 switchport mode trunk
 load-interval 60
!
interface FastEthernet0/4
 port-type nni
 switchport trunk allowed vlan 1052,3803
 switchport mode trunk
 load-interval 60
!
!
interface FastEthernet0/12
 port-type nni
 switchport trunk allowed vlan 2-4094
 switchport mode trunk

!
interface FastEthernet0/13
 port-type nni
 switchport trunk allowed vlan 2-4094
 switchport mode trunk
!
end

3400 メトロ エッジ
!
version 12.2
!
interface FastEthernet0/12
 port-type nni
 switchport mode trunk
 load-interval 60
 storm-control broadcast level 1.00
 spanning-tree portfast disable
 spanning-tree bpdufilter disable
!
interface FastEthernet0/13
 port-type nni
 switchport mode trunk
 load-interval 60
 storm-control broadcast level 1.00
 spanning-tree portfast disable
 spanning-tree bpdufilter disable
!
!
interface Vlan3503
 ip address 172.16.41.18 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip ospf authentication-key 7 072C0E6B6B272D
 ip ospf network point-to-point
 ip ospf hello-interval 3
 ip ospf dead-interval 10
!
interface Vlan3803
 ip address 172.16.73.139 255.255.255.248 secondary
 ip address 172.16.41.22 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip ospf authentication-key 7 072C0E6B6B272D
 ip ospf network point-to-point
 ip ospf cost 5
 ip ospf hello-interval 3
 ip ospf dead-interval 10
!

!--- Output omitted.

!
end

観察

パケットが Dot1Q トンネルを通過すると、ランダム ping ドロップが発生します。 ただし、インターフェイスでの入出力のドロップはありません。また、物理層の問題の症状もありません。 show interface <interface> コマンドを発行して、インターフェイスでの入出力のドロップを確認します。

7609-Dot1Q#show interface gi9/44 

!--- Output omitted.

 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    0 input errors, 0 CRC, 1 frame, 0 overrun, 0 ignored
    0 output errors, 0 collisions, 1 interface resets
    0 lost carrier, 0 no carrier, 0 PAUSE output

!--- Output omitted.

100 個の ping に関する ICMP トラフィックをメトロ エッジから送信したときに、95 個のエコーだけがコアで受信された場合、ICMP パケットがパスでドロップされていることを示しています。

Metro-Edge#ping 172.16.41.21 re 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.41.21, timeout is 2 seconds:
.....!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 95 percent (95/100), round-trip min/avg/max = ?/9 ms

注: 7609 で実行した show ip traffic コマンドは 95 個のエコーだけを受信したことを示します。一方、メトロ エッジでは 100 個のエコーが送信されたことが示されます。

show ip traffic
メトロ エッジ
ICMP statistics:
  Rcvd: 0 format errors, 0 checksum errors, 0 redirects, 0 unreachable
        0 echo, 95 echo reply, 0 mask requests, 0 mask replies, 0 quench
        0 parameter, 0 timestamp, 0 info request, 0 other
        0 irdp solicitations, 0 irdp advertisements
  Sent: 0 redirects, 0 unreachable, 100 echo, 0 echo reply
        0 mask requests, 0 mask replies, 0 quench, 0 timestamp
        0 info reply, 0 time exceeded, 0 parameter problem
        0 irdp solicitations, 0 irdp advertisements

!--- The above output shows that 100 echos are sent
!--- but received 95 replies from 7609-Core.

7609 コア
ICMP statistics:
  Rcvd: 0 format errors, 0 checksum errors, 0 redirects, 0 unreachable
        95 echo, 0 echo reply, 0 mask requests, 0 mask replies, 0 quench
        0 parameter, 0 timestamp, 0 info request, 0 other
        0 irdp solicitations, 0 irdp advertisements
  Sent: 0 redirects, 0 unreachable, 0 echo, 95 echo reply
        0 mask requests, 0 mask replies, 0 quench, 0 timestamp
        0 info reply, 0 time exceeded, 0 parameter problem
        0 irdp solicitations, 0 irdp advertisements

トラブルシューティング

パケットのドロップをトラブルシューティングするために、MAC アドレスが正しく学習されているかどうかを確認します。

show mac address table コマンドを使用して MAC アドレス エントリを確認します。

正常な ping の場合

7609-DOT1q#sh mac-address-table address E05F.B972.1F00 all
Legend: * - primary entry
age - seconds since last seen
n/a - not available
vlan mac address type learn age ports
------+----------------+--------+-----+----------+--------------------------
Active Supervisor:
* 24 e05f.b972.1f00 dynamic Yes 0 Gi9/44

!--- This output displays the MAC address learnt
!--- and its associated port, in this case the associated 
!--- port for successful ping is Gi9/44.

問題のある ping の場合

7609-DOT1q#sh mac-address-table address E05F.B972.1F00 all
Legend: * - primary entry
age - seconds since last seen
n/a - not available
vlan mac address type learn age ports
------+----------------+--------+-----+----------+--------------------------
Active Supervisor:
* 24 e05f.b972.1f00 dynamic Yes 5 Gi9/45

!--- This output displays the MAC address learnt
!--- and its associated port, in this case, 
!--- the port number is Gi9/45.

詳細な MAC インデックス プログラミングを表示するには、show mac-address-table コマンドを使用します。

7609-DOT1q#sh mac-address-table address E05F.B972.1F00 det

MAC Table shown in details
========================================

PI_E RM RMA Type Alw-Lrn Trap Modified Notify Capture Flood Mac Address Age Pvlan SWbits Index XTag
----+---+---+----+-------+----+--------+------+-------+------+--------------+----+------+------+----

Active Supervisor:

Yes No No DY No No Yes No No No e05f.b972.1f00 0xE0 24 0 0x22C 0

Remote login switch および test mcast ltl-info index <Index number> コマンドを発行して、以前の HEX 値に示されたポート番号を把握します。

7609-DOT1q-sp#test mcast ltl-info index 22B
index 0x22B contain ports 9/44
7609-DOT1q-sp#test mcast ltl-info index 22C
index 0x22C contain ports 9/45

!--- The output shows that hex number 22B 
!--- points to 9/44 port and hex 22C points to 9/45.

ping が失敗した場合、送信元と宛先のインデックスが同じポートになり、そのためドロップされます。 7600 で mac-address-table notification mac-move コマンドを使用して MAC 移動が有効にされると、以下のように 2 つの異なるポート間の MAC フラップが示されます。これはエラー メッセージです。

注: 6500/7600 ではスイッチに対して 1 個の共通の MAC アドレスを使用するため、同じ MAC アドレスが異なるポート間に割り当てられました。 show catalyst 6000 chassis-mac-address コマンドは、予約済みスイッチ MAC アドレスを示します。

* Jul 2 10:29:44.011: %MAC_MOVE-SP-4-NOTIF: Host e05f.b972.1f00 in 
vlan 24 is flapping between port Gi9/45 and port Gi9/44

!--- The previous error message indicates 
!--- that the same MAC address is assigned between 
!--- two different ports: Gi9/45 and port Gi9/44.

解決策

前述のネットワークは、同じスイッチに DOT1Q トンネルのエンドポイントがあるフル メッシュ ネットワーク設定です。 このようなネットワーク設定では、MAC フラップが予想されます。 MAC フラッピングを回避するには、次の解決方法のいずれかを実行できます。

  • トンネルのエンドポイントを別のスイッチに移動します(たとえば、カプセル化とカプセル化解除が異なるスイッチで行われるようにします)。

  • いずれかのトランク ポートで VLAN を調整するために、VLAN プルーニングを実行できます。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 113632