IP : IP バージョン 6(IPv6)

EIGRPv6 の IPv6 BGP デフォルト ルートの再配布の設定例

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、EIGRPv6 および IPv6 BGP 間の相互再配布を使用して Enhanced Interior Gateway Routing Protocol(EIGRPv6)にボーダー ゲートウェイ プロトコル(IPv6 BGP)デフォルト ルートを再配布するための設定例について説明します。

前提条件

この設定を行う前に、以下の要件を満たしていることを確認してください。

  • EIGRPv6 の基本的な知識がある

  • IPv6 BGP の基本的な知識がある

  • IPv6 アドレッシングの基本的な知識がある

ハードウェアとソフトウェアのバージョン

この資料のコンフィギュレーションは Cisco IOS が付いている Cisco 7200 シリーズ ルータに基づいていますか。 ソフトウェア リリース 15.0(1)。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この例では、ルータ R2 と R1 は IPv6 eBGP を使用して相互に通信します。 ルータ R1 と R3 は EIGRPv6 を使用します。 neighbor default-originate コマンドを発行すると、デフォルト ルートがルータ R2 に作成されます。 IPv6 eBGP ルートを EIGRPv6 に相互に再配布するため、EIGRP メトリックの redistribute bgp コマンドを使用します。 同様に、EIGRPv6 ルートを IPv6BGP に再配布するために、アドレス ファミリ コンフィギュレーション モードで redistribute eigrp AS number コマンドを使用します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用します。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113598-redis-ipv6-default-route-01.gif

設定

このドキュメントでは、次の設定を使用します。

ルータ R1
R1#show run
Building configuration...
!
version 15.0
!
hostname R1
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback10
 no ip address
 ipv6 address BB10::10/128
!
interface Loopback20
 no ip address
 ipv6 address BB20::20/128
!
interface Loopback30
 no ip address
 ipv6 address BB30::30/128
 ipv6 eigrp 1
!
interface Serial1/0
 no ip address
 ipv6 address 3030:1:1:1::11/64
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 ipv6 address 4040:1:1:1::10/64
 ipv6 eigrp 1
 serial restart-delay 0
!
!
router bgp 505
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 3030:1:1:1::10 remote-as 500
 no auto-summary
 !
 address-family ipv6
  redistribute eigrp 1

!--- EIGRP is redistributed in to BGP.

  no synchronization
  network BB10::10/128
  network BB20::20/128
  neighbor 3030:1:1:1::10 activate
 exit-address-family
!
!
ipv6 router eigrp 1
 eigrp router-id 1.1.1.1
 redistribute bgp 505 metric 100 1 255 1 1500

!--- EIGRP for IPv6 has a shutdown feature.
!--- Make sure that the routing process is in "no shut" mode 
!--- in order to start running the protocol.


!--- BGP is redistributed with EIGRP default metrics.

!
end

ルータ R2
R2#show run
Building configuration...
!
hostname R2
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback10
 no ip address
 ipv6 address AB10::10/128
!
interface Loopback20
 no ip address
 ipv6 address AB20::20/128
!
interface Serial1/0
 no ip address
 ipv6 address 3030:1:1:1::10/64
 serial restart-delay 0
!
router bgp 500
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 3030:1:1:1::11 remote-as 505
 neighbor 3030:1:1:1::11 default-originate
 no auto-summary
!
 address-family ipv6
  no synchronization
  network AB10::10/128
  network AB20::20/128
  neighbor 3030:1:1:1::11 activate
  neighbor 3030:1:1:1::11 default-originate
 exit-address-family
!
end

!--- Originates default route to the 
!--- neighbor 3030:1:1:1::11.

ルータ R3
R3#show run
!
version 15.0
!
hostname R3
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback10
 no ip address
 ipv6 address CC10::10/128
 ipv6 eigrp 1
!
interface Loopback20
 no ip address
 ipv6 address CC20::20/128
 ipv6 eigrp 1
!
interface Serial1/0
 no ip address
 ipv6 address 4040:1:1:1::11/64
 ipv6 eigrp 1
 serial restart-delay 0
!
!
ipv6 router eigrp 1
 eigrp router-id 3.3.3.3
!
end

確認

このセクションでは、設定が正常に機能していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

show コマンド

ルータ R3 で再配布された IPv6 BGP デフォルト ルートを受信していることを確認するには、ルータ R3 で show ipv6 route eigrp コマンドを使用します。

show ipv6 route eigrp
ルータ R3 内
R3#show ipv6 route eigrp
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
EX  ::/0 [170/26112256]
     via FE80::C806:16FF:FE08:0, Serial1/0
EX  AB10::10/128 [170/26112256]
     via FE80::C806:16FF:FE08:0, Serial1/0
EX  AB20::20/128 [170/26112256]
     via FE80::C806:16FF:FE08:0, Serial1/0
D   BB30::30/128 [90/2297856]
     via FE80::C806:16FF:FE08:0, Serial1/0

!--- The above output shows that the default route
!--- is redistributed in EIGRP. EX indicates EIGRP external routes.

EIGRPv6 ルートがルータ R2 に正しく再配布されていることを確認するには、ルータ R2 で show ipv6 route bgp コマンドを使用します。

show ipv6 route bgp
ルータ R2 内
R2#show ipv6 route bgp
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B   BB10::10/128 [20/0]
     via FE80::C806:16FF:FE08:0, Serial1/0
B   BB20::20/128 [20/0]
     via FE80::C806:16FF:FE08:0, Serial1/0
B   CC10::10/128 [20/2297856]
     via FE80::C806:16FF:FE08:0, Serial1/0
B   CC20::20/128 [20/2297856]
     via FE80::C806:16FF:FE08:0, Serial1/0

!--- The above output shows that the eigrp routes
!--- are redistributed in to BGP.

ping コマンドを使用してルータ R2 と R3 間の到達可能性を確認します。

ping
ルータ R2 から:
 
R2#ping  CC10::10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to CC10::10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/40/96 ms

R2#ping CC20::20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to CC20::20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/44/100 ms
ルータ R3 から:
 
R3#ping AA10::10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to AA10::10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/33/92 ms

R3#ping AA20::20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to AA20::20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/33/92 ms

!--- The above ping responses shows that R1 and R3 are able
!--- to communicate with each other.


関連情報


Document ID: 113598