IP : ボーダー ゲートウェイ プロトコル(BGP)

32 ビット AS 番号を使用した BGP の実装の設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、32 ビット AS 番号を使用してボーダー ゲートウェイ プロトコル(BGP)を設定する方法について説明します。 BGP では、各ルーティング ドメインは単一 管理ドメインで、それに割り当てられるユニークな AS 数がありルーティングポリシーの設定 されるユニフォームの内で操作されます。 また、ドメイン間ルーティングを維持します。

この資料では、BGP ピアリングは 16 ビットおよび 32ビット話す BGPルータの間で設定されます。 新しい 32ビット AS モードは the16-bit AS モードでの矛盾しないです。 32ビット モードで操作できる BGPピアは新しい機能およびそれに肯定的に応答しますセッションは新しいモードで動作します。 一方では 16 ビット BGPスピーカーと交信を行うとき、16 ビット通信中のルータ、32ビット BGPピアはこの新しい機能を無視し、16 ビット モードの BGPセッションを操作します。

前提条件

要件

BGP に関する基本的な知識があることが推奨されます。

ハードウェアとソフトウェアのバージョン

この資料のコンフィギュレーションは Cisco IOS が付いている Cisco 7200 シリーズ ルータに基づいていますか。 ソフトウェア リリース 15.0(1)。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この例では、ルータ R1 および R3 は 16 ビット AS モードを使用して AS 100 形成 iBGP 関係であるために設定されます。 ルータ R2 および R4 は設定された AS 10.1 で、32ビット AS モードを使用して iBGP ピアリングを形成します。 互い間のこの例 OSPF のルータ R1 および R2 実行および IGP プロトコルは、またおよびその間で近隣 eBGP を形成します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用します。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/113593-config-bgp-using-32bit-ASN-01.gif

設定

このドキュメントでは、次の設定を使用します。

ルータ R1
R1#show run
Building configuration...
!
version 15.0
!
hostname R1
!
ip cef
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback10
ip address 192.168.100.1 255.255.255.0
!
interface Loopback20
ip address 192.168.200.1 255.255.255.0
!
interface FastEthernet1/0
ip address 192.168.10.1 255.255.255.0
duplex auto
 speed auto
!
interface Serial2/0
 ip address 10.10.100.1 255.255.255.0
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 10.10.100.0 0.0.0.255 area 0
!
router bgp 100

!--- BGP is configured using 16-bit AS number

 no synchronization
 bgp router-id 10.10.10.10
 bgp asnotation dot

!--- This command change the default asplain notation
to dot notation.


!--- Note that without this command the AS number will 
treated as asplain notation i.e. 10.1 will 
be displayed as 655361


 bgp log-neighbor-changes
 network 192.168.100.0
 network 192.168.200.0
 neighbor 2.2.2.2 remote-as 10.1

!--- The AS number of the eBGP peer in 32-bit

 neighbor 2.2.2.2 ebgp-multihop 255
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 192.168.10.2 remote-as 100
 neighbor 192.168.10.2 next-hop-self
 no auto-summary
!
end

ルータ R2
R2#show run
!
version 15.0
!
hostname R2
!
ip cef
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Loopback10
ip address 10.1.1.1 255.255.255.255
!
interface Loopback20
ip address 20.1.1.1 255.255.255.255
!
interface FastEthernet1/0
ip address 172.16.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
ip address 10.10.100.2 255.255.255.0
serial restart-delay 0
!
!
router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 10.10.100.0 0.0.0.255 area 0
!
router bgp 10.1

!--- BGP is configured using 32-bit AS number

 no synchronization
 bgp router-id 20.20.20.20
 bgp asnotation dot
 bgp log-neighbor-changes
 network 10.1.1.1 mask 255.255.255.255
 network 20.1.1.1 mask 255.255.255.255
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 ebgp-multihop 255
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 172.16.10.2 remote-as 10.1
 neighbor 172.16.10.2 next-hop-self
 no auto-summary
!
end

ルータ R3
R3#show run
Building configuration...
!
version 15.0
ip cef
!
interface Loopback0
 ip address 30.30.30.30 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.168.10.2 255.255.255.0
 duplex auto
 speed auto
!
router bgp 100
 no synchronization
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 network 30.30.30.30 mask 255.255.255.255
 neighbor 192.168.10.1 remote-as 100
 neighbor 192.168.10.1 next-hop-self
 no auto-summary

!--- iBGP peering is formed between routers R1 and R3
using 16-bit AS number.

!
end

ルータ R4
R4#show run
Building configuration...
!
version 15.0
ip cef
!
interface Loopback0
 ip address 40.40.40.40 255.255.255.255
!
interface FastEthernet1/0
 ip address 172.16.10.2 255.255.255.0
 duplex auto
 speed auto
!
router bgp 10.1
 no synchronization
 bgp router-id 4.4.4.4
 bgp asnotation dot
 bgp log-neighbor-changes
 network 40.40.40.40 mask 255.255.255.255
 neighbor 172.16.10.1 remote-as 10.1
 no auto-summary
!
end

!--- iBGP peering is formed between routers 
R2 and R4 using 32-bit AS number.

確認

このセクションでは、設定が正常に機能していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

show コマンド

BGP が 32ビット ASN をサポートできることを確認するために show ip bgp neighbor コマンドを使用して下さい。

show ip bgp neighbor
ルータ R1 内
 
R1#show ip bgp neighbor 2.2.2.2
BGP neighbor is 2.2.2.2,  remote AS 10.1, external link
  BGP version 4, remote router ID 20.20.20.20
  BGP state = Established, up for 03:28:22
  Last read 00:00:41, last write 00:00:29, hold time is 180, keepalive interval is 60 seconds
  Neighbor sessions:
    1 active, is multisession capable
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    Four-octets ASN Capability: advertised and received
    Address family IPv4 Unicast: advertised and received
    Multisession Capability: advertised and received
  Message statistics, state Established:
    InQ depth is 0
    OutQ depth is 0

                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                3          3
    Keepalives:           229        230
    Route Refresh:          0          0
    Total:                233        234


!--- Output omitted---!

エントリを BGPルーティングテーブルで示すために、show ip bgp コマンドを使用して下さい。

show ip bgp
ルータ R1 内
 
R1#sh ip bgp
BGP table version is 13, local router ID is 10.10.10.10
Status codes: s suppressed, d damped, h history, * valid, > best, I - internal,
              r RIB-failure, S Stale
Origin codes: I - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.1.1.1/32      2.2.2.2                  0             0 10.1 I
*> 20.1.1.1/32      2.2.2.2                  0             0 10.1 I
*>i30.30.30.30/32   192.168.10.2             0    100      0 I
*> 40.40.40.40/32   2.2.2.2                                0 10.1 I
*> 192.168.100.0    0.0.0.0                  0         32768 I
*> 192.168.200.0    0.0.0.0                  0         32768 I


!--- Note that the routes highlighted are received from the eBGP peer 
router R2 which is in 32-bit AS 10.1.


In router R3
R3#sh ip bgp
BGP table version is 11, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, I - internal,
              r RIB-failure, S Stale
Origin codes: I - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.1.1.1/32      192.168.10.1             0    100      0 655361 I
*>i20.1.1.1/32      192.168.10.1             0    100      0 655361 I
*> 30.30.30.30/32   0.0.0.0                  0         32768 I
*>i40.40.40.40/32   192.168.10.1             0    100      0 655361 I
*>i192.168.100.0    192.168.10.1             0    100      0 I
*>i192.168.200.0    192.168.10.1             0    100      0 I


!--- The router R3 does not have bgp asnotation dot
configured in it. Therefore, the route received from the router in 32-bit AS AS 10.1 
is displayed as 655361.


In router R4
R4#sh ip bgp
BGP table version is 7, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, I - internal,
              r RIB-failure, S Stale
Origin codes: I - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.1.1.1/32      172.16.10.1              0    100      0 I
*>i20.1.1.1/32      172.16.10.1              0    100      0 I
*>i30.30.30.30/32   172.16.10.1              0    100      0 100 I
*> 40.40.40.40/32   0.0.0.0                  0         32768 I
*>i192.168.100.0    172.16.10.1              0    100      0 100 I
*>i192.168.200.0    172.16.10.1              0    100      0 100 I


!--- The above output shows the entries in BGP routing table of router R4.

ルータ間の到達可能性を確認するために、ping コマンドを使用して下さい。

ping
ルータ R3 から
 
R3#ping 40.40.40.40

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.40.40.40, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/101/148 ms
ルータ R4 から
 
R4#ping 30.30.30.30

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.30.30.30, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/89/112 ms

!--- The above output shows that End to End connectivity is established between R3 and R4,
where R3 is AS 100(16-bit AS) and router R4 is in AS 10.1(32-bit AS).

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 113593