ワイヤレス / モビリティ : ワイヤレス LAN(WLAN)

Wireless LAN Controller(WLC)および Lightweight アクセス ポイント(LAP)によるマルチキャストの設定例

2012 年 9 月 26 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2009 年 2 月 4 日) | フィードバック

Wireless LAN Controller(WLC)および Lightweight アクセス ポイント(LAP)によるマルチキャストの設定例

概要

このドキュメントでは、マルチキャストおよびマルチキャスト対応有線ネットワークとの通信用に、Wireless LAN Controller(WLC)および Lightweight アクセス ポイント(LAP)を設定する方法に関する設定例を示します。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • LAP および Cisco WLC の設定に関する基本的な知識

  • 有線ネットワークでの基本的なルーティングおよびマルチキャストの設定方法に関する知識

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • ファームウェア リリース 4.0 が稼働している Cisco 4400 WLC

  • Cisco 1000 シリーズ LAP

  • ファームウェア リリース 2.6 が稼働している Cisco 802.11a/b/g ワイヤレス クライアント アダプタ

  • Cisco IOS® ソフトウェア リリース 12.4(2) が稼働する Cisco 2500 ルータ

  • Cisco IOS ソフトウェア リリース 12.0(5)WC3b が稼働する Cisco 3500 XL シリーズ スイッチ 2 台

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

Wireless LAN Controller(WLC)でのマルチキャスト

Cisco Unified Wireless Network ソフトウェア リリース 3.2 の前までは、IP マルチキャストが有効に設定されている場合、コントローラはマルチキャスト パケットのコピーを作成してから、ユニキャストの Lightweight アクセス ポイント プロトコル(LWAPP)トンネルを介してコントローラに接続している各アクセス ポイント(AP)にパケットを転送することで、マルチキャスト パケットをワイヤレス LAN(WLAN)クライアントに送信しました。ファースト ホップ ルータ上の VLAN からコントローラが受信した各マルチキャスト フレームは、コピーされて、コントローラに接続されている各 AP に、LWAPP トンネルを介して送信されていました。

コントローラでは、AP の数に応じて、各マルチキャスト パケットのコピーを最大 300 個生成する必要がありました。このメカニズムは効率が悪く、コントローラに大きな処理の負荷を与えます。この結果、重複する大量のユニキャスト パケットがネットワークにあふれることになります。

Cisco Unified Wireless Network ソフトウェア リリース 3.2 以降では、Cisco Unified Wireless Network のマルチキャスト パフォーマンスが最適化されています。これらのリリースには、コントローラから AP に効率的にマルチキャスト トラフィックを送信する方法が導入されています。ユニキャストを使用し、LWAPP トンネルを介して各 AP にそれぞれのマルチキャスト パケットを送信する代わりに、LWAPP マルチキャスト グループを使用してマルチキャスト パケットを各 AP に送信します。これにより、ネットワーク内のルータは標準のマルチキャスト手法を使用してマルチキャスト パケットを複製し、AP に送信できるようになります。LWAPP マルチキャスト グループの場合は、コントローラがマルチキャスト送信元になり、AP がマルチキャスト受信側になります。マルチキャスト パフォーマンス機能のために、AP では、ルータからの Internet Group Management Protocol(IGMP)クエリのみと、現在 AP と関連付けられているコントローラを送信元 IP アドレスとするマルチキャスト パケットを受け入れます。

ネットワークがパケット マルチキャストをサポートしている場合は、コントローラで使用するマルチキャスト方式を設定できます。コントローラでは、次の 2 つのモードでマルチキャストを実行します。

  • ユニキャスト モード:コントローラにアソシエートしているすべての AP に、すべてのマルチキャスト パケットがユニキャストされます。このモードは非効率的ですが、マルチキャストをサポートしないネットワークで必要な場合があります。

  • マルチキャスト モード:マルチキャスト パケットは LWAPP マルチキャスト グループに送信されます。この方法では、コントローラ プロセッサのオーバーヘッドが軽減され、パケット レプリケーションの作業はネットワークに移されます。これは、ユニキャストを使った方法より、はるかに効率的です。

    マルチキャスト モードは、コントローラ GUI または CLI を使用して有効に設定できます。

さまざまな WLC ソフトウェア バージョンでのマルチキャスト動作

リリース 4.0.206.0 よりも前の WLC ファームウェアでは、ユニキャスト モードとマルチキャスト モードのいずれかでマルチキャスト パケット転送を有効にすると、ブロードキャスト パケット転送も有効になります。WLC ファームウェア リリース 4.0.206.0 では、ブロードキャストとマルチキャスト トラフィックは、別々に有効にする必要があります。ブロードキャストは、デフォルトでは無効に設定にされています。ブロードキャストを有効にするには、WLC CLI から次のコマンドを発行します。

config network broadcast enable

また、ブロードキャストでは、マルチキャストがオンでない場合でも、WLC 上に設定されているマルチキャスト モードを使用します。マルチキャストを有効にしないでブロードキャストを有効にするには、GUI からではなく CLI からこれを行います。マルチキャストを有効にしていない場合、GUI では、IP アドレスおよびモードを設定できないためです。したがって、マルチキャスト モードがユニキャストで、ブロードキャストをオンにしている場合、ブロードキャストではこのモードが使用されます(ブロードキャスト トラフィックを複製して各 AP にユニキャスト)。マルチキャスト モードにマルチキャストを設定し、マルチキャスト アドレスを指定した場合、ブロードキャストではこのモードが使用されます(マルチキャスト グループを介して各ブロードキャスト パケットを AP に送信)。

config network multicast mode multicast 
                           Or
config network multicast unicast

AAA Override を含むマルチキャストは、Wireless LAN Controller リリース 4.2 以降でサポートされています。マルチキャストで AAA Override を機能させるには、コントローラ上で IGMP スヌーピングを有効にする必要があります。

IGMP スヌーピングはマルチキャスト パケットの振り分けを最適化するためにコントローラ ソフトウェア リリース 4.2 に導入されました。この機能が有効になっている場合、コントローラは IGMP レポートをクライアントから収集して処理し、レイヤ 3 マルチキャスト アドレスと VLAN 番号をチェックした後に IGMP レポートから一意なマルチキャスト グループ ID(MGID)を作成し、その IGMP レポートをインフラストラクチャ スイッチへ送信します。コントローラから送信されるレポートの送信元アドレスには、コントローラでレポートをクライアントから受信したインターフェイスのアドレスが使用されます。

次に、コントローラは、AP 上のアクセス ポイント MGID テーブルを、クライアント MAC アドレスで更新します。特定のマルチキャスト グループに対するマルチキャスト トラフィックを受信した場合、コントローラは、すべての AP にこのトラフィックを転送します。ただし、この特定の WLAN 上でマルチキャスト トラフィックを送信するのは、そのマルチキャスト グループをリスニングしているかサブスクライブしているアクティブなクライアントが存在する AP のみになります。IP パケットは、入力 VLAN および宛先マルチキャスト グループで一意の MGID を使用して転送されます。レイヤ 2 マルチキャスト パケットは、入力インターフェイスで一意の MGID を使用して転送されます。

注:IGMP スヌーピングは、2000 シリーズ コントローラ、2100 シリーズ コントローラ、Cisco Integrated Services Router 用 Cisco Wireless LAN Controller ネットワーク モジュールではサポートされていません。

2100 シリーズ コントローラ上および Cisco Integrated Services Router 用 Cisco Wireless LAN Controller ネットワーク モジュール上のマルチキャスト アプリケーションには、既知の制限事項があります。シスコでは、今後の製品コード リリースでこれらの制限事項を解消するよう尽力しています。マルチキャストを盛んに使用するアプリケーションの場合、当面は、4400 シリーズまたは WiSM コントローラを使用することを推奨します。

注:2100 シリーズ コントローラのローカル ポートに直接接続されている AP では、マルチキャストはサポートされていません。

WLC を使用したマルチキャストの詳細については、『エンタープライズ モビリティ設計ガイド』の「Cisco Unified Wireless マルチキャストの設計」の章を参照してください。

このドキュメントでは、マルチキャスト対応有線ネットワークに接続するための WLC 上のマルチキャストの設定方法を説明する設定例を示します。

ワイヤレス マルチキャスト ローミング

ワイヤレス環境のマルチキャスト クライアントでは、WLAN 内を移動するときのマルチキャスト グループ メンバーシップの維持が大きな課題となります。AP 間を移動するときにワイヤレス接続がドロップすると、クライアントのマルチキャスト アプリケーションで中断が発生することがあります。グループ メンバーシップ情報の動的メンテナンスでは、Internet Group Management Protocol(IGMP)が重要な役割を果たします。

クライアントがネットワーク内を動き回るときのマルチキャスト セッションの動作を理解するには、IGMP の基本的な知識が重要です。レイヤ 2 ローミングの場合、適切に設定されている外部 AP であればすでにそのマルチキャスト グループに属しており、トラフィックはネットワーク上の別のアンカー ポイントにトンネリングされないため、セッションはそのまま維持されます。レイヤ 3 ローミング環境では仕組みがもう少し複雑で、コントローラに設定したトンネリング モードによって異なっており、ワイヤレス クライアントから送信された IGMP メッセージに影響することがあります。コントローラ上のデフォルトのモビリティ トンネリング モードは非同期です。つまり、クライアントへのリターン トラフィックはアンカー WLC に送信されてから、関連するクライアント接続のある外部 WLC に転送されます。発信パケットは、外部 WLC インターフェイスに向けて転送されます。同期モビリティ トンネリング モードでは、着信と発信の両方のトラフィックがアンカー コントローラまでトンネリングされます。

マルチキャスト モードを使用する場合の注意点

ネットワークでマルチキャスト モードを有効にする場合は、次のガイドラインに従ってください。

  • Cisco Unified Wireless Network ソリューションでは、いくつかの IP アドレス範囲を特定の目的で使用します。マルチキャスト グループを設定するときは、この範囲に留意してください。

    推奨はしませんが、任意のマルチキャスト アドレスを LWAPP マルチキャスト グループに割り当て可能です。これには、OSPF、EIGRP、PIM、HSRP、およびその他のマルチキャスト プロトコルで使用する、予約済みのリンクローカル マルチキャスト アドレスを含みます。

    シスコでは、管理用スコープのブロック 239/8 からマルチキャスト アドレスを割り当てることを推奨します。IANA では、プライベート マルチキャスト ドメインで使用するために、管理用スコープのアドレスとして 239.0.0.0 〜 239.255.255.255 の範囲を予約しています。その他の制限については、次の注を参照してください。これらのアドレスは、RFC 1918 で定義されている予約済みのプライベート IP ユニキャストの範囲(10.0.0.0/8 など)と事実上よく似ています。ネットワーク管理者は、インターネット上での競合を気にすることなく、管理しているドメイン内でこの範囲のマルチキャスト アドレスを自由に使用できます。この管理用またはプライベートのアドレス空間は、企業内で使用する必要があり、Autonomous Domain(AS)への出入りはブロックされます。

    注:アドレス範囲 239.0.0.X および 239.128.0.X は使用しないでください。これらの範囲のアドレスは、リンク ローカル MAC アドレスとオーバーラップし、IGMP スヌーピングがオンの場合でも、すべてのスイッチ ポートに向けてフラッディングします。

    シスコでは、企業ネットワーク管理者がこのアドレス範囲を企業ネットワーク内のさらに細かい地理上の管理用スコープに分けて、特定のマルチキャスト アプリケーションの「スコープ」を限定することを推奨します。これによって、高レートのマルチキャスト トラフィックがキャンパス(帯域幅が十分)から出て WAN リンクを混雑させることを防止できます。高帯域幅のマルチキャストを効率的にフィルタリングすることによって、高帯域幅のマルチキャストがコントローラおよび無線ネットワークに到達することも防止できます。マルチキャスト アドレスのガイドラインの詳細は、『企業 IP マルチキャスト アドレスの割り当てのガイドライン』を参照してください。

  • コントローラ上のマルチキャスト モードを有効にする場合は、コントローラ上で LWAPP マルチキャスト グループ アドレスを設定する必要があります。AP は、Internet Group Management Protocol(IGMP)を使用して LWAPP マルチキャスト グループに加入します。

  • Cisco AP 1100、1130、1200、1230、および 1240 は、IGMP バージョン 1、2、および 3 を使用します。ただし、Cisco 1000 シリーズ AP では、マルチキャスト グループへの加入に IGMP v1 だけを使用します。

  • マルチキャスト モードは、レイヤ 3 LWAPP モードのみで機能します。

  • モニタ モード、スニファ モード、または不正検出モードの AP は、LWAPP マルチキャスト グループ アドレスには加入しません。

  • バージョン 4.1 以前を実行するコントローラを使用する場合は、すべてのコントローラ上で同じマルチキャスト アドレスを使用できます。バージョン 4.2 以降を実行するコントローラを使用する場合、コントローラ上に設定する LWAPP マルチキャスト グループは、ネットワーク上で使用されているコントローラごとに異なる必要があります。

  • バージョン 4.1 以前を搭載したコントローラを使用する場合、ゲスト トンネリング、サイト別 VLAN、RADIUS を使用したインターフェイスの上書きなどのサブネット間モビリティ イベント間では、マルチキャスト モードは機能しません。有線 LAN 上のレイヤ 2 IGMP スヌーピング機能および CGMP 機能を無効にすれば、これらのサブネット モビリティ イベントでもマルチキャスト モードが機能します。

    新しいバージョン、つまり 4.2 以降のバージョンでは、ゲスト トンネリングなどのサブネット間モビリティ イベントをまたいで、マルチキャスト モードが機能しません。ただし、RADIUS を使用したインターフェイスの上書き(IGMP スヌーピングが有効になっている場合のみ)およびサイト専用の VLAN(アクセス ポイント グループ VLAN)では機能します。

  • コントローラは、UDP ポート番号 12222、12223、12224 に対して送信されるすべてのマルチキャスト パケットをドロップします。ネットワーク上のマルチキャスト アプリケーションで、これらのポート番号を使用していないことを確認してください。

  • 802.11a ネットワークの場合、マルチキャスト トラフィックは、6 Mbps で送信されます。したがって、複数の WLAN が 1.5 Mbps での送信を試みると、パケット損失が発生します。その結果、マルチキャスト セッションが切断されます。

ネットワーク設定

このセットアップでは、R1、R2、R3 の 3 台のルータで有線ネットワークが構成されており、ルータ間に OSPF を実行しています。

有線ホストは、ルータ R1 に接続されるレイヤ 2 スイッチを介してネットワークに接続されます。ワイヤレス ネットワークは、のように、ルータ R3 を介してネットワークに接続されます。

基本 IP 接続をデバイスに設定する必要があり、ネットワーク内のマルチキャストを有効にする必要があります。したがって、ユーザは、有線側からワイヤレス側(およびワイヤレス側から有線側)のマルチキャスト トラフィックを送受信できます。

このドキュメントでは、WLC、LAP、ワイヤレス クライアントに次の IP アドレスを、使用します。

WLC Management Interface IP address: 172.16.1.30/16
WLC AP Manager Interface IP address: 172.16.1.31/16
LAP IP address: 172.16.1.50/16
Wireless Client C1 IP address: 172.16.1.75/16
Wireless Client C2 IP address: 172.16.1.76/16
Wired Client W1 IP address: 192.168.0.20/16
Wired Client W2 IP address: 192.168.0.30/16
Wired Client W3 IP address: 192.168.0.40/16

/image/gif/paws/81671/multicast-wlc-lap1.gif

設定

このセットアップ用にデバイスを設定するには、次の処理を実行する必要があります。

マルチキャストのためのワイヤレス ネットワークの設定

WLC 上のマルチキャストの設定を行う前に、WLC の基本動作を設定し、WLC に LAP を登録する必要があります。このドキュメントでは、基本動作用に WLC が設定されており、WLC に LAP が登録されていることを前提としています。WLC で LAP との基本動作を初めて設定する場合は、「Lightweight アクセス ポイント(LAP)の無線 LAN コントローラ(WLC)への登録」を参照してください。

注:アドレス範囲 239.0.0.X および 239.128.0.X は使用しないでください。これらの範囲のアドレスは、リンク ローカル MAC アドレスとオーバーラップし、IGMP スヌーピングが有効の場合でもすべてのスイッチ ポートにフラッディングします。マルチキャスト MAC アドレスのオーバーラップの詳細については、『IP マルチキャスト テクノロジーの概要』の「レイヤ 2 マルチキャスト アドレス」を参照してください。

WLC に LAP を登録し終えたら、次のタスクを実行して、このセットアップ用に LAP および WLC を設定します。

  1. クライアント用の WLAN の設定

  2. GUI からのイーサネット マルチキャスト モードの有効化

クライアント用の WLAN の設定

最初の手順では、ワイヤレス クライアントの接続先にでき、ネットワークへのアクセスを得ることができる、WLAN を作成します。WLC 上に WLAN を作成するには、次の手順を実行します。

  1. WLAN を作成するために、コントローラの GUI で [WLANs] をクリックします。

  2. 新規の WLAN を設定するために [New] をクリックします。

    この例では、WLAN に MulticastUsers と名前を付けており、WLAN ID は 1 です。

    /image/gif/paws/81671/multicast-wlc-lap2.gif

  3. [Apply] をクリックします。

  4. [WLAN] > [Edit] ウィンドウで、WLAN 固有のパラメータを定義します。

    1. WLAN に対し、[Interface Name] フィールドから適切なインターフェイスを選択します。

      この例では、管理インターフェイスを WLAN にマッピングします。

    2. 設計要件に応じて、その他のパラメータを選択します。

      この例では、デフォルト値を使用します。

    3. [Apply] をクリックします。

      multicast-wlc-lap3.gif

      注:この例では、ワイヤレス ユーザを認証するためにレイヤ 2 セキュリティ方式は使用しません。したがって、[Layer 2 Security] フィールドでは [None] を選択します。デフォルトでは、レイヤ 2 セキュリティ オプションは 802.1x です。

      注:WLAN(SSID)を管理インターフェイスにマッピングする代わりとして、WLC 上にダイナミック インターフェイスを設定してワイヤレス ユーザをセグメント化し、このダイナミック インターフェイスに WLAN をマッピングすることができます。WLC でダイナミック インターフェイスを設定する方法については、『無線 LAN コントローラでの VLAN の設定例』を参照してください。

CLI を使用し、WLC 上で WLAN を設定するには、次のコマンドを発行します。

  1. 新しい WLAN を作成するために config wlan create <wlan-id> <wlan-name> コマンドを発行します。wlan-id に対して、1 〜 16 の ID を入力します。wlan-name に対して、31 文字以下の英数字で SSID を入力します。

  2. WLAN を有効にするために config wlan enable <wlan-id> コマンドを発行します。

    このドキュメントの例の場合、このコマンドは次のようになります。

    config wlan create 1 MulticastUsers
    config wlan enable 1
    

GUI からのイーサネット マルチキャスト モードの有効化

次の手順では、マルチキャスト用に WLC を設定します。次の手順を実行します。

  1. コントローラの全般 Web ページで、LWAPP トランスポート モードに [Layer 3] が設定されていることを確認します。

    マルチキャスト パフォーマンス機能は、このモードでだけ動作します。

    /image/gif/paws/81671/multicast-wlc-lap4.gif

    注:マルチキャストがマルチキャスト ユニキャストとして有効にされる場合、パケットは各 AP 用に複製されます。これはプロセッサに負荷がかかる可能性があるため、慎重に使用してください。マルチキャスト マルチキャストとして有効にされたマルチキャストでは、AP に対してより従来型のマルチキャストを行うために、ユーザによって割り当てられるマルチキャスト アドレスが使用されます。

  2. [Ethernet Multicast Modem] ドロップダウン メニューから [Multicast] を選択し、マルチキャスト グループ アドレスを入力します。

    この例では、アドレスは 239.255.1.60 です。

    /image/gif/paws/81671/multicast-wlc-lap7.gif

  3. [Apply] をクリックします。

    注:WLC 4100 ではマルチキャスト モードはサポートされていません。マルチキャストは、ユニキャスト モードだけで行われます。つまり、コントローラでは、各 AP 用にマルチキャスト パケットを複製し、このマルチキャスト パケットを各 AP にユニキャストする必要があります。

    CLI からマルチキャストを有効にするには、次のコマンドを発行します。

    1. コマンド ラインから config network multicast global enable コマンドを発行します。

    2. コマンド ラインから config network multicast mode multicast <multicast-group-ip-address> コマンドを発行します。

      このドキュメントの例の場合、このコマンドは次のようになります。

      config network multicast global enable
      config network multicast mode multicast 239.255.1.60
      

管理者がマルチキャストを有効にし(マルチキャスト モードはデフォルトで無効)、LWAPP マルチキャスト グループを設定すると、新しいマルチキャスト アルゴリズムが次のいずれかの方法で動作します。

マルチキャスト グループの送信元が有線 LAN 上にある場合

LWAPP AP では、コントローラへの通常の加入プロセスの間(ブート時)にコントローラ LWAPP マルチキャスト グループ アドレスをダウンロードします。コントローラに加入して設定をダウンロードした AP では、コントローラの LWAPP マルチキャスト グループに加入するために IGMP 要求を発行します。これにより、マルチキャスト対応ルータで、コントローラと AP の間のマルチキャスト ステートに対する通常のセットアップが開始されます。マルチキャスト グループの送信元 IP アドレスは、レイヤ 3 モードに使用される AP マネージャの IP アドレスではなく、コントローラ管理インターフェイスの IP アドレスです。

ファースト ホップ ルータ上の任意のクライアント VLAN からマルチキャスト パケットを受信した場合、コントローラでは、管理インターフェイスを介して、最低の QoS レベルで、LWAPP マルチキャスト グループにパケットを送信します。LWAPP マルチキャスト パケットの QoS ビットには、最低レベルがハードコードされており、ユーザは変更できません。

マルチキャスト対応ネットワークでは、LWAPP マルチキャスト グループに加入している各 AP に LWAPP マルチキャスト パケットが送信されます。マルチキャスト対応ネットワークでは、ルータ内で通常のマルチキャスト メカニズムを使用して、必要に応じて途中でパケットを複製することにより、すべての AP にマルチキャスト パケットを届けます。これにより、コントローラでは、マルチキャスト パケットを複製する必要がなくなります。

AP で、他のマルチキャスト パケットを受信することはありますが、現在加入しているコントローラからのマルチキャスト パケットだけを処理します。その他のコピーはすべて廃棄されます。元のマルチキャスト パケットの送信元である VLAN に複数の WLAN SSID が関連付けられていた場合、AP では、各 WLAN SSID を使用してマルチキャスト パケットを送信します(LWAPP ヘッダー内の WLAN ビットマップに従う)。さらに、WLAN SSID が両方の無線(802.11g と 802.11a)上にある場合、関連付けられたクライアントがあれば、そのクライアントでマルチキャスト トラフィックを要求しなかった場合でも、両方の無線で WLAN SSID 宛てにマルチキャスト パケットが送信されます。

マルチキャスト グループの送信元がワイヤレス クライアント上にある場合

マルチキャスト パケットは、標準のワイヤレス クライアント トラフィック同様に、AP からコントローラへのユニキャスト(LWAPP-encapsulated)です。

コントローラは、マルチキャスト パケットのコピーを 2 つ作成します。コピーの 1 つは、到着した WLAN SSID と関連付けられた VLAN に向けて送信されます。これにより、有線 LAN 上の受信機でマルチキャスト ストリームを受信でき、ルータで新しいマルチキャスト グループについて学習できます。パケットの 2 つ目のコピーは、LWAPP-encapsulated であり、ワイヤレス クライアントでマルチキャスト ストリームを受信できるように、LWAPP マルチキャスト グループに送信されます。

マルチキャストのための有線ネットワークの設定

このセットアップ用に有線ネットワークを設定するには、基本的な接続用のルータを設定し、有線ネットワーク内でマルチキャストを有効にする必要があります。

すでに述べたように、ユニキャスト ルーティング プロトコルには OSPF を使用します。

有線ネットワークでは、任意のマルチキャスト プロトコルを使用できます。このドキュメントでは、PIM-DM をマルチキャスト プロトコルとして使用します。有線ネットワークでマルチキャスト用に使用できるさまざまなプロトコルの詳細については、『Cisco IOS IP マルチキャスト設定ガイド』を参照してください。

ルータ R1、R2、および R3 の設定を、次に示します。

ルータ R1

RouterR1#show run
Building configuration...

Current configuration : 836 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterR1
!
!
ip subnet-zero
!
ip multicast-routing

!--- ネットワーク上の IP マルチキャストを有効にします。

!
!
!
interface Ethernet0
 ip address 192.168.0.1 255.255.0.0
 ip pim dense-mode

!--- インターフェイスで PIM デンス モードのマルチキャスト プロトコルを有効にします。

 ip cgmp

!--- レイヤ 2 スイッチに接続されているインターフェイス上の Cisco Group Management Protocol(CGMP)を 
!--- 有効にします。

!
interface Serial0
 description Connected to RouterR2
 ip address 10.2.3.2 255.255.255.0
 ip pim dense-mode

!--- インターフェイスで PIM デンス モードのマルチキャスト プロトコルを有効にします。

!
interface Serial1
 description Connected to RouterR3
 ip address 10.2.4.1 255.255.255.0
 ip pim dense-mode

!--- インターフェイスで PIM デンス モードのマルチキャスト プロトコルを有効にします。

!
interface Serial2
 no ip address
 shutdown
!
interface Serial3
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router ospf 1

!--- ユニキャスト ルーティング プロトコルとして OSPF を設定します。

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
 !
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

ルータ R2

RouterR2#show run
Building configuration...

Current configuration : 616 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterR2
!
!
ip subnet-zero
!
ip multicast-routing

!--- ネットワーク上の IP マルチキャストを有効にします。

!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 description Connnected to RouterR3
 ip address 10.2.2.2 255.255.255.0
 ip pim dense-mode

!--- インターフェイスで PIM デンス モードのマルチキャスト プロトコルを有効にします。

!
interface Serial1
 description Connected to RouterR1
 ip address 10.2.3.1 255.255.255.0
 ip pim dense-mode

!--- インターフェイスで PIM デンス モードのマルチキャスト プロトコルを有効にします。

!
router ospf 1

!--- ユニキャスト ルーティング プロトコルとして OSPF を設定します。

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
!
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

ルータ R3

RouterR3#show run
Building configuration...

Current configuration : 711 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterR3
!
!
ip subnet-zero
!
ip multicast-routing

!--- ネットワーク上の IP マルチキャストを有効にします。

!
!
!
interface Ethernet0
 ip address 172.16.1.1 255.255.0.0
 ip pim dense-mode

!--- インターフェイスで PIM デンス モードのマルチキャスト プロトコルを有効にします。

 ip cgmp

!--- レイヤ 2 スイッチに接続されているインターフェイス上の Cisco Group Management Protocol(CGMP)を 
!--- 有効にします。

 
!
interface Serial0
 description Connected to RouterR2
 ip address 10.2.2.1 255.255.255.0
 ip pim dense-mode

!--- インターフェイスで PIM デンス モードのマルチキャスト プロトコルを有効にします。

!
interface Serial1
 description Connected to RouterR1
 ip address 10.2.4.2 255.255.255.0
 ip pim dense-mode

!--- インターフェイスで PIM デンス モードのマルチキャスト プロトコルを有効にします。

!
router ospf 1

!--- ユニキャスト ルーティング プロトコルとして OSPF を設定します。

 log-adjacency-changes
 network 172.16.0.0 0.0.255.255 area 0
 network 10.0.0.0 0.255.255.255 area 0
!
ip classless
ip http server
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

レイヤ 2 スイッチの場合は、マルチキャストのために必要な設定はありません。IOS ベースのすべてのレイヤ 2 スイッチで、CGMP はデフォルトで有効に設定されています。したがって、スイッチは、ルータからの CGMP メッセージを自動で処理します。

確認とトラブルシューティング

ここでは、設定が正常に動作していることを確認します。

アウトプット インタープリタ ツール(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。OIT を使用して、show コマンド出力の解析を表示できます。

設定を検証するには、送信元 W1 からマルチキャスト トラフィックを送信し、マルチキャスト トラフィックが有線ネットワークを通過して、有線およびワイヤレスのグループ メンバ、W2、C1、C2 に到達しているかどうかを確認する必要があります。

ネットワークに IP マルチキャストが適切に設定されているかどうかをテストするには、次の作業を実行します。

すべてのマルチキャスト対応ルータが単一マルチキャスト グループのメンバの場合は、そのグループを ping すると、すべてルータが応答します。この動作は、管理ツールおよびデバッグ ツールとして有用です。

ルータをマルチキャスト グループに加入させるもう 1 つの理由として、IGMP クエリに正しく応答できないように Interior Gateway Routing Protocol(IGRP)を設定した別のホストが、ネットワーク上に存在する場合があります。ルータをマルチキャスト グループに加入させた場合、これによってアップストリーム ルータでこのグループのマルチキャスト ルーティング テーブル情報が維持され、このグループのパスがアクティブに保たれます。ルータをマルチキャスト グループの一部として設定するには、インターフェイス コンフィギュレーション モードから次のコマンドを発行します。

ip igmp join-group <group-address> 
Example: Router(config-if)#ip igmp join-group 239.255.1.60

ルータ R3 からの ping 出力を次に示します。

RouterR3#ping 239.255.1.60

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.255.1.60, timeout is 2 seconds:

Reply to request 0 from 10.2.2.2, 40 ms
Reply to request 0 from 10.2.3.1, 84 ms
Reply to request 0 from 10.2.4.1, 44 ms

ホップ障害の場所の確認

この作業は、基本 IP マルチキャスト設定のモニタおよび診断のために実行します。受信側および送信側が予期どおりに動作しない場合に次の手順を実行できます。

/image/gif/paws/81671/multicast-wlc-lap6.gif

設定例に対する show ip igmp membership コマンドと show ip mroute count コマンドの出力を次に示します。これらの出力は、ルータ R3 から取得されています。

RouterR3#sh ip igmp membership
Flags: A  - aggregate, T - tracked
       L  - Local, S - static, V - virtual, R - Reported through v3
       I - v3lite, U - Urd, M - SSM (S,G) channel
       1,2,3 - The version of IGMP the group is in
Channel/Group-Flags:
       / - Filtering entry (Exclude mode (S,G), Include mode (*,G))
Reporter:
       <ip-address> - last reporter if group is not explicitly tracked
       <n>/<m>      - <n> reporter in include mode, <m> reporter in exclude

 Channel/Group                  Reporter        Uptime   Exp.  Flags  Interface
 *,224.0.1.40                   10.2.2.1        1d21h    stop  2LA    Se0
 *,239.255.1.60                    172.16.1.1      1d06h    02:17 1LA    Et0
RouterR3#sh ip mroute count
IP Multicast Statistics
5 routes using 3094 bytes of memory
2 groups, 1.50 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group: 239.255.1.60, Source count: 3, Packets forwarded: 6860, 
Packets received: 7087
  Source: 172.16.1.30/32, Forwarding: 304/1/147/0, Other: 304/0/0
  Source: 172.16.1.75/32, Forwarding: 6329/8/57/3, Other: 6329/0/0
  Source: 192.168.0.20/32, Forwarding: 227/1/69/0, Other: 454/227/0

Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0

これらの出力により、送信元の W1 からのマルチキャスト トラフィック フローがグループ メンバによって受信されることを確認できます。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 81671