音声とユニファイド コミュニケーション : Cisco Unified Communications Manager Express

Cisco CallManager Express(CME)SIP トランキング設定の例

2012 年 9 月 26 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2007 年 11 月 16 日) | フィードバック

Cisco CallManager Express(CME)SIP トランキング設定の例

概要

現在、電気通信業界は長期にわたって確立されたスイッチおよびトランスポート テクノロジーから IP ベースのトランスポートとエッジ デバイスへの移行の途上にあります。IP 通信の進化は、中堅中小企業にとって商業上大きな影響を及ぼしています。中堅中小企業は、IP では音声、ビデオ、データ機能を 3 つの専用ネットワークではなく 1 つのネットワークで使用できることから、IP の利用が非常に効果的であることを理解し始めています。図 1 に、IP トランキングを採用する傾向にある IP テレフォニー システムを示します。

図 1:IP テレフォニー システム

cme-sip-trunking-config1.gif

IP PBX が音声テクノロジーの分野で優位になりつつあり、TDM PBX は 2 つの音声ネットワーク間のクロスオーバーとしての主要な装置ではなくなりつつあります。過去数年間において TDM PBX の利用が減少し、IP PBX の導入が IP LAN および WAN における優れた投資となりつつあります。PSTN に接続するために、PBX では TDM(T1/E1)やアナログ回線のような何らかのトランキングが必要です。IP PBX はこのようなトランキングを使用して PSTN にアクセスできますが、IP 音声トラフィックを従来の PSTN に変換するメディア ゲートウェイが必要であるために、IP ドメインから TDM ドメインへの連続的な変換が行われることがあります。このような連続的な変換により、ゲートウェイのメンテナンス コストが上昇し、遅延が増加し、音声品質が低下します。

このような問題を回避するため、IP PBX はセッションの初期化と管理のためのプロトコルを使用します。このようなプロトコルの中でも最も有名なのが Session Initiation Protocol(SIP)です。このドキュメントでは、SIP トランキングと Cisco CallManager Express(CME)について説明し、着信と発信に SIP トランキングを使用する CME を採用した IP ベースのテレフォニー システムを実装するための設定について説明します。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • CME リリース 4.1 がインストールされている

  • Cisco IOS® ソフトウェア リリース 12.4(11)XJ または IOS 12.4(6th)T のイメージがルータに存在する

  • NM-CUE モジュールが CUE リリース 2.3.4 と共にインストールされている

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco 3825 ルータ(Cisco IOS ソフトウェア リリース 12.4(11)XJ 搭載)

  • Cisco Catalyst 3550 スイッチ(Cisco IOS ソフトウェア リリース 12.4 搭載)

  • Cisco IP 7960 Phone

  • Cisco CallManager Express 4.1

  • Cisco Unity Express 2.3.4

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

SIP プロトコル

SIP は、ASCII ベースのアプリケーション層制御プロトコルであり、複数のエンドポイント間のコールの確立、維持、および終了に使用できます。SIP は音声の他にビデオ セッションとインスタント メッセージに使用できるマルチメディア プロトコルであるため、IP 通信で使用される標準プロトコルとして急速に浮上しました。また、SIP は 1 対 1 のセッションの他にコンファレンス セッションとブロードキャストも処理できます。SIP は、通信のあり方を変化し進化させる大きな可能性を秘めています。このため、シスコはこれまでもそして今後も、IP 通信の標準として SIP とその応用を確立する新たなテクノロジーの開発を先導する存在として、重要な役割を担っていきます。

SIP トランクは電話回線に似ていますが、SIP トランクは PSTN ではなく IP ネットワークを使用する点が異なります。また SIP トランクでは音声とデータを共通のオール IP 接続に収束できます。SIP トランクを使用して IP ネットワークにアクセスするには、顧客側と同様にサービス プロバイダー側でも設定を行う必要があります。顧客は CME を設定する必要があります。CME は、SIP 信号を適切に解釈してトラフィックを適切に受け渡す PBX です。サービス プロバイダーは SIP プロキシ サーバを設定する必要があります。ただし SIP トランクの確立は通常の PSTN トランクよりも複雑です。このことから、顧客は装置ベンダーによって異なる SIP の解釈と実装に対処し、セキュリティを実装し、QoS(Quality of Service)を管理し、ネットワーク アドレス変換(NAT)とファイアウォール トラバーサルを可能にし、サービスのキャリアグレードの信頼性と継続性を維持するうえで課題に直面しています。

中堅中小企業で SIP トランクが明らかに有望である理由を以下に示します。

  • 簡単かつ迅速な導入

  • ネットワーク キャパシティ使用率の改善

  • テレフォニー関連コストの一元化と削減の可能性

  • 経済的なダイヤルイン方式(DID)

  • ビジネス継続性

CME SIP トランク サポート

Cisco CME は、Cisco IOS ソフトウェアに直接統合されている IP テレフォニー ソリューションです。中堅中小企業は、CME により音声、データ、ビデオを 1 つのプラットフォームに導入できます。CME は 1 つのルータで稼働し、PBX 機能を提供するため、IP テレフォニー ネットワークは容易に設定できます。したがって CME を利用することで、中堅中小企業は最小限のコストで 1 つの統合ソリューションを使用して IP テレフォニーとデータ ルーティング機能を実現できます。

SIP トランクの DTMF リレー

CME 3.1 から SIP トランキングがサポートされています。ただし SIP 電話が SCCP 電話を呼び出すかまたはボイスメールにアクセスするときに問題がありました。これは、CME に接続する SCCP 電話では、アウトオブバンド DTMF リレーを使用して VoIP 接続で DTMF(ディジット)を転送する必要があり、また SIP 電話はインバンド転送を使用するという問題です。2 つのデバイス間で DTMF の歪みが発生しました。CME 3.2 がリリースされた時点で、DTMF リレーのサポートが追加されました。SCCP からの DTMF ディジットは RFC2833 または Notify メソッドによってインバンド DTMF リレー メカニズムに変換されます。

現在 CME は、SIP 間コールで次の DTMF インターネットワーキングをサポートしています。

  • Notify <---> Notify(12.4(4)T 以降)

  • RFC2833 <---> Notify(12.4(4)T 以降)

  • Notify <---> RFC2833(12.4(4)T 以降)

  • インバンド G711 <--->(12.4(11)T 以降)(トランスコーダが必要)

現在 CME は SIP/SCCP コールで次の DTMF インターネットワーキングをサポートしています。

  • SCCP アウトバンド:SIP Notify / RFC2833(12.4(4)T 以降)

コーデック サポートおよびトランスコード

SIP トランクのセットアップ時に考慮すべきもう 1 つの重要な点として、サポートされているコーデックがあります。コーデックは、音声周波数の信号のパルス符号変調サンプルを表します。SIP トランクではコーデックG.711 と G.729 がサポートされています。ただし Cisco Unity Express(CUE)や保留音(MOH)などのさまざまな機能では G.711 のみがサポートされています。つまり CUE 機能に対応するように音声ストリームの圧縮および圧縮解除を可能にするトランスコーダがない場合、コーデック G.729 を使用する SIP トランクを使用するボイスコールは CUE にアクセスできません。MOH ではコーデック G.729 を使用して帯域幅が節約されますが、このコーデックでは MOH ストリームに適切な品質が提供されません。これは、G.729 が会話用に最適化されているためです。したがって MOH では G.711 を強制的に使用するように設定する必要があります。

コール自動転送

SIP トランクに着信したコールが自動転送されると(CFNA / CFB / CFA)、デフォルトでは CME は 302「Moved Temporarily」SIP メッセージをサービス プロバイダー(SP)プロキシに送信します。302 メッセージの Contact Header のユーザ部分を変換して、SP プロキシをルーティングできる DID を反映する必要があります。302 メッセージの Contact Header のホスト部分を変更して、sip-ua の host-registrar CLI と CUE に移動する VoIP ダイヤルピアの b2bua CLI を使用する Address of Record(AOR)に反映する必要があります。

一部の SIP プロキシではこれはサポートされていません。サポートされていない場合は以下を追加する必要があります。

Router(config)#voice service voip
Router(conf-voi-serv)#no supplementary-service sip moved-temporarily

図 2 に、302 メッセージが無効な状態での CME システムの動作を示します。

図 2:302 メッセージが無効な状態での Call Forward Busy(CFB)フロー

cme-sip-trunking-config2.gif

この方法では CME でのコール転送のために 302 SIP メッセージをヘアピニングできます。SP プロキシがこのようなコールのルーティング方法を認識していないことがあるため、DID マッピングがない特定の内線がある場合にも上記が必要となります。3xx 応答を無効にした場合は、calling-number initiator を使用して発信元の発信者 ID を維持できます。

コール転送

SCCP 電話または CUE AutoAttendant(AA)への SIP トランクにコールが着信して転送されると、デフォルトでは CME が SIP REFER メッセージを SP プロキシに送信します。ほとんどの SP プロキシ サーバでは REFER メソッドはサポートされていません。CME でコールを強制的にヘアピニングするため、次のように設定する必要があります。

Router(config)#voice service voip
Router(conf-voi-serv)#no supplementary-service sip refer

図 3 は、REFER メソッドが無効な状態での CME システムの動作を示します。

図 3:REFER が無効な状態での転送

cme-sip-trunking-config3.gif

SIP プロキシで REFER がサポートされている場合、Refer-To と Referred-By のユーザ部分を、SP プロキシが認識できる DID に変換する必要があります。Refer-To フィールドと Referred-By フィールドのホスト部分には、SP プロキシがルーティングできる IP アドレスまたは DNS が指定されている必要があります(CME 4.1 ではこれはデフォルトで指定されます)。

コール保留

SCCP 電話が PSTN からのコールを HOLD にすると、CME はメディアをローカルに変更します。SIP メッセージは SIP トランク経由で送信されません。CME 設定に基づき SIP トランク上でユーザに対して保留音が再生されます。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注:この項で使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク ダイアグラム

このドキュメントで使用されているネットワーク構成を次に示します。

cme-sip-trunking-config4.gif

設定

以下の設定要素から、CME と SIP トランクを設定するための手順の概要がわかります。

  • インフラストラクチャ要素:インターフェイス、TFTP および DHCP サービス、NTP など

  • テレフォニー サービス:CME プラットフォームで IOS「PBX」コール制御を有効にします(電話管理要素を含む)

  • Ephone と Ephone-dns:IP 電話とその電話番号を定義します。

  • ダイヤルプラン:ダイヤルピア、内線、音声トランスレーション ルール

  • IOS SIP 設定:SIP、SIP プロキシへの電話登録、トランクを介したコール ルーティングなど

  • ボイスメール サポート:Cisco Unity Express

  • スイッチ Catalyst 設定:IP アドレス、インターフェイスなど

CME システムと SIP トランクを導入するために必要な構成全体を次に示します。

ルータ - CME 設定
!
AUSNML-3825-01#show run
Building configuration...

Current configuration : 8634 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname AUSNML-3825-01
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$vBU1$MCMG1rXM5ejME8Wap6W0H1
!
no aaa new-model
clock timezone central -8
clock summer-time central recurring
ip cef
!

!--- DHCP 設定。

ip dhcp pool Voice
   network 172.22.100.0 255.255.255.0
   option 150 ip 172.22.1.107 
   default-router 172.22.100.1 
!
ip dhcp pool Data
   network 172.22.101.0 255.255.255.0
   option 150 ip 172.22.1.107 
   default-router 172.22.101.1 
!
!
ip domain name cisco.com
ip name-server 205.152.0.20
multilink bundle-name authenticated
!
voice-card 0
 no dspfarm
!
!
!
!

!--- 音声クラスとサービス VoIP 設定 ---

voice service voip 
 allow-connections sip to sip
 no supplementary-service sip moved-temporarily

!---302 送信を無効にする

 no supplementary-service sip refer

!---REFER 送信を無効にする

 sip
  registrar server expires max 3600 min 3600
  localhost dns:domain.test.com 
!
!
voice class codec 1
 codec preference 1 g711ulaw
!
!
!
!
!
!
!
!
!
!
!

!--- 音声トランスレーション ルール ---

voice translation-rule 1
 rule 1 /5123781291/ /601/

!--- AA パイロット「601」のインバウンド ルール

 rule 2 /5123781290/ /600/

!--- ボイスメール パイロット「600」のインバウンド ルール

!
voice translation-rule 2
 rule 1 /^911$/ /911/

!---「911」を許可するアウトバウンド ルール

 rule 2 /^9\(.*\)/ /\1/


!--- PSTN コールから「9」を削除するアウトバウンド ルール

!
voice translation-rule 3
 rule 1 /^.*/ /5123781291/

!--- 発信元番号 CLID を「メイン」番号に変更する
!--- アウトバウンド ルール

!
voice translation-rule 4
 rule 1 /^9(.......)$/ /512\1/

!--- 市内通話に市外局番を追加するアウトバウンド ルール

 rule 2 /600/ /5123788000/

!--- ボイスメール パイロット内線を DID として示すアウトバウンド ルール

 rule 3 /601/ /5123788001/

!--- AA パイロット内線を DID として示すアウトバウンド ルール

 rule 4 /^2(..)$/ /51237812\1/

!--- 転送とコール自動転送をサポートするアウトバウンド ルール

 rule 5 /^9(.*)/ /\1/

!---「9+」転送とコール自動転送から「9」を削除するアウトバウンド ルール

!
!
voice translation-profile CUE_Voicemail/AutoAttendant

!--- CUE のインバウンド ダイヤルピアに適用

 translate called 1
!
voice translation-profile PSTN_CallForwarding

!--- CUE ダイヤルピアに適用

 translate redirect-target 4
 translate redirect-called 4
!
voice translation-profile PSTN_Outgoing

!--- すべてのアウトバウンド ダイヤルピアに適用

 translate calling 3
 translate called 2
 translate redirect-target 4
 translate redirect-called 4
!
!
!
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!

!--- インターネット接続設定 ---

interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 media-type rj45
 no keepalive
!
interface GigabitEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 172.22.1.71 255.255.255.0
!
interface GigabitEthernet0/0.20
 encapsulation dot1Q 20
 ip address 172.22.101.1 255.255.255.0
!
interface GigabitEthernet0/0.100
 encapsulation dot1Q 100
 ip address 172.22.100.1 255.255.255.0
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
 no keepalive
!
interface Service-Engine1/0
 ip unnumbered GigabitEthernet0/0.1
 service-module ip address 172.22.1.253 255.255.255.0
 service-module ip default-gateway 172.22.1.71
!
ip route 0.0.0.0 0.0.0.0 172.22.1.1
ip route 172.22.1.253 255.255.255.255 Service-Engine1/0
!
!
ip http server
no ip http secure-server
!
!
!

!--- TFTP サーバ設定 ---

tftp-server flash:P0030702T023.bin
tftp-server flash:P0030702T023.loads
tftp-server flash:P0030702T023.sb2
tftp-server flash:P0030702T023.sbn
!
control-plane
!
!
!
!
!
!
!

!--- SIP トランク設定 ---

dial-peer voice 1 voip
 description **Incoming Call from SIP Trunk**
 translation-profile incoming CUE_Voicemail/AutoAttendant
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 incoming called-number .%
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 2 voip
 description **Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9........
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 3 voip
 description **Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9[2-9]..[2-9]......
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 4 voip
 description **Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9[0-1][2-9]..[2-9]......
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 5 voip
 description **911 Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 911
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 6 voip
 description **Emergency Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9911
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 7 voip
 description **911/411 Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9[2-9]11
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 8 voip
 description **International Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9011T
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 9 voip
 description **Star Code to SIP Trunk**
 destination-pattern *..
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!

!--- ボイスメール設定 ---

dial-peer voice 10 voip
 description **CUE Voicemail**
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 600
 b2bua

!--- IP アドレスを CUE ではなく SP プロキシに送信するために CME により使用される

 session protocol sipv2
 session target ipv4:172.22.1.155
 dtmf-relay sip-notify

!--- CUE への RFC2833 も使用可能

 codec g711ulaw

!--- CUE はコーデックとして G711ulaw のみサポート

 no vad

!--- VAD が有効な状態では CUE にはブランクまたは低品質のメッセージが残っている可能性がある

!
!
!
dial-peer voice 11 voip
 description **CUE Auto Attendant**
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 601
 b2bua
 session protocol sipv2
 session target ipv4:172.22.1.155
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
!

!--- SIP UA 設定 ---

sip-ua 
 authentication username 5123781000 password 075A701E1D5E415447425B
 no remote-party-id
 retry invite 2
 retry register 10
 retry options 0
 timers connect 100
 registrar dns:domain.test.com expires 3600
 sip-server dns:domain.test.com
  host-registrar
!
!

!--- CME テレフォニー サービス設定 ---

telephony-service
 no auto-reg-ephone
 load 7960-7940 P0030702T023
 max-ephones 168
 max-dn 500
 ip source-address 172.22.1.107 port 2000
 calling-number initiator

!--- コール転送または自動転送時にコールの発信者 ID を維持

 dialplan-pattern 1 51237812.. extension-length 3 extension-pattern 2.. no-reg
 voicemail 600
 max-conferences 12 gain -6
 call-forward pattern .T
 call-forward system redirecting-expanded

!--- コール自動転送でトランスレーション ルール機能を有効にする

 moh music-on-hold.au
 transfer-system full-consult dss
 transfer-pattern 9.T
 secondary-dialtone 9
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!

!--- Ephone および Ephone-dn の設定 ---

ephone-dn  11  dual-line
 number 201 secondary 5123781201 no-reg both

!---「no-reg both」は、SP SIP プロキシにいずれの内線も登録しないことを意味する

 name John Smith
 call-forward busy 600
 call-forward noan 600 timeout 15
!
!
ephone-dn  12  dual-line
 number 202 secondary 5123781202 no-reg both
 name Enrique Zurita
 call-forward busy 600
 call-forward noan 600 timeout 15
!
!
ephone-dn  13
 number 5123788000
 description **DID Number for Voicemail**
!
!
ephone-dn  14
 number 5123788001
 description **DID Number for Auto Attendant*
!
!
ephone-dn  15
 number 8000... no-reg primary
 mwi on
!
!
ephone-dn  16
 number 8001... no-reg primary
 mwi off
!
!
ephone  1
 mac-address 0008.A371.28E9
 type 7960
 button  1:11
!
!
!
ephone  2
 mac-address 0008.A346.5C7F
 type 7960
 button  1:12
!
!
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 password ut69coe
 login
!
scheduler allocate 20000 1000
ntp server 172.22.1.107
!
end

ルータ - CUE 設定
se-172-22-1-253#show run
 
Generating configuration:


clock timezone America/Chicago

hostname se-172-22-1-253

ip domain-name localdomain



groupname Administrators create
groupname Broadcasters create


!--- ユーザ ---

username Enrique create
username John create
username Enrique phonenumberE164 "5123781202"
username John phonenumberE164 "5123781201"
username Enrique phonenumber "202"
username John phonenumber "201"


!--- AutoAttendant ---

ccn application autoattendant
 description "**AutoAttendant**"
 enabled
 maxsessions 4
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "operExtn" "601"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "disconnectAfterMenu" "false"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "false"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "businessSchedule" "systemschedule"
 parameter "MaxRetry" "3"
 end application


!--- MWI ---

ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "CallControlGroupID" "0"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 end application


!--- ボイスメール ---

ccn application voicemail
 description "**Voicemail**"
 enabled
 maxsessions 4
 script "voicebrowser.aef"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 end application


!--- SIP ---

ccn subsystem sip
 gateway address "172.22.100.1"

!--- テレフォニー サービスの「ip source-address」に一致している必要がある

 dtmf-relay sip-notify
 mwi sip outcall

!--- Subscribe / Notify および Unsolicited Notify はテストされていない

 transfer-mode blind bye-also

!--- CUE での REFER メソッドのテストにより特定のコール フローが中断された

 end subsystem


!--- 電話のトリガー ---

ccn trigger sip phonenumber 600
 application "voicemail"
 enabled
 maxsessions 4
 end trigger

ccn trigger sip phonenumber 601
 application "autoattendant"
 enabled
 maxsessions 4
 end trigger

service phone-authentication
 end phone-authentication

service voiceview
 enable
 end voiceview


!--- ボイスメール メールボックス ---

voicemail default mailboxsize 21120
voicemail broadcast recording time 300

voicemail mailbox owner "Enrique" size 300
 description "**Enrique_Mailbox**"
 expiration time 10
 messagesize 120
 end mailbox

voicemail mailbox owner "John" size 300
 description "**John'sMailbox**"
 expiration time 10
 messagesize 120
 end mailbox

end

スイッチの設定

!--- CME/CUE ルータに接続しているインターフェイス ---

interface FastEthernet0/2
 description Trunk to 3825
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
 duplex full
 speed 100


!--- IP Phone に接続しているインターフェイス ---

interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20

!--- データ トラフィック ---

 switchport mode trunk
 switchport voice vlan 100

!--- 音声トラフィック ---

 no ip address
 spanning-tree portfast


interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport mode trunk
 switchport voice vlan 100
 no ip address
 spanning-tree portfast
 

!--- IP アドレス ---

interface Vlan1
 ip address 172.22.1.194 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.22.1.1
ip http server

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

この項では、設定のトラブルシューティングに役立つ情報について説明します。

アウトプット インタープリタ ツール(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。OIT を使用して、show コマンド出力の解析を表示できます。

注:debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

トラブルシューティング:登録

CME での SIP トランクのトラブルシューティングでは、IOS SIP GW と CME のトラブルシューティングに使用するコマンドと同じものを使用します。次に示すコマンドを使用して、DN が登録されているかどうかを確認します。

  • show sip-ua register status:このコマンドを使用して、SIP ゲートウェイが外部のプライマリ SIP レジストラに登録した E.164 番号のステータスを表示します。

  • debug ccsip message:SIP ユーザ エージェント クライアント(UAC)とアクセス サーバ間で交換されるメッセージのトレースなど、すべての SIP SPI メッセージ トレースを有効にします。

トラブルシューティング:コール セットアップ

SIP トランク経由のコールのトラブルシューティングに使用するコマンドは、SIP GW および CME の標準的なトラブルシューティングに使用するコマンドと基本的には同じです。

show コマンド:

  • show ephone registered:ephone の登録を確認します。

  • show voip rtp connection:RTP 名前付きイベント パケットの情報(ローカルおよびリモート エンドポイントの発信者 ID 番号、IP アドレス、ポートなど)を表示します。

  • show sip-ua call:SIP コールのアクティブな UAC とユーザ エージェント サーバ(UAS)に関する情報を表示します。

  • show call active voice brief:進行中のボイスコールまたは FAX 送信に関するアクティブ コール情報を表示します。

debug コマンド:

  • debug ccsip messages:SIP UAC とアクセス サーバ間で交換されるメッセージのトレースなど、すべての SIP SPI メッセージ トレースを有効にします。

  • debug voip ccapi inout:コール制御 API を介して実行パスをトレースします。

  • debug voice translation:トランスレーション ルールの機能を確認します。

  • debug ephone detail mac-address <mac of phone>:Cisco IP Phone の詳細なデバッグを設定します。

  • debug voip rtp session named-events:Real-Time Transport Protocol(RTP)名前付きイベント パケットのデバッグを有効にします。

  • debug sccp message:SCCP メッセージのシーケンスを表示します。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 91535