Multiple Vulnerabilities in Cisco TelePresence Immersive Endpoint Devices

2012 年 9 月 25 日 - ライター翻訳版
その他のバージョン: PDFpdf | 英語版 (2012 年 9 月 24 日) | フィードバック

Advisory ID: cisco-sa-20120711-cts

http://www.cisco.com/cisco/web/support/JP/111/1115/1115546_cisco-sa-20120711-cts-j.html

日本語による情報は、英語による原文の非公式な翻訳であり、英語原文との間で内容の齟齬がある場合には、英語原文が優先します。

Revision 1.1

Last Updated 2012 September 24 14:56 UTC (GMT)

For Public Release 2012 July 11 16:00 UTC (GMT)


要約

Cisco TelePresence エンドポイント デバイスには、次の脆弱性が含まれます。

  • Cisco TelePresence API におけるリモートからのコマンド実行の脆弱性
  • Cisco TelePresence におけるリモートからのコマンド実行の脆弱性
  • Cisco TelePresence における Cisco Discovery Protocol に起因するリモート実行の脆弱性
API におけるリモートからのコマンド実行の脆弱性の不正利用に成功した場合、認証されていない近接した攻撃者は、API リクエストにコマンドを注入できる可能性があります。注入されたコマンドは基盤のオペレーティング システムによって特権権限で実行されます。

リモートからのコマンド実行の脆弱性の不正利用に成功した場合、認証されたリモートの攻撃者は、管理用 Web インターフェイスへのリクエストにコマンドを注入できる可能性があります。注入されたコマンドは基盤のオペレーティング システムによって特権権限で実行されます。


Cisco TelePresence における Cisco Discovery Protocol に起因するリモート実行の脆弱性の不正利用に成功した場合、認証されていない近接した攻撃者が特権権限を使用して任意のコードを実行できる可能性があります。

シスコはこれらの脆弱性に対応するための無償ソフトウェア アップデートを提供しています。
これらの脆弱性を軽減する回避策はありません。

このアドバイザリは、次のリンク先で確認できます。

http://www.cisco.com/cisco/web/support/JP/111/1115/1115546_cisco-sa-20120711-cts-j.html

該当製品

脆弱性が存在する製品

Cisco TelePresence Manager、Cisco TelePresence Recording Server、Cisco TelePresence Multipoint Switch、Cisco TelePresence Immersive Endpoint System は、このセキュリティ アドバイザリに記載されている脆弱性の影響を受ける可能性があります。次の表に、各脆弱性に関する具体的な情報を記載します。

Cisco TelePresence API におけるリモートからのコマンド実行の脆弱性

Product Affected
Cisco TelePresence Manager
NO
Cisco TelePresence Recording Server NO
Cisco TelePresence Multipoint Switch NO
Cisco TelePresence Immersive Endpoint System YES

Cisco TelePresence におけるリモートからのコマンド実行の脆弱性


Product Affected
Cisco TelePresence Manager NO
Cisco TelePresence Recording Server NO
Cisco TelePresence Multipoint Switch NO
Cisco TelePresence Immersive Endpoint System YES

Cisco TelePresence における Cisco Discovery Protocol に起因するリモート実行の脆弱性 

Product Affected
Cisco TelePresence Manager YES
Cisco TelePresence Recording Server YES
Cisco TelePresence Multipoint Switch YES
Cisco TelePresence Immersive Endpoint System YES


脆弱性が存在する製品に関する詳細情報

このセキュリティ アドバイザリでは、Cisco TelePresence エンドポイント デバイスの脆弱性について説明します。脆弱性が存在する他の製品に対してこれらの脆弱性が与える影響については、次の表に記載されたリンク先にある各製品のセキュリティ アドバイザリを参照してください。 

Product Security Advisory Publication Link
Cisco TelePresence Multipoint Switch http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20120711-ctms
Cisco TelePresence Manager http://www.cisco.com/cisco/web/support/JP/111/1115/1115546_cisco-sa-20120711-cts-j.htmlman
Cisco TelePresence Recording Server http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20120711-ctrs

ソフトウェア バージョンを知る方法

該当するバージョンのソフトウェアが稼働している Cisco TelePresence Recording Server デバイスには脆弱性が存在します。

Cisco TelePresence Endpoint System で稼働しているソフトウェア バージョンを確認するには、デバイスへの SSH 接続を確立し、show version active および show version inactive コマンドを実行します。次のような結果が出力されます。

admin: show version active
Active Master Version: 1.7.0.0-471

Active Version Installed Software Options: 
No Installed Software Options Found.

admin: show version inactive
Inactive Master Version: 1.6.0.0-342

Inactive Version Installed Software Options: 
No Installed Software Options Found.

上記の例では、デバイスにはバージョン 1.6.0 および 1.7.0 がロードされており、現在アクティブなバージョンは 1.7.0 です。デバイスは、アクティブとなっているソフトウェア バージョンに存在する脆弱性のみの影響を受けます。


脆弱性が存在しない製品

他のシスコ製品においてこのアドバイザリの影響を受けるものは、現在確認されていません。

詳細

Cisco TelePresence エンドポイント デバイスは、イマーシブなリモート プレゼンス体験を提供します。


このセクションでは、Cisco TelePresence Immersive Endpoint デバイスに影響を与える各脆弱性に関する追加情報を提供します。

Cisco TelePresence API におけるリモートからのコマンド実行の脆弱性

リモートからのコマンド実行の脆弱性は、Immersive Endpoint デバイス上でホストされる Cisco TelePresence API の 1 つに存在します。この問題が不正利用されると、認証されていない近接した攻撃者が特権権限を使用して、基盤のオペレーティング システム上で任意のコマンドを実行できる可能性があります。

攻撃者は、物理または論理レイヤ 3 近接コンテキストから不正なリクエストを TCP ポート 61460 に送信できる必要があります。この脆弱性を不正利用するには、3 ウェイ TCP ハンドシェイクが必要です。

この脆弱性は、Cisco Bug ID CSCtz38382登録ユーザのみ)として文書化され、Common Vulnerabilities and Exposures(CVE)ID として CVE-2012-3074 が割り当てられています。

Cisco TelePresence におけるリモートからのコマンド実行の脆弱性

リモートからのコマンド実行の脆弱性は、Immersive Endpoint デバイス上でホストされる Cisco TelePresence 管理用 Web インターフェイスに存在します。この問題が不正利用されると、認証されたリモートの攻撃者が特権権限を使用して、基盤のオペレーティング システム上で任意のコマンドを実行できる可能性があります。

攻撃者は、不正なリクエストを TCP ポート 443 に送信できる必要があります。この脆弱性を不正利用するには、3 ウェイ TCP ハンドシェイクが必要です。

この脆弱性は、Cisco Bug ID CSCtn99724登録ユーザのみ)として文書化され、Common Vulnerabilities and Exposures(CVE)ID として CVE-2012-3075 が割り当てられています。


Cisco TelePresence における Cisco Discovery Protocol に起因するリモート実行の脆弱性 

Cisco Discovery Protocol コンポーネントの実装に存在する、リモートからのコード実行の脆弱性により、認証されていない近接した攻撃者が特権権限を使用して任意のコードを実行できる可能性があります。この脆弱性は、不正な Cisco Discovery Protocol パケットの不適切な処理によるものです。攻撃者は不正な Cisco Discovery Protocol パケットを該当するデバイスに渡すことにより、この脆弱性を悪用する可能性があります。この脆弱性の不正利用に成功した場合、攻撃者は特権権限を使用して任意のコードを実行できる可能性があります。

Cisco Discovery Protocol はデータリンク層(レイヤ 2)で動作するため、攻撃者は該当するデバイスにイーサネット フレームを直接送る方法を必要とします。これは、該当のデバイスがブリッジ型ネットワークに組み込まれている場合や、ネットワーク ハブのようなパーティション機能のないデバイスに接続されている場合に可能になります。


この脆弱性は、Cisco Bug ID
CSCtz40953登録ユーザのみ)として文書化され、Common Vulnerabilities and Exposures(CVE)ID として CVE-2012-2486 が割り当てられています。

脆弱性スコア詳細

シスコはこのアドバイザリでの脆弱性に対して Common Vulnerability Scoring System(CVSS)に基づいたスコアを提供しています。このセキュリティ アドバイザリでの CVSS スコアは CVSS バージョン 2.0 に基づいています。

CVSS は、脆弱性の重要度を示唆するもので、緊急性および対応の優先度を決定する組織の手助けとなる標準ベースの評価法です。

シスコは基本評価スコア(Base Score)および現状評価スコア(Temporal Score)を提供しています。お客様はこれらを用いて環境評価スコア(Environmental Score)を算出し、自身のネットワークにおける脆弱性の影響度を導き出すことができます。

シスコは次のリンクで CVSS に関する追加情報を提供しています。

http://www.cisco.com/web/about/security/intelligence/cvss-qandas.html

また、シスコは個々のネットワークにおける環境影響度を算出する CVSS 計算ツールを次のリンクで提供しています。

http://tools.cisco.com/security/center/cvssCalculator.x/

Cisco TelePresence API Remote Command Execution Vulnerability - CSCtz38382

Calculate the environmental score of CSCtz38382

CVSS Base Score - 8.3

Access Vector

Access Complexity

Authentication

Confidentiality Impact

Integrity Impact

Availability Impact

Adjacent Network

Low

None

Complete

Complete

Complete

CVSS Temporal Score - 6.9

Exploitability

Remediation Level

Report Confidence

Functional

Official-Fix

Confirmed



Cisco TelePresence Remote Command Execution Vulnerability- CSCtn99724

Calculate the environmental score of CSCtn99724

CVSS Base Score - 9.0

Access Vector

Access Complexity

Authentication

Confidentiality Impact

Integrity Impact

Availability Impact

Network

Low

Single

Complete

Complete

Complete

CVSS Temporal Score - 7.4

Exploitability

Remediation Level

Report Confidence

Functional

Official-Fix

Confirmed




Cisco TelePresence Cisco Discovery Protocol Remote Code Execution Vulnerability - CSCtz40941

Calculate the environmental score of CSCtz40941

CVSS Base Score - 8.3

Access Vector

Access Complexity

Authentication

Confidentiality Impact

Integrity Impact

Availability Impact

Adjacent Network

Low

None

Complete

Complete

Complete

CVSS Temporal Score - 6.9

Exploitability

Remediation Level

Report Confidence

Functional

Official-Fix

Confirmed


影響

これらの脆弱性の不正利用に成功すると、攻撃者は特権権限を使用して、該当するデバイス上で任意のコマンドまたはコードを実行することが可能になる場合があります。この操作によって、攻撃者は該当するデバイスを完全に改ざんすることができる可能性があります。

ソフトウェア バージョンおよび修正

このセクションでは、Cisco TelePresence Immersive Endpoint System に影響を与える各脆弱性について、該当するリリースおよび修正に関する詳細情報を提供します。

Cisco TelePresence API におけるリモートからのコマンド実行の脆弱性

Version First Fixed Release
Prior to 1.6
  1.8.4 or 1.9.1
1.6
  1.8.4 or 1.9.1
1.7
  1.8.4 or 1.9.1
1.8
  1.8.4 or 1.9.1


Cisco TelePresence におけるリモートからのコマンド実行の脆弱性

Version First Fixed Release
Prior to 1.6
 1.7.4
1.6
 1.7.4
1.7  1.7.4
1.7.4 and later
Not affected
1.8
Not affected


Cisco TelePresence における Cisco Discovery Protocol に起因するリモート実行の脆弱性

Version First Fixed Release
Prior to 1.6
 1.8.4 or 1.9.1
1.6
 1.8.4 or 1.9.1
1.7
 1.8.4 or 1.9.1
1.8
 1.8.4 or 1.9.1

推奨リリース

次の表に、このアドバイザリで説明のあるすべての脆弱性への修正が含まれたリリースに関する情報を記載します。

Version Release
Prior to 1.6
Upgrade to 1.9.1 or later
1.6
Upgrade to 1.9.1 or later
1.7
Upgrade to 1.9.1 or later
1.8
Upgrade to 1.8.4 or upgrade to 1.9.1 or later

ソフトウェアのアップグレードを検討する場合は、http://www.cisco.com/go/psirt/ の Cisco Security Advisories and Responses アーカイブや、本アドバイザリ以降に公開のアドバイザリを参照して、起こりうる障害と完全なアップグレード ソリューションを判断してください。

いずれの場合も、アップグレードするデバイスに十分なメモリがあること、および現在のハードウェアとソフトウェアの構成が新しいリリースで引き続き適切にサポートされていることの確認を十分に行ってください。情報が不明確な場合は、Cisco Technical Assistance Center(TAC)もしくは契約しているメンテナンス プロバイダーにお問い合わせください。


回避策

これらの脆弱性を軽減する回避策はありません。

修正済みソフトウェアの入手

シスコはこのアドバイザリに記載された脆弱性に対処する無償のソフトウェア アップデートを提供しています。ソフトウェアの導入を行う前に、お客様のメンテナンス プロバイダーにご相談いただくか、ソフトウェアのフィーチャ セットの互換性およびお客様のネットワーク環境に特有の問題に関してご確認ください。

お客様がインストールしたりサポートを受けたりできるのは、ご購入いただいたフィーチャ セットに対してのみとなります。そのようなソフトウェア アップグレードをインストール、ダウンロード、アクセスまたはその他の方法で使用した場合、お客様は http://www.cisco.com/en/US/docs/general/warranty/English/EU1KEN_.html に記載のシスコのソフトウェア ライセンスの条項に従うことに同意したことになります。

サービス契約をご利用のお客様

サービス契約をご利用のお客様は、通常のアップデート チャネルからアップグレード ソフトウェアを入手してください。ほとんどのお客様は、Cisco.com の Software Navigator からアップグレードを入手することができます。http://www.cisco.com/cisco/software/navigator.html

サードパーティのサポート会社をご利用のお客様

シスコ パートナー、正規販売代理店、サービス プロバイダーなど、サードパーティのサポート会社と以前に契約していたか、または現在契約しており、その会社からシスコ製品の提供または保守を受けているお客様は、該当するサポート会社に連絡し、適切な処置について支援を受けてください。

回避策の効果は、使用製品、ネットワーク トポロジー、トラフィックの性質や組織の目的などのお客様の状況に依存します。影響製品およびリリースが多種多様であるため、回避策を実際に展開する前に、対象とするネットワークで適用する回避策または修正が最適であるか、お客様のサービス プロバイダーやサポート会社にご相談ください。

サービス契約をご利用でないお客様

シスコから直接購入したがシスコのサービス契約をご利用いただいていない場合、また、サードパーティ ベンダーから購入したが修正済みソフトウェアを購入先から入手できない場合は、Cisco Technical Assistance Center(TAC)に連絡してアップグレードを入手してください。

  • +1 800 553 2447(北米内からのフリー ダイヤル)
  • +1 408 526 7209(北米以外からの有料通話)
  • 電子メール:tac@cisco.com

無償アップグレードの対象であることをご証明いただくために、製品のシリアル番号と、このアドバイザリの URL をご用意ください。サービス契約をご利用でないお客様は TAC を通して無償アップグレードをお求めください。

さまざまな言語向けの各地の電話番号、説明、電子メール アドレスなどの、この他の TAC の連絡先情報については、シスコ ワールドワイドお問い合わせ先を参照してください。http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html

不正利用事例と公式発表

Cisco Product Security Incident Response Team(PSIRT)では、本アドバイザリに記載されている脆弱性の不正利用事例とその公表は確認しておりません。

これらの脆弱性は、Cisco TelePresence エンドポイントの社内セキュリティ監査中に発見されました。

この通知のステータス:FINAL

本アドバイザリは無保証のものとしてご提供しており、いかなる種類の保証を示唆するものでもありません。本アドバイザリの情報およびリンクの使用に関する責任の一切はそれらの使用者にあるものとします。またシスコシステムズはいつでも本ドキュメントの変更や更新を実施する権利を有します。

後述する情報配信の URL を省略し、本アドバイザリの記述内容に関して単独の転載や意訳を実施した場合には、事実誤認ないし重要な情報の欠落を含む統制不可能な情報の伝搬が行われる可能性があります。


情報配信

このアドバイザリは次のリンクにある Cisco Security Intelligence Operations に掲載されます。

http://www.cisco.com/cisco/web/support/JP/111/1115/1115546_cisco-sa-20120711-cts-j.html

また、このアドバイザリのテキスト版が Cisco PSIRT PGP キーによるクリア署名つきで次の電子メールで配信されています。

  • cust-security-announce@cisco.com
  • first-bulletins@lists.first.org
  • bugtraq@securityfocus.com
  • vulnwatch@vulnwatch.org
  • cisco@spot.colorado.edu
  • cisco-nsp@puck.nether.net
  • full-disclosure@lists.grok.org.uk

このアドバイザリに関する今後の更新があれば、Cisco.com に掲載されますが、メーリング リストで配信されるとは限りません。このアドバイザリの URL で更新をご確認いただくことができます。


更新履歴

Revision 1.1 2012-September-24 Cisco has released software version 1.8.4, which remediates the following CVEs in the 1.8.x Train:CVE-2012-2486, CVE-2012-3074, and CVE-2012-3075
Revision 1.0 2012-July-11 Initial public release.

シスコ セキュリティ手順

シスコ製品におけるセキュリティの脆弱性の報告、セキュリティ事故に関する支援、およびシスコからセキュリティ情報を入手するための登録方法について詳しく知るには、Cisco.com の http://www.cisco.com/en/US/products/products_security_vulnerability_policy.html にアクセスしてください。この Web ページには、シスコのセキュリティ アドバイザリに関してメディアが問い合わせる際の指示が掲載されています。すべてのシスコ セキュリティ アドバイザリは、http://www.cisco.com/go/psirt/ で確認することができます。