スイッチ : Cisco Catalyst 6500 シリーズ スイッチ

VPLS を使用した Catalyst 6500 シリーズ スイッチの設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、企業が複数のサイトからサービス プロバイダーを経由してイーサネット ベース LAN をリンクできる Cisco Catalyst 6500 シリーズ スイッチの仮想プライベート LAN サービス(VPLS)の設定例を紹介します。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • Cisco Catalyst 6500 シリーズ スイッチでの設定に関する基本的な知識

  • VPLS の基本的な知識があること

使用するコンポーネント

このドキュメントの情報は、Cisco Catalyst 6500 シリーズ スイッチに基づくものです。

VPLS Cisco IOS との SIP-600/SUP3B またはそれ以降の Catalyst 6500 スイッチでサポートされますか。 ソフトウェア リリース 12.2(33)SXH または それ 以降。 スイッチでは、VPLS 機能を実行するために、SIP カードを使用する必要があります。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

企業側から見た場合、VPLS は、サービス プロバイダーのパブリック ネットワークを、複数のサイトの CE デバイスを接続する 1 つの巨大なイーサネット LAN として使用します。これは、IP/MPLS ネットワーク上で管理される論理ブリッジに接続されているように見えます。

VPLS によって LAN/WAN の境界が単純化され、1 つのイーサネット インターフェイスとして、場所に関係なく同じ LAN 上にあるように見えます。

まず、VPLS を設定するため、各 Catalyst 6500 スイッチ上で仮想転送インスタンス(VFI)を作成します。 VFI によって VPLS ドメインの VPN ID、そのドメインの他のデバイスのアドレス、トンネルのシグナリングのタイプ、各ピア デバイスのカプセル化のメカニズムが指定されます。 デバイスの相互接続によって形成される VFI のセットは VPLS インスタンスと呼ばれ、パケット スイッチド ネットワーク上で論理的なブリッジを形成します。

パケット転送の判断は、レイヤ 2 の仮想転送インスタンス(VFI)を探すときに行われます。 プロバイダー コアでのパケット ループの問題を回避するために、デバイスは、エミュレート VC に「スプリット ホライズン」の原則を適用します。

VPLS を設定する前に、コアで MPLS を設定し、デバイス間にラベル スイッチド パス(LSP)が存在するようにします。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-series-switches/113563-vpls-6500-config-01.gif

設定

このドキュメントでは、次の設定を使用します。

Catalyst 6500 スイッチ 1
switch6500_1#configure terminal


!--- Enable the Layer 2 VFI manual configuration mode.

switch6500_1(config)#l2 vfi VPLS-A manual

!--- Configure a VPN ID for a VPLS domain.

switch6500_1(config-vfi)#vpn id 500

!--- Specify the remote peering router ID 
!--- and the tunnel encapsulation type or the pseudo-wire 
!--- property to be used to set up the emulated VC.

switch6500_1(config-vfi)#neighbor 10.7.1.3 encapsulation mpls
switch6500_1(config-vfi)#exit

switch6500_1(config)#interface Loopback 0
switch6500_1(config-if)#ip address 10.7.1.2 255.255.255.255

switch6500_1(config)#interface GigabitEthernet 6/3
switch6500_1(config-if)#switchport

!--- Set the interface as an 802.1Q tunnel port. 

switch6500_1(config-if)#switchport mode dot1qtunnel

!--- Set the VLAN when the interface is in Access mode.

switch6500_1(config-if)#switchport access vlan 500


!--- Create a dynamic switched virtual interface (SVI).

switch6500_1(config)#interface Vlan 500

!--- Disable IP processing.

switch6500_1(config-if)#no ip address

!--- Specify the Layer 2 VFI that you are binding to the VLAN port.

switch6500_1(config-if)#xconnect vfi VPLS-A
switch6500_1(config-if)#exit

switch6500_1(config)#vlan 500
switch6500_1(config-vlan)#state active
switch6500_1(config-vlan)#exit


!--- Save the configurations in the device.

switch6500_1(config)#copy running-config startup-config
switch6500_1(config)#exit

Catalyst 6500 スイッチ 2
switch6500_2#configure terminal

switch6500_2(config)#l2 vfi VPLS-B manual
switch6500_2(config-vfi)#vpn id 500
switch6500_2(config-vfi)#neighbor 10.7.1.2 encapsulation mpls
switch6500_2(config-vfi)#exit

switch6500_2(config)#interface Loopback 0
switch6500_2(config-if)#ip address 10.7.1.3 255.255.255.255

switch6500_2(config)#interface GigabitEthernet 3/3
switch6500_2(config-if)#switchport
switch6500_2(config-if)#switchport mode dot1qtunnel
switch6500_2(config-if)#switchport access vlan 500

switch6500_2(config)#interface Vlan 500
switch6500_2(config-if)#no ip address
switch6500_2(config-if)#xconnect vfi VPLS-B
switch6500_2(config-if)#exit

switch6500_2(config)#interface vlan 500
switch6500_2(config-vlan)#state active
switch6500_2(config-vlan)#exit


!--- Save the configurations in the device.

switch6500_2(config)#copy running-config startup-config
switch6500_2(config)#exit

確認

ここでは、設定が正常に動作していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 113563