IP : IP バージョン 6(IPv6)

IPv6 パス スルー設定例(ルーテッド インターフェイスの場合)

2015 年 10 月 14 日 - 日本オリジナル版
その他のバージョン: PDFpdf | フィードバック

2015 年 10 月 「必要なハードウェア/ソフトウェア要件」と「システムの前提条件」を更新

概要

本ドキュメントでは、GW ルータで IPv6 パス スルー機能を使用し、LAN 側の端末が WAN 側からの RA (Router Advertisement) を受信することによって IPv6 プレフィックスを自動取得する方法を紹介します。

ネットワーク構成図

システムの前提条件

オフィスや家庭において、GW ルータが ISP(インターネット サービス プロバイダー)と PPPoE 方式でインターネット接続をして、 回線提供者が網内で IPv6 サービスを提供している環境を前提とします。また、この IPv6 パス スルーの設定は、IPv4/PPPoE が既に設定されている状態でおこないます。

想定される環境

ルータを ONU や ADSL モデムなどに接続し、PPPoE にてサービス プロバイダーに接続します。一つの IP アドレスを動的に払い出す端末型払い出しとし、LAN 側セグメントは NAT によりインターネットに接続します。
この接続環境において、さらに以下のような要求の端末が同一セグメントにある場合を想定します。

  • 回線提供者の閉域 IPv6 サービスを受ける
  • RA にて IPv6 端末に直接アドレスを払い出す必要がある

必要なハードウェア/ソフトウェア要件

ISR G2 はすべてオンボードにて、2FE(または GE)を具備します。ISR G2 シリーズにて本構成が実現可能なハードウェア/ソフトウェアの組み合わせは以下になります。

プラットホーム 必要なハードウェア*1 IOS
841M N/A 15.5(3)M 以降
1900 シリーズ
(1921/1941)
EHWIC-D-8ESG
EHWIC-4ESG
HWIC-D-9ESW
HWIC-4ESW
などの EHWIC/HWIC Ethernet モジュール
15.2(3)T 以降
2900 シリーズ
(2901/2911/2921/2951)
上記 EHWIC/HWIC
および
SM-D-ES3G-48
SM-ES3G-24
などのサービス モジュール
3900 シリーズ
(3925/3925E/3945/3945E)

*1 詳細は「Interfaces and Modules」を参照してください。
本構成では ISR892J IOS15.2(3)T を使用しています。

また 15.2(3)T 以前の設定方法は以下を参考してください。

フレッツ ネクスト接続設定例(ルーテッド ポートの場合) - ルータ : Cisco 800 シリーズ ルータ

フレッツ ネクスト接続設定例(SVI の場合) - ルータ : Cisco 800 シリーズ ルータ

15.2(3)T 以降より BVI インターフェイスでの PPPoE が可能になり、IPv6 パススルーの設定がより簡潔になりました。

サンプル コンフィグレーション

hostname 892j-PPPoE-BVI
!
ip cef
no ipv6 cef
!
bridge irb
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface FastEthernet0
no ip address
!
#(Fa0-7 は同一設定のため、以下省略)
!
interface FastEthernet8
no ip address
duplex auto
speed auto
bridge-group 1
bridge-group 1 input-type-list 200
!
interface GigabitEthernet0
no ip address
duplex auto
speed auto
bridge-group 1
!
interface Vlan1
no ip address
bridge-group 1
!
interface Dialer1
ip address negotiated
ip mtu 1454
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname cisco
ppp chap password 0 cisco@example.com
!
interface BVI1
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1414
pppoe-client dial-pool-number 1
!
no ip http server
no ip http secure-server
ip forward-protocol nd
!
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 200 permit 0x86DD 0x0000
!
dialer-list 1 protocol ip permit

control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
transport input all
!

キーとなるコマンドの解説

"bridge irb"

<コマンド種別>

グローバル コンフィグレーション コマンド

<コマンドの機能>

IRB をイネーブルにします。トラフィックのブリッジングを有効にします。

"bridge group 1"

<コマンド種別>

インターフェイス コンフィグレーション コマンド

<コマンドの機能>

インターフェイスにブリッジ グループ番号 1 をアサインします。

" bridge-group 1 input-type-list 200"

<コマンド種別>

インターフェイス コンフィグレーション コマンド

<コマンドの機能>

"access-list 200"で定義されたトラフィック パターンを本インターフェイスに適用します。

"access-list 200 permit 0x86DD 0x0000"

<コマンド種別>

グローバル コンフィグレーション コマンド

<コマンドの機能>

イーサ タイプ 0x86DD (IPv6) のトラフィックがマッチするアクセス リストです。

"interface BVI1"

<コマンド種別>

グローバル コンフィグレーション コマンド

<コマンドの機能>

ブリッジ グループ番号 1に対応する BVI を設定します。各ブリッジ グループに対応させることができる BVI は、1 つだけです。

"pppoe-client dial-pool-number 1"

<コマンド種別>

インターフェイス コンフィグレーション コマンド

<コマンドの機能>

このコマンドにより、論理インターフェイス Dialer1 を使って、PPPoE セッションを確立するように設定します。
Dialer1 インターフェイスに設定されている"dialer pool 1"と"pppoe-client dial-pool-number 1"コマンドの番号 1 が対応します。

"interface Dialer1"

<コマンド種別>

グローバル コンフィグレーション コマンド

<コマンドの機能>

Dialer 1 論理インターフェイスを定義します。PPPoE セッションは、この Dialer インターフェイスにより終端されます。また、PPPoE セッションはダイアラの動作により確立要求されます。

"ip mtu 1454"

<コマンド種別>

インターフェイス コンフィグレーション コマンド

<コマンドの機能>

パケットの最大送信サイズを定義します。この事例では、Dialer1 インターフェイスから送信されるパケットの最大サイズは 1454 バイトに調整されます。

"encapsulation ppp"

<コマンド種別>

インターフェイス コンフィグレーション コマンド

<コマンドの機能>

このインターフェイスは PPP カプセル化によりパケットの入出力をします。

"dialer pool 1"

<コマンド種別>

インターフェイス コンフィグレーション コマンド

<コマンドの機能>

Dialer1 論理インターフェイスと実際に PPPoE 接続する物理インターフェイスが紐付けられます。
"dialer pool 1"と FastEthernet0 インターフェイスの"pppoe-client dial-pool-number 1"コマンドの番号 1 が対応します。

"ip address negotiated"

<コマンド種別>

インターフェイス コンフィグレーション コマンド

<コマンドの機能>

PPP セッション確立時に IP アドレスがダイナミックにインターフェイスに対してアサインされます。

"dialer-group 1"

<コマンド種別>

インターフェイス コンフィグレーション コマンド

<コマンドの機能>

"dialer-list 1"で定義されたトラフィックパターンを本 Dialer インターフェイスに適用します。
このトラフィックがダイアル対象として認識され本 Dialer インターフェイスから出て行くときに、PPPoE セッションの確立要求を起動します。

"ppp authentication chap callin"

<コマンド種別>

インターフェイス コンフィグレーション コマンド

<コマンドの機能>

ISP にアクセスする際の認証方法を CHAP に指定します。"callin"パラメータにより、認証は ISP によるユーザー認証の片方向のみ行われます。

"ppp chap hostname cisco@example.com "

<コマンド種別>

インターフェイス コンフィグレーション コマンド

<コマンドの機能>

PPP の CHAP または PAP 認証(本事例では CHAP)を行なう際に必要なユーザー名を設定します。
このユーザー名の @ 以下 (ispid) により、接続先 ISP を判別します。

"ppp chap password 0 cisco"

<コマンド種別>

インターフェイス コンフィグレーション コマンド

<コマンドの機能>

PPP の CHAP または PAP 認証(本事例では CHAP)を行なう際に必要なパスワードを設定します。本事例では、"cisco"というパスワードを設定しています。

"ip tcp adjust-mss 1414"

<コマンド種別>

インターフェイス コンフィグレーション コマンド

<コマンドの機能>

このインターフェイスを通過する TCP セッションは、TCP の最大セグメント サイズが 1414 バイトでネゴシエーションがおこなわれるようになります。指定できる最大セグメントサイズは、500 バイトから 1460 バイトの間になります。

"ip route 0.0.0.0 0.0.0.0 Dialer1"

<コマンド種別>

グローバル コンフィグレーション コマンド

<コマンドの機能>

スタティック デフォルト ルートとして Dialer1 が指定されます

"dialer-list 1 protocol ip permit"

<コマンド種別>

グローバル コンフィグレーション コマンド

<コマンドの機能>

dialer-list に適用させるトラフィックを指定します。

"bridge 1 protocol ieee"

<コマンド種別>

グローバル コンフィグレーション コマンド

<コマンドの機能>

ブリッジグループ番号 1 をアサインし、IEEE 802.1D スパニング ツリー プロトコルを適用します。

"bridge 1 route ip"

<コマンド種別>

グローバル コンフィグレーション コマンド

<コマンドの機能>

IP をルーティング対象にします。

設定に際しての注意点

PPPoE 使用時の MTU サイズは、通常時よりも小さくなります。(フレッツでは、1454 バイトを推奨)そのため、MTU サイズを変更すると共に、TCP の MSS(最大セグメント サイズ)の値をそれに合わせて調整することが必要となる点に注意してください。
PPP MTU/MRU は PPP セッション確立においての必須項目ではありませんが、LCP ネゴシエーションで通知される MRU に合致していないと受け入れる事ができないサービスが存在します。Dialer interface にて以下のコマンドを追記し、通知される MRU に合わす事が可能になります。

ppp mtu adaptive

実際に導入し、運用される際には障害解析などの観点により以下のようなコマンドも追加する事を推奨します。

service timestamps debug datetime localtime msec
service timestamps log datetime localtime msec
clock timezone JST 9
!
logging buffered 512000 debugging
!
clock calendar-valid

補足;イメージ図

本設定では IPv6 (0x86DD) のパケット(ソース MAC アドレス AAA, ディスティネーション MAC アドレス BBB)は入力インターフェイス (FE8) より、同一の Bridge-group をもつインターフェイス (interface giga0) にブリッジされます。


     


本設定では FE8 に IPv6 専用端末を接続することを想定しているため、IPv6 以外のイーサ タイプを持つパケットはフィルタされます。



また VLAN1 (FE0-7) に入力された IPv4 パケット (0x0800) や ARP パケット (0x0806) は”bridge 1 route ip”があるため、BVI インターフェイスへルーティング処理されます。




BVI インターフェイスで Dialer インターフェイスでとルーティングされるケースではアドレス変換 (NAT) をおこないます。
その後ダイアラ インターフェイスにて PPPoE ヘッダーを追加し、WAN インターフェイス (GE0) へ出力をおこないます。