IP : ボーダー ゲートウェイ プロトコル(BGP)

MP-EBGP の設定例

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Cisco IOS ルータにマルチプロトコル拡張 Border Gateway Protocol(MP-EBGP)を設定する方法を説明します。 MP-BGP は、BGP で IPv6、VPNv4 などの複数のネットワーク層プロトコルのルーティング情報を伝送するための拡張 BGP です。 MP-BGP により、マルチキャスト ルーティング トポロジとは異なるユニキャスト ルーティング トポロジを使用できるので、ネットワークおよびリソースの制御に役立ちます。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

この資料のコンフィギュレーションは Cisco IOS を実行するルータに Cisco 3700 シリーズ基づいていますか。 ソフトウェア リリース 12.4 (15)T 13。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この例では、AS 5500 内で iBGP を形成するように R1 ルータと R3 ルータが 設定されます。 R2 ルータは AS 6500 内に設定されます。 R1 および R2 ルータの相互通信には、MP-EBGP が使用されます。 すべてのルータはループバック アドレスで設定されます。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/113555-mp-ebgp-config-01.gif

設定

このドキュメントでは、次の設定を使用します。

ルータ R1 の設定
R1#show run
Building configuration...
!
version 12.4
!
hostname R1
!
ip cef
!
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.100.10 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.16.10.1 255.255.255.0
 mpls ip
 clock rate 2000000
!
router bgp 5500
 no synchronization
 bgp router-id 10.10.10.10
 bgp log-neighbor-changes
 network 192.168.100.0
 redistribute connected
 neighbor 172.16.10.2 remote-as 6500
 neighbor 172.16.10.2 soft-reconfiguration inbound
 neighbor 192.168.100.11 remote-as 5500
 no auto-summary
 !
 address-family vpnv4
  neighbor 172.16.10.2 activate
  neighbor 172.16.10.2 send-community both

!--- Sends the community attribute to a BGP neighbor.

 exit-address-family
!
!
end

ルータ R2 の設定
R2#show run
Building configuration...
!
version 12.4
!
hostname R2
!
ip cef
!
ip vrf WAN
 rd 2020:1
 route-target export 2020:1
 route-target import 2020:1
!
!
interface Loopback0
 ip vrf forwarding WAN

!--- Associates a VRF instance with an interface or subinterface.

 ip address 20.20.20.20 255.255.255.255
!
interface Serial0/0
 ip vrf forwarding WAN
 ip address 172.16.10.2 255.255.255.0
 mpls ip
 clock rate 2000000
!
router bgp 6500
 no synchronization
 bgp router-id 20.20.20.20
 bgp log-neighbor-changes
 neighbor 172.16.10.1 remote-as 5500
 no auto-summary
 !
 !
 address-family vpnv4
  neighbor 172.16.10.1 activate
  neighbor 172.16.10.1 send-community both
 exit-address-family
 !
 address-family ipv4 vrf WAN
  redistribute connected
  redistribute static
  neighbor 172.16.10.1 remote-as 5500
  neighbor 172.16.10.1 activate
  no synchronization
 exit-address-family
!
!
!
end

ルータ R3 の設定
R3#show run
Building configuration...
!
version 12.4
!
hostname R3
!
ip cef
!
!
!
interface Loopback0
 ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.100.11 255.255.255.0
 duplex auto
 speed auto
!
router bgp 5500
 no synchronization
 bgp router-id 11.11.11.11
 bgp log-neighbor-changes
 neighbor 192.168.100.10 remote-as 5500
 no auto-summary
!
end

確認

(BGP)ルーティング テーブルのエントリを表示するには、show ip bgp コマンドを使用します。

show ip bgp
ルータ R1 内
R1#show ip bgp 172.16.10.2
BGP routing table entry for 172.16.10.2/32, version 14
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Advertised to update-groups:
        1    2
  Local
    0.0.0.0 from 0.0.0.0 (10.10.10.10)
      Origin incomplete, metric 0, localpref 100, weight 32768, valid, sourced, best

!--- Displays the routing table entries for the host 172.16.10.2

R1#sh ip bgp 192.168.100.11
BGP routing table entry for 192.168.100.0/24, version 4
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Advertised to update-groups:
        1    2
  Local
    0.0.0.0 from 0.0.0.0 (10.10.10.10)
      Origin IGP, metric 0, localpref 100, weight 32768, valid, sourced, local, best

!--- Displays the entries for the host 192.168.100.11

ルータ R3 内
R3#sh ip bgp 192.168.100.10
BGP routing table entry for 192.168.100.0/24, version 4
Paths: (1 available, best #1, table Default-IP-Routing-Table, RIB-failure(17))
  Not advertised to any peer
  Local
    192.168.100.10 from 192.168.100.10 (10.10.10.10)
      Origin IGP, metric 0, localpref 100, valid, internal, best

!--- Displays the entries for the host 192.168.100.10

R2 ルータで show ip bgp vpnv4 コマンドを使用して、(BGP)テーブルに含まれる(VPNv4)アドレス情報を表示します。

show ip bgp vpnv4
ルータ R2 内
R2#sh ip bgp vpnv4 vrf WAN
BGP table version is 24, local router ID is 20.20.20.20
Status codes: s suppressed, d damped, h history, * valid, > best, I - internal,
              r RIB-failure, S Stale
Origin codes: I - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 2020:1 (default for vrf WAN)
*> 10.10.10.0/24    172.16.10.1              0             0 5500 ?
*> 20.20.20.20/32   0.0.0.0                  0         32768 ?
*  172.16.10.0/24   172.16.10.1              0             0 5500 ?
*>                  0.0.0.0                  0         32768 ?
r> 172.16.10.2/32   172.16.10.1              0             0 5500 ?
*> 192.168.100.0    172.16.10.1              0             0 5500 I

!--- Displays prefixes associated with the (VRF) instance WAN. 

R2#show ip bgp vpnv4 vrf WAN 172.16.10.1
BGP routing table entry for 2020:1:172.16.10.0/24, version 7
Paths: (2 available, best #2, table WAN)
  Advertised to update-groups:
        1
  5500
    172.16.10.1 from 172.16.10.1 (10.10.10.10)
      Origin incomplete, metric 0, localpref 100, valid, external
      Extended Community: RT:2020:1
      mpls labels in/out 18/nolabel
  Local
    0.0.0.0 from 0.0.0.0 (20.20.20.20)
      Origin incomplete, metric 0, localpref 100, weight 32768, valid, sourced, best
      Extended Community: RT:2020:1
      mpls labels in/out 18/aggregate(WAN)

!--- Displays prefixes associated with neighbor 172.16.10.1

MP-EBGP は、R1 ルータと R2 ルータの間に確立されます。 ping コマンドを使用して、R1 から R2 への到達可能性およびその逆の到達可能性を確認します。

ping
ルータ R1 内
R1#ping 172.16.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/64/208 ms

R1#ping 192.168.100.11

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/41/96 ms

!--- Router R1 can successfully ping the routers R2 and R3.

ルータ R2 内
R2#ping vrf WAN 172.16.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/32/96 ms

R2#ping vrf WAN 192.168.100.11

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/73/204 ms


!--- Router R2 can successfully reach router R1 and R3.


関連情報


Document ID: 113555