IP : ホット スタンバイ ルータ プロトコル(HSRP)

HSRPv2 の追跡オプションの設定例

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2014 年 4 月 2 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、ホットスタンバイ ルータ プロトコル(HSRP)for IPv6(HSRPv2)のスタンバイ グループを設定してオブジェクトを追跡し、オブジェクトの状態に基づいて HSRP 優先順位を変更する方法について説明します。

各トラッキング オブジェクトには、トラッキング コマンドライン インターフェイス(CLI)で指定される一意の番号があります。 HSRPv2 では、この番号が特定のオブジェクトの追跡に使用されます。 トラッキング プロセスは、追跡対象オブジェクトに値の変化がないかどうかを定期的にポーリングし、(アップまたはダウン値など)変化があれば HSRPv2 に通知します。ただちに通知する場合と、指定された時間遅延後に通知する場合があります。 このドキュメントでは track interface コマンドを使用し、追跡するインターフェイスを設定します。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • HSRP の設定に関する知識。 詳細は、『HSRP の設定』を参照してください。

  • IPv6 アドレッシングと基本接続を実装する基礎知識。 詳細については、「IPv6 アドレッシングおよび基本的な接続の実装」を参照してください。

  • 強化されたオブジェクト追跡』の基礎知識

  • HSRP IPv6 を設定する前に、インターフェイスに対して HSRPv2 をイネーブルにする必要があります。

  • HSRP IPv6 を設定するには、IPv6 ユニキャスト ルーティングをデバイスで有効にする必要があります。

使用するコンポーネント

この資料のコンフィギュレーションは Cisco IOS を実行する Cisco7200 シリーズ ルータに基づいていますか。 ソフトウェア リリース 15.0(1)。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

R2 ルータおよび R3 ルータをシリアル インターフェイスで R1 に接続します。 R2 および R3 のファースト イーサネット インターフェイスは、R2 がアクティブ ルータとして動作して R3 がスタンバイ ルータとして動作するように、HSRP IPv6 で設定します。 ルータ R2 では、シリアル インターフェイス 1/0 のインターフェイス ライン プロトコルの状態を追跡するように追跡プロセスを設定します。 R2 のシリアル インターフェイス S1/0 がダウンすると、R3 ルータの状態がスタンバイからアクティブに変わります。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/hot-standby-router-protocol-hsrp/113553-to-hsrpv2-config-01.gif

設定

このドキュメントでは、次の設定を使用します。

ルータ R1 の設定
!
version 15.0
!
hostname R1
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Serial1/0
 no ip address
 ipv6 address 2010:10:10:10::1/64
 serial restart-delay 0
!
!
interface Serial1/1
 no ip address
 ipv6 address 2011:11:11:11::1/64
 serial restart-delay 0
 !
end

ルータ R2 の設定
!
version 15.0
!
hostname R2
!
ipv6 unicast-routing
ipv6 cef
!
track 1 interface Serial1/0 line-protocol

!--- Tracking process 1 is configured in the router
!--- to track state of the interface line protocol
!--- of serial interface 1/0

!
interface Serial1/0
 no ip address
 ipv6 address 2010:10:10:10::2/64
 serial restart-delay 0
!
!
interface FastEthernet2/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 1010:1:1:1::10/64
 standby version 2
 standby 10 ipv6 autoconfig

!--- Assigns a standby group and standby IP address.

 standby 10 preempt delay minimum 45

!--- The preempt command allows the router to become the 
!--- active router when it has the priority higher than all the other
!--- HSRP-configured routers. Without this command, even if a router has higher 
!--- priority value, it will not become an active router.
!--- The delay minimum value causes the local router to postpone
!--- taking over the active role for a minimum of 45 seconds.

 standby 10 track 1 decrement 10

!--- Configures HSRP to track an object and change the Hot Standby
!--- priority on the basis of the state of the object.



!--- In this example,the HSRP tracks the interface s1/0 mentioned
!--- in the track process 1.


!--- Decrement value specified the amount by which the Hot Standby 
!--- priority for the router is decremented (or incremented) when the tracked object 
!--- goes down (or comes back up). The range is from 1 to 255. The default is 10. 

!
end

ルータ R3 の設定
!
version 15.0
!
hostname R3
!
ipv6 unicast-routing
ipv6 cef
!
interface Serial1/0
 no ip address
 ipv6 address 2011:11:11:11::2/64
 serial restart-delay 0
!
interface FastEthernet2/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 1010:1:1:1::11/64
 standby version 2
 standby 10 ipv6 autoconfig
 standby 10 priority 95
 standby 10 preempt delay minimum 45
!
end

確認

設定を確認するには、R2 と R3 ルータで show standby コマンドを使用します。

ルータ R2
R2#show standby
FastEthernet2/0 - Group 10 (version 2)
  State is Active
    5 state changes, last state change 00:26:03
  Virtual IP address is FE80::5:73FF:FEA0:A
  Active virtual MAC address is 0005.73a0.000a
    Local virtual MAC address is 0005.73a0.000a (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.872 secs
  Preemption enabled, delay min 45 secs
  Active router is local
  Standby router is FE80::C802:AFF:FE10:38, priority 95 (expires in 8.048 sec)
  Priority 100 (default 100)
    Track object 1 state Up decrement 10
  Group name is "hsrp-Fa2/0-10" (default)

ルータ R3
R3#show standby
FastEthernet2/0 - Group 10 (version 2)
  State is Standby
    4 state changes, last state change 00:26:25
  Virtual IP address is FE80::5:73FF:FEA0:A
  Active virtual MAC address is 0005.73a0.000a
    Local virtual MAC address is 0005.73a0.000a (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.176 secs
  Preemption enabled, delay min 45 secs
  Active router is FE80::C801:14FF:FEF4:38, priority 100 (expires in 9.888 sec)
    MAC address is ca01.14f4.0038
  Standby router is local
  Priority 95 (configured 95)
  Group name is "hsrp-Fa2/0-10" (default)

追跡情報を表示するには、ルータ R2 で show track コマンドを使用します。

ルータ R2
R2#show track 1
Track 1
  Interface Serial1/0 line-protocol
  Line protocol is Up
    3 changes, last change 00:28:39
  Tracked by:
    HSRP FastEthernet2/0 10

!--- Displays the information about the objects that 
!--- are tracked by tracking process 1.

R2#show track int brief
Track   Object                           Parameter        Value Last Change
1       interface   Serial1/0            line-protocol    Up    00:31:19

!--- Displays the information about the tracked interface.

アクティブ ルータ(この例では R2)がダウンすると、次のテーブルのようにスタンバイ ルータの状態がすぐにアクティブに変わります。

アクティブ ルータ(R2)がダウンした場合
ルータ R2
R2(config)#interface s1/0
R2(config-if)#shut
R2(config-if)#
*May 21 20:56:54.223: %TRACKING-5-STATE: 1 interface Se1/0 line-protocol Up->Down
R2(config-if)#
*May 21 20:56:56.203: %LINK-5-CHANGED: Interface Serial1/0, changed state to administratively down
*May 21 20:56:57.203: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down
R2(config-if)#
*May 21 20:57:43.087: %HSRP-5-STATECHANGE: FastEthernet2/0 Grp 10 state Active -> Speak
R2(config-if)#
*May 21 20:57:54.479: %HSRP-5-STATECHANGE: FastEthernet2/0 Grp 10 state Speak -> Standby


!--- When the interface goes down, the active router changes 
!--- its state to Standby.

ルータ R3
R3#
*May 21 20:56:53.419: %HSRP-5-STATECHANGE: FastEthernet2/0 Grp 10 state Standby-> Active


!--- The standby router is now the active router.
 

R3#show standby
FastEthernet2/0 - Group 10 (version 2)
  State is Active
    5 state changes, last state change 00:02:32
  Virtual IP address is FE80::5:73FF:FEA0:A
  Active virtual MAC address is 0005.73a0.000a
    Local virtual MAC address is 0005.73a0.000a (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.080 secs
  Preemption enabled, delay min 45 secs
  Active router is local
  Standby router is FE80::C801:14FF:FEF4:38, priority 90 (expires in 9.664 sec)
  Priority 95 (configured 95)
  Group name is "hsrp-Fa2/0-10" (default)

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連情報


Document ID: 113553