スイッチ : Cisco Nexus 7000 シリーズ スイッチ

Nexus 7000 シリーズ スイッチ ERSPAN の設定例

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、2 台の Nexus 7000 シリーズ スイッチのイーサネット ポート間のトラフィックをモニタする Nexus 7000 シリーズ スイッチでカプセル化リモート スイッチド ポート アナライザ(ERSPAN)セッションを設定する方法について説明します。

前提条件

要件

この設定を行う前に、以下の要件を満たしていることを確認してください。

  • Nexus 7000 シリーズ スイッチの設定に関する基本的な知識がある

  • ERSPAN の基本的な知識がある

使用するコンポーネント

このドキュメントの情報は、Cisco NX-OS ソフトウェア リリース 5.1(3) の Nexus 7018 シリーズ スイッチに基づくものです。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

ERSPAN について

  • ERSPAN は、ネットワークにおける複数のスイッチのリモート モニタリングを有効にします。

  • ERSPAN は、複数のスイッチの送信元ポートからミラーリングされたトラフィックを宛先ポートへ送信します。ここにネットワーク アナライザが接続されています。

  • トラフィックは送信元のスイッチでカプセル化され、宛先のスイッチに転送されます。ここでパケットがカプセル化解除され、宛先ポートへ送信されます。

  • ERSPAN は、ERSPAN 送信元セッション、ルーティング可能な ERSPAN 総称ルーティング カプセル化(GRE)カプセル化トラフィック、および ERSPAN 宛先セッションで構成されています。

  • 複数のスイッチ上で、ERSPAN の送信元セッションと宛先セッションを個別に設定することができます。

  • ERSPAN は送信元に関係なく、スーパーバイザによって生成されるパケットをモニタしません。

ERSPAN 送信元

  • トラフィックをモニタできるモニタ元インターフェイスのことを ERSPAN ソースと呼びます。

  • 送信元ポートのすべてのパケット、すなわち受信(入力)、送信(出力)、または双方向(両方)を監視できます。

  • ERSPAN 送信元には、送信元ポート、送信元 VLAN、または送信元 VSAN が含まれています。 VLAN が ERSPAN 送信元として指定されている場合は、VLAN 内でサポートされているすべてのインターフェイスが ERSPAN 送信元になります。

ERSPAN 宛先

  • 宛先ポートは ERSPAN 送信元からコピーされたトラフィックを受信します。

  • 宛先ポートは、SwitchProbe デバイスや他のリモート モニタリング(RMON)プローブなどのデバイス、またはセキュリティ デバイスに接続したポートで、1 つまたは複数のソース ポートからコピーしたパケットを受信して分析することができます。

  • 宛先ポートはスパニングツリー インスタンスまたはレイヤ 3 プロトコルに参加しません。

設定

この設定例では、Nexus 7000 シリーズ スイッチ 1 の送信元ポート、およびもうひとつの Nexus 7000 スイッチの宛先ポートを使用します。ここにネットワーク アナライザが接続されています。 に示すように、2 つのスイッチ間にはイーサネット リンクがあります。

注: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/switches/nexus-7000-series-switches/113480-erspan-nexus-7k-01.gif

設定

このドキュメントでは、次の設定を使用します。

Nexus 7000 スイッチ 1
switch_1#configure terminal


!--- Configures an ERSPAN source session.

switch_1(config)#monitor session 48 type erspan-source

!--- Configure the sources and traffic direction.

switch_1(config-erspan-src)#source interface Ethernet2/10 both

!--- Configure the destination IP address in the ERSPAN session.

switch_1(config-erspan-src)#destination ip 10.11.11.3

!--- Configure the ERSPAN ID.

switch_1(config-erspan-src)#erspan-id 902

!--- Configure the VRF.

switch_1(config-erspan-src)#vrf default

!--- Enable the ERSPAN source session (by default the session is 
!--- in shutdown state).

switch_1(config-erspan-src)#no shut
switch_1(config-erspan-src)#exit


!--- Configure the ERSPAN global origin IP address.

switch_1(config)#monitor erspan origin ip-address 10.254.254.21 global



!--- Configure the IP address for loopback interface, which is used
!--- as source of the ERSPAN traffic.

switch_1(config)#interface loopback1
switch_1(config-if)#ip address 10.254.254.21/32
switch_1(config-if)#exit

switch_1(config)#interface Ethernet1/1
switch_1(config-if)#switchport
switch_1(config-if)#switchport mode trunk
switch_1(config-if)#no shutdown
switch_1(config-if)#exit

switch_1(config)#feature interface-vlan
switch_1(config)#interface Vlan 11
switch_1(config-if)#ip address 10.11.11.2/29
switch_1(config-if)#no ip redirects
switch_1(config-if)#no shutdown
switch_1(config-if)#exit


!--- Save the configurations in the device.

switch_1(config)#copy running-config startup-config
Switch_1(config)#exit

Nexus 7000 スイッチ 2
switch_2#configure terminal


!--- Configures an ERSPAN destination session.

switch_2(config)#monitor session 47 type erspan-destination

!--- Configures the source IP address.

switch_2(config-erspan-src)#source ip 10.11.11.3

!--- Configures a destination for copied source packets.

switch_2(config-erspan-src)#destination interface Ethernet2/34

!--- Configure the ERSPAN ID.

switch_2(config-erspan-src)#erspan-id 902

!--- Configure the VRF.

switch_2(config-erspan-src)#vrf default

!--- Enable the ERSPAN destination session (by default the session is 
!--- in shutdown state).

switch_2(config-erspan-src)#no shut
switch_2(config-erspan-src)#exit

switch_2(config)#interface Ethernet2/34
switch_2(config-if)#switchport monitor
switch_2(config-if)#exit

switch_2(config)#feature interface-vlan
switch_2(config)#interface Vlan 11
switch_2(config-if)#ip address 10.11.11.3/29
switch_2(config-if)#no ip redirects
switch_2(config-if)#no shutdown
switch_2(config-if)#exit

switch_2(config)#interface Ethernet1/2
switch_2(config-if)#switchport
switch_2(config-if)#switchport mode trunk
switch_2(config-if)#no shutdown
switch_2(config-if)#exit


!--- Save the configurations in the device.

switch_2(config)#copy running-config startup-config
Switch_2(config)#exit

確認

このセクションでは、設定が正常に機能していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

次に、ERSPAN の確認コマンドをいくつか示します。

  • ERSPAN のセッションの状態を表示するには、show monitor コマンドを使用します。

    switch_1# show monitor
    Session  State        Reason                  Description
    -------  -----------  ----------------------  --------------------------------
    4        up           The session is up
  • ERSPAN セッションの設定を表示するには、show monitor session [session session_number] コマンドを使用します。

    switch_1# show monitor session 48
       session 48
    ---------------
    type              : erspan-source
    state             : up
    erspan-id         : 902
    vrf-name          : default
    acl-name          : acl-name not specified
    ip-ttl            : 255
    ip-dscp           : 0
    destination-ip    : 10.11.11.3
    origin-ip         : 10.254.254.21 (global)
    source intf       :
        rx            : Eth2/10
        tx            : Eth2/10
        both          : Eth2/10
    source VLANs      :
        rx            :
        tx            :
        both          :
    filter VLANs      : filter not specified
  • デバイスのすべての ERSPAN セッションの設定を表示するには、show monitor session all コマンドを使用します。

  • 実行中の ERSPAN の設定を表示するには、show running-config monitor コマンドを使用します。

    switch_1# show running-config monitor
    
    !Command: show running-config monitor
    !Time: Thu Apr 19 10:15:33 2012
    
    version 5.1(3)
    monitor session 48 type erspan-source
      erspan-id 902
      vrf default
      destination ip 10.11.11.3
      source interface Ethernet2/10 both
      no shut
    
    monitor erspan origin ip-address 10.254.254.21 global
  • ERSPAN のスタートアップ設定を表示するには、show startup-config monitor コマンドを使用します。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 113480