IP : IP バージョン 6(IPv6)

BGP の OSPFv3 ルートの再配布の設定例

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントは、Open Shortest Path First バージョン 3(OSPFv3)ルートを Multiprotocol BGP for IPv6 へ再配送する例について説明します。 OSPFv3 は、IPv6 のルーティング プレフィックスおよびサイズの大きい IPv6 アドレスのサポートを提供するために、OSPF バージョン 2 を拡張したものです。 マルチプロトコル BGP は、IPv6 アドレス ファミリや IP マルチキャスト ルートなど、複数のネットワーク層プロトコルのアドレス ファミリに関するルーティング情報を伝送する拡張 BGP です。

前提条件

前提条件

この設定を行う前に、以下の要件を満たしていることを確認してください。

ハードウェアとソフトウェアのバージョン

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

この資料のコンフィギュレーションは Cisco IOS が付いているルータに Cisco 3700 シリーズ基づいていますか。 ソフトウェア リリース 12.4 (15)T1。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この例では、ルータ R2 と R3 はシリアル インターフェイスを介して接続され、Multiprotocol BGP で設定されています。 ルータ R2 と R3 は、OSPFv3 を使用してローカル ルータ R1 および R4 と通信します。 ネットワークを生成するために、ルータ内にループバック アドレスが作成されます。 ルータ R2 と R3 は BGP と OSPFv3 の両方を実行しており、redistribute コマンドを使用して OSPFv3 ルートを BGP へ再配送します。 すべてのルータは IPv6 アドレスで設定されます。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113453-redis-ospfv3-bgp-01.gif

設定

このドキュメントでは、次の設定を使用します。

ルータ R1
!
version 12.4
!
hostname R1
!
ip cef
!
ipv6 unicast-routing

!--- Enables the forwarding of IPv6 packets.

!
interface Loopback0
 no ip address
 ipv6 address 2222::1/128
 ipv6 ospf 1 area 0

!--- Enables OSPFv3 on the interface and associates
!--- the interface loopback0 to area 0.

!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 1010:1:1:1::1/64
 ipv6 ospf 1 area 0

!--- Associates the Interface Fa0/0 to area 0.

!
ipv6 router ospf 1
 router-id 1.1.1.1

!--- Router R1 uses 1.1.1.1 as router ID.

 log-adjacency-changes
!
end

ルータ R2
!
version 12.4
!
hostname R2
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 2010::1/128
 ipv6 ospf 1 area 1
!
interface Loopback1
 no ip address
 ipv6 address 2011::1/128
 ipv6 ospf 1 area 1
!
interface Loopback99
 no ip address
 ipv6 address 5050:55:55:55::55/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 1010:1:1:1::2/64
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 3030:1:1:1::10/64
 clock rate 2000000
!
router bgp 65000
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast

!--- Without configuring "no bgp default ipv4-unicast" only 
!--- IPv4 will be advertised.

 bgp log-neighbor-changes
 neighbor 3030:1:1:1::11 remote-as 65000
 neighbor 3030:1:1:1::11 update-source Serial0/0
 !
 address-family ipv6
  neighbor 3030:1:1:1::11 activate
  network 5050:55:55:55::55/128
  redistribute connected
  redistribute ospf 1 match internal external 1 external 2

!--- This redistributes all OSPF routes into BGP.

  no synchronization
 exit-address-family
!
ipv6 router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
!
end

ルータ R3
!
version 12.4
!
hostname R3
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 1111::1/128
 ipv6 ospf 1 area 1
!
interface Loopback1
 no ip address
 ipv6 address 1112::1/128
 ipv6 ospf 1 area 1
!
interface Loopback99
 no ip address
 ipv6 address 6060:66:66:66::66/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:1:1:1::2/64
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 3030:1:1:1::11/64
 clock rate 2000000
!
router bgp 65000
 bgp router-id 2.2.2.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 3030:1:1:1::10 remote-as 65000
 neighbor 3030:1:1:1::10 update-source Serial0/0
 !
 address-family ipv6
  neighbor 3030:1:1:1::10 activate
  network 6060:66:66:66::66/128
  redistribute connected
  redistribute ospf 1 match internal external 1 external 2
  no synchronization
 exit-address-family
!
ipv6 router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
!
end

ルータ R4
!
version 12.4
!
hostname R4
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 3333::1/128
 ipv6 ospf 1 area 0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:1:1:1::1/64
 ipv6 ospf 1 area 0
!
ipv6 router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
!
end

確認

このセクションでは、設定が正常に機能していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

次の show コマンドを使用して、設定を確認します。

OSPFv3 設定の確認

OSPFv3 が適切に設定されていることを確認するには、ルータ R1 および R4 で show ipv6 route ospf コマンドを使用します。

show ipv6 route ospf
ルータ R1 内
 
R1#show ipv6 route ospf
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
OI  2010::1/128 [110/10]
     via FE80::C001:16FF:FEDC:0, FastEthernet0/0
OI  2011::1/128 [110/10]
     via FE80::C001:16FF:FEDC:0, FastEthernet0/0
ルータ R4 内
 
R4#show ipv6 route ospf
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
OI  1111::1/128 [110/10]
     via FE80::C002:16FF:FEDC:0, FastEthernet0/0
OI  1112::1/128 [110/10]
     via FE80::C002:16FF:FEDC:0, FastEthernet0/0

BGP 設定の確認

OSPFv3 ルートが BGP に再配送されているかどうかを確認するには、ルータ R2 および R3 で show ipv6 route bgp コマンドを使用します。

show ipv6 route bgp
ルータ R2 内
R2#show ipv6 route bgp
IPv6 Routing Table - 14 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   1111::1/128 [200/0]
     via 3030:1:1:1::11
B   1112::1/128 [200/0]
     via 3030:1:1:1::11
B   2020:1:1:1::/64 [200/0]
     via 3030:1:1:1::11
B   3333::1/128 [200/10]
     via 3030:1:1:1::11

!--- The above routes are OSPFv3 routes
!--- that are redistributed in to BGP.

B   6060:66:66:66::66/128 [200/0]
     via 3030:1:1:1::11
ルータ R3 内
R3#show ipv6 route bgp
IPv6 Routing Table - 14 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   1010:1:1:1::/64 [200/0]
     via 3030:1:1:1::10
B   2010::1/128 [200/0]
     via 3030:1:1:1::10
B   2011::1/128 [200/0]
     via 3030:1:1:1::10
B   2222::1/128 [200/10]
     via 3030:1:1:1::10

!--- The above routes are OSPFv3 routes
!--- that are redistributed in to BGP.

B   5050:55:55:55::55/128 [200/0]
     via 3030:1:1:1::10


関連情報


Document ID: 113453