ワイヤレス : Cisco 5500 シリーズ ワイヤレス コントローラ

Wireless LAN ごとのレート制限ソリューション

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

http://www.cisco.com/c/dam/en/us/support/docs/wireless/5500-series-wireless-controllers/113435-wlan-user-rls-01.gif

Cisco Wireless LAN Controller でワイヤレス ユーザにダウンストリームのユーザごとのレート制限を提供することは可能ですが、IOS マイクロフロー ポリシングをソリューションに追加すると、アップストリームおよびダウンストリームの両方向により細かくレート制限が可能です。 ユーザごとの比率制限を設定するための動機づけは帯域幅「hog」保護からカスタマーネットワーク アクセスのための段になった帯域幅モデルを、場合によっては設定すること、です要件として帯域幅 ポリシングから免除されている whitelist 特定のリソース及び。 現在の世代別 IPv4 トラフィックの停止に加えて、ソリューションはユーザごとの IPv6 比率制限することができます。 これは投資保護を提供します。

前提条件

要件

Microflow ポリシングはスーパバイザ 720 またはそれ以降の使用を必要とします Cisco IOS のバージョンを実行するか。 ソフトウェア リリース 12.2(14)SX または それ 以降。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • ワイヤレス LAN コントローラ

  • アクセス ポイント(AP)

  • Cisco Catalyst Supervisor 720 またはそれ以降

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

Catalyst 6500 の設定

Microflow ポリシング 設定

次の手順を実行します。

  1. Microflow ポリシングを利用することは最初にトラフィックを識別するようにスロットリング ポリシーを適用するために Access Control List (ACL)が作成されることを必要とします。

    注: この設定例は無線クライアントのために 192.168.30.x/24 サブネットを使用します。

    ip access-list extended acl-wireless-downstream
    permit ip any 192.168.30.0 0.0.0.255
    ip access-list extended acl-wireless-upstream
    permit ip 192.168.30.0 0.0.0.255 any
  2. 前の ACL で一致するために class-map を作成して下さい。

    class-map match-all class-wireless-downstream
    match access-group name acl-wireless-downstream
    class-map match-all class-wireless-upstream
    match access-group name acl-wireless-upstream
  3. policy-map を作成することはトラフィックに適用する個別の操作に以前に作成された ACL および class-map をリンクします。 この場合トラフィックは両方向の 1Mbps に停止されています。 ソース フロー マスクはアップストリーム 方向(AP へのクライアント)で使用され、デスティネーションフロー マスクはダウンストリーム 方向(クライアントへの AP)で使用されます。

    policy-map police-wireless-upstream
    class class-wireless-upstream
    police flow mask src-only 1m 187500 conform-action transmit exceed-action drop
    policy-map police-wireless-downstream
    class class-wireless-downstream
    police flow mask dest-only 1m 187500 conform-action transmit exceed-action drop

Microflow ポリシングの設定に関する詳細については、Cisco Catalyst 6500 で制限するユーザベース 比率を参照して下さい。

帯域幅 ポリシング ポリシーの調節

policy-map 内のポリシー文は実際の帯域幅(ビットで)です設定されるおよびバースト サイズ(バイトで設定される)パラメータは設定されます。

バースト サイズのためのよい経験に基づく方法は次のとおりです:

Burst = (Bandwidth / 8) * 1.5

例:

この回線利用率 1Mbps (ビット)の比率:

police flow mask dest-only 1m 187500 conform-action transmit exceed-action drop

この回線利用率 5Mbps (ビット)の比率:

police flow mask dest-only 5mc 937500 conform-action transmit exceed-action drop

帯域幅 ポリシングからの Whitelisting リソース

場合によっては、ある特定のネットワークリソースは Windows アップデート サーバのような帯域幅 ポリシングから免除されているまたは治療アプライアンスをポーズをとらせる必要があります。 ホストに加えて、whitelisting も帯域幅 ポリシングからのサブネット全体を免除するのに使用することができます。

例:

この例はあらゆる帯域幅制限から 192.168.30.0/24 ネットワークと通信するときホスト 192.168.20.22 を除外します。

ip access-list extended acl-wireless-downstream
deny ip host 192.168.20.22 192.168.30.0 0.0.0.255
permit ip any 192.168.30.0 0.0.0.255
ip access-list extended acl-wireless-upstream
deny ip 192.168.30.0 0.0.0.255 host 192.168.20.22
permit ip 192.168.30.0 0.0.0.255 any

IPv6 Microflow ポリシング

http://www.cisco.com/c/dam/en/us/support/docs/wireless/5500-series-wireless-controllers/113435-wlan-user-rls-02.gif

次の手順を実行します。

  1. 絞られるべき IPv6 トラフィックを識別するために Catalyst 6500 に別のアクセス リストを追加して下さい。

    ipv6 access-list aclv6-wireless-downstream
    permit ipv6 any 2001:DB8:0:30::/64
    !
    ipv6 access-list aclv6-wireless-upstream
    permit ipv6 2001:DB8:0:30::/64 any
    
  2. IPv6 ACL を含むために class-map を修正して下さい。

    class-map match-any class-wireless-downstream
    match access-group name aclv6-wireless-downstream
    match access-group name acl-wireless-downstream
    class-map match-any class-wireless-upstream
    match access-group name aclv6-wireless-upstream
    match access-group name acl-wireless-upstream

機器ベース(2500、4400、5500) コントローラ設定

Microflow ポリシングに、5508 シリーズのような機器ベース コントローラを与えるために、設定は単純化しています。 コントローラ インターフェイスは Catalyst 6500 サービス ポリシーはコントローラ インターフェイスに適用されるが、他のどの VLAN へもの設定された類似したです。

http://www.cisco.com/c/dam/en/us/support/docs/wireless/5500-series-wireless-controllers/113435-wlan-user-rls-03.gif

次の手順を実行します。

  1. コントローラから着信ポートのポリシングするワイヤレス アップストリームを適用して下さい。

    interface GigabitEthernet4/13
    description WLC
    switchport
    switchport trunk allowed vlan 30
    switchport mode trunk
    service-policy input police-wireless-upstream
    end
    
  2. アップリンク LAN/WAN ポートのポリシー ワイヤレス ダウンストリームを適用して下さい。

    interface GigabitEthernet4/20
    description WAN
    switchport
    switchport access vlan 20
    switchport mode access
    service-policy input police-wireless-downstream
    end

モジュール ベースの(WiSM、WiSM2)コントローラ設定

ワイヤレスサービス Module2 (WiSM2)を用いる Catalyst 6500 の Microflow ポリシングを活用 するために VLANベース Quality of Service (QoS)を使用するために、設定は調整する必要があります。 これは Microflow ポリシング ポリシーがポート インターフェイスに直接(たとえば、Gi1/0/1)適用されないが意味しましたり、VLANインターフェイスでことを適用されます。

http://www.cisco.com/c/dam/en/us/support/docs/wireless/5500-series-wireless-controllers/113435-wlan-user-rls-04.gif

次の手順を実行します。

  1. VLANベース QoS のための WiSM を設定して下さい:

    wism service-vlan 800
    wism module 1 controller 1 allowed-vlan 30
    wism module 1 controller 1 qos vlan-based
  2. クライアント VLAN SVI のポリシー ワイヤレス アップストリームを適用して下さい:

    interface Vlan30
    description Client-Limited
    ip address 192.168.30.1 255.255.255.0
    ipv6 address 2001:DB8:0:30::1/64
    ipv6 enable
    service-policy input police-wireless-upstream
    end
  3. アップリンク LAN/WAN ポートのポリシー ワイヤレス ダウンストリームを適用して下さい。

    interface GigabitEthernet4/20
    description WAN
    switchport
    switchport access vlan 20
    switchport mode access
    service-policy input police-wireless-downstream
    end

ソリューション 確認

ユーザごとの比率制限の主要な必要条件の 1 つはから来る特定のユーザにすべてのフローを予定されて制限する機能であり。 Microflow ポリシング ソリューションがこの要件を満足させることを確認するために、IxChariot が特定のユーザ向けの 4 同時ダウンロード セッションおよび 4 同時アップロード セッションを模倣するのに使用されています。 これは大きい添付ファイルによって電子メールを送信 して いる間先祖などを視聴している誰かを FTPセッションを起動させ、Web を参照し、ビデオ ストリーム表すことができます

停止されたトラフィックを使用してリンクの速度を測定するためにこのテストで IxChariot は TCPトラフィックを使用して「Throughput.scr」スクリプトで設定されます。 Microflow ポリシング ソリューションはユーザ向けの 1Mbps ダウンストリームおよび 1Mbps アップストリームの合計にすべてのストリームを絞れます。 さらに、ストリームすべては利用可能 な 帯域幅の大体 25% を使用します(たとえば、ストリーム X 4 ごとの 250kbps = 1Mbps)。

http://www.cisco.com/c/dam/en/us/support/docs/wireless/5500-series-wireless-controllers/113435-wlan-user-rls-05.gif

注: Microflow ポリシング治安活動がレイヤ3 に発生するので、TCPトラフィック スループットのための最終結果はプロトコル オーバーヘッドのために設定速度より小さいできます。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 113435