Cisco インターフェイスとモジュール : Cisco インターフェイス プロセッサ

メインフレームで実行するための OMPROUTE の設定

2012 年 2 月 9 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 9 月 9 日) | フィードバック

メインフレームで実行するための OMPROUTE の設定

概要

このドキュメントでは、OMPROUTE プロシージャをメインフレームで実行し、他の TCP/IP ネットワークとルーティング アップデートを交換するホストおよびルータの設定例を紹介します。この例のとおり、OMPROUTE は仮想 IP アドレス(VIPA)と組み合わせてよく使用されます。これにより、クライアントに設定されているメインフレームの IP アドレスを、1 つのチャネル インターフェイスから独立させることができます。こうすることによって、チャネルの冗長性が確保されます。本来、IBM メインフレームの TCP/IP 実装では、OROUTED プロシージャを使用して、ルーティング プロトコルとして Routing Information Protocol(RIP)のみがサポートされていました。より新しい OMPROUTE では、RIP V1 または V2 および Open Shortest Path First(OSPF)のいずれかがサポートされています。IBM では、OROUTED ではなく OMPROUTE の使用を推奨しています。また、IBM では今後 OROUTED を廃止する予定です。



前提条件

要件

このドキュメントに関する固有の要件はありません。



使用するコンポーネント

この設定で使用された Cisco IOS ソフトウェア リリースは xCPA マイクロコード 27-9 を装備した 12.1(3a)T2 です。これは、このテストが行われた時点での最新版です。ただし、CLAW を使用している場合は、Cisco IOS ソフトウェアの任意のバージョンで動作します。CMPC+ を使用するには、少なくとも Cisco IOS ソフトウェア リリース 12.1T が必要です。

ルータは xCPA ポート アダプタを装備した Cisco 7206 でした。または、CIP カードを装備した Cisco 7500 ルータの設定を多少変更しても使用できます。詳細は、このドキュメントの後半で説明します。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼動中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。



表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。



コンフィギュレーション

メインフレームの設定 - OMPROUTE ファイル

メインフレームでの OMPROUTE の設定は、OROUTED の設定に非常によく似ています。OMPROUTE は少なくとも 2 つの設定ファイルを使用します。OMVS アドレス領域で、次の 2 つの環境変数を指定して、これらの設定ファイルの場所を示す必要があります。

  • export resolver_conf=/etc/resolv.conf

  • export omproute_file=/etc/omproute.conf

次に、resolver_conf の内容の例を示します。

TCPJobName TCPIP
DomainOrigin cisco.com
domain cisco.com
Datasetprefix TCPIP
HostName P390
Messagecase mixed

omproute_file は、RIP と OSPF のどちらが使用されているかによって異なります。次に RIP の設定例を示します。

;
Originate_RIP_Default Condition=Always Cost=1
;
RIP_Interface IP_Address=10.64.3.34
Name=LDIPTG
Subnet_Mask=255.255.255.240
Receive_Dynamic_Nets=YES
Receive_Dynamic_Subnets=YES
MTU=1470
Destination_Addr=10.64.3.33
;
RIP_Interface IP_Address=10.64.3.17
Name=VIPALINK
Subnet_Mask=255.255.255.240
MTU=1470
;

OSPF の場合、さらに多くの設定オプションを利用できます。これには、メインフレームをスタブ エリアとして動作させる機能も含まれています。これにより、多くの論理パーティション(LPAR)が同じチャネルを経由して接続されている場合に、チャネル上に配置されるアップデートをルーティングする負荷を大幅に削減できます。次に例を示します。

Area Area_Number=0.0.0.0 Authentication_Type=None Stub_Area=NO
;
Comparison=Type2
;
AS_Boundary_Routing Import_Subnet_Routes=YES
Import_Direct_Routes=YES
;
OSPF_Interface IP_Address=10.64.3.34
Name=LDIPTG
Subnet_Mask=255.255.255.240
Attaches_To_Area=0.0.0.0
MTU=1470
Destination_Addr=10.64.3.33
Hello_Interval=30
Dead_Router_Interval=120
;
OSPF_Interface IP_Address=10.64.3.17
Name=VIPALINK
Subnet_Mask=255.255.255.240


メインフレームの設定 - TCP/IPスタック

TCP/IP プロファイル データセットには、OMPROUTE の特別な設定は必要ありません。ただし、すべてのスタティックおよびデフォルトのルート設定と BSDROUTINGPARMS セクション(OROUTED でのみ使用)をコメント アウトする必要があります。この抜粋では、コメント アウトする必要がある部分と、OMPROUTE 設定ファイルが参照するパラメータのみを示しています。

TCPIP Profile dataset
---------------------
 -----------------------------------------------------------------------
; Hardware definitions:
 -----------------------------------------------------------------------
; NOTE: To use these device and link statements, update the statements
; to reflect your installation configuration and remove the semicolon
;
DEVICE DIPTG MPCPTP
LINK LDIPTG MPCPTP DIPTG
DEVICE VIPADEV VIRTUAL 0
LINK VIPALINK VIRTUAL 0 VIPADEV
;
;
; -----------------------------------------------------------------------
;
; HOME Internet (IP) addresses of each link in the host.
;
; NOTE: To use this home statement, update the ipaddress and linknames 
; to reflect your installation configuration and remove the semicolon
;
HOME
10.64.3.17    VIPALINK
10.64.3.34    LDIPTG
; -----------------------------------------------------------------------
;
; IP routing information for the host.	All static IP routes should
; be added here.
;
; NOTE: To use this GATEWAY statement, update the addresses and links
; to reflect your installation configuration and remove the semicolon
;
; GATEWAY
;
; Direct Routes - Routes that are directly connected to my interfaces.
;
; Network  First Hop  Link Name Packet Size  Subnet Mask  Subnet Value
; 10           =       CIS1      1500       0.255.255.0    0.101.1
; 10           =       LDIPTG    1500       0.255.255.240  0.64.3.32
; 9            =       LIS1      1500       0.255.255.0    0.117.56.0
; 130.50       =       TR1       2000       0.0.255.0      0.0.10.0
; 193.5.2      =       ETH1      1500       0
; 9            =       FDDI1     4000       0.255.255.0    0.67.43.0
; 193.7.2.2    =       SNA1      2000       HOST
;
; Indirect Routes - Routes that are reachable through routers on my
;		    network.
;
; Network     First Hop   Link Name Packet Size  Subnet Mask  Subnet Value
; DEFAULTNET  10.64.3.33  LDIPTG    DEFAULTSIZE  0
; 193.12.2    130.50.10.1 TR1       2000         0
; 10.5.6.4    193.5.2.10  ETH1      1500         HOST
;
; Default Route - All packets to an unknown destination are routed
;		  through this route.
;
; Network     First Hop   Link Name Packet Size  Subnet Mask  Subnet Value
; DEFAULTNET  9.67.43.1   FDDI1     DEFAULTSIZE  0
;
; -----------------------------------------------------------------------
;
; orouted Routing Information
;
; if you are using orouted, comment out the GATEWAY statement and
; update the BSDROUTINGPARMS statement to reflect your installation
; configuration and remove the semicolon
;
;    Link     Maxmtu   Metric   Subnet Mask     Dest Addr
; BSDROUTINGPARMS false
; LDIPTG       1500       0     255.255.255.240 10.64.3.33
; VIPALINK     1500       0     255.255.255.240 0
;    TR1       2000       0     255.255.255.0   0
;    ETH1      1500       0     255.255.255.0   0
;    FDDI1  DEFAULTSIZE   0     255.255.255.0   0
; ENDBSDROUTINGPARMS

!--- 最後の 2 つのセクションがすべてコメント アウトされていることに注目してください。



メインフレームの設定 - VTAM の定義および TCP/IP の開始

アップデートのルーティングは、CLAW 接続または CMPC+ 接続を介して交換できます。CLAW を使用している場合、メインフレームでの追加の設定は必要ありません。この例では CMPC を使用しているため、VTAM Transport Resource List(TRL)のエントリが必要です。これは VTAM メンバです。

DIPTGTRL VBUILD TYPE=TRL
*
*
DIPTG	 TRLE  LNCTL=MPC,MAXBFRU=16,READ=(E24),WRITE=(E25)
*

TCPIP 起動タスクが起動する前に、TRL をアクティブ化する必要があります。次に例を示します。

V NET,ACT,ID=DIPTRL1,UPDATE=ALL
IST097I VARY ACCEPTED
ISTTRL ACTIVE

次に、S TCPIP MVS コンソール コマンドで、TCP/IP 起動タスクをアクティブ化します。TCP/IP 起動タスクが実行されたら、Job Control Language(JCL)を起動タスクとして使用するか、OMVS アドレス領域内から、OMPROUTE プロシージャを開始できます。OMVS 内で開始するには、次のコマンドを実行します。

cd /usr/lpp/tcpip/sbin

omproute &

OMPROUTE が実行されていることを確認するには、次のコンソール コマンドを実行します。ここで、p390 は OMPROUTE デーモンを開始したユーザ ID です。

d omvs,u=p390


ルータの設定

チャネルを介してブロードキャストを送信するように、broadcast キーワードを使用して、CLAW と CMPC の両方を特別に設定する必要があります。たとえば、CLAW の場合は次のようになります。

claw 0100 20 10.101.1.10 P390D C7000D TCPIP TCPIP broadcast

この例では CMPC+ が使用されているため、関連するルータ設定の部分は以下のようになります。

!
interface Channel2/0
 ip address 10.64.3.33 255.255.255.240
 ip ospf network point-to-multipoint
 no keepalive
 cmpc 0100 24 DIPTG READ
 cmpc 0100 25 DIPTG WRITE
 tg DIPTG    ip 10.64.3.34 10.64.3.33 broadcast
 router ospf 1
  network 10.0.0.0 0.255.255.255 area 0
!

これが、xCPA ポート アダプタを装備する 7200 ではなく、CIP カードを装備する Cisco 7500 ルータの場合、tg 文は virtual /2 インターフェイスで設定されます。ip ospf network point-to-multipoint コマンドに注目してください。このコマンドは OSPF が正常に動作するために必要です。チャネル インターフェイスは、フレームリレーのようなマルチポイント インターフェイスと見なされます。ネットワーク全体で OSPF を実行しない場合は、チャネル インターフェイス自体でのみ実行して、他のルーティング プロトコル間には再配布を使用できます。次に例を示します。

!
router eigrp 1
 redistribute ospf 1
 passive-interface Channel2/0
 network 10.0.0.0
 no eigrp log-neighbor-changes
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 1
 network 10.64.3.33 0.0.0.0 area 0
!


ルータの表示

diplodocus# show extended channel 2/0 status

Path: 0100  -- ESTABLISHED
       Command    Selective   System     Device    CU
Dev    Connects    Retries    Cancels    Reset    Reset    Errors    Busy
24        30         21          1         0        0        0        0
25        29         0           1         0        0        0        0
Blocks         Bytes         Dropped Blk         Memd
Dev-Lnk    Read    Write    Read    Write    Read    Write    wait    Con
24-00       29       6      3484     789      0        0       0       Y
25-00        9      29       801    3920      0        0       0       Y
Path 0100
Total:      38      35      4285    4709      0        0       0
Last statistics 0 seconds old, next in 10 seconds

diplodocus# show extended channel 2/0 cmpc

Path    Dv    TGName    Dir    Bfrs     Status
CMPC   0100     24     DIPTG  READ  16  Active+
CMPC   0100     25     DIPTG  WRITE 16  Active+

diplodocus# show ip ospf i

Channel2/0 is up, line protocol is up
Internet Address 10.64.3.33/28, Area 0
Process ID 1, Router ID 200.100.100.9, Network Type POINT_TO_MULTIPOINT,
Cost: 4
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:10
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.64.3.17
Suppress hello for 0 neighbor(s)

diplodocus# show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address       Interface
10.64.3.17       1    FULL/  -        00:01:35
Neighbor is up for 00:04:01           10.64.3.34  Channel2/0

diplodocus# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 10.64.3.1 to network 0.0.0.0
1.0.0.0/27 is subnetted, 1 subnets
C	1.1.1.0 is directly connected, Loopback1
200.100.100.0/29 is subnetted, 1 subnets
C	200.100.100.8 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
D	10.0.0.0/8 is a summary, 00:06:40, Null0
C	10.64.3.0/28 is directly connected, Ethernet6/0
O E2	10.64.3.17/32 [110/1] via 10.64.3.34, 00:03:57, Channel2/0
O	10.64.3.16/28 [110/5] via 10.64.3.34, 00:03:57, Channel2/0
C	10.64.3.32/28 is directly connected, Channel2/0
S	10.64.3.34/32 [1/0] via 10.64.3.34, Channel2/0
S	10.64.3.37/32 [1/0] via 10.64.3.37, Channel2/0
C	10.64.3.48/28 is directly connected, Serial1/3.1
C	10.64.3.128/28 is directly connected, Serial1/3.2
S*   0.0.0.0/0 [1/0] via 10.64.3.1


メインフレームの表示

システム コンソールの VTAM 表示

D NET,TRL

IST097I DISPLAY ACCEPTED
ST350I DISPLAY TYPE = TRL 042
IST1314I TRLE = DIPTG	  STATUS = ACTIV       CONTROL = MPC
IST1454I 1 TRLE(S) DISPLAYED
IST314I END

D NET,TRL,TRLE=DIPTG

IST097I DISPLAY ACCEPTED
IST075I NAME = DIPTG, TYPE = TRLE 045
IST486I STATUS= ACTIV, DESIRED STATE= ACTIV
IST087I TYPE = LEASED		  , CONTROL = MPC , HPDT = YES
IST1715I MPCLEVEL = HPDT       MPCUSAGE = SHARE
IST1577I HEADER SIZE = 4092 DATA SIZE = 60 STORAGE = ***NA***
IST1221I WRITE DEV = 0E25 STATUS = ACTIVE     STATE = ONLINE
IST1577I HEADER SIZE = 4092 DATA SIZE = 60 STORAGE = DATASPACE
IST1221I READ  DEV = 0E24 STATUS = ACTIVE     STATE = ONLINE
IST314I END


netstat コマンドからの TSO でのルーティング情報の表示

netstat route はルーティング テーブルを表示します。次に例を示します。

===> netstat route

EZZ2350I MVS TCP/IP NETSTAT CS V2R7       TCPIP NAME: TCPIP       15:56:33
EZZ2755I Destination       Gateway       Flags  Refcnt  Interface
EZZ2756I -----------       -------       -----  ------  ---------
EZZ2757I 10.0.0.0          10.64.3.33    UG     000000  LDIPTG
EZZ2757I 10.64.3.32        0.0.0.0       U      000000  LDIPTG
EZZ2757I 10.64.3.33        0.0.0.0       UH     000000  LDIPTG

netstat device は、接続されているすべてのデバイスまたはリンクの状態などを示します。次に例を示します。

===> netstat device

EZZ2350I MVS TCP/IP NETSTAT CS V2R7	  TCPIP NAME: TCPIP	   15:58:04
EZZ2760I DevName: LOOPBACK	    DevType: LOOPBACK  DevNum: 0000
EZZ2761I   LnkName: LOOPBACK	      LnkType: LOOPBACK    Status: Ready
EZZ2762I     NetNum: 0	 QueSize: 0   ByteIn: 0000004278   ByteOut: 0000004278
EZZ2768I   BSD Routing Parameters:
EZZ2769I     MTU Size: 00000		 Metric: 00
EZZ2770I     DestAddr: 0.0.0.0		 SubnetMask: 0.0.0.0
EZZ2810I   Multicast Specific:
EZZ2811I     Multicast Capability: No
EZZ2760I DevName: DIPTG 	    DevType: MPC       DevNum: 0000
EZZ2761I   LnkName: LDIPTG	      LnkType: MPC	   Status: Ready
EZZ2762I     NetNum: 0	 QueSize: 0   ByteIn: 0000001848   ByteOut: 0000001936
EZZ2768I   BSD Routing Parameters:
EZZ2769I     MTU Size: 01470		 Metric: 01
EZZ2770I     DestAddr: 0.0.0.0		 SubnetMask: 255.255.255.240
EZZ2810I   Multicast Specific:
EZZ2811I     Multicast Capability: Yes
EZZ2812I     Group            RefCnt
EZZ2813I     -----            ------
EZZ2814I     224.0.0.5        0000000001
EZZ2814I     224.0.0.1        0000000001
EZZ2760I DevName: VIPADEV	    DevType: VIPA      DevNum: 0000
EZZ2761I   LnkName: VIPALINK	      LnkType: VIPA	   Status: Ready
EZZ2762I     NetNum: 0	 QueSize: 0   ByteIn: 0000000000   ByteOut: 0000000000
EZZ2768I   BSD Routing Parameters:
EZZ2769I     MTU Size: 01470		 Metric: 01
EZZ2770I     DestAddr: 0.0.0.0		 SubnetMask: 255.255.255.240
EZZ2810I   Multicast Specific:
EZZ2811I     Multicast Capability: No

netstat では、さらに多くのオプションを利用できます。netstat ? コマンドを実行すると、それらのオプションをすべて表示できます。



関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12257