IP : Open Shortest Path First(OSPF)

サブネット キーワードを使用した、接続ネットワークの OSPF への再配布

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2014 年 4 月 2 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、接続経路を Open Shortest Path First(OSPF)に再配布するときの動作について説明します。 接続ネットワークを再配布する際にサブネット キーワードを指定しているかどうかによって、2 とおりの動作があります。 一般に、redistribute コマンドを使用してルートを OSPF ドメインに再配布する場合、ルータは自動的に Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)になります。 デフォルトでは、プロトコルからのルートが connected キーワードを使用してOSPF に再配布されると、これらのルートは AS に対して外部として再配布されることになり、サブネット化されていないルートのみが再配布されます。 サブネット キーワードが含まれているとき、OSPF はサブネット化されるルーティングを再配布します。 プロセスはデフォルト メトリックとして「20」を使用します。 この値は、メトリック タイプのキーワードを使用してメトリックを指定していない場合に使用されます。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • 一般的な IP ルーティングに関する知識

  • OSPF ルーティング プロトコルの概念と用語に関する知識

使用するコンポーネント

この資料のコンフィギュレーションは Cisco IOS のルータに Cisco 3700 シリーズ基づいていますか。 ソフトウェア リリース ソフトウェア 12.4 (15)T 13。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

ルータ R1、R2 および R3 はシリアル インターフェイスを介して相互に接続されており、これらのルータには IP アドレスが設定されています。 R1 と R3 には、ネットワークを生成するために何らかのループバック アドレスが作成されています。 ルータ R1 と R2 では EIGRP が稼働しており、R3 は OSPF を使用して R1 と通信しています。 EIGRP と OSPF の両方が稼働しているルータ R2 は、redistribute コマンドを使用して、EIGRP ルートを OSPF に再配布します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/113339-ospf-connected-net-01.gif

設定

このドキュメントでは、次の設定を使用します。

ルータ R1
version 12.4
!
hostname R1
!
ip cef
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.240
!
interface Loopback1
 ip address 20.20.20.20 255.255.255.240
!
interface Loopback2
 ip address 30.30.30.30 255.255.255.240
!
interface Serial0/0
 ip address 172.16.10.1 255.255.248.0
 clock rate 2000000
!
router eigrp 100
 network 10.10.10.0 0.0.0.15
 network 20.20.20.16 0.0.0.15
 network 30.30.30.16 0.0.0.15
 network 172.16.8.0 0.0.7.255
 no auto-summary

!--- Auto-summary is disabled so that 
!--- the networks are summarized with subnets.

!
end

ルータ R2
version 12.4
!
hostname R2
!
ip cef
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 2.2.2.2 255.255.255.255
!
interface Loopback2
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
 ip address 172.16.10.2 255.255.248.0
 clock rate 2000000
!
interface Serial0/1
 ip address 172.16.64.1 255.255.255.0
 clock rate 2000000
!
router eigrp 100
 network 1.0.0.0
 network 3.0.0.0
 network 172.16.8.0 0.0.7.255
 auto-summary
!
router ospf 100
 log-adjacency-changes
 redistribute eigrp 100 
 redistribute connected
 network 2.2.2.2 0.0.0.0 area 0
 network 172.16.64.0 0.0.0.255 area 0
!
end

ルータ R3
version 12.4
!
hostname R3
!
ip cef
!
interface Loopback0
 ip address 11.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 12.1.1.1 255.255.255.255
!
interface Loopback2
 ip address 13.1.1.1 255.255.255.255
!
interface Serial0/0
 ip address 172.16.64.2 255.255.255.0
 clock rate 2000000
!
router ospf 100
 log-adjacency-changes
 network 11.1.1.1 0.0.0.0 area 0
 network 12.1.1.1 0.0.0.0 area 0
 network 13.1.1.1 0.0.0.0 area 0
 network 172.16.64.0 0.0.0.255 area 0
!
end

確認

接続ネットワークの OSPF への再配布の確認

このセクションでは、設定が正常に機能していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

ルータ R3 が再割り当てされたルートを受け取ったことを確認するために show ip route ospf コマンドを使用して下さい。

show ip route ospf
接続経路がルータ R2 で redistribute connected を使用して再配布された場合、次のようになります。 ルータ R3 内
R3#show ip route ospf
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 06:14:14, Serial0/0

!--- Only the classful routes are shown without actual subnets.

ルータ R2 で、subnets キーワードを指定して redistribute connected subnets で再配布された場合、次のようになります。 ルータ R3 内
R3#show ip route ospf
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 06:14:14, Serial0/0
R3#sh ip route ospf
     1.0.0.0/32 is subnetted, 1 subnets
O E2    1.1.1.1 [110/20] via 172.16.64.1, 00:00:02, Serial0/0

!--- When routes are redistributed in to OSPF, 
!--- OSPF uses 20 as the default metric if 
!--- the metric-type keyword is not mentioned
!--- and the routes are redistributed as External Type 2(E2) routes.

     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 06:36:58, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
O E2    3.3.3.3 [110/20] via 172.16.64.1, 00:00:02, Serial0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2    172.16.8.0/21 [110/20] via 172.16.64.1, 00:00:02, Serial0/0

!--- On specifying the keyword subnets, 
!--- the routes are reflected along with the subnets.



!--- Only the classful routes are shown without actual subnets.

OSPF への EIGRP ルートの再配布の確認

EIGRPルートが再配布 eigrp < プロセス ID > コマンドで OSPF に再配布されるとき、ルートは 20 のデフォルト メトリックの E2 ルートとして metric-type キーワードが規定 されないとき再配布されます。

show ip route ospf
ルータ R2 で redistribute eigrp 100 コマンドを使用して EIGRP が再配布される場合、次のようになります。 ルータ R3 内
R3#show ip route ospf
O E2 1.0.0.0/8 [110/20] via 172.16.64.1, 00:00:09, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 07:03:16, Serial0/0
O E2 3.0.0.0/8 [110/20] via 172.16.64.1, 00:00:09, Serial0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2    172.16.0.0/16 [110/20] via 172.16.64.1, 00:00:09, Serial0/0

!--- Only classful networks are redistributed by default.

ルータ R2 で redistribute eigrp 100 subnets コマンドにサブネット キーワードを指定した場合、次のようになります。 ルータ R3 内
R3#sh ip route ospf
O E2 1.0.0.0/8 [110/20] via 172.16.64.1, 00:06:19, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 07:09:26, Serial0/0
O E2 3.0.0.0/8 [110/20] via 172.16.64.1, 00:06:19, Serial0/0
     20.0.0.0/28 is subnetted, 1 subnets
O E2    20.20.20.16 [110/20] via 172.16.64.1, 00:00:06, Serial0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2    172.16.0.0/16 [110/20] via 172.16.64.1, 00:06:19, Serial0/0
     10.0.0.0/28 is subnetted, 1 subnets
O E2    10.10.10.0 [110/20] via 172.16.64.1, 00:00:06, Serial0/0
     30.0.0.0/28 is subnetted, 1 subnets
O E2    30.30.30.16 [110/20] via 172.16.64.1, 00:00:06, Serial0/0

!--- On specifying the keyword subnets, 
!--- the subnetted routes are reflected along
!--- with their subnet mask.

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 113339