IP : 拡張内部ゲートウェイ ルーティング プロトコル(EIGRP)

EIGRP IPv6 の設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、IPv6 の Enhanced Interior Gateway Routing Protocol(EIGRP)を設定する方法について説明します。 EIGRP は Cisco によって開発される IGRP の拡張バージョンです。 ネットワーク内の宛先に最短パスを計算するために Diffused Update Algorithm (DUAL)に頼るのは強化された距離ベクトル プロトコルです。 IPv6 のための EIGRP はそれらが別々に設定・管理することができる EIGRP IPv4 と同様にはたらきます。

前提条件

  • EIGRPv4 の基本的な知識

  • IPv6 当たることの基本的な知識

制約事項

IPv6 のための EIGRP を設定することにいくつかの制限があります; それらは下記のようにリストされています:

  • インターフェイスはグローバル な IPv6 アドレスの使用なしで IPv6 のための EIGRP で直接、設定することができます。 IPv6 のための EIGRP にネットワークステートメントがありません。

  • Router ID は動作できる前に EIGRPv6 プロトコル インスタンスのために設定される必要があります。

  • IPv6 のための EIGRP にシャットダウン機能があります。 経路制御プロセスがプロトコルを作動させ始めるべき「no shut」モードにあるようにして下さい。

使用するコンポーネント

この資料のコンフィギュレーションは Cisco IOS ソフトウェア リリース 12.4(15)T 13 のルータに Cisco 3700 シリーズ基づいています。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この例では、2 人のルータは IPv6 アドレスで(R1 および R2)設定されます。 ループバックアドレスは両方のルータで割り当てられ、EIGRP1 にあるために設定されます。 EIGRPv6 はこのコマンドを使用してインターフェイス レベルごとに有効に なります: IPv6 eigrp as-number

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

この例では、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/113267-eigrp-ipv6-01.gif

設定

この例では、次の設定を使用します。

R1 の設定
hostname R1
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 1010:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback1
 no ip address
 ipv6 address 2020:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback2
 no ip address
 ipv6 address 3030:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Serial0/0
 no ip address
 ipv6 address FE80::1 link-local
 ipv6 address 2010:AB8::1/64
 ipv6 enable
 ipv6 eigrp 1
 clock rate 2000000
!
ipv6 router eigrp 1
 router-id 2.2.2.2
 no shutdown
!
end

R2 の設定
hostname R2
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 1000:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback1
 no ip address
 ipv6 address 2000:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback2
 no ip address
 ipv6 address 3000:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Serial0/0
 no ip address
 ipv6 address FE80::2 link-local
 ipv6 address 2010:AB8::2/64
 ipv6 enable
 ipv6 eigrp 1
 clock rate 2000000
!
ipv6 router eigrp 1
 router-id 1.1.1.1
 no shutdown
!
end

確認

ここでは、設定が正常に動作していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

show コマンド

提示 IPv6 EIGRPネイバはコマンド EIGRPv6 によって検出される隣接を表示する。

IPv6 EIGRPネイバを示して下さい
ルータ R1
IPv6-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                            (sec)         (ms)       Cnt Num
0   Link-local address:     Se0/0             13 15:17:58   44   264  0  12
    FE80::2

!--- Shows the link local address of router R2. 

ルータ R2
IPv6-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                            (sec)         (ms)       Cnt Num
0   Link-local address:     Se0/0             14 16:32:05   30   300  0  12
    FE80::1

!--- Shows the link local address of router R1. 

show ipv6 route EIGRP コマンドは EIGRP に特定のルーティングを含む IPv6 ルーティング テーブルのコンテンツを示します。

show ipv6 route eigrp
ルータ R1
R1#show ipv6 route eigrp
IPv6 Routing Table - 12 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
D   1000:AB8::/64 [90/2297856]
     via FE80::2, Serial0/0
D   2000:AB8::/64 [90/2297856]
     via FE80::2, Serial0/0
D   3000:AB8::/64 [90/2297856]
     via FE80::2, Serial0/0

!--- This command shows IPv6-specific EIGRP routes.

ルータ R2
R2#show ipv6 route eigrp
IPv6 Routing Table - 12 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
D   1010:AB8::/64 [90/2297856]
     via FE80::1, Serial0/0
D   2020:AB8::/64 [90/2297856]
     via FE80::1, Serial0/0
D   3030:AB8::/64 [90/2297856]
     via FE80::1, Serial0/0

提示 IPv6 eigrp interface コマンドは EIGRP のために設定されるインターフェイスについての情報を表示するものです。

IPv6 eigrp interface を示して下さい
ルータ R1
R1#show ipv6 eigrp 1 interface
IPv6-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              1        0/0        44       0/15         199           0
Lo0                0        0/0         0       0/1            0           0
Lo1                0        0/0         0       0/1            0           0
Lo2                0        0/0         0       0/1            0           0

!--- This command determines which interface EIGRP is active.

ルータ R2
R2#show ipv6 eigrp 1 interface
IPv6-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              1        0/0        30       0/15         135           0
Lo0                0        0/0         0       0/1            0           0
Lo1                0        0/0         0       0/1            0           0
Lo2                0        0/0         0       0/1            0           0

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 113267