IP : ホット スタンバイ ルータ プロトコル(HSRP)

IPv6 HSRP の設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2013 年 10 月 3 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、ホット スタンバイ ルータ プロトコル(HSRP)を IPv6 用に設定する方法について説明します。 アクティブ ルータとスタンバイ ルータを選択するには、ルータのグループ内で HSRP を使用します。 ルータ インターフェイスのグループでは、アクティブ ルータが、パケットのルーティングのために選択するルータです。 アクティブ ルータで障害が発生したとき、または事前設定の条件が満たされたときは、スタンバイ ルータが引き継ぎます。 HSRP は、IPv6 ホストに仮想ファースト ホップだけを提供するように設計されています。

HSRP IPv6 グループには、HSRP グループ番号に基づく仮想 MAC アドレス、およびデフォルトで HSRP 仮想 MAC アドレスに基づく HSRP の仮想 IPv6 リンクローカル アドレスがあります。 HSRP グループがアクティブな場合、定期的なルート アドバタイズメント(RA)が HSRP 仮想 IPv6 リンクローカル アドレス宛てに送信されます。 これらの RA は、グループがアクティブ状態ではなくなるときに最後の RA が送信されると停止します。

HSRP では、プライオリティ メカニズムを使用して、デフォルトのアクティブ ルータにする HSRP 設定済みルータを決定します。 ルータをアクティブ ルータとして設定するには、他のすべての HSRP 設定済みルータのプライオリティよりも高いプライオリティをそのルータに割り当てる必要があります。 デフォルトのプライオリティは 100 です。 このため、1 つのみのルータのプライオリティを高く設定すると、そのルータがデフォルトのアクティブ ルータになります。 HSRP バージョン 2 では新しい IP マルチキャスト アドレス 224.0.0.102 を使用して hello パケットを送信します。バージョン 1 では、このマルチキャスト アドレスが 224.0.0.2 です。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • HSRP の設定に関する知識。 詳細は、『HSRP の設定』を参照してください。

  • IPv6 アドレッシングと基本接続を実装する基礎知識。 詳細については、「IPv6 アドレッシングおよび基本的な接続の実装」を参照してください。

  • HSRP IPv6 を設定する前に、インターフェイスに対して HSRP バージョン 2 をイネーブルにする必要があります。

  • HSRP IPv6 を設定するには、IPv6 ユニキャスト ルーティングをデバイスで有効にする必要があります。

使用するコンポーネント

このドキュメントの設定は、Cisco IOS Software Release ソフトウェア 12.4 (15)T 13 の Cisco 3700 シリーズ ルータに基づきます。

注: IPv6 コマンドのライセンス情報を確認してください。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

ルータ R1 と R2 は、シリアル インターフェイスを介して R3 に接続します。 R1 と R2 のファスト イーサネット インターフェイスは、R1 がアクティブ ルータ、R2 がスタンバイ ルータとして動作するような方法で HSRP IPv6 で設定されています。 R1 のシリアル インターフェイス S0/0 がダウンすると、R2 ルータの状態がスタンバイからアクティブに変わります。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/hot-standby-router-protocol-hsrp/113216-ipv6-hsrp-01.gif

設定

このドキュメントでは、次の設定を使用します。

次のビデオへのリンクを参照してください(Cisco サポート コミュニティ で利用可能)。Cisco IOS ルータで IPv6 用に HSRP を設定する方法が説明されています。leavingcisco.com

IPv6 の HSRP の設定 leavingcisco.com

http://www.cisco.com/c/dam/en/us/support/docs/ip/hot-standby-router-protocol-hsrp/113216-ipv6-hsrp-02.gif

ルータ R1 の設定
R1#show run
Building configuration...
!
hostname R1
!
ip cef
!
ipv6 unicast-routing
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:AB8:2001::1010/64
 ipv6 enable
 standby version 2
 standby 1 ipv6 autoconfig

!--- Assigns a standby group and standby IP address.


 standby 1 priority 120


!--- R1 is configured as the active router.
!--- This is done by assigning a priority value 
!--- (in this case 120) to the router's Fa0/0 interface.
!--- The default priority value is 100.


 standby 1 preempt delay minimum 30


!--- The preempt command allows the router to become the 
!--- active router when it has the priority higher than 
!--- all the other HSRP-configured routers. 
!---- Without this command, even if a router has higher 
!--- priority value, it will not become an active router.
!--- The delay minimum value causes the local router to postpone
!--- taking over the active role for a minimum of 30 seconds.


 standby 1 track Serial0/0 90


!--- Indicates that HSRP tracks serial0/0.
!--- The interface priority is configured (in this case 90) which 
!--- indicates that if the tracked interface goes down the router 
!--- priority value is to be decremented by 90. 
!--- Default decrement value is 10.

!
interface Serial0/0
 no ip address
 ipv6 enable
 ipv6 address 2010:AB8:2001::1010/64
 clock rate 2000000
!
end

ルータ R2 の設定
R2#show run
Building configuration...
!
hostname R2
!
ip cef
!
ipv6 unicast-routing
!
interface FastEthernet0/0

!--- R2 is configured as a standby router
!--- with a default priority value of 100.

 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:AB8:2001::1011/64
 ipv6 enable
 standby version 2
 standby 1 ipv6 autoconfig
 standby 1 preempt delay minimum 30
 standby 1 track Serial0/0
!
interface Serial0/0
 no ip address
 ipv6 address 2010:AB8:2010::1020/64
 ipv6 enable
 clock rate 2000000
!
end

ルータ R3 設定
R3#show run
Building configuration...
!
hostname R3
!
ip cef
!
ipv6 unicast-routing
!
interface Serial0/0
 no ip address
 ipv6 address 2010:AB8:2001::1011/64
 ipv6 enable
 clock rate 2000000
!
interface Serial0/1
 no ip address
 ipv6 address 2010:AB8:2010::1021/64
 clock rate 2000000
!
end

確認

設定を確認するには、R1 と R2 ルータで show standby コマンドを使用します。

ルータ R1
R1#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Active 
!--- R1 router is in Active state.

    4 state changes, last state change 02:51:30
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.480 secs
  Preemption enabled, delay min 30 secs
  Active router is local
  Standby router is FE80::C010:21FF:FE78:0, priority 100 (expires in 7.036 sec)
  Priority 120 (configured 120)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

ルータ R2
R2#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Standby
!--- R2 router is in Standby state.

    4 state changes, last state change 02:51:43
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.900 secs
  Preemption enabled, delay min 30 secs
  Active router is FE80::C00F:21FF:FE78:0, priority 120 (expires in 9.928 sec)
    MAC address is c20f.2178.0000
  Standby router is local
  Priority 100 (default 100)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

アクティブ ルータ(この例では R1)がダウンすると、次のテーブルのようにスタンバイ ルータの状態がすぐにアクティブに変わります。

アクティブ ルータ(R1)がダウンすると
ルータ R1
R1(config)#interface s0/0
R1(config-if)#shut
R1(config-if)#exit
*Mar  1 00:01:34.879: %LINK-5-CHANGED: Interface Serial0/0, changed state to 
      administratively down
*Mar  1 00:01:35.879: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, 
      changed state to down
R1#
*Mar  1 00:04:06.691: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Mar  1 00:04:36.175: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Active -> Speak
R1#
*Mar  1 00:04:46.175: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Speak -> Standby

!--- When the interface goes down, the active router changes its state to Standby.

ルータ R2
*Mar  1 00:04:35.631: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Standby ->Active


!--- The standby router is now the active router.
 

R2#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Active
    2 state changes, last state change 00:10:39
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.532 secs
  Preemption enabled, delay min 30 secs
  Active router is local
  Standby router is FE80::C00F:21FF:FE78:0, priority 30 (expires in 7.524 sec)
  Priority 100 (default 100)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 113216