IP : Open Shortest Path First(OSPF)

OSPFv3 仮想リンクの設定例

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Open Shortest Path First バージョン 3(OSPFv3)の仮想リンクの設定の例を示します。 OSPFv3 は、OSPF バージョン 2 を拡張したもので、IPv6 ルーティング プレフィックスと大きいサイズの IPv6 アドレスのサポートを提供します。

仮想リンクごとに、マスター セキュリティ情報データブロックが作成されます。 各インターフェイスでセキュア ソケットをオープンする必要があるため、中継エリア内のインターフェイスごとに、対応するセキュリティ情報データブロックが存在することになります。 セキュア ソケット ステートは、インターフェイスのセキュリティ情報データブロック内に保持されます。 マスター セキュリティ情報データブロック内のステート フィールドは、仮想リンクに対してオープンされたすべてのセキュア ソケットのステータスを反映しています。 すべてのセキュア ソケットが UP の場合、仮想リンクのセキュリティ ステートは UP に設定されます。

IPsec が設定された仮想リンクで送信されるパケットは、事前に決定された送信元アドレスと宛先アドレスを使用する必要があります。 エリアのルータのエリア内プレフィックス LSA で検出された最初のローカル エリア アドレスが、送信元アドレスとして使用されます。 この送信元アドレスはエリア データ構造で保存されます。セキュア ソケットがオープンされ、パケットが仮想リンク経由で送信されるときにこの送信元アドレスが使用されます。 送信元アドレスが選択されるまで、仮想リンクはポイントツーポイント ステートに移行しません。 また、送信元アドレスまたは宛先アドレスが変更された場合は、以前のセキュア ソケットをクローズして、新しいセキュア ソケットをオープンする必要があります。

この設定例では、ルータ コンフィギュレーション モードで OSPF 仮想リンクを定義する area virtual-link コマンドを使用します。

注: 仮想リンクを正しく設定するには、各仮想リンク ネイバーに、中継エリア ID および対応する仮想リンク隣接ルータ ID が含まれている必要があります。 ルータ ID を表示するには、show ip ospf EXEC コマンドを使用します。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • ご使用の IPv6 ネットワークに対する OSPF ネットワーク戦略と計画を完成させます。

  • IPv6 ユニキャスト ルーティングをイネーブルにします。

  • インターフェイスで IPv6 をイネーブルにします。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

この資料のコンフィギュレーションは Cisco IOS のルータに Cisco 3700 シリーズ基づいていますか。 ソフトウェア リリース ソフトウェア 12.4 (15)T 13。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/113204-ospfv3-vlink-config-01.gif

設定

このドキュメントでは、次の設定を使用します。

  • ルータ R1

  • ルータ R2

  • ルータ R3

  • ルータ R4

ルータ R1
hostname R1
! 
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:1::1/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:1::1/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
ipv6 router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes

ルータ R2
hostname R2
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:2::2/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:1::2/64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface Serial2/0
 no ip address
 ipv6 address 2011:8:8:2::2/64
 ipv6 enable
 ipv6 ospf 10 area 23
 serial restart-delay 0
 clock rate 64000
 !
ipv6 router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
 area 23 virtual-link 3.3.3.3
!

ルータ R3
hostname R3
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:3::3/64
 ipv6 enable
 ipv6 ospf 10 area 23
 !

interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:3::3/64
 ipv6 enable
 ipv6 ospf 10 area 34
 !
interface Serial2/0
 no ip address
 ipv6 address 2011:8:8:2::3/64
 ipv6 enable
 ipv6 ospf 10 area 23
 serial restart-delay 0
 !
ipv6 router ospf 10
 router-id 3.3.3.3
 log-adjacency-changes
 area 23 virtual-link 2.2.2.2
!

ルータ R4
hostname R4
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:4::4/64
 ipv6 enable
 ipv6 ospf 10 area 34
 !
interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:3::4/64
 ipv6 enable
 ipv6 ospf 10 area 34
 !
ipv6 router ospf 10
 router-id 4.4.4.4
 log-adjacency-changes
!

確認

設定を確認するには、次のコマンドを使用します。

ルータ R1 内

この出力は、ルータ R1 がルータ R4 のループバック アドレスに対して ping を正常に実行できることを示しています。

ping ipv6
R1#ping ipv6
Target IPv6 address: fe01:4::4

Ping Loopback 0 interface of R4
   	
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands? [no]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE01:4::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/72/96 ms

ルータ R2 内

show ipv6 ospf neighbor コマンドは、インターフェイスごとのネイバー情報を提供します。

show ipv6 ospf neighbor
R2# show ipv6 ospf neighbor

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
3.3.3.3                 0   FULL/  -                -                22        OSPFv3_VL0   

Virtual Link Between R2 & R3
       
1.1.1.1                 1   FULL/DR         00:00:35         4                 Ethernet1/0
3.3.3.3                 0   FULL/  -           00:00:31      12                Serial2/0

ルータ R4 内

この出力は、ルータ R4 がルータ R1 のループバック インターフェイスに対して ping を正常に実行できることを示しています。

ping ipv6
R4#ping ipv6
Target IPv6 address: fe01:1::1				

Ping Loopback 0 interface of R1

Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands? [no]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE01:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/100/224 ms

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 113204