音声 : メディア ゲートウェイ コントロール プロトコル(MGCP)

VRF の対応ルータの MGCP サポートの設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Voice Routing and Forwarding(VRF)の有効なルータで、メッセージ ゲートウェイ コントロール プロトコル(MGCP)を設定する方法について説明します。

MGCP を見なすことを理解するはずである 2 つの主要な要素があります:

  • エンドポイント

  • コール エージェント

エンドポイントとは、指定されたゲートウェイ上にある任意の音声ポートです。 これらの音声ポートは PSTN にアナログポートへの接続、外国為替事務所 (FXO)/Foreign Exchange Station (FXS)のような、およびデジタルトランクを、T1 または E1 のような、提供します。 ゲートウェイは含まれているポートの数に依存した複数のエンドポイントがある場合があります。

コール エージェントは音声システムの外部制御デバイスです。 このドキュメントでは、Cisco CallManager がコール エージェントに相当します。 MGCP におけるコール エージェントは、ゲートウェイを完全に制御できるデバイスです。 すべての管理がコール エージェントによって実行されるので、これは非常に効率的なシステムです。 すべてのルート パターンとダイヤル プランの設定は Cisco CallManager で行うので、ゲートウェイ側で行う必要がある設定作業はごくわずかです。

このプロトコルは制御だけを目的として使用されることに注意してください。 MGCP プロトコル自体は、音声データの転送には使用されません。 音声データの転送はすべて、電話機とゲートウェイの間で直接行われます。 このグラフィックは MGCP 通信関係を描写します:

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-01.gif

この使用中例の Cisco IP 電話 Cisco Unified CallManager と通信する Skinny Client Control Protocol(SCCP)。 実際の音声データは、Real-time Transport Protocol(RTP; リアルタイム転送プロトコル)を使用して、2 つのデバイス間で直接転送されます。 MGCP はゲートウェイの制御だけを目的として Cisco CallManager により使用されます。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS ソフトウェア バージョン 12.4(24)T 4

  • Cisco 2800 シリーズ ルータ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

MGCP および VRF ライト

VRF ルーティングインテリジェンスは MGCP プロトコルにありません。

MGCP が「VRF わかっている」プロトコルではないので、音声 VRF に MGCP トラフィックを入れるために IOS音声ゲートウェイを設定できません。 MGCP トラフィックは VRF コンフィギュレーションに関係なくだけルータのデフォルト ルーティング ルーティング・テーブルを使用します。

典型的な VRF 配備の MGCP をサポートする 2 つのソリューションがあります。 この典型的な VRF ネットワークシナリオを参照して下さい:

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-02.gif

2 人のルータを使用する MPLS VRF ルーティングをする第 2 ルータにイーサネットトラフィックを提供する基本的なルータ(VRF 無し)として機能している MGCP ゲートウェイとの 1 つを、すなわち、確立できます。 それがちょうどルーティング手法である MGCP が気づいていないのでそれから VRF ルータ上の MGCP トラフィックをルーティングでき。

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-03.gif

もう一つの同じようなソリューションは単一 VRF ルータを使用し、音声ネットワークに MGCP トラフィックを送信するのに第 2 利用可能 な インターフェイスを利用することです。

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-04.gif

スイッチングネットワークの voice VLAN にインターフェイスを接続することは VRF インターフェイスおよび最終的に CallManager によってルータに再びルーティングされるに MGCP プロトコルを可能にします。

VRF ルータ VRF インターフェイスの IP をまたは voice VLAN を離れて DHCPアドレスを与えられる必要だけのグローバル な ルート指す IP およびスタティック ルート。 これらのコンフィギュレーションの詳細を参照して下さい:

hostname VRF_MGCP_rtr
!
ip DATA
rd 65232:1
route-target export 65232:1
route-target import 65232:1
!
ip VOICE
rd 65232:3
route-target export 65232:3
route-target import 65232:3
!
interface GigabitEthernet0/0
 description MGCP interface
 ip address dhcp 
!-- USE DHCP or Static IP address from VOICE VLAN

!
interface GigabitEthernet0/1
 no ip address
 duplex full
 speed auto
 no keepalive
!
interface GigabitEthernet0/1.100
description DATA VLAN
encapsulation dot1Q 1 native
ip forwarding DATA
ip address 10.1.232.1 255.255.255.0
ntp broadcast
!
Interface GigabitEthernet0/1.300
Description VOICE VLAN
encapsulation dot1Q 2
ip forwarding VOICE
ip address 10.2.20.129 255.255.255.128
!
Interface Serial0/0/0
no ip address
no encapsulation ppp
encapsulation frame-relay IETF
!
interface Serial0/0/0.100 point-to-point
description DATA PVC
ip forwarding DATA
ip address 10.1.52.198 255.255.255.252
frame-relay interface-dlci 100 IETF
!
interface Serial0/0/0.300 point-to-point
description VOICE PVC
ip forwarding VOICE
ip address 10.2.54.198 255.255.255.252
frame-relay interface-dlci 300 IETF
!
mgcp
mgcp call-agent 10.1.255.241 2427 service-type mgcp version 0.1
mgcp bind control source-interface GigabitEthernet0/0 
!-- Bind to MGCP Interface

mgcp bind media source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!

確認

現在、この設定に使用できる確認手順はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 113180