IP : IP バージョン 6

IPv6 トラフィック フィルタリングのアクセス リストの設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、IPv6 アクセス リストの設定例を紹介します。 この資料に説明がある例ではルータ R1 および R2 は IPv6 アドレス方式で設定され、シリアルリンクを通して接続されます。 2 人のルータで有効に なる ルーティング プロトコルは IPv6 OSPF であり、両方のルータで設定されるループバックアドレスはこのコマンドでエリア 0 で(R1 および R2)互いにアドバタイズされます: IPv6 OSPFのプロセスID エリア エリアID [例例 ID]。 この例ではルータ R2 のループバック 0 インターフェイスから発信し、ルータ R1 のループバックインターフェイス 4 に達する Telnetトラフィックを拒否することを、必要とします。

この設定例はルータ R1 の IPv6 アクセス リスト(ネームド DENY_TELNET_Lo4)を組み立てるために IPv6 access-list access-list-name コマンドを使用します。 Deny ステートメント deny TCP ホスト 400A:0:400C::1 ホスト 1001:ABC:2011:7::1 eq telnet は割り当て文割り当て IPv6 あらゆるに先行しています。

IPv6 ACL をインターフェイスに割り当てるために、インターフェイス設定モードでこのコマンドを使用して下さい: IPv6 トラフィック フィルタ access-list-name {で | }

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

使用するコンポーネント

この文書に記載されている情報は Cisco IOS ソフトウェア リリース 15.1 の Cisco 7200 シリーズ ルータに基づいています(ルータ R1 および R2 コンフィギュレーションのために)。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113126-ipv6-acl-01.gif

設定

このドキュメントでは、次の設定を使用します。

  • ルータ R1

  • ルータ R2

ルータ R1
R1#show running-config

version 15.0
!
hostname R1
ip source-route
ip cef
!
no ip domain lookup
ipv6 unicast-routing

!--- Enables the forwarding of IPv6 packets.

ipv6 cef

interface Loopback1
 no ip address
 ipv6 address 100A:0:100C::1/64
 ipv6 enable
 ipv6 ospf 10 area 0

!--- Enables OSPFv3 on the interface and associates


!--- the interface looback1 to area 0.

 !
!
interface Loopback2
 no ip address
 ipv6 address 200A:0:200C::1/64
 ipv6 ospf 10 area 0
 !
!
interface Loopback3
 no ip address
 ipv6 address 300A:0:300C::1/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
!
interface Loopback4
 no ip address
 ipv6 address 400A:0:400C::1/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
interface Serial1/0
 no ip address
 ipv6 address AB01:2011:7:100::/64 eui-64
 ipv6 enable
 ipv6 ospf network point-to-point

!--- Sets the OSPFv3 network type as point-to-point.

 ipv6 ospf 10 area 0
 ipv6 traffic-filter DENY_TELNET_Lo4 in

!--- Filters the traffic based on access list.

 serial restart-delay 0
 clock rate 64000
 !
ipv6 router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes
!
ipv6 access-list DENY_TELNET_Lo4
 sequence 20 deny tcp host 400A:0:400C::1 host 1001:ABC:2011:7::1 eq telnet

!--- Denies telnet access to Lo4 from Lo1 of router R2.

 permit ipv6 any any
!
end

ルータ R2
R2#show running-config

version 15.0
hostname R2
ip source-route
ip cef
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address 1001:ABC:2011:7::1/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
!
interface Serial1/0
 no ip address
 ipv6 address AB01:2011:7:100::/64 eui-64
 ipv6 enable
 ipv6 ospf network point-to-point
 ipv6 ospf 10 area 0
 serial restart-delay 0
 !
ipv6 router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
!
end

確認

設定を確認するために、ping コマンドを使用して下さい。

ルータ R2

この出力例はルータ R2 がルータ R1 のループバックインターフェイスに達することができることを示します:

R2#ping ipv6 400A:0:400C::1 source lo0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 400A:0:400C::1, timeout is 2 seconds:
Packet sent with a source address of 1001:ABC:2011:7::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/32/44 ms

ルータ R2 のループバック 0 インターフェイスからのルータ R1 の telent ループバック 4 インターフェイスを試みて下さい。

R2#telnet 400A:0:400C::1 /source-interface lo0
Trying 400A:0:400C::1, 23 ...
% Connection refused by remote host

上記の ouput は telnet がリモートホストによって否定されることを確認します(すなわち、ルータ R1 によって)。

この例に示すようにルータ R1 で作成されるアクセス リストをチェックするために提示 IPv6 access-list DENY_TELNET_Lo4 コマンドを使用して下さい:

ルータ R1

R1#
show ipv6 access-list DENY_TELNET_Lo4

IPv6 access list DENY_TELNET_Lo4
    deny tcp host 400A:0:400C::1 host 1001:ABC:2011:7::1 eq telnet sequence 20    
    permit ipv6 any any (82 matches) sequence 30

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 113126