IP : IP バージョン 6(IPv6)

IPv6 シリアル リンクでの PPP CHAP/PAP の認証の設定例

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、IPv6 シリアル リンク上でのポイントツーポイント プロトコル(PPP)によるチャレンジ ハンドシェイク認証プロトコル(CHAP)およびパスワード認証プロトコル(PAP)認証の設定例を紹介します。

PAP または CHAP をイネーブルにすると、ローカル ルータは、リモート デバイスにデータ トラフィックの送受信を許可する前に、ID を証明するように要求します。 PAP 認証では、ローカル ユーザ名データベース内またはリモート セキュリティ サーバ データベース内の一致するエントリに照らし合わせてチェックする名前とパスワードを送信するために、リモート デバイスが必要です。 CHAP 認証はリモート デバイスにチャレンジ メッセージを送信します。 リモート デバイスは、共有秘密を使用してチャレンジの値を暗号化し、暗号化された値とその名前を応答メッセージでローカル ルータに戻します。 ローカル ルータはリモート デバイスの名前をローカル ユーザ名またはリモート セキュリティ サーバ データベースに保存された関連秘密に一致させようとします。 保存された秘密を使用して元のチャレンジを暗号化し、暗号化された値が一致していることを確認します。

前提条件

要件

この設定を行う前に、以下の要件を満たしていることを確認してください。

  • PAP/CHAP 認証プロセスを理解している

  • 基本的な IPv6 を理解している

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS ソフトウェア リリース 12.4、拡張 IP サービス機能セット

  • Cisco 3700 シリーズ マルチサービス アクセス ルータ

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

例では、ルータ R1 と R2 は、PPP 認証を使用して設定されています。 ルータ R1 では、インターフェイス S1/0 は IPv6 がイネーブルにされています。EUI-64 を実装することにより、このインターフェイスの IPv6 のアドレスは 2011:2706:ABC::/64 eui-64 になります。 Extended Unique Identifier(EUI)によって、ホストは自己の一意の 64 ビット IPv6 インターフェイス ID を自動的に割り当てることができます。手動設定や DHCP は必要ありません。 これは、すでに一意の 48 ビット MAC アドレスを参照し、その値を再フォーマットして EUI-64 仕様と一致させることによって、イーサネットのインターフェース上で行われます。 同様に、ルータ R2 の S1/0 インターフェイスもイネーブルにされています。アドレスは 2011:2706:ABC::/64 eui-64 になります。

設定

ルータ R1 と R2 は、基本の PPP/CHAP 認証を使用して設定されます。

ネットワーク図

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113073-ppp-chap-ipv6-01.gif

設定

このドキュメントでは、次の設定を使用します。

R1 の設定
hostname R1
!
aaa new-model
!
aaa authentication ppp default local
!
username R2 password 0 cisco

interface Serial1/0
 no ip address
 encapsulation ppp
 ipv6 address 2011:2706:ABC::/64 eui-64
 ipv6 enable
 no fair-queue
 ppp authentication chap callin
!

R2 の設定
interface Serial1/1
 no ip address
 encapsulation ppp
 ipv6 address 2011:2706:ABC::/64 eui-64
 ipv6 enable
 clock rate 64000
 ppp chap hostname R2
 ppp chap password 0 cisco

確認

このセクションでは、設定が正しく動作していることを確認するための方法について説明します。

ルータ R1 上で、次のコマンドを発行します。

  1. debug ppp negotiation

    debug ppp negotiation
    
    
    *Jun 27 08:34:56:357: Se1/0 PPP: Outbound cdp packet dropped
    *Jun 27 08:34:56:845: %SYS-5-CONFIG_|: Configured from console by console
    *Jun 27 08:34:58:357: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
    *Jun 27 08:34:58:357: Se1/0 PPP: Using default call direction
    *Jun 27 08:34:58:357: Se1/0 PPP: Treating connection as a dedicated line
    *Jun 27 08:34:58:357: Se1/0 PPP: Session handle[470002F8] Session id[29]
    *Jun 27 08:34:58:357: Se1/0 PPP: Phase is ESTABLISHING, Active Open
    *Jun 27 08:34:58:357: Se1/0 LCP: O CONFREQ [Closed] id 72 len 15
    *Jun 27 08:34:58:357: Se1/0 LCP:  AuthProto CHAP (0x0305C22305)
    *Jun 27 08:34:58:357: Se1/0 LCP:  MagicNumber 0x35B44C0F (0x050635B44C0F)
    *Jun 27 08:34:58:361: Se1/0 LCP: I CONFREQ {REQsent] id 59 len 10
    *Jun 27 08:34:58:361: Se1/0 LCP:  MagicNumber 0x1FEDF9A2 (0x05061FEDF9A2)
    *Jun 27 08:34:58:361: Se1/0 LCP: O CONFACK {REQsent] id 59 len 10
    *Jun 27 08:34:58:361: Se1/0 LCP:  MagicNumber 0x1FEDF9A2 (0x05061FEDF9A2)
    *Jun 27 08:34:58:365: Se1/0 LCP: I CONFACK {ACKsent] id 72 len 15
    *Jun 27 08:34:58:365: Se1/0 LCP:  AuthProto CHAP (0x0305C22305)
    *Jun 27 08:34:58.365: Se1/0 LCP:    MagicNumber 0x35B44C0F (0x050635B44C0F)
    *Jun 27 08:34:58.365: Se1/0 LCP: State is Open
    *Jun 27 08:34:58.365: Se1/0 PPP: Phase is AUTHENTICATING, by this end
    *Jun 27 08:34:58.365: Se1/0 CHAP: O CHALLENGE id 5 len 23 from "R1"
    *Jun 27 08:34:58.377: Se1/0 CHAP: I RESPONSE id 5 len 23 from "R2"
    *Jun 27 08:34:58.377: Se1/0 PPP: Phase is FORWARDING, Attempting Forward
    *Jun 27 08:34:58.377: Se1/0 PPP: Phase is AUTHENTICATING, Unauthenticated User
    *Jun 27 08:34:58.381: Se1/0 PPP: Phase is FORWARDING, Attempting Forward
    *Jun 27 08:34:58.381: Se1/0 PPP: Phase is AUTHENTICATING, Authenticated User
    *Jun 27 08:34:58.381: Se1/0 CHAP: O SUCCESS id 5 len 4
    *Jun 27 08:34:58.381: Se1/0 PPP: Phase is UP
    *Jun 27 08:34:58.381: Se1/0 CDPCP: O CONFREQ [Closed] id 1 len 4
    *Jun 27 08:34:58.381: Se1/0 IPV6CP: O CONFREQ [Closed] id 1 len 14
    *Jun 27 08:34:58.381: Se1/0 IPV6CP:    Interface-Id 021B:54FF:FEA9:24B0 
        (0x010A021B54FFFEA924B0)
    *Jun 27 08:34:58.381: Se1/0 PPP: Process pending ncp packets
    *Jun 27 08:34:58.389: Se1/0 CDPCP: I CONFREQ [REQsent] id 1 len 4
    *Jun 27 08:34:58.389: Se1/0 CDPCP: O CONFACK [REQsent] id 1 len 4
    *Jun 27 08:34:58.389: Se1/0 IPV6CP: I CONFREQ [REQsent] id 1 len 14
    *Jun 27 08:34:58.389: Se1/0 IPV6CP:    Interface-Id 021F:CAFF:FE04:F918 
        (0x010A021FCAFFFE04F918)
    *Jun 27 08:34:58.389: Se1/0 IPV6CP: O CONFACK [REQsent] id 1 len 14
    *Jun 27 08:34:58.389: Se1/0 IPV6CP:    Interface-Id 021F:CAFF:FE04:F918 
        (0x010A021FCAFFFE04F918)
    *Jun 27 08:34:58.393: Se1/0 CDPCP: I CONFACK [ACKsent] id 1 len 4
    *Jun 27 08:34:58.393: Se1/0 CDPCP: State is Open
    *Jun 27 08:34:58.393: Se1/0 IPV6CP: I CONFACK [ACKsent] id 1 len 14
    *Jun 27 08:34:58.393: Se1/0 IPV6CP:    Interface-Id 021B:54FF:FEA9:24B0 
        (0x010A021B54FFFEA924B0)
    *Jun 27 08:34:58.393: Se1/0 IPV6CP: State is Open
    *Jun 27 08:34:59.381: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0,
        changed state to up
    
  2. debug ppp authentication

    *Jun 27 08:37:46.045: Se1/0 PPP: Using default call direction
    *Jun 27 08:37:46.045: Se1/0 PPP: Treating connection as a dedicated line
    *Jun 27 08:37:46.045: Se1/0 PPP: Session handle[C40002F9] Session id[30]
    *Jun 27 08:37:46.045: Se1/0 PPP: Authorization NOT required
    *Jun 27 08:37:46.053: Se1/0 CHAP: O CHALLENGE id 6 len 23 from "R1"
    *Jun 27 08:37:46.065: Se1/0 CHAP: I RESPONSE id 6 len 23 from "R2"
    *Jun 27 08:37:46.065: Se1/0 PPP: Sent CHAP LOGIN Request
    *Jun 27 08:37:46.065: Se1/0 PPP: Received LOGIN Response PASS
    *Jun 27 08:37:46.069: Se1/0 CHAP: O SUCCESS id 6 len 4
    
    

ルータ R2 上で、次のコマンドを発行します。

  • debug ppp authentication

    debug ppp authentication 
    
    *Feb 28 05:18:39.439: Se1/1 PPP: Using default call direction
    *Feb 28 05:18:39.439: Se1/1 PPP: Treating connection as a dedicated line
    *Feb 28 05:18:39.439: Se1/1 PPP: Session handle[E300000B] Session id[35]
    *Feb 28 05:18:39.439: Se1/1 PPP: Authorization required
    *Feb 28 05:18:39.451: Se1/1 PPP: No authorization without authentication
    *Feb 28 05:18:39.455: Se1/1 CHAP: I CHALLENGE id 7 len 23 from "R1"
    *Feb 28 05:18:39.459: Se1/1 CHAP: Using hostname from interface CHAP
    *Feb 28 05:18:39.459: Se1/1 CHAP: Using password from interface CHAP
    *Feb 28 05:18:39.459: Se1/1 CHAP: O RESPONSE id 7 len 23 from "R2"
    *Feb 28 05:18:39.467: Se1/1 CHAP: I SUCCESS id 7 len 4
    

関連情報


Document ID: 113073