IP : IP バージョン 6

IPv6 BGP ローカル プリファレンスの機能の設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、IPv6 ボーダーゲートウェイ プロトコル(BGP)のローカル プリファレンス機能について説明します。 ローカル プリファレンスは AS に対する指標で、その AS から特定のネットワークに到達する際にどのパスが優先されるかを示します。 ローカル プリファレンス値の高いパスが優先されます。 プリファレンスのデフォルト値は 100 です。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • BGP ルーティング プロトコルおよびオペレーションの知識

  • IPv6 アドレス方式の知識

使用するコンポーネント

この文書に記載されている情報はこれらのソフトウェア および ハードウェア バージョンでテストされます

  • Cisco IOS ソフトウェア リリース 12.4、先発 IP サービス 機能セット

  • • Cisco 3700 シリーズ マルチサービス アクセス ルータ

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

例では、ルータ R1、R2 および R3 は BGP 自律システム番号 123 の一部です。 R4 は自律システム 自律システム 100 の 101 および R5 部の一部です。

3 人のルータ(R1、R2 および R3)は IGP 接続のための OSPFv3 で設定されます。 すべての 3 人のルータのループバック インターフェイス Lo 0 (1111:111:111:A::/64 eui-64、2222:222:222:A::/64 eui-64 および 3333:333:333:A::/64 eui-64)の IPv6 プレフィクスは OSPFv3 ルーティング プロトコルのエリア 0 でアドバタイズされます。

IBGP ピアリングは学習されたループバック プレフィックスによるルータ R1、R2 および R3 の間で形成されます。 ルータ R1 および R4 は WAN リンク(シリアル接続)に接続され、EBGP ピアリングを形成します。 同様にルータ R3 および R5 は WAN リンク上の EBGP ピアリングを形成しています。

ルータ R4 および R5 は同じ IPv6 プレフィックスをインジェクトします:

  1. ネットワーク BC01:BC1:10:A::/64

  2. ネットワーク BC02:BC1:11:A::/64

  3. ネットワーク BC03:BC1:12:A::/64

2 人のルータ R4 および R5 が同じ IPv6 プレフィックスをインジェクトするので、パス選択は BGP よく知られている な属性に基づいています。 この例では、ローカルプリファレンスは選択されます。 500 という BGP ローカルプリファレンス値はルート マップを通したルータ R3 のプレフィクス BC01:BC1:10:A::/64 のために設定 されます。 これはこのプレフィクスおよび R1 のための出力点として R3 という結果に残りの 2 つのプレフィックスのための出力点終ります。

設定

ルータ R1、R2 および R3 のファーストイーサネット インターフェイスは(F0/0 および F0/1)形式 eui-64 の IPv6 アドレスと有効に なる IPv6 です。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-01.gif

設定

このドキュメントでは、次の設定を使用します。

注: ルータ全員は IPv6 パケットのフォワーディングと IPv6 ユニキャストルーティング コマンドの使用によって有効に なります。

R1
interface Loopback0
 no ip address
 ipv6 address 1111:111:111:A::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0

!--- Enables OSPFv3 on the interface and associates
!--- the interface loopback0 to area 0.

!
interface FastEthernet0/0
 description CONNECTED TO Rtr2
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:A::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface Serial0/0
 no ip address
 ipv6 address AB01:CD1:123:C::/64 eui-64
 ipv6 enable
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:B::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
ipv6 router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes
 redistribute connected route-map CONNECTED
!
route-map CONNECTED permit 10
 match interface Serial0/0
!
router bgp 123
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2222:222:222:A:C602:3FF:FEF0:0 remote-as 123
 neighbor 2222:222:222:A:C602:3FF:FEF0:0 update-source Loopback0
 neighbor 3333:333:333:A:C603:3FF:FEF0:0 remote-as 123
 neighbor 3333:333:333:A:C603:3FF:FEF0:0 update-source Loopback0
 neighbor AB01:CD1:123:C:C604:16FF:FE98:0 remote-as 101
 neighbor AB01:CD1:123:C:C604:16FF:FE98:0 ebgp-multihop 5
 !
 address-family ipv6
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 activate
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 next-hop-self
  neighbor 3333:333:333:A:C603:3FF:FEF0:0 activate
  neighbor 3333:333:333:A:C603:3FF:FEF0:0 next-hop-self
  neighbor AB01:CD1:123:C:C604:16FF:FE98:0 activate
 exit-address-family

R2
interface Loopback0
 no ip address
 ipv6 address 2222:222:222:A::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:A::/64 eui-64
 ipv6 ospf 10 area 0
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:D::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
ipv6 router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
!
router bgp 123
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 1111:111:111:A:C601:3FF:FEF0:0 remote-as 123
 neighbor 1111:111:111:A:C601:3FF:FEF0:0 update-source Loopback0
 neighbor 3333:333:333:A:C603:3FF:FEF0:0 remote-as 123
 neighbor 3333:333:333:A:C603:3FF:FEF0:0 update-source Loopback0
 no auto-summary
 !
 address-family ipv6
  neighbor 1111:111:111:A:C601:3FF:FEF0:0 activate
  neighbor 3333:333:333:A:C603:3FF:FEF0:0 activate
 exit-address-family

R3
interface Loopback0
 no ip address
 ipv6 address 3333:333:333:A::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:B::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface Serial0/0
 no ip address
 ipv6 address AB01:CD1:123:E::/64 eui-64
 ipv6 enable
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:D::/64 eui-64
 ipv6 ospf 10 area 0
!
ipv6 router ospf 10
 router-id 3.3.3.3
 log-adjacency-changes
 redistribute connected route-map CONNECTED
!
router bgp 123
 no synchronization
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 neighbor 1111:111:111:A:C601:3FF:FEF0:0 remote-as 123
 neighbor 1111:111:111:A:C601:3FF:FEF0:0 update-source Loopback0
 neighbor 2222:222:222:A:C602:3FF:FEF0:0 remote-as 123
 neighbor 2222:222:222:A:C602:3FF:FEF0:0 update-source Loopback0
 neighbor AB01:CD1:123:E:C605:16FF:FE98:0 remote-as 202
 neighbor AB01:CD1:123:E:C605:16FF:FE98:0 ebgp-multihop 5
 no auto-summary
 !
 address-family ipv6
  neighbor 1111:111:111:A:C601:3FF:FEF0:0 activate
  neighbor 1111:111:111:A:C601:3FF:FEF0:0 next-hop-self
  neighbor 1111:111:111:A:C601:3FF:FEF0:0 route-map LOCAL_PREF out
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 activate
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 next-hop-self
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 route-map LOCAL_PREF out
  neighbor AB01:CD1:123:E:C605:16FF:FE98:0 activate
 exit-address-family

!
ipv6 prefix-list 10 seq 5 permit BC01:BC1:10:A::/64
!
route-map LOCAL_PREF permit 10
 match ipv6 address prefix-list 10
 set local-preference 500
!
route-map LOCAL_PREF permit 20
!
route-map CONNECTED permit 10
 match interface Serial0/0

R4
interface Serial0/0
 no ip address
 ipv6 address AB01:CD1:123:C::/64 eui-64
 ipv6 enable
 clock rate 2000000
!
interface Loopback10
 no ip address
 ipv6 address BC01:BC1:10:A::/64 eui-64
 ipv6 enable
!
interface Loopback11
 no ip address
 ipv6 address BC02:BC1:11:A::/64 eui-64
 ipv6 enable
!
interface Loopback12
 no ip address
 ipv6 address BC03:BC1:12:A::/64 eui-64
 ipv6 enable

router bgp 101
 bgp router-id 4.4.4.4
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor AB01:CD1:123:C:C601:3FF:FEF0:0 remote-as 123
 neighbor AB01:CD1:123:C:C601:3FF:FEF0:0 ebgp-multihop 5
 !
 address-family ipv6
  neighbor AB01:CD1:123:C:C601:3FF:FEF0:0 activate
  network BC01:BC1:10:A::/64
  network BC02:BC1:11:A::/64
  network BC03:BC1:12:A::/64
 exit-address-family

R5
interface Serial0/0
 no ip address
 ipv6 address AB01:CD1:123:E::/64 eui-64
 ipv6 enable
 clock rate 2000000
!
interface Loopback10
 no ip address
 ipv6 address BC01:BC1:10:A::/64 eui-64
 ipv6 enable
!
interface Loopback11
 no ip address
 ipv6 address BC02:BC1:11:A::/64 eui-64
 ipv6 enable
!
interface Loopback12
 no ip address
 ipv6 address BC03:BC1:12:A::/64 eui-64
 ipv6 enable
!
router bgp 202
 bgp router-id 5.5.5.5
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor AB01:CD1:123:E:C603:3FF:FEF0:0 remote-as 123
 neighbor AB01:CD1:123:E:C603:3FF:FEF0:0 ebgp-multihop 5
 !
 address-family ipv6
  neighbor AB01:CD1:123:E:C603:3FF:FEF0:0 activate
  network BC01:BC1:10:A::/64
  network BC02:BC1:11:A::/64
  network BC03:BC1:12:A::/64
 exit-address-family

確認

このセクションでは、設定が正しく動作していることを確認するために使用できる情報を説明します。

ルータ R1

  1. show ipv6 interface brief

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-02.gif

  2. show bgp ipv6 unicast summary

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-03.gif

ルータ R2

  1. show ipv6 interface brief

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-04.gif

  2. show bgp ipv6 unicast

    注: ローカルプリファレンスが設定されないとき、ルータ R2 (Rtr2)はすべての学習された IPv6 アドレスのためのネクスト ホップとしてルータ R1 (Rtr1)を備えています。 http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-05.gif

  3. show bgp ipv6 unicast

    プレフィクス BC01:BC1:10:A::/64 のためのローカルプリファレンス 500 を設定した後、R2 にこのプレフィクスのためのだけ別の終了があります。

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-06.gif

    注: ローカルプリファレンスがより高く設定 されると同時にプレフィクス BC01:BC1:10:A::/64 はルータ R3 の終了パスを選択します。

ルータ R3

  1. show ipv6 interface brief

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-07.gif

  2. show bgp ipv6 unicast summary

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-08.gif

トラブルシューティング

トラブルシューティングのためにこれらのコマンドを使用して下さい

  1. debug bgp ipv6 更新
  2. clear bgp ipv6 {ユニキャスト | マルチキャスト}

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 113035