Cisco インターフェイスとモジュール : Cisco Catalyst 6500 シリーズ マルチレイヤ スイッチ フィーチャ カード

VRF-Lite 上での Catalyst 6500 EIGRP の設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2013 年 5 月 17 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Cisco Catalyst 6500 シリーズ スイッチで Virtual Route Forwarding(VRF)-Lite を介して EIGRP を設定する方法について説明します。 スティック ルートはスイッチで設定され、スイッチ間で EIGRP を介して再配布されます。

前提条件

要件

次の項目に関する知識があることが推奨されます。

  • EIGRP に関する基礎知識

  • Catalyst 6500 設定に関する基礎知識

使用するコンポーネント

このドキュメントの情報は、ソフトウェア バージョン 12.2(33).SXH6 を実行する Catalyst 6500 シリーズ スイッチに基づいています。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

VRF-Lite によって、サービス プロバイダーは 1 つのインターフェイスを使用して、重複する IP アドレスを持つ複数の VPN をサポートできます。 VRF-Lite は、Multi-VRF CE、または Multi-VRF CE デバイスとも言います。 以前、VRF-Lite は、RIP、OSPF および BGP だけでサポートされていました。 ただし、最新のバージョンでは、VRF-Lite は EIGRP でもサポートされます。 このドキュメントでは、スタティック VRF ルートが EIGRP を介して他のスイッチに再配布される VRF-Lite CLI を介した EIGRP の設定例を示します。

Catalyst 6500 上での VRF-Lite の設定

次に、Catalyst 6500 上での VRF-Lite の設定のガイドラインを示します。

  • VRF-Lite が設定されたスイッチは複数のカスタマーで共有され、すべてのカスタマーが独自のルーティング テーブルを持ちます。

  • お客様は別々の VRF テーブルを使用するので、同じ IP アドレスを再利用できます。 別々の VPN では IP アドレスの重複が許可されます。

  • VRF-Lite では、複数のカスタマーが PE と CE の間で同一の物理リンクを共有できます。 複数の VLAN を持つトランク ポートでは、パケットがお客様間で分離されます。 すべてのカスタマーが独自の VLAN を持ちます。

  • PE ルータでは、VRF-Lite の使用と複数の CE の使用には違いがありません。

  • お客様は、別のお客様と重複しない限り、複数の VLAN を使用できます。 お客様の VLAN は、スイッチに保存されている適切なルーティング テーブルの識別に使用される特定のルーティング テーブル ID にマッピングされます。

  • VRF-Lite は、パケット スイッチング レートに影響しません。

CLI 設定

このセクションでは、CLI の設定を示します。

 6500A(config)#ip vrf TEST-LAB
 6500A(config)#rd 10.244.0.10:100

 6500A(config)#interface Loopback100
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.1 255.255.255.255
 6500A(config-if)#exit

 6500A(config)#interface GigabitEthernet7/1
 6500A(config-if)# ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.121 255.255.255.252
 6500A(config-if)#exit

 6500A(config)#no snmp trap link-status
 6500A(config)#interface TenGigabitEthernet8/6
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.21 255.255.255.252
 6500A(config-if)#exit
 6500A(config)# no snmp trap link-status
 6500A(config)# router eigrp 99
 6500A(config-router)# network 10.0.0.0
 6500A(config-router)# no auto-summary
 6500A(config-router)# address-family ipv4 vrf TEST-LAB
 6500A(config-router)# redistribute static metric 10000 100 255 1 1500
 
 
!--- Redistribute static routes

 6500A(config-router)# network 10.244.128.0 0.0.0.255
 6500A(config-router)# network 10.244.129.0 0.0.0.255 
 6500A(config-router)# autonomous-system 99
 6500A(config-router)#exit-address-family
 6500A(config-router)#exit  
 6500A(config)#ip classless
 6500A(config)#ip route vrf TEST-LAB 10.0.0.0 255.0.0.0 10.244.129.251
 6500A(config)#interface Vlan129
 6500A(config)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.250 255.255.255.248
 6500A(config)#ip vrf TEST-LAB
 6500A(config)#rd 10.244.0.10:100

 6500A(config)#interface Loopback100
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.1 255.255.255.255
 6500A(config-if)#exit

 6500A(config)#interface GigabitEthernet7/1
 6500A(config-if)# ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.121 255.255.255.252
 6500A(config-if)#exit

 6500A(config)#no snmp trap link-status
 6500A(config)#interface TenGigabitEthernet8/6
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.21 255.255.255.252
 6500A(config-if)#exit
 6500A(config)# no snmp trap link-status
 6500A(config)# router eigrp 99
 6500A(config-router)# network 10.0.0.0
 6500A(config-router)# no auto-summary
 6500A(config-router)# address-family ipv4 vrf TEST-LAB
 6500A(config-router)# redistribute static metric 10000 100 255 1 1500
 
 
!--- Redistribute static routes

 6500A(config-router)# network 10.244.128.0 0.0.0.255
 6500A(config-router)# network 10.244.129.0 0.0.0.255 
 6500A(config-router)# autonomous-system 99
 6500A(config-router)#exit-address-family
 6500A(config-router)#exit  
 6500A(config)#ip classless
 6500A(config)#ip route vrf TEST-LAB 10.0.0.0 255.0.0.0 10.244.129.251
 6500A(config)#interface Vlan129
 6500A(config)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.250 255.255.255.248

 6500c(config)#ip vrf TEST-LAB
 6500c(config)#rd 10.244.0.10:100
!
 6500c(config-if)#interface Loopback0
 6500c(config-if)#ip vrf forwarding TEST-LAB
 6500c(config-if)#ip address 1.1.1.1 255.255.255.0
!         
 6500c(config-if)#interface GigabitEthernet1/1
 6500c(config-if)#switchport
 6500c(config-if)#switchport access vlan 129
 6500c(config-if)#no ip address
!                  
 6500c(config-if)#interface Vlan129
 6500c(config-if)#ip vrf forwarding TEST-LAB
 6500c(config-if)#ip address 10.244.129.251 255.255.255.248

EIGRP のトラブルシューティング

EIGRP での一般的な問題として、ローカル ルータは、隣接ルータとの EIGRP ネイバー関係を確立しません。

EIGRP に再配布されないスタティック ルート

  1. redistribute static コマンドのスタティック ルートでデフォルトのメトリック値を使用します。

  2. ルータで redistribute static コマンドを削除し追加します。 スタティック ルート 10.0.0.0/8 が、EIGRP トポロジに示されます。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 112245