IP : ボーダー ゲートウェイ プロトコル(BGP)

BGP での Allowas-in 機能の設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2013 年 4 月 19 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、2 台のブランチ ルータが ISP 経由で接続され、ルータ間でボーダー ゲートウェイ プロトコル(BGP)を動作させているシナリオについて説明しています。 2 台のブランチ ルータ(R1 および R2)は異なる場所にあるものの、同一の AS 番号を共有しています。 ルートがブランチ(この場合、R1)からサービス プロバイダー(SP)ネットワークに達すると、ルートにユーザの AS がタグ付けされます。 SP がルートを他のブランチ ルータ(R2)に渡すと、他のブランチも同一の AS 番号を使用して SP と BGP を動作させている場合、デフォルトではそのルートはドロップされます。 このシナリオでは、相手側の BGP がアップデートを注入できるようにするために、neighbor allowas-in コマンドを発行します。 このドキュメントでは、BGP の Allowas-in 機能の理解に役立つ設定例を提供しています。

注: この機能を使用できるのは、本当の eBGP ピアの場合だけです。 異なるコンフェデレーション サブ AS のメンバーである 2 つのピアに対しては、この機能を使用できません。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、このドキュメントで説明する機能を設定するために必要な情報について記載しています。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112236-allowas-in-bgp-config-example-1.gif

設定

このドキュメントでは、次の設定を使用します。

ルータ A の設定
Router_A#interface Loopback1
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback2
 ip address 2.2.2.2 255.255.255.255
!
interface Loopback3
 ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/1
 no switchport
 ip address 192.1.12.2 255.255.255.0
!
router eigrp 100
 network 1.1.1.1 0.0.0.0
 network 2.2.2.2 0.0.0.0
 network 3.3.3.3 0.0.0.0
 network 192.1.12.0
 auto-summary
!

ルータ R1 の設定
R1#interface Loopback22
 ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.1.12.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 172.16.12.1 255.255.255.0
!
!
router eigrp 100
 network 192.1.12.0
 no auto-summary
!
router bgp 121
 no synchronization
 bgp router-id 22.22.22.22
 bgp log-neighbor-changes
 network 22.22.22.22 mask 255.255.255.255 

!--- This is the advertising loopback address.

 redistribute eigrp 100 

!--- This shows the redistributing internal routes in BGP.

 neighbor 172.16.12.2 remote-as 500 

!--- This shows the EBGP connection with ISP.

 neighbor 172.16.12.2 ebgp-multihop 5
 no auto-summary
!

この例は、EIGRP がルータ A とルータ R1 の間で動作していることを示しています。

r1#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.1.12.2              Fa0/0             14 01:17:12  828  4968  0  7

この例は、ルータ R1 が EIGRP を通じてルータ A からルートを学習している様子を示しています。

r1#show ip route eigrp 100
D    1.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0
D    2.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0
D    3.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0

この例は、ルータ R1 が BGP AS500 を動作させている ISP と BGP 接続を確立している様子を示しています。

r1#show ip bgp summary
BGP router identifier 22.22.22.22, local AS number 121
BGP table version is 19, main routing table version 19
7 network entries using 924 bytes of memory
7 path entries using 364 bytes of memory
5/4 BGP path/bestpath attribute entries using 840 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 2) using 32 bytes of memory
BGP using 2184 total bytes of memory
BGP activity 40/33 prefixes, 42/35 paths, scan interval 60 secs

Neighbor        V          AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.12.2     4        500      86      76       19    0    0 00:25:13        2

この例は、BGP がルートを学習したことを R1 がアナウンスしている様子を示しています。

r1#show ip bgp
BGP table version is 19, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.0.0.0          192.1.12.2          156160         32768 ? 
*> 2.0.0.0          192.1.12.2          156160         32768 ?
*> 3.0.0.0          192.1.12.2          156160         32768 ?
*> 10.10.12.0/24    172.16.12.2              0             0 500 i
*> 22.22.22.22/32   0.0.0.0                  0         32768 i
r> 172.16.12.0/24   172.16.12.2              0             0 500 i
*> 192.1.12.0       0.0.0.0                  0         32768 ?
r1#ping 10.10.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.12.2, timeout is 2 seconds:
!!!!!  
!--- This is the connectivity with Router 2 across the Internet cloud.

ルータ R2 の設定
R2#interface Loopback33
 ip address 33.33.33.33 255.255.255.255
!
interface Serial1/0
 ip address 10.10.12.1 255.255.255.0

router bgp 121
 no synchronization
 bgp router-id 33.33.33.33
 bgp log-neighbor-changes
 network 33.33.33.33 mask 255.255.255.255 

!--- This is the advertising loopback address.
 
 neighbor 10.10.12.2 remote-as 500 

!--- This is the EBGP connection with ISP.

 neighbor 10.10.12.2 ebgp-multihop 5
no auto-summary

ルータ R2 はルータ R1 からルートを学習しません。

BGP はルーティングのループを避けようとしているため、これは自然な動作です。 たとえば、デフォルトでは、重複した自律システム番号(ASN)を含むすべてのプレフィクスの再アドバタイズは無効化されています。

R1 から再配布された EIGRP ルート(1.0.0.0、2.0.0.0、3.0.0.0)および BGP 内部ルート 22.22.22.22 は、インターネットを介して同一の ASN から発信されているため、R2 では受信されません。 R2 は AS-PATH で自身の AS 番号(121)を把握しているため、R2 はこれらのルートをとりません。

r2#show ip bgp
BGP table version is 20, local router ID is 33.33.33.33
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r> 10.10.12.0/24    10.10.12.2               0             0 500 i
*> 33.33.33.33/32   0.0.0.0                  0         32768 i
*> 172.16.12.0/24   10.10.12.2               0             0 500 i

重複した ASN を含むすべてのプレフィクスの再アドバタイズを許可するには、ルータ R2 のルータ コンフィギュレーション モードで neighbor allowas-in コマンドを使用します。

r2(config-router)#neighbor 10.10.12.2 allowas-in
r2#clear ip bgp*
r2#show ip bgp
BGP table version is 10, local router ID is 33.33.33.33
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.0.0.0          10.10.12.2                             0 500 121 ?
*> 2.0.0.0          10.10.12.2                             0 500 121 ?
*> 3.0.0.0          10.10.12.2                             0 500 121 ?
r> 10.10.12.0/24    10.10.12.2               0             0 500 i
*> 22.22.22.22/32   10.10.12.2                             0 500 121 i
*  33.33.33.33/32   10.10.12.2                             0 500 121 i
*>                  0.0.0.0                  0         32768 i
*> 172.16.12.0/24   10.10.12.2               0             0 500 i
*> 192.1.12.0       10.10.12.2                             0 500 121 ?

R1 から R2 に ping を実行してみてください。

r2#ping 22.22.22.22
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

エラー メッセージ

「Message: %BGP% Neighbor A.B.C.D recv bogus route: AS loop」というエラー メッセージを受信した。

この通知は、CE ルータが受信した BGP ルートに AS パス独自の AS 番号が存在し、CE ルータのルータ ループと考えられることを意味します。 この問題を回避するには、以前の例で説明したとおり、Allowas-in 機能を搭載した CE ルータを設定します。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 112236