IP : IP ルーテッド プロトコル

2 つの異なるサービス プロバイダー(マルチホーミング)を使用した BGP の IPv6 設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

ボーダー ゲートウェイ プロトコル(BGP)は、インターネット接続の冗長性を実現するために使用する主要プロトコルの 1 つです。 2 つの異なるインターネット サービス プロバイダー(ISP)にネットワークを接続することを、マルチホーミングと呼びます。 マルチホーミングにより、冗長性とネットワークの最適化が実現されます。 これはリソースへの最適なパスを提供する ISP を選択します。 複数のサービス プロバイダーの BGP を実行している場合、自律システム(AS)が中継 AS になる危険性があります。 これが原因で、インターネット トラフィックがこの AS を通過し、帯域幅およびルータの CPU リソースすべてを使い果たす可能性があります。 このドキュメントでは、この問題を取り扱い、適切な設定例を示します。

前提条件

要件

先へ進む前に、次のドキュメントを参照してください。

2 つの異なるサービス プロバイダー(マルチホーミング)を使用した BGP の設定例

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco 2800 シリーズ Cisco IOS が付いているルータか。 ソフトウェア リリース 12.4(13r)T

  • Cisco IOS ソフトウェア リリース 12.4(13r)T が稼働する Cisco 3800 シリーズ ルータ

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/112228/bgp2isp-01.gif

このネットワークでは、AS 101 によって 1010:1010::/64 と 2020:2020::/64 010:1010 が外部にアドバタイズされるマルチホーミングを形成するサービス プロバイダー SP-A と SP-B にルータ A が接続され、2 つの異なる AS(AS 202 および AS 303)からネットワーク 1212:1212::/64 が受信されます。

注: BGP マルチホーミングの概要を説明し、ピアリングや高 CPU 使用率などの一般的な BGP の問題のトラブルシューティングを行う方法をアドバイスするビデオ(シスコ サポート コミュニティ で入手可能)leavingcisco.com へのリンクを以下に示します。

BGP マルチホーミング: 設計とトラブルシューティング - ライブ Web キャストからのビデオ leavingcisco.com

設定

このドキュメントでは、次の設定を使用します。

ルータ A
Router-A#
ipv6 unicast-routing

!---Enables the forwarding of IPv6 packets.

ipv6 cef
interface Serial3/0
 description CONNECTED TO SP-A
 ip address 192.168.10.1 255.255.255.0
 ipv6 address 1202:ABCD::/64 eui-64
 ipv6 enable
 no fair-queue
 clock rate 64000
!
interface Serial3/1
 description CONNECTED TO SP-B
 no ip address
 ipv6 address 2303:ABCD::/64 eui-64
 clock rate 64000
!
 router bgp 101
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1202:ABCD::21B:54FF:FEA9:24B0 remote-as 202

!--- Configures SP-A as neighbor.

 neighbor 1202:ABCD::21B:54FF:FEA9:24B0 ebgp-multihop 2
 neighbor 2303:ABCD::21B:54FF:FE54:FB10 remote-as 303

!--- Configures SP-B as neighbor.

 !
 address-family ipv6
  neighbor 1202:ABCD::21B:54FF:FEA9:24B0 activate
  neighbor 2303:ABCD::21B:54FF:FE54:FB10 activate
  network 1010:1010::/64
  network 2020:2020::/64
 exit-address-family
!

サービス プロバイダー A
SP-A#
ipv6 unicast-routing
ipv6 cef
interface Serial1/0
 no ip address
 ipv6 address 1202:ABCD::/64 eui-64
 ipv6 enable
 no fair-queue
!
router bgp 202
 bgp router-id 2.2.2.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1202:ABCD::21C:58FF:FEED:3E90 remote-as 101

!--- Configuers Router A as neighbor.

 !
 address-family ipv6
  neighbor 1202:ABCD::21C:58FF:FEED:3E90 activate
  network 1212:1212::/64
 exit-address-family
!

サービス プロバイダー B
SP-B#
ipv6 unicast-routing
ipv6 cef
interface Serial1/0
 no ip address
 ipv6 address 2303:ABCD::/64 eui-64
 no fair-queue
!
router bgp 303
 no synchronization
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 neighbor 2303:ABCD::21C:58FF:FEED:3E90 remote-as 101

!--- Configures as Router A as neighbor.

 neighbor 2303:ABCD::21C:58FF:FEED:3E90 ebgp-multihop 5
 no auto-summary
 !
 address-family ipv6
  neighbor 2303:ABCD::21C:58FF:FEED:3E90 activate
  network 1212:1212::/64
 exit-address-family
!

確認

ここでは、設定が正常に動作していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

  • 2 つの ISP によってピアリングされるルータ A

    Router-A#
    show bgp ipv6 unicast summary
    
    BGP router identifier 1.1.1.1, local AS number 101
    BGP table version is 6, main routing table version 6
    3 network entries using 447 bytes of memory
    4 path entries using 304 bytes of memory
    4/2 BGP path/bestpath attribute entries using 496 bytes of memory
    2 BGP AS-PATH entries using 48 bytes of memory
    0 BGP route-map cache entries using 0 bytes of memory
    0 BGP filter-list cache entries using 0 bytes of memory
    BGP using 1295 total bytes of memory
    BGP activity 3/0 prefixes, 14/10 paths, scan interval 60 secs
    
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    1202:ABCD::21B:54FF:FEA9:24B0   4   202   108     119   6    0    0 00:31:41   1
    2303:ABCD::21B:54FF:FE54:FB10   4   303   108     121   6    0    0 00:25:1    1
    
    !--- Indicates that Router A is peering with both the ISP SP-A and SP-B
    
    
  • ルータ A が SP-A と SP-B から学習したルート

    Router-A#show bgp ipv6 unicast
    BGP table version is 6, local router ID is 1.1.1.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 1010:1010::/64   ::                       0                          32768 i
    *  1212:1212::/64   2303:ABCD::21B:54FF:FE54:FB10 0  0 303 i
    *>                              1202:ABCD::21B:54FF:FEA9:24B0 0  0 202 i
    *> 2020:2020::/64   ::                       0                         32768 i
  • SP-A での設定:

    SP-A#sh bgp ipv6 unicast
    BGP table version is 4, local router ID is 2.2.2.2
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 1010:1010::/64   1202:ABCD::21C:58FF:FEED:3E90 0 0 101 i
    *> 1212:1212::/64   ::                       0            32768              i
    *> 2020:2020::/64   1202:ABCD::21C:58FF:FEED:3E90 0 0 101 i
  • SP-B での設定:

    SP-B#sh bgp ipv6 unicast
    BGP table version is 4, local router ID is 3.3.3.3
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 1010:1010::/64   2303:ABCD::21C:58FF:FEED:3E90 0             0 101 i
    *  1212:1212::/64   2303:ABCD::21C:58FF:FEED:3E90  0                 101 202 i
    *>                  ::                       0         32768 i
    *> 2020:2020::/64   2303:ABCD::21C:58FF:FEED:3E90 0             0 101 i

トラブルシューティング

debug bgp ipv6 update コマンドを使用して、アップデートに関するデバッグ情報を表示し、ピアリングの状態の識別に役立てます。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 112228