IP : IP ルーティング

一部の OSPF ルートがデータベースには存在するのに、ルーティング テーブルには存在しない理由

2010 年 12 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2008 年 9 月 15 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
原因 1:ネットワーク タイプのミスマッチ
      解決策
原因 2:デュアル リンクのセットアップで間違ったアドレスが割り当てられている
      解決策
原因 3:ポイントツーポイント リンクの片側が間違ったメジャーネットまたはサブネットに接続されている
原因 4:リンクの片側がアンナンバード、もう片側がナンバードに設定されている
      解決策
原因 5:フル メッシュ構造のフレーム リレー環境における PVC の切断
原因 6:フォワーディング アドレスが外部ルート経由で学習されている
原因 7:配布リストがルートをブロッキングしている
      解決策
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

Open Shortest Path First(OSPF)を使用する際によく見られる問題として、データベースに存在しているルートがルーティング テーブルには表示されない、という現象があります。この問題は、ほとんどの場合、OSPF データベースに不一致が生じているために、ルーティング テーブルにルートを追加できないことにより発生します。この問題が発生すると、多くの場合、データベースのリンクステート アドバタイズメント(LSA)の先頭に Adv Router is not-reachable というメッセージ(LSA をアドバタイジングしているルータに、OSPF 経由では到達できないという意味)が表示されます。次に例を示します。

Adv Router is not-reachable
LS age: 418
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 172.16.32.2
Advertising Router: 172.16.32.2
LS Seq Number: 80000002
Checksum: 0xFA63
Length: 60
 Number of Links: 3

この問題にはいくつかの原因が考えられますが、最も一般的なのは設定の誤りか、またはトポロジの破損です。設定が修正されて、OSPF データベースの不一致が解消されると、ルーティング テーブルにルートが表示されるようになります。このドキュメントでは、データベースに不一致をもたらす可能性のあるいくつかの原因について説明します。

このドキュメントの説明で、OSPF の動作確認に使用されるコマンドには、show ip ospf interfaceip ospf database routershow ip ospf neighborおよび show ip ospf database external などがあります。ご使用の Cisco デバイスからのコマンドの出力データがあれば、を使用して潜在的な問題や修正を表示できます。を使用するためには、登録ユーザであり、ログインしていて、さらに JavaScript を有効にしている必要があります。



前提条件

要件

このドキュメントの読者は次の項目に関する知識が必要です。



使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • すべてのルータで Cisco IOS® ソフトウェア リリース 12.3 が稼働している。

  • これは、すべてのシスコのルータ プラットフォームでサポートされている。

  • このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。



    表記法

    ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。



    原因 1:ネットワーク タイプのミスマッチ

    次のネットワーク ダイアグラムを例として使用します。

    /image/gif/paws/7112/26a.gif

    R4-4K

    R1-7010

    interface Loopback0
     ip address 172.16.33.1 255.255.255.255
    
    interface Serial2
     ip address 172.16.32.1 255.255.255.0
     ip ospf network broadcast
    
    router ospf 20
     network 172.16.0.0 0.0.255.255 area 0
    interface Loopback0
     ip address 172.16.30.1 255.255.255.255
    !
    interface Serial1/0
     ip address 172.16.32.2 255.255.255.0
     clockrate 64000
    
    router ospf 20
     network 172.16.0.0 0.0.255.255 area 0

    R4-4K(4)# show ip ospf interface serial 2
    Serial2 is up, line protocol is up 
      Internet Address 172.16.32.1/24, Area 0 
      Process ID 20, Router ID 172.16.33.1, Network Type BROADCAST, Cost: 64
      Transmit Delay is 1 sec, State DR, Priority 1 
      Designated Router (ID) 172.16.33.1, Interface address 172.16.32.1
      Backup Designated router (ID) 172.16.32.2, Interface address 172.16.32.2
      Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
        Hello due in 00:00:08
      Neighbor Count is 1, Adjacent neighbor count is 1 
        Adjacent with neighbor 172.16.32.2  (Backup Designated Router)
      Suppress hello for 0 neighbor(s)
    
    R1-7010(5)# show ip ospf interface serial 1/0
    Serial1/0 is up, line protocol is up 
      Internet Address 172.16.32.2/24, Area 0 
      Process ID 20, Router ID 172.16.32.2, Network Type POINT_TO_POINT, Cost: 64
      Transmit Delay is 1 sec, State POINT_TO_POINT,
      Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
        Hello due in 00:00:02
      Neighbor Count is 1, Adjacent neighbor count is 1 
        Adjacent with neighbor 172.16.33.1
      Suppress hello for 0 neighbor(s)
    

    上記からわかるように、ルータ R4-4K にはブロードキャストが、そしてルータ R1-7010 にはポイントツーポイントが設定されています。このようなネットワーク タイプのミスマッチがあると、アドバタイジング ルータが到達不能になります。

    R4-4K(4)# show ip ospf database router 172.16.32.2
    
      Adv Router is not-reachable
      LS age: 418
      Options: (No TOS-capability, DC)
      LS Type: Router Links
      Link State ID: 172.16.32.2
      Advertising Router: 172.16.32.2
      LS Seq Number: 80000002
      Checksum: 0xFA63
      Length: 60
       Number of Links: 3
    
        Link connected to: another Router (point-to-point)
        (Link ID) Neighboring Router ID: 172.16.33.1
        (Link Data) Router Interface address: 172.16.32.2
        Number of TOS metrics: 0
        TOS 0 Metrics: 64
    
        Link connected to: a Stub Network
        (Link ID) Network/subnet number: 172.16.32.0
        (Link Data) Network Mask: 255.255.255.0
        Number of TOS metrics: 0
        TOS 0 Metrics: 64
    
    R1-7010(5)# show ip ospf database router 172.16.33.1
    
      Adv Router is not-reachable
      LS age: 357
      Options: (No TOS-capability, DC)
      LS Type: Router Links
      Link State ID: 172.16.33.1
      Advertising Router: 172.16.33.1
      LS Seq Number: 8000000A
      Checksum: 0xD4AA
      Length: 48
       Number of Links: 2
    
         Link connected to: a Transit Network
         (Link ID) Designated Router address: 172.16.32.1
         (Link Data) Router Interface address: 172.16.32.1
         Number of TOS metrics: 0
         TOS 0 Metrics: 64

    ここでは、サブネット 172.16.32.0/24 に対して、ルータ R1-7010 はポイントツーポイント リンクを、ルータ R4-4K はトランジット リンクを作成しています。そのため、リンクステート データベースに不一致が生じます。つまり、ルータはルーティング テーブルに追加されません。

    R1-7010(5)# show ip route
    172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
    C       172.16.32.0/24 is directly connected, Serial1/0
    C       172.16.30.1/32 is directly connected, Loopback0


    解決策

    この問題を解決するには、両方のルータを同一のネットワーク タイプに設定します。つまり、ルータ R1-7010 のネットワーク タイプをブロードキャストに変更するか、またはルータ R4-4K のシリアル インターフェイスをポイントツーポイントに変更します。

    注:一方がマルチポイント インターフェイス、もう一方がサブインターフェイスという状況では、両方のネットワーク タイプをブロードキャストに変更します。

    次の例では、両側で High-Level Data Link Control(HDLC; 高レベル データリンク制御)によりカプセル化されたポイントツーポイント インターフェイスが使用されているため、R4-4K の「network-type broadcast」文が削除されています。

    R4-4K(4)# configure terminal 
    R4-4K(4)(config)# interface serial 2 
    R4-4K(4)(config-if)# no ip ospf network broadcast 
    R4-4K(4)(config-if)# end
    
    R4-4K(4)# show ip ospf interface serial 2
     Serial2 is up, line protocol is up 
      Internet Address 172.16.32.1/24, Area 0 
      Process ID 20, Router ID 172.16.33.1, Network Type POINT_TO_POINT, Cost: 64
      Transmit Delay is 1 sec, State POINT_TO_POINT,
      Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
       Hello due in 00:00:04
      Neighbor Count is 1, Adjacent neighbor count is 1 
      Adjacent with neighbor 172.16.32.2
      Suppress hello for 0 neighbor(s)


    原因 2:デュアル リンクのセットアップで間違ったアドレスが割り当てられている

    例として次のネットワーク ダイアグラムを使用します。

    /image/gif/paws/7112/26b.gif

    R4-4K

    R1-7010

    interface loopback 0
     ip address 172.16.35.1 255.255.255.255
    
    interface Serial2
     ip address 172.16.29.1 255.255.255.0
    !
    interface Serial3
     ip address 172.16.32.1 255.255.255.0
    
    router ospf 20
     network 172.16.0.0 0.0.255.255 area 0
    interface loopback 0
     ip address 172.16.30.1 255.255.255.255
    
    interface Serial1/0
     ip address 172.16.32.2 255.255.255.0
     clockrate 64000
    !
    interface Serial1/1
     ip address 172.16.29.2 255.255.255.0
     clockrate 38400
    
    router ospf 20
     network 172.16.0.0 0.0.255.255 area 0

    上記の例では、IP アドレスが反転していることがわかります。それによって、OSPF データベースに不一致が生じます。しかし、バージョン 12.1 より前の Cisco IOS では、この状態でもネイバー ルータが形成されます。それは、ポイントツーポイント リンクでは、ネイバー ルータが同一サブネット上に存在しているかどうかを、OSPF ルータが確認しないためです。

    R4-4K(4)# show ip ospf neighbor
    
    Neighbor ID     Pri   State           Dead Time   Address         Interface
    172.16.32.2       1   FULL/  -        00:00:37    172.16.32.2     Serial2
    172.16.32.2       1   FULL/  -        00:00:31    172.16.29.2     Serial3

    上記の出力結果によれば、Serial2 は IP アドレス 172.16.32.2 でネイバー関係を形成しようとしていることがわかりますが、この IP アドレスは同一サブネットにはありません。そのため、ネイバー関係は形成されますが、ルートはルーティング テーブルに追加されません。

    R1-7010(5)# show ip route
    172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
    C       172.16.32.0/24 is directly connected, Serial1/0
    C       172.16.29.0/24 is directly connected, Serial1/1
    C       172.16.30.1/32 is directly connected, Loopback0


    解決策

    この問題を解決するには、IP アドレスを正しく割り当てるか、またはシリアル ケーブルに切り替えます。次の例では、IP アドレスが修正されています。

    R4-4K

    R1-7010

    interface loopback 0
     ip address 172.16.35.1 255.255.255.255
    
    interface Serial2
     ip address 172.16.32.1 255.255.255.0
    !
    interface Serial3
     ip address 172.16.29.1 255.255.255.0
    
    router ospf 20
     network 172.16.0.0 0.0.255.255 area 0
    interface loopback 0
     ip address 172.16.30.1 255.255.255.255
    
    interface Serial1/0
     ip address 172.16.32.2 255.255.255.0
     clockrate 64000
    !
    interface Serial1/1
     ip address 172.16.29.2 255.255.255.0
     clockrate 38400
    
    router ospf 20
     network 172.16.0.0 0.0.255.255 area 0

    R4-4K(4)# show ip ospf neighbor
    
    Neighbor ID     Pri   State           Dead Time   Address         Interface
    172.16.32.2       1   FULL/  -        00:00:36    172.16.32.2     Serial2
    172.16.32.2       1   FULL/  -        00:00:39    172.16.29.2     Serial3

    今回は、Serial 2 インターフェイスに正しいネイバー アドレスが表示されています。また、ルーティング テーブルにもルータが追加されています。

    R1-7010(5)# show ip route
    172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
    C       172.16.32.0/24 is directly connected, Serial1/0
    O       172.16.35.1/32 [110/65] via 172.16.32.1, 00:03:12, Serial1/0
                           [110/65] via 172.16.29.1, 00:03:12, Serial1/1
    C       172.16.29.0/24 is directly connected, Serial1/1
    C       172.16.30.1/32 is directly connected, Loopback0


    原因 3:ポイントツーポイント リンクの片側が間違ったメジャーネットまたはサブネットに接続されている

    例として次のネットワーク ダイアグラムを使用します。

    /image/gif/paws/7112/26c.gif

    この状況では、「デュアル リンクのセットアップで間違ったアドレスが割り当てられている」で説明した内容とまったく同じ現象が見られます。問題を解決するには、両方のルータで同一サブネットの IP アドレスを割り当てます。



    原因 4:リンクの片側がアンナンバード、もう片側がナンバードに設定されている

    例として次のネットワーク ダイアグラムを使用します。

    /image/gif/paws/7112/unnum.gif

    R4-4K

    R1-7010

    interface Loopback0
     ip address 172.16.35.1 255.255.255.255
    
    interface Serial2
     ip unnumbered Loopback0
     router ospf 20
     network 172.16.0.0 0.0.255.255 area 0
    interface Loopback0
     ip address 172.16.30.1 255.255.255.255
    !
    interface Serial1/0
     ip address 172.16.32.2 255.255.255.0
     clockrate 64000
    
    router ospf 20
     network 172.16.0.0 0.0.255.255 area 0

    R4-4K(4)# show interface serial 2
    Serial2 is up, line protocol is up 
      Hardware is cxBus Serial
      Interface is unnumbered.  Using address of Loopback0 (172.16.35.1)
    
    R1-7010(5)# show interface serial 1/0
    Serial1/0 is up, line protocol is up 
      Hardware is cxBus Serial
      Internet address is 172.16.32.2/24
    

    上記の出力では、R4-4K の Serial 2 インターフェイスは Loopback0 にアンナンバードされていますが、R1-7010 の Serial 1/0 はナンバード インターフェイスになっています。

    R4-4K(4)# show ip ospf interface serial 2
    Serial2 is up, line protocol is up 
      Internet Address 0.0.0.0/24, Area 0 
      Process ID 20, Router ID 172.16.35.1, Network Type POINT_TO_POINT, Cost: 64
      Transmit Delay is 1 sec, State POINT_TO_POINT,
      Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
        Hello due in 00:00:02
      Neighbor Count is 1, Adjacent neighbor count is 1 
        Adjacent with neighbor 172.16.32.2
      Suppress hello for 0 neighbor(s)
    
    R1-7010(5)# show ip ospf interface serial 1/0
    Serial1/0 is up, line protocol is up 
      Internet Address 172.16.32.2/24, Area 0 
      Process ID 20, Router ID 172.16.32.2, Network Type POINT_TO_POINT, Cost: 64
      Transmit Delay is 1 sec, State POINT_TO_POINT,
      Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
        Hello due in 00:00:02
      Neighbor Count is 1, Adjacent neighbor count is 1 
        Adjacent with neighbor 172.16.33.1
      Suppress hello for 0 neighbor(s)

    出力結果からわかるように、ネットワーク タイプはどちらもポイントツーポイントです。問題は、片側がアンナンバードでありながら、もう片側がそうではないことにあります。その結果、次のように、データベースに不一致が生じています。

    R4-4K(4)# show ip ospf database router 172.16.30.1
    
      OSPF Router with ID (172.16.35.1) (Process ID 20)
     Router Link States (Area 0)
     LS age: 202
         Options: (No TOS-capability, DC)
         LS Type: Router Links
         Link State ID: 172.16.30.1
         Advertising Router: 172.16.30.1
         LS Seq Number: 80000002
         Checksum: 0xC899
         Length: 60
         Number of Links: 3
     Link connected to: another Router (point-to-point)
         (Link ID) Neighboring Router ID: 172.16.35.1
         (Link Data) Router Interface address: 172.16.32.2
         Number of TOS metrics: 0
         TOS 0 Metrics: 64
     Link connected to: a Stub Network
         (Link ID) Network/subnet number: 172.16.32.0
         (Link Data) Network Mask: 255.255.255.0
         Number of TOS metrics: 0
         TOS 0 Metrics: 64
     Link connected to: a Stub Network
         (Link ID) Network/subnet number: 172.16.30.1
         (Link Data) Network Mask: 255.255.255.255
         Number of TOS metrics: 0
         TOS 0 Metrics: 1
    
         R4-4k(4)#
        
    R1-7010(5)# show ip ospf database router 172.16.35.1
    
    OSPF Router with ID (172.16.30.1) (Process ID 20)
         Router Link States (Area 0)
     Adv Router is not-reachable
         LS age: 396
         Options: (No TOS-capability, DC)
         LS Type: Router Links
         Link State ID: 172.16.35.1
         Advertising Router: 172.16.35.1
         LS Seq Number: 80000003
         Checksum: 0xBEA1
         Length: 48
         Number of Links: 2
     Link connected to: another Router (point-to-point)
         (Link ID) Neighboring Router ID: 172.16.30.1
         (Link Data) Router Interface address: 0.0.0.3
    
              
    !--- アンナンバード リンクの場合は、Management Information Base(MIB) 
    !--- II IfIndex 値を使用します。通常、この値は 0 で始まります。
    
              
         Number of TOS metrics: 0
         TOS 0 Metrics: 64
     Link connected to: a Stub Network
         (Link ID) Network/subnet number: 172.16.35.1
         (Link Data) Network Mask: 255.255.255.255
         Number of TOS metrics: 0
         TOS 0 Metrics: 1
    
         R1-7010(5)#

    R1-7010 は、インターフェイス アドレスを保持した Link Data フィールドを使用して、このポイントツーポイント リンクの LSA を生成しています。一方、R4-4K は MIBII IfIndex 値を使用して、同じリンクの LSA を生成していることがわかります。そのため、リンクステート データベースに不一致が生じます。つまり、ルータはルーティング テーブルに追加されません。

    R1-7010(5)# show ip route
    172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
    C       172.16.32.0/24 is directly connected, Serial1/0
    C       172.16.30.1/32 is directly connected, Loopback0


    解決策

    この問題を解決するには、両方のルータのシリアル インターフェイスを、ナンバードまたはアンナンバードのどちらかに統一して設定します。この例では、ルータ R4-4K の Serial 2 インターフェイスをナンバードに設定しています。

    R4-4K(4)# configure terminal 
    R4-4K(4)(config)# interface serial 2
    R4-4K(4)(config-if)# no ip unnumbered loopback 0 
    R4-4K(4)(config-if)# ip address 172.16.32.1 255.255.255.0
    
    R4-4K(4))# show ip ospf interface serial 2
    Serial2 is up, line protocol is up 
      Internet Address 172.16.32.1/24, Area 0 
      Process ID 20, Router ID 172.16.33.1, Network Type POINT_TO_POINT, Cost: 64
      Transmit Delay is 1 sec, State POINT_TO_POINT,
      Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
        Hello due in 00:00:02
      Neighbor Count is 1, Adjacent neighbor count is 1 
        Adjacent with neighbor 172.16.32.2
      Suppress hello for 0 neighbor(s)
    
    R1-7010(5)# show ip route
    172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
    C       172.16.32.0/24 is directly connected, Serial1/0
    O       172.16.33.1/32 [110/65] via 172.16.32.1, 00:03:08, Serial1/0
    C       172.16.30.1/32 is directly connected, Loopback0


    原因 5:フル メッシュ構造のフレーム リレー環境における PVC の切断

    例として次のネットワーク ダイアグラムを使用します。

    /image/gif/paws/7112/26d.gif

    R9-2500

    interface Loopback0
     ip address 50.50.50.50 255.255.255.255
     !
    interface Serial0
     ip address 10.10.10.5 255.255.255.0
     encapsulation frame-relay
     ip ospf network broadcast 
     frame-relay map ip 10.10.10.6 102 broadcast
     frame-relay map ip 10.10.10.7 101 broadcast
    
    router ospf 10
     network 10.10.10.0 0.0.0.255 area 0
     network 50.50.50.0 0.0.0.255 area 0

    R4-4K

    interface Loopback0
     ip address 70.70.70.70 255.255.255.255
    !
    interface Serial0
     ip address 10.10.10.7 255.255.255.0
     encapsulation frame-relay
     ip ospf network broadcast
     frame-relay map ip 10.10.10.5 101 broadcast
     frame-relay map ip 10.10.10.6 100 broadcast
    
    router ospf 10
     network 10.10.10.0 0.0.0.255 area 0
     network 70.70.70.0 0.0.0.255 area 0

    R3-4K

    interface Loopback0
     ip address 60.60.60.60 255.255.255.255
     !
    interface Serial0
     no ip address
     encapsulation frame-relay
    !
    interface Serial0.1 multipoint
     ip address 10.10.10.6 255.255.255.0
     ip ospf network broadcast
     frame-relay map ip 10.10.10.5 102 broadcast
     frame-relay map ip 10.10.10.7 100 broadcast
    !
    router ospf 10
     network 10.10.10.0 0.0.0.255 area 0
     network 60.60.60.0 0.0.0.255 area 0

    フレームリレー越しのブロードキャスト モデルが正しく機能するのは、フレームリレー クラウドがフル メッシュであるときだけです。Permanent Virtual Circuit(PVC; 相手先固定接続)のいずれかが切断している場合には、OSPF データベースに問題が発生するため、Adv router not reachable メッセージが生成されます。

    この例では、R9-2500 と R4-4K 間の PVC が切断しており、また R9-2500 の代表ルータ(DR)とのリンクも切断しています。その結果、R9-2500 では、(DR ではない)R3-4K から送信されたすべての LSA が到達不能であると断定します。表示からわかるように、R9-2500 は、R3-4K に接続されたシリアル インターフェイスのトランジット リンクを生成していません。R9-2500 から見れば、このリンク上には DR が存在しないため、代わりにスタブ リンクを生成しています。

    R9-2500(3)# show ip ospf database router
    
           OSPF Router with ID (50.50.50.50) (Process ID 10)
                    Router Link States (Area 0)
      LS age: 148
      Options: (No TOS-capability, DC)
      LS Type: Router Links
      Link State ID: 50.50.50.50
      Advertising Router: 50.50.50.50
      LS Seq Number: 8000000B
      Checksum: 0x55A
      Length: 48
       Number of Links: 2
    
        Link connected to: a Stub Network
        (Link ID) Network/subnet number: 10.10.10.0
        (Link Data) Network Mask: 255.255.255.0
        Number of TOS metrics: 0
        TOS 0 Metrics: 64
    
        Link connected to: a Stub Network
        (Link ID) Network/subnet number: 50.50.50.50
        (Link Data) Network Mask: 255.255.255.255
        Number of TOS metrics: 0
        TOS 0 Metrics: 1
    
      Adv Router is not-reachable
      LS age: 1081
      Options: (No TOS-capability, DC)
      LS Type: Router Links
      Link State ID: 60.60.60.60
      Advertising Router: 60.60.60.60
      LS Seq Number: 80000006
      Checksum: 0x4F72
      Length: 48
       Number of Links: 2
    
        Link connected to: a Stub Network
        (Link ID) Network/subnet number: 60.60.60.60
        (Link Data) Network Mask: 255.255.255.255
        Number of TOS metrics: 0
        TOS 0 Metrics: 1
    
        Link connected to: a Transit Network
        (Link ID) Designated Router address: 10.10.10.7
        (Link Data) Router Interface address: 10.10.10.6
        Number of TOS metrics: 0
        TOS 0 Metrics: 64
    
              
      Adv Router is not-reachable
      LS age: 306
      Options: (No TOS-capability, DC)
      LS Type: Router Links
      Link State ID: 70.70.70.70
      Advertising Router: 70.70.70.70
      LS Seq Number: 80000007
      Checksum: 0xC185
      Length: 48
       Number of Links: 2
    
        Link connected to: a Stub Network
        (Link ID) Network/subnet number: 70.70.70.70
        (Link Data) Network Mask: 255.255.255.255
        Number of TOS metrics: 0
        TOS 0 Metrics: 1
    
        Link connected to: a Transit Network
        (Link ID) Designated Router address: 10.10.10.7
        (Link Data) Router Interface address: 10.10.10.7
        Number of TOS metrics: 0
        TOS 0 Metrics: 64

    この問題に関する詳細は、『フレームリレーを介しての NBMA とブロードキャスト モードでの OSPF の実行に関する問題』を参照してください。



    原因 6:フォワーディング アドレスが外部ルート経由で学習されている

    例として次のネットワーク ダイアグラムを使用します。

    /image/gif/paws/7112/foradd.gif

    R2507

    interface Serial0
    ip address 1.1.1.1 255.255.255.0
             
    interface Serial1
    ip address 7.7.7.1 255.255.255.0
             
    router ospf 1
    network 1.1.1.1 0.0.0.0 area 0
    default- information originate metric 20
             
    ip route 0.0.0.0 0.0.0.0 Serial1

    R2504

    interface Serial0
    ip address 1.1.1.2 255.255.255.0
             
    interface TokenRing0
    ip address 3.3.4.2 255.255.255.0
             
    router ospf 1
    network 1.1.1.0 0.0.0.255 area 0
    network 3.0.0.0 0.255.255.255 area 1
    area 1 range 3.0.0.0 255.0.0.0

    R2515

    interface Serial1
    ip address 4.4.4.3 255.255.255.0
           
    interface TokenRing0
    ip address 3.3.4.3 255.255.255.0
           
    interface ethernet 0
    ip address 3.44.66.3 255.255.255.0
           
    interface ethernet 1
    ip address 3.22.88.3 255.255.255.0
           
    router ospf 1
    redistribute rip metric 20 subnets
    network 0.0.0.0 255.255.255.255 area 1
           
    router rip
    network 3.0.0.0

    R2513

    interface TokenRing0
    ip address 3.3.4.4 255.255.255.0
           
    interface ethernet 0
    ip address 200.1.1.4 255.255.255.0
           
    router rip
    network 3.0.0.0
    network 200.1.1.0

    R2507# show ip ospf data external 200.1.1.0
           OSPF Router with ID (7.7.7.1) (Process ID 1)
           Type- 5 AS External Link States
           LS age: 72
           Options: (No TOS- capability, DC)
           LS Type: AS External Link
           Link State ID: 200.1.1.0 (External Network Number )
           Advertising Router: 3.44.66.3
           LS Seq Number: 80000001
           Checksum: 0xF161
           Length: 36
           Network Mask: /24
                       Metric Type: 2 (Larger than any link state path)
                       TOS: 0
                       Metric: 20
                       Forward Address: 3.3.4.4
                       External Route Tag: 0

    R2507 は、データベースには 200.1.1.0/24 が存在しますが、3.3.4.4 が OSPF の外部ルート経由で学習されているため、ルーティング テーブルには追加されていません。

    R2507# show ip route 3.3.4.4
           Routing entry for 3.3.4.0/ 24
           Known via "ospf 1", distance 110, metric 20,type extern 2, forward metric 70
           Redistributing via ospf 1
           Last update from 1.1.1.2 on Serial0, 00: 00: 40 ago
           Routing Descriptor Blocks:
           * 1.1.1.2, from 3.44.66.3, 00: 00: 40 ago, via Serial0
              Route metric is 20, traffic share count is 1

    注:Cisco bug ID CSCdp72526登録ユーザ専用)により修正されたため、オーバーラップした外部ネットワークについては、OSPF はタイプ 5 のリンクステート アドバタイズメント(LSA)を生成しません。そのため、R2507 は、エリア内ルートであるサマリー ルート 3.0.0.0/8 だけを使用します。さらに、R2507 は、転送アドレスとして 200.1.1.0/24 を追加することによって、エリア内ルート 3.0.0.0/8 経由で到達可能にします。これによって、RFC 2328 leavingcisco.com に準拠したことになります。

    上記のバグを修正した後では、出力は次のようになります。

    R2507# show ip route 3.3.4.4
          Routing entry for 3.0.0.0/8
          Known via "ospf 1", distance 110, metric 74, type inter area
          Last update from 1.1.1.2 on Serial0, 00:19:20 ago
          Routing Descriptor Blocks:
          * 1.1.1.2, from 3.3.4.2, 00:19:20 ago, via Serial0
    
    
    
    R2507# show ip route  
          Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
          D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
          N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
          E1 - OSPF external type 1, E2 - OSPF external type 2
          i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
          ia - IS-IS inter area, * - candidate default, U - per-user static route
          o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is not set
    
    1.0.0.0/24 is subnetted, 1 subnets
        C 1.1.1.0 is directly connected, Serial0
        O IA 3.0.0.0/8 [110/74] via 1.1.1.2, 00:30:18, Serial0
        O E2 200.1.1.0/24 [110/20] via 1.1.1.2, 00:22:58, Serial0
        Route metric is 74, traffic share count is 1
    
    R2507#

    フォワーディング アドレスも外部ルート経由で学習されている場合には、OSPF はそのルートをルーティング テーブルに追加しません。この問題に関する詳細は、『OSPF フォワーディング アドレスに関する一般的なルーティング問題』を参照してください。



    原因 7:配布リストがルートをブロッキングしている

    次のネットワーク ダイアグラムを例として使用します。

    /image/gif/paws/7112/26a.gif

    R4-4K

    R1-7010

    interface Loopback0
     ip address 172.16.33.1 255.255.255.255
    
    interface Serial2
     ip address 172.16.32.1 255.255.255.0
    
    router ospf 20
     network 172.16.0.0 0.0.255.255 area 0
    interface Loopback0
     ip address 172.16.30.1 255.255.255.255
    !
    interface Serial1/0
     ip address 172.16.32.2 255.255.255.0
     clockrate 64000
    
    router ospf 20
     network 172.16.0.0 0.0.255.255 area 0
     distribute-list 1 in
    !
    access-list 1 permit 172.16.32.0. 0.0.0.255

    上記のように、R1-7010 には distribute-list コマンドが設定されており、追加が許可されるのは 172.16.32.0/24 の範囲のアドレスだけです。リンクステート プロトコルでは、distribute-list コマンドを使用して LSA をフィルタリングすることは、実際には不可能です。そのため、LSA はデータベースには登録されますが、ルーティング テーブルには追加されません。

    R1-7010(5)# show ip ospf database router 172.16.33.1
    
      LS age: 357
      Options: (No TOS-capability, DC)
      LS Type: Router Links
      Link State ID: 172.16.33.1
      Advertising Router: 172.16.33.1
      LS Seq Number: 8000000A
      Checksum: 0xD4AA
      Length: 48
       Number of Links: 3
    
     Link connected to: another Router (point-to-point)
        (Link ID) Neighboring Router ID: 172.16.32.2
        (Link Data) Router Interface address: 172.16.32.1
        Number of TOS metrics: 0
        TOS 0 Metrics: 64

    R1-7010 の distribute-list 設定コマンドによって、ネットワーク 172.16.33.1/32 がフィルタリングされているため、ルーティング テーブルには追加されません。

    R1-7010(5)# show ip route
    172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
    C       172.16.32.0/24 is directly connected, Serial1/0
    C       172.16.30.1/32 is directly connected, Loopback0


    解決策

    この問題を解決するには、R1-7010 を設定して、Access Control List(ACL; アクセス コントロール リスト)で 172.16.33.0/24 が許可されるようにします。それによって、このネットワークがルーティング テーブルに追加されるようになります。

    R1-7010(5)# configure terminal 
    R1-7010(5)(config)# access-list 1 permit 172.16.33.0 0.0.0.255 
    R1-7010(5)(config)# end
    
    R1-7010(5)# show ip access-list 1
    Standard IP access list 1
        permit 172.16.32.0, wildcard bits 0.0.0.255
        permit 172.16.33.0, wildcard bits 0.0.0.255
    
    R1-7010(5)# show ip route
    172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
    C       172.16.32.0/24 is directly connected, Serial1/0
    O       172.16.33.1/32 [110/65] via 172.16.32.1, 00:00:08, Serial1/0
    C       172.16.30.1/32 is directly connected, Loopback0



    関連するシスコ サポート コミュニティ ディスカッション

    シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


    関連情報


    Document ID: 7112