スイッチ : Cisco Catalyst 6500 Virtual Switching System 1440

Cisco Catalyst 6500 Virtual Switching System 1440 でのスーパーバイザ モジュールの交換

2010 年 11 月 9 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2009 年 5 月 14 日) | フィードバック

概要

このドキュメントでは、Cisco Catalyst 6500 Virtual Switching System の故障したスーパーバイザを交換する手順について、段階的に説明します。

Virtual Switching System(VSS)は、2 つの Catalyst 6500 シャーシで構成されており、それぞれのシャーシにはスーパーバイザ エンジンが 1 つ搭載されています。ハードウェアの障害によりいずれかのスーパーバイザが機能しなくなり、交換した場合には、設定がデフォルトのままであるため、自動的には VSS メンバーにはなりません。この新しいスーパーバイザは、最初はスタンドアロン モードで起動します。VSS モードで起動させるには、VSS を設定する必要があります。



前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • アクティブ側 VSS スーパーバイザ からコンパクト フラッシュ デバイスに有効がイメージをコピーされている。

  • アクティブ側 VSS の設定がコンパクト フラッシュ デバイス(同じデバイスを使用しても可)にコピーされている。



使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

Cisco IOS® ソフトウェア リリース 12.2(33)SXH1 以降で稼働する Cisco Catalyst 6500 Virtual Switching System 1440

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。



表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。



設定

このセクションでは、このドキュメントで説明する機能の設定に必要な情報を提供します。

注:このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

新しいスーパーバイザは、有効なイメージと設定を使用して起動される必要があります。イメージは TFTP またはコンパクト フラッシュ デバイスを使用してコピーできます。コンパクト フラッシュが利用できない場合は、TFTP を使用しても同様にソフトウェア イメージおよび設定ファイルをコピーできます。

  1. アクティブ側 VSS スーパーバイザ からコンパクト フラッシュ デバイスに有効なイメージをコピーします。

    VSS#dir sup-bootdisk:
    Directory of sup-bootdisk:/
    1 -rwx 117668516 Jan 22 2008 11:53:58 +00:00 s72033-
       ipservices_wan-vz.122-33.SXH1
    2 -rwx 33554432 Aug 16 2007 12:40:22 +00:00 sea_log.dat
    3 -rwx 7366 Aug 22 2007 20:05:42 +00:00 default-config
    

    VSS モードでは、アクティブ側とスタンバイ側のスーパーバイザで同じバージョンのソフトウェア イメージが実行されていることに注意してください。

    VSS#copy sup-bootdisk:s72033-ipservices_wan-vz.122-33.SXH1 disk0:
    Destination filename [s72033-ipservices_wan-vz.122-33.SXH1]?
    Copy in progress...CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
       CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
     
    !--- 出力を省略。
    
    
  2. アクティブ側 VSS スーパーバイザ からコンパクト フラッシュ デバイスに現在の設定をコピーします。

    VSS#copy running-config disk0:
    Destination filename [startup-config]? <VSS.cfg>
    11196 bytes copied in 0.712 secs (15725 bytes/sec)


ネットワーク ダイアグラム

このドキュメントでは、次のネットワーク構成を使用しています。

Switch 2 のスーパーバイザが故障

replace_vss_sup_proc_v1.gif



新しいスーパーバイザのインストールと設定

次の指示に従って、新しいスーパーバイザのインストールと設定を行います。

  1. 新しいスーパーバイザをシャーシに取り付けます。ここでは、スーパーバイザのアップリンクは VSL に使用されますので、それらを物理的に接続します。コンパクト フラッシュからイメージを起動します。

  2. 新しいスーパーバイザのスタートアップ コンフィギュレーション ファイルを消去します。新しいスーパーバイザに古いコンフィギュレーションが存在しないようにするために、このステップが必要になります。

  3. あらかじめコンパクト フラッシュ デバイスにコピーしておいたソフトウェア イメージを、新しいスーパーバイザの sup-bootdisk にコピーします。

    Router#copy disk0:s72033-ipservices_wan-vz.122-33.SXH1 sup-bootdisk:
    Destination filename [s72033-ipservices_wan-vz.122-33.SXH1]?
    Copy in progress ..CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    117668516 bytes copied in 332.283 secs (354121 bytes/sec)
     
    !--- 出力を省略。
    
     
    !--- TFTP サーバからソフトウェア イメージをダウンロードする場合には、
    TFTP サーバとの接続を確立するために、 
    スイッチ インターフェイスの 1 つをネットワークに接続します。管理インターフェイスに IP アドレスを設定します。スイッチと 
    TFTP サーバの接続を確認します。
    
     
    !--- 管理 IP アドレスには、アクティブ側 VSS スイッチに割り当てられている 
    のと異なるアドレスを指定する必要があります。
    !--- 管理 IP アドレスを設定します。
    
    Router(config)#interface gig 1/3
    Router(config-if)#ip address 10.10.10.100 255.255.255.0
    Router(config-if)#no shutdown
     
    !--- 管理インターフェイスのステータスと設定を確認します。
    
    Router#show interface gig 1/3
    GigabitEthernet1/3 is up, line protocol is up (connected)
    Hardware is C6k 1000Mb 802.3, address is 0005.dce7.8180 
       (bia 0005.dce7.8180)
    Internet address is 10.10.10.100/24
     
    !--- 出力を省略。
    !--- TFTP サーバとスイッチの管理インターフェイスが同じ レイヤ 3 サブネットに 
    存在しない場合には、(デフォルト)ルートを追加します。
    
    Router(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.1
     
    !--- スイッチと TFTP サーバ IP 接続を確認します。
    
    Router#ping 10.20.20.200
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.20.20.200, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
     
    !---新しいソフトウェア イメージをスーパーバイザの bootflash: にコピーします。
    
    Router#copy tftp: sup-bootdisk:
    Address or name of remote host []? 10.20.20.200
    Source filename []? s72033-ipservices_wan-vz.122-33.SXH1
    Destination filename [s72033-ipservices_wan-vz.122-33.SXH1]?
    Copy in progress ..CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
     
    !--- 出力を省略。
    
    
  4. あらかじめコンパクト フラッシュ デバイスに保存しておいたアクティブ側スーパーバイザの設定を、新しいスーパーバイザの startup-config コンフィギュレーション ファイルにコピーします。

    Router#copy disk0:VSS.cfg startup-config
    Destination filename [startup-config]?
    11196 bytes copied in 7.460 secs (1501 bytes/sec)
    VSS#

    注:VSS 設定や、正しい IOS ソフトウェア イメージを起動するのに必要なブート変数があればここで追加されるため、このステップはきわめて重要です。

     
    !--- 太字で表記された VSS 設定コマンドは、VSS モードで 
    スーパーバイザを起動するのに不可欠です。
    !--- startup-config ファイルの VSS 設定を確認します。
    
    VSS#more nvram:startup-config
    !
    hostname VSS
    boot system flash sup-bootdisk:s72033-ipservices_wan-vz.122-33.SXH1
     
    !--- スイッチ プロパティごとに、virtual domain <id> が 
    設定されます。
    
    switch virtual domain 1
    switch mode virtual 
     
    !--- このコマンドはスタンドアロン スイッチが VSS モードに変換されるときに指定されます。 
    コンフィギュレーションにこのコマンドが含まれていることを確認してください。
    
    switch 1 priority 110
    switch 2 priority 100
    
     
    !--- Virtual Switch Link(VSL)設定を確認します。
    
    interface Port-channel1
    no switchport
    no ip address
    switch virtual link 1
    mls qos trust cos
    no mls qos channel-consistency
    !
    interface Port-channel2
    no switchport
    no ip address
    switch virtual link 2
    mls qos trust cos
    no mls qos channel-consistency
     
    !--- VSL を構成する物理インターフェイス
    
    interface TenGigabitEthernet1/1/4
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 1 mode on
    
    interface TenGigabitEthernet1/1/5
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 1 mode on
    
    interface TenGigabitEthernet2/1/4
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 2 mode on
    
    interface TenGigabitEthernet2/1/5
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 2 mode on
    
  5. Virtual Switching ドメイン内で Catalyst 6500 スイッチを識別する VSS Switch_ID を設定します。VSS を構成できるのは 2 台のスイッチに限られるため、アクティブ側のスイッチに定義された値に応じて、1 または 2 を選択する必要があります。1 または 2 以外の値は使用できません。

     
    !--- アクティブ側スイッチの Switch_ID を確認します。
    
    VSS#switch read switch_num local
    Read switch_num from Active rommon is 1
     
    !--- アクティブ側スイッチでは Switch_ID=1 が使用されているため、  
    新しいスーパーバイザには Switch_ID=2 を定義することに注意してください。
    
     
    !--- スーパーバイザに Switch_ID を定義します。
    
     
    !--- 次のコマンドでは Switch_ID ROMMON 変数を設定します。 
    VSS の起動中に VSS ドメイン内のスイッチを特定するのに使用されます。
    !--- Switch_ID は、スーパーバイザのステート(アクティブまたはスタンバイ)を指示するものではないことに注意してください。
    
    Router#switch set switch_num 2
    Set rommon's switch_num to 2
     
    !--- 新しいスーパーバイザの Switch_ID 設定を確認します。
    
    Router#switch read switch_num
    Read switch_num from Active rommon is 2
  6. スイッチをリロードすると、リロード時には、スイッチは VSS モードで起動します。

    caution 注意: この時点では、running-config を startup-config に保存しないでください。保存した場合には、startup-config がデフォルトのコンフィギュレーションで上書きされてしまうため、スイッチが VSS モードで起動しなくなります。

    CLI の出力例:

    Router# reload
    System configuration has been modified. Save? [yes/no]: no
    Proceed with reload? [confirm]
    00:25:07: %SYS-5-RELOAD: Reload requested by console. 
       Reload Reason: Reload Command.
    00:26:49: %SYS-SP-3-LOGGER_FLUSHING: 
       System pausing to ensure console debugging output.
    00:26:49: %OIR-SP-6-CONSOLE: 
       Changing console ownership to switch processor
     
    !--- 出力を省略。
    !--- SP の起動中は、SP によってロードされるイメージの名前に注意してください。
    
    System Bootstrap, Version 8.5(1)
    Copyright (c) 1994-2006 by cisco Systems, Inc.
    Cat6k-Sup720/SP processor with 1048576 Kbytes of main memory
    Autoboot executing command: “ boot system flash 
       sup-bootflash:s72033-ipservices_wan-vz.122-33.SXH1”
    Loading image, please wait ...
    Initializing ATA monitor library...
    Self decompressing the image : 
       ######################################
       #####################################
    Restricted Rights Legend
    Use, duplication, or disclosure by the Government is
    subject to restrictions as set forth in subparagraph
    (c) of the Commercial Computer Software - Restricted
    Rights clause at FAR sec. 52.227-19 and subparagraph
    (c) (1) (ii) of the Rights in Technical Data and Computer
    Software clause at DFARS sec. 252.227-7013.
    cisco Systems, Inc.
    170 West Tasman Drive
    San Jose, California 95134-1706
    Cisco IOS Software, s72033_sp Software 
       (s72033_sp-IPSERVICES_WAN-VM), 
       Version 12.2(33)SXH1, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2008 by Cisco Systems, Inc.
    Compiled Thu 17-Jan-08 04:38 by prod_rel_team
    Image text-base: 0x01020150, data-base: 0x01021000
     
    !--- VSS 設定は起動中に事前に解析されます。
    
    System detected Virtual Switch configuration...
    Interface TenGigabitEthernet 2/8/4 is member of Portchannel 2
    
     
    !--- 出力を省略。
    
    Initializing as Virtual Switch STANDBY processor
     
    !--- VSL モジュール(このシナリオではスーパーバイザ)が立ち上がり、 
    すでにアクティブな VSS スイッチが存在するため、役割は 
    スタンバイとして解決されます。
    
    
    00:00:30: %VSL_BRINGUP-6-MODULE_UP: 
       VSL module in slot 8 switch 2 brought up
    00:00:57: %VSLP-5-VSL_UP: 
       Ready for Role Resolution with Switch=1, 
       MAC=0014.1bc6.1c00 over 8/4
    00:01:01: %VSLP-5-RRP_ROLE_RESOLVED: 
       Role resolved as STANDBY by VSLP
    00:01:01: %VSL-5-VSL_CNTRL_LINK: New VSL Control Link 8/4
     
    !--- RP が起動します。
    
    System Bootstrap, Version 12.2(17r)SX5, RELEASE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 2006 by cisco Systems, Inc.
    Cat6k-Sup720/RP platform with 1048576 Kbytes of main memory
    Download Start
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    Restricted Rights Legend
    Use, duplication, or disclosure by the Government is
    subject to restrictions as set forth in subparagraph
    (c) of the Commercial Computer Software - Restricted
    Rights clause at FAR sec. 52.227-19 and subparagraph
    (c) (1) (ii) of the Rights in Technical Data and Computer
    Software clause at DFARS sec. 252.227-7013.
    cisco Systems, Inc.
    170 West Tasman Drive
    San Jose, California 95134-1706
    Cisco IOS Software, s72033_rp Software (s72033_rp-IPSERVICES_WAN-VM), 
       Version 12.2(33)SXH1, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2008 by Cisco Systems, Inc.
    Compiled Thu 17-Jan-08 04:04 by prod_rel_team
    Image text-base: 0x01020150, data-base: 0x01021000
     
    !--- 出力を省略。
    
    Press RETURN to get started!
     
    !--- アクティブ側のコンソールの次のメッセージに注意してください。 
    “%PFREDUN-SW2_SPSTBY-6-STANDBY:Initializing for SSO mode”
    スタンバイが SSO モードで実行されていることを確認します。
    !--- スタンバイで起動した後は、コンソールはロックされます。
    
    VSS-sdby>
    Standby console disabled
    VSS-sdby>
    Standby console disabled


確認

現在、この設定に使用できる確認手順はありません。

特定の show コマンドが、アウトプットインタープリタ ツール登録ユーザ専用)(OIT)でサポートされています。OIT を使用して、show コマンド出力の解析を表示できます。



トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つ情報を紹介します。

スーパーバイザ エンジン間でのソフトウェアのミスマッチ

スーパーバイザ エンジン同士のソフトウェアにミスマッチがあると、スタンバイ側スーパーバイザが(SSO 冗長性モードではなく)RPR 冗長性モードで起動するため、VSS は完全には初期化されません。

この問題を解決するには、スタンバイ側スーパーバイザのフラッシュに必要なソフトウェアが存在していること、さらにブート設定が正しいソフトウェアをポイントしていることを確認します。正しいソフトウェアで起動されて、VSS に接続できるように、スタンバイ側スーパーバイザをリロードします。




関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 109334