IP : IP バージョン 6(IPv6)

IPv6 のマルチプロトコル BGP の設定例

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2011 年 1 月 18 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、IPv6 のマルチプロトコル Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)の設定例を提供しています。 BGP は、独立したルーティング ポリシーを含む、独自のルーティング ドメイン(自律システム)への接続に主に使用される Exterior Gateway Protocol(EGP; エクステリア ゲートウェイ プロトコル)です。 一般的に BGP は、インターネットへのアクセスのため、サービス プロバイダーへの接続に使用されています。 自律システム内で BGP を使用することもでき、この形態は internal BGP(iBGP; 内部 BGP)と呼ばれます。 マルチプロトコル BGP は、IPv6 アドレス ファミリや IP マルチキャスト ルートなど、複数のネットワーク層プロトコルのアドレス ファミリに関するルーティング情報を伝送する拡張 BGP です。 すべての BGP コマンドおよびルーティング ポリシー機能は、マルチプロトコル BGP で使用できます。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このトポロジーでは、ルータ R0 および R1 は EBGP 関係を形成します: R0 は自律システム番号 1 (AS1 に)あり、R1 は AS2 にあります。 ルータ R0 はアドバタイジング 2 つの IPv6 ネットワークです: 2010:AB8:2::/48 および 2010:AB8:3::/48。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/112135/ipv6-bgp-01.gif

設定

これは、図に示したルータの IPv6 マルチプロトコル BGP の設定例です。

ルータ R0

ipv6 unicast-routing

!--- Enables forwarding of IPv6 packets.

ipv6 cef

interface Loopback10
 no ip address
 ipv6 address 2010:AB8:2::/48
 ipv6 enable
!
interface Loopback20
 no ip address
 ipv6 address 2010:AB8:3::/48
 ipv6 enable
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2010:AB8:0:2::/64 eui-64
 ipv6 enable
!

router bgp 1
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast

!--- Without configuring ""no bgp default ipv4-unicast"" only IPv4 will be 

!--- advertised

 bgp log-neighbor-changes
 neighbor 2010:AB8:0:2:C601:10FF:FE58:0 remote-as 2
 !
 address-family ipv6
  neighbor 2010:AB8:0:2:C601:10FF:FE58:0 activate
  network 2010:AB8:2::/48
  network 2010:AB8:3::/48
 exit-address-family
!

ルータ R1
ipv6 unicast-routing
ipv6 cef

interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2010:AB8:0:2::/64 eui-64
 ipv6 enable
!

router bgp 2
 bgp router-id 2.2.2.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2010:AB8:0:2:C600:10FF:FE58:0 remote-as 1
 !
 address-family ipv6
  neighbor 2010:AB8:0:2:C600:10FF:FE58:0 activate
 exit-address-family
!

確認

ここでは、設定が正常に動作していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

show ipv6 route

このコマンドは、IPv6 ルーティング テーブルを表示します。

R1#
show ipv6 route

IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
C   2010:AB8:0:2::/64 [0/0]
     via ::, FastEthernet0/0
L   2010:AB8:0:2:C601:10FF:FE58:0/128 [0/0]
     via ::, FastEthernet0/0
B   2010:AB8:2::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0
B   2010:AB8:3::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0
L   FF00::/8 [0/0]
     via ::, Null0

show ipv6 route bgp

プロトコルを指定する場合、その特定のルーティング プロトコルのルートだけが表示されます。 この例は、BGP キーワードを指定して入力した show ipv6 route コマンドからの出力です。

R1#
show ipv6 route bgp

IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   2010:AB8:2::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0
B   2010:AB8:3::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0

show bgp ipv6 unicast summary

このコマンドは、IPv6 固有のものを除き、show ip bgp summary コマンドと同様の内容が出力されます。

R1#
show bgp ipv6 unicast summary

BGP router identifier 2.2.2.2, local AS number 2
BGP table version is 3, main routing table version 3
2 network entries using 304 bytes of memory
2 path entries using 152 bytes of memory
2/1 BGP path/bestpath attribute entries using 248 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 728 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2010:AB8:0:2:C600:10FF:FE58:0
                4     1      15      14        3    0    0 00:11:52        2

関連情報


Document ID: 112135