IP : IP バージョン 6

IPv6 over MPLS(VPN)

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2012 年 1 月 26 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

IP バージョン 6(IPv6)は IP バージョン 4(IPv4)の代替として作られた IP の新しいバージョンであり、現在世界中で広範に導入および使用されています。 IPv6 の主な利点は、インターネット対応機器の急増に伴うインターネットの拡大に対応するために必要なより大きなアドレス レンジを利用できることです。

IPv6 VPN は IPv6 インターフェイス、または PE ルータを介してサービス プロバイダー(SP)のバックボーンへのサブインターフェイスを介して接続されます。 サイトは IPv4 と IPv6 の両方に対応できます。 各 IPv6 VPN には独自のアドレス レンジがあります。ここでは、特定のアドレスが、別の VPN 内にある異なるシステムを表します。 これは、ルート識別子(RD)を IP アドレスに付加する、新しいアドレス ファミリである VPN-IPv6 または VPNv6 アドレス ファミリによって行われます。

VPNv6 アドレスは、8 バイトの RD で始まり、16 バイトの IPv6 アドレスで終わる 24 バイトの数列です。 サイトが IPv4 と IPv6 に対応している場合、IPv4 アドレスと IPv6 アドレスの両方のアドバタイズに同じ RD を使用できます。

前提条件

要件

このドキュメントに関する特別な要件はありません。

注: いくつかのプラットフォームの IPv6 バーチャルルーティングおよびフォワーディング(VRF)サポートに関しては(たとえば、7600 シリーズ ルータ)、グローバルコンフィギュレーションの MLS IPv6 VRF を設定する必要があります。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

ipv6-over-mpls-vpn-01.gif

VRF の設定

CE1 ルータ
ipv6 unicast-routing
ipv6 cef
!
interface Serial 0/0
 ipv6 address 2001:1::1/124
!
interface Loopback 0
 ipv6 address ABCD::1/128
!

CE2 ルータ
ipv6 unicast-routing
ipv6 cef
!
interface Serial 0/0
 ipv6 address 2001:2::1/124
!
interface Loopback 0
 ipv6 address ABCD::2/128
!

6VPE1 ルータ
ipv6 unicast-routing
ipv6 cef
!
mpls label protocol ldp
mpls ldp router-id Loopback 0 force

!
!----- The VRF is defined with vrf definition <vrf-name> and is made IPv6 aware
!

vrf definition CUST1
 rd 1:1
 !
 address-family ipv6
 route-target import 1:1
 route-target export 1:1
 exit-address-family
!
interface Serial 0/0
 vrf forwarding CUST1
 ipv6 address 2001:1::2/124
!
interface Loopback 0
 ip address 1.1.1.1 255.255.255.255
 ip ospf 1 area 0
!

6VPE2 ルータ
ipv6 unicast-routing
ipv6 cef
!
mpls label protocol ldp
mpls ldp router-id Loopback 0 force
!
vrf definition CUST1
 rd 1:1
 !
 address-family ipv6
 route-target import 1:1
 route-target export 1:1
 exit-address-family
!
interface Serial 0/0
 vrf forwarding CUST1
 ipv6 address 2001:2::2/124
!
interface Loopback 0
 ip address 3.3.3.3 255.255.255.255
 ip ospf 1 area 0
!

マルチプロトコル BGP(MP-BGP)の設定

iBGP 接続用にアドレス ファミリ VPNv6 が 6VPE ルータ上で設定されています。 6VPE ルータと CE ルータ間に eBGP 接続があります。

CE1 ルータ
router bgp 65101
 neighbor 2001:1::2 remote-as 100
 !
 address-family ipv6
 neighbor 2001:1::2 activate
 network ABCD::1/128
 exit-address-family
!

6VPE1 ルータ
router bgp 100
 neighbor 3.3.3.3 remote-as 100
 neighbor 3.3.3.3 update-source Loopback 0
 !
 address-family vpnv6
 neighbor 3.3.3.3 activate
 exit-address-family
 !
 address-family ipv6 vrf CUST1
 neighbor 2001:1::1 remote-as 65101
 neighbor 2001:1::1 activate
 redistribute connected
 exit-address-family
!

CE2 ルータ
router bgp 65102
 neighbor 2001:2::2 remote-as 100
 !
 address-family ipv6
 neighbor 2001:2::2 activate
 network ABCD::2/128
 exit-address-family
!

6VPE2 ルータ
router bgp 100
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 update-source Loopback 0
 !
 address-family vpnv6
 neighbor 1.1.1.1 activate
 exit-address-family
 !
 address-family ipv6 vrf CUST1
 neighbor 2001:2::1 remote-as 65102
 neighbor 2001:2::1 activate
 redistribute connected
 exit-address-family
!

確認

BGP のネクストホップ アドレス

6VPE2# 
show bgp vpnv6 unicast vrf CUST1
BGP table version is 30, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:1 (default for vrf CUST1)
*>i2001:1::/124     ::FFFF:1.1.1.1           0    100      0 ?
*> 2001:2::/124     ::                       0         32768 ?
*>iABCD::1/128      ::FFFF:1.1.1.1           0    100      0 65101 i
*> ABCD::2/128      2001:2::1                0             0 65102 i

6VPE2# show bgp vpnv6 unicast vrf CUST1 ABCD::1/128
BGP routing table entry for [1:1]ABCD::1/128, version 30
Paths: (1 available, best #1, table CUST1)
  Advertised to update-groups:
        2
  65101
    ::FFFF:1.1.1.1 (metric 3) from 1.1.1.1 (1.1.1.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Extended Community: RT:1:1
      mpls labels in/out nolabel/20

ラベル インポジション

接続されている CE ルータからのパケットを 6VPE ルータが受信すると、6VPE ルータはその CE ルータに対応する VRF テーブルで、パケットの IPv6 宛先アドレスをルックアップします。 これにより、6VPE ルータで VPNv6 経路を検出できます。 VPNv6 経路には、関連付けられている MPLS ラベル(トップ ラベル)と、関連付けられている BGP ネクストホップ ラベル(ボトム ラベル)があります。

6VPE2# show bgp vpnv6 unicast vrf CUST1 ABCD::1/128
BGP routing table entry for [1:1]ABCD::1/128, version 30
Paths: (1 available, best #1, table CUST1)
  Advertised to update-groups:
        2
  65101
    ::FFFF:1.1.1.1 (metric 3) from 1.1.1.1 (1.1.1.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Extended Community: RT:1:1
      mpls labels in/out nolabel/20

6VPE2# 
show ip cef 1.1.1.1
1.1.1.1/32
  nexthop 10.2.2.1 FastEthernet2/0 label 16

6VPE2# 
show ipv6 cef vrf CUST1 ABCD::1/128 detail
ABCD::1/128, epoch 0
  recursive via 1.1.1.1 label 20
    nexthop 10.2.2.1 FastEthernet2/0 label 16

CE ルータにアドバタイズされる IPv6 プレフィクス

show ipv6 route bgp コマンドでは、ルータにより学習された BGP 経路を表示します。

CE1# show ipv6 route bgp
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   2001:2::/124 [20/0]
     via FE80::C808:17FF:FE2C:0, Serial0/0
B   ABCD::2/128 [20/0]
     via FE80::C808:17FF:FE2C:0, Serial0/0
CE2# show ipv6 route bgp
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   2001:1::/124 [20/0]
     via FE80::C809:14FF:FEB4:0, Serial0/0
B   ABCD::1/128 [20/0]
     via FE80::C809:14FF:FEB4:0, Serial0/0

トラブルシューティング

ここでは、設定に関するトラブルシューティングについて説明します。

BGP 機能ネゴシエーション

MP-BGP は MP_REACH NLRI 内で IPv6 VPN 経路をアドバタイズするために使用されます。

注: 使用されるアドレス ファミリ識別子/後続アドレス ファミリ識別子(AFI/SAFI)は 2/128 です。 AFI = 2 の値は IPv6 を表し、SAFI = 128 は MPLS ラベルの VPNv6 を表します。

debug ip bgp

21:10:10.387: BGP: 3.3.3.3 went from Active to OpenSent
21:10:10.391: BGP: 3.3.3.3 sending OPEN, version 4, my as: 100, holdtime 180
    seconds
21:10:10.395: BGP: 3.3.3.3 send message type 1, length (incl. header) 61
21:10:10.579: BGP: 3.3.3.3 rcv message type 1, length (excl. header) 42
21:10:10.579: BGP: 3.3.3.3 rcv OPEN, version 4, holdtime 180 seconds
21:10:10.583: BGP: 3.3.3.3 rcv OPEN w/ OPTION parameter len: 32
21:10:10.583: BGP: 3.3.3.3 rcvd OPEN w/ optional parameter type 2 (Capability)
    len 6
21:10:10.583: BGP: 3.3.3.3 OPEN has CAPABILITY code: 1, length 4
21:10:10.587: BGP: 3.3.3.3 OPEN has MP_EXT CAP for afi/safi: 1/1
21:10:10.587: BGP: 3.3.3.3 rcvd OPEN w/ optional parameter type 2 (Capability)
    len 6
21:10:10.587: BGP: 3.3.3.3 OPEN has CAPABILITY code: 1, length 4
21:10:10.587: BGP: 3.3.3.3 OPEN has MP_EXT CAP for afi/safi: 2/128
21:10:10.591: BGP: 3.3.3.3 rcvd OPEN w/ optional parameter type 2 (Capability)
    len 2
21:10:10.591: BGP: 3.3.3.3 OPEN has CAPABILITY code: 128, length 0
21:10:10.591: BGP: 3.3.3.3 OPEN has ROUTE-REFRESH capability(old) for all
    address-families
21:10:10.591: BGP: 3.3.3.3 rcvd OPEN w/ optional parameter type 2 (Capability)
    len 2
21:10:10.595: BGP: 3.3.3.3 OPEN has CAPABILITY code: 2, length 0
21:10:10.595: BGP: 3.3.3.3 OPEN has ROUTE-REFRESH capability(new) for all 
    address-families
21:10:10.595: BGP: 3.3.3.3 rcvd OPEN w/ optional parameter type 2 (Capability)
    len 6
21:10:10.595: BGP: 3.3.3.3 OPEN has CAPABILITY code: 65, length 4
21:10:10.599: BGP: 3.3.3.3 OPEN has 4-byte ASN CAP for: 100
BGP: 3.3.3.3 rcvd OPEN w/ remote AS 100, 4-byte remote AS 100
21:10:10.599: BGP: 3.3.3.3 went from OpenSent to OpenConfirm
21:10:10.603: BGP: 3.3.3.3 went from OpenConfirm to Established
21:10:10.603: %BGP-5-ADJCHANGE: neighbor 3.3.3.3 Up
21:10:11.547: %BGP-5-ADJCHANGE: neighbor 2001:1::1 vpn vrf CUST1 Up
6VPE1# show bgp vpnv6 unicast all neighbors
BGP neighbor is 3.3.3.3,  remote AS 100, internal link
  BGP version 4, remote router ID 3.3.3.3
  BGP state = Established, up for 00:05:32
  Last read 00:00:30, last write 00:00:20, hold time is 180, keepalive interval
      is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    New ASN Capability: advertised and received
    Address family IPv4 Unicast: advertised and received
    Address family VPNv6 Unicast: advertised and received

    !
    !---output omitted
    !

BGP neighbor is 2001:1::1,  vrf CUST1,  remote AS 65101, external link
  BGP version 4, remote router ID 10.210.0.1
  BGP state = Established, up for 00:05:54
  Last read 00:00:54, last write 00:00:43, hold time is 180, keepalive interval
      is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    New ASN Capability: advertised
    Address family IPv6 Unicast: advertised and received

    !
    !---output omitted
    !

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 112085